Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

ADSL/VDSL

configurar route cisco 1721

heliod

hola, estoy teniendo problemas con mi router cisco 1721 para salir a internet.
el run es:
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
no logging buffered
no logging console
!
memory-size iomem 25
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
ip host-routing
!
!
ip name-server 80.58.61.250
ip name-server 80.58.61.254
!
vpdn enable
!
vpdn-group pppoe
request-dialin
protocol pppoe
!
!
!
!
interface ATM0
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
no ip mroute-cache
no atm ilmi-keepalive
pvc 8/32
pppoe-client dial-pool-number 1
!
dsl operating-mode auto
no fair-queue
hold-queue 224 in
!
interface BRI0
no ip address
shutdown
!
interface FastEthernet0
ip address 192.168.0.1 255.255.255.0
ip nat inside
ip tcp adjust-mss 1452
speed auto
no cdp enable
hold-queue 100 out
!
interface Dialer0
ip address negotiated
ip nat outside
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap callin
ppp chap hostname adslppp@telefonicanetpa
ppp chap password 0 adslppp
ppp ipcp dns request
ppp ipcp wins request
!
ip nat inside source list 50 interface Dialer0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
no ip http server
ip pim bidir-enable
!
!
access-list 50 permit 192.168.0.0 0.0.0.255
dialer-list 1 protocol ip permit
!
!
line con 0
line aux 0
line vty 0 4
login
!
end

Router#show ip int brief
Interface IP-Address OK? Method Status Prot
ocol
ATM0 unassigned YES TFTP up up

BRI0 unassigned YES TFTP administratively down down

BRI0:1 unassigned YES unset administratively down down

BRI0:2 unassigned YES unset administratively down down

Dialer0 unassigned YES NVRAM up up

FastEthernet0 192.168.0.1 YES NVRAM up up

Virtual-Access1 unassigned YES unset up down

he aplicado un debug ppp y el router dice que no se registra es decir que no se autentifica, por eso el virtual-access1 el protocolo is down.

espero respuestas gracias

Este tema está cerrado a nuevas respuestas. Abre un nuevo tema para retomar la conversación.
Risky

Hola, tan solo una cuestión.

Te has cerciorado que la conexión pppoe de tu isp soporte CHAP?

Podría ser MS-CHAP ó PAP

Saludos

BocaDePez
BocaDePez

Hola.

Efectivamente yo tengo el mismo router que tu , con el mismo operador y me pasa exactamente lo mismo, efectivamente es de la negociación pero yo he cambiado a pap y continua sin asignarme ip, si alguien ha encontrado una solucion que nos lo comente mientras continuaremos con el modem guarro de telefonica.

heliod

es telefonica ¿que autentificación tiene?

he cambiado el IOS a la versión 12.3
estoy haciendo muchas pruebas y mi router no tiene tráfico de entrada tengo todo e UP.

🗨️ 5
BocaDePez
BocaDePez

tengo chap y pap y si es telefonica, yo tampoco recibo nada de trafico y tambien estoy realizando un monton de pruebas si encontramos algo hablamos

Frankie2004

No tengo un Cisco y no puedo ayudar demasiado, pero si ya habéis probado con PAP y sigue sin validarse, suena mal. ¿Qué pone en el debug? En mi router tengo la posibilidad de "PAP Only" o "CHAP/PAP" que es la opción activa, sin embargo el log me dice que se ha usado PAP, no sé si es porque CHAP ha sido rechazado.

Por cierto ... ¿no sobraría "ppp ipcp wins request" en este entorno?

🗨️ 3
nene01

Hola, da igoner esecomando o no ya que no asigna ninguna wins , en le tema de los debug me aparece que no recibe authentication es decir yo envio pero no recibo de todas formas hay otro dato que me preocupa que es reliability este dato es la señal de la linea en el interface atm y tendria que ser 255/255 y el mio es 26/255 y va subiendo segun el tiempo que este conectado y puede venir de aqui el problema si alguien tiene este problema de no authenticar que verifique este dato haber si pasa lo mismo que con el mio, si es asi podria ser problema de ruido en linea y yo daria un aviso para la mia

Risky

Hola

¿Cómo es posible que actualice por PAP? Según tengo entendido esta autenticación está obsoleta, ya que va el password sin cifrar, en texto plano...

No me lo explico...

Saludos

🗨️ 1
marge

¿Autenticación PAP obsoleta?
No sé de dónde te has sacado eso. El hecho de que vaya en claro es un punto en contra, pero CHAP tampoco es infalible. Hay escenarios donde sirven por igual las dos y otros donde se recomienda utilizar sólo CHAP, pero de ahí a que esté obsoleta...

Por otro lado, hay ISPs que sólo soportan PAP.

Saludos...

heliod

poner el show run para ver si lo tenemos todos igual.

nene01

Building configuration...

Current configuration : 2216 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname mvpemq100v
!
boot-start-marker
boot-end-marker
!
no logging monitor
enable secret
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
no aaa new-model
ip subnet-zero
no ip source-route
!
!
no ip domain lookup
!
ip cef
ip inspect name ccnp ftp alert on
ip inspect name ccnp tftp alert on
ip inspect name ccnp udp alert on
ip inspect name ccnp http alert on
ip inspect name ccnp icmp alert on
ip audit attack action alarm drop
ip audit po max-events 100
ip audit protected 192.168.1.0
ip audit name ccie attack action drop
vpdn enable
!
vpdn-group 1
request-dialin
protocol pppoe
!
no ftp-server write-enable
!
!
!
!
!
!
!
interface ATM0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
pvc 8/32
pppoe-client dial-pool-number 1
!
!
interface FastEthernet0
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip audit ccie in
speed auto
no cdp enable
hold-queue 100 in
!
interface Dialer0
ip address negotiated
ip nat outside
ip inspect ccnp in
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication pap chap callin
ppp chap hostname adslppp@telefonicanetpa
ppp chap password 7 050A021C2D5C5E19
ppp pap sent-username adslppp@telefonicanetpa password 7 1416161800143A3B
!
ip nat inside source list 1 interface Dialer0 overload
ip nat inside source static tcp 192.168.1.2 4662 interface Dialer0 4662
ip nat inside source static udp 192.168.1.2 4672 interface Dialer0 4672
ip nat inside source static tcp 192.168.1.2 4664 interface Dialer0 4664
ip nat inside source static tcp 192.168.1.2 4663 interface Dialer0 4663
ip nat inside source static tcp 192.168.1.2 4661 interface Dialer0 4661
ip nat inside source static tcp 192.168.1.2 4660 interface Dialer0 4660
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
no ip http server
no ip http secure-server
!
!
access-list 1 permit 192.168.1.0 0.0.0.255
dialer-list 1 protocol ip permit
no cdp run
!
!
line con 0
line aux 0
line vty 0 4
access-class 2 in
password 7
login
!
end

heliod

haz un show vpdn a mi me sale esto, quiere decir que no realizamos la fase de establecimiento porque no tenemos comunicación de entrada la solución es contactar con los de telefónica pero no quiern saber nada de este router.
mira a ver si te sale esto a ti.puede leer esta dirección

(link roto)

Router#show vpdn

%No active L2TP tunnels

%No active L2F tunnels

%No active PPTP tunnels

PPPoE Tunnel and Session Information Total tunnels 1 sessions 1

PPPoE Session Information
UID SID RemMAC OIntf Intf Session
LocMAC VASt state
0 0 0000.0000.0000 ATM0.1 N/A N/A
0000.0000.0000 VP/VC: 8/32

nene01

Ya se que no quieren saber nada del tema ya he estado pegandome con ellos un tiempo, pero nos quedea otra solucion ya que esta configuracion esta funcionando con otros usuarios, yo creo que es por la calidad de la linea yo he dado un aviso del ruido en la linea, para que vean la calidad de ella haber si asi se puede solucionar, he probado con mil configuraciones poniendo el router en modo bridge y tampoco la configuracion esta correcta por lo que tiene que ser un tema fisico de la linea,

heliod

bueno, te diré que me han dicho que tengo mucha atenuación en subida, por lo tanto puede ser un problema de la linea. si solucionas o te solucionan algo me lo dices gracias. Mientras tanto daré parte a telefonica del problema de ruido.

🗨️ 2
nene01

Vale una cosita, si estas en casa puedes hacer una prueba mira me he enterado que la red rima de telefonica autentica mediante un radius es decir que en los cisco tenemos la opcion de generar un.
aaa new-model.
aaa athentication ppp local es importante esto o algo asi no estoy en casa y no puedo ponerte el comando entero.
y generarte un
username adslppp@telefonicanetpa password adslpppn

Esto es para conexiones remotas atraves de rdsi es decir que tu seas un servidor radius pero un dato que en las propiedades de mi conexion por modem veo que authentico con pap y que mi conexion es rdsi aunque no tiene sentido pero ya no se me ocurre muchas cosas por probar.

puedes hacer la prueba?
yo la hare por la noche si lo pruebas y si te funciona ponlo.
gracias.

🗨️ 1
Frankie2004

Hay una cosa que sí te puedo confirmar, y es que los servidores RADIUS de Telefónica están configurados para admitir conexiones únicamente desde los NAS asociados, usando redes privadas aisladas.

La única forma que tú tienes para comunicarte con tu NAS es como cliente PPP una vez que la capa ATM y la capa PPPoE están activas, como muy bien indicaba el interesante documento de Cisco del enlace puesto por heliod.

heliod

lo del servidor radius,no se como hacerlo. yo tengo adsl sobre rtb (linea normal).

con el modem USB haciendo doble click en el icono y estando saliendo en internet tengo una atenuación, de linea de 67 db. teleonica marca como límite 60 db para una señal muy debil, luego puede ser que el router cisco sea muy exigente y me rechace los paquetes, he leido en otro foro que le está pasando a más gente. lo curioso es que yo salgo a internet con el modem usb pero con el router después de hacer un montón de prueabas no lo consigo, si tengo atenuación de linea como me ha reconocido telefónica para ellos (63db) ¿que solución puede haber?
a mi se me ocurre una que no sé si será posible y es puentear 2 pares desde la central en mi enlace, y ver la atenuación.
no es problema mío porque en estos momentos estoy haciendo una prueba desde el PTR y tengo 67 db. bueno la solución de telefonica es que ponga un router de ellos.
ya os comentaré más cosas ..........
gracias por contestar.

🗨️ 4
nene01

Ahora mismo me esta funcionando. Lo he dejado toda la noche con un debug atm packet , y ahora mismo estoy sincronizado creo que con estos cambios de telefonica en la dslam los router cisco tardan bastante en sincronizar estos son mis datos.
Router#sh running-config
Building configuration...

Current configuration : 1861 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
ip audit po max-events 100
ip audit protected 192.168.1.0
vpdn enable
!
vpdn-group pppoe
request-dialin
protocol pppoe
!
no ftp-server write-enable
!
!
!
!
!
!
!
interface ATM0
no ip address
no atm auto-configuration
no atm ilmi-keepalive
no atm address-registration
no atm ilmi-enable
bundle-enable
dsl operating-mode ansi-dmt
hold-queue 208 in
!
interface ATM0.1 point-to-point
pvc 8/32
pppoe-client dial-pool-number 1
!
!
interface FastEthernet0
ip address 192.168.1.1 255.255.255.0
ip nat inside
speed auto
!
interface Dialer1
mtu 1492
ip address negotiated
ip nat outside
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
ppp chap hostname adslppp@telefonicanetpa
ppp chap password 0 adslppp
ppp pap sent-username adslppp@telefonicanetpa password 0 adslppp
!
ip nat inside source list 1 interface Dialer1 overload
ip nat inside source static tcp 192.168.1.2 4662 interface Dialer1 4662
ip nat inside source static udp 192.168.1.2 4672 interface Dialer1 4672
ip nat inside source static tcp 192.168.1.2 4664 interface Dialer1 4664
ip nat inside source static tcp 192.168.1.2 4663 interface Dialer1 4663
ip nat inside source static tcp 192.168.1.2 4661 interface Dialer1 4661
ip nat inside source static tcp 192.168.1.2 4660 interface Dialer1 4660
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
no ip http server
no ip http secure-server
!
!
access-list 1 permit 192.168.1.0 0.0.0.255
!
!
line con 0
line aux 0
line vty 0 4

login
!
end

Router#sh dsl interface atM 0
Alcatel 20150 chipset information
ATU-R (DS) ATU-C (US)
Modem Status: Showtime (DMTDSL_SHOWTIME)
DSL Mode: ANSI T1.413
ANSI Issue/rev: 2/1 2/7
Vendor ID: 0x0022 0x0039
Capacity Used: 12% 28%
Noise Margin: 35.5 dB 30.0 dB
Output Power: 12.0 dBm 12.0 dBm
Attenuation: 15.5 dB 11.0 dB
Defect Status: None None
Last Fail Code: Protocol error received
Selftest Result: 0x00
Subfunction: 0x15
Interrupts: 4083 (0 spurious)
PHY Access Err: 0
Activations: 4
Init FW: embedded
Operation FW: embedded
SW Version: 3.8131
FW Version: 0x1A04

Interleave Fast Interleave Fast
Speed (kbps): 512 0 128 0
Reed-Solomon EC: 0 0 0 0
CRC Errors: 0 0 1 0
Header Errors: 0 0 0 0
Bit Errors: 0 0
BER Valid sec: 0 0
BER Invalid sec: 0 0

DMT Bits Per Bin
00: 0 0 0 0 0 0 0 2 2 2 3 3 4 4 4 3
10: 3 3 3 3 4 3 3 3 2 2 2 2 2 2 0 0
20: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
30: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
40: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
50: 2 2 2 0 0 2 2 2 2 2 2 2 2 2 2 0
60: 2 0 0 0 2 2 2 2 2 2 0 0 2 2 2 2
70: 2 2 2 2 2 2 2 2 2 2 2 2 2 0 0 0
80: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
90: 0 2 2 2 2 0 0 0 0 0 0 2 2 2 2 2
A0: 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2
B0: 2 3 2 2 2 2 2 2 2 2 2 0 0 0 2 2
C0: 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2
D0: 2 2 2 2 2 0 2 2 2 2 2 2 2 0 2 2
E0: 2 2 2 2 2 2 2 2 0 2 0 0 0 0 0 0
F0: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

DSL: Training log buffer capability is not enabled

Espero que no me vuelva a fallar y que os sirva de ayuda

🗨️ 3
sergiosanche

Buenas. Acabo de comprar un cisco 1721 pero me viene con una version de IOS 12.1 y el comando vpdn enable no lo admite. Os importaria decirme la version de IOS que usais?
Muchisimas gracias

🗨️ 2
BocaDePez
BocaDePez

Version 12.2(7r)XM1

🗨️ 1