BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

No escucho al llamar desde Grandstream Networks GXP1610 a números fuera de mi proveedor VoIP

Solospam
1

Tengo una cuenta VoIP que intento configurar en este terminal sin éxito; el aparato aparece con línea registrada y da tono pero:

  • (a) si realizo una llamada a números de la misma empresa VoIP todo funciona correctamente
  • (b) si realizo una llamada desde el Grandstream a cualquier numeración todo funciona correctamente
  • (c) si realizo una llamada desde cualquier numeración (a excepción de aquellas que están en la misma empresa VoIP) me escuchan pero yo no escucho

¿Alguien que conozca este teléfono puede ayudarme a configurarlo?

Desde la empresa VoIP lo que obtengo es que no tengo el "internet ideal" para telefonía VoIP, pero si eso fuera así no podría entablar conversaciones entre numeraciones de la misma empresa VoIP, ¿no?

La conexión es en una aldea a la que todavía no llega la fibra, es una tarjeta SIM 5G en un Android que da conexión a un mikrotik y este al grandstream

Se que estóy tras CG-NAT pero tengo levantado un tunel l2tp entre mis routers para saltárme la limitación y poder recibir y enviar llamadas.

Lo que no me parece normal es poder hacer llamadas pero no poder recibirlas

A ver si alguien me puede echar un cable

Gracias de antemano

kotBegemot

Típico problema de NAT

Tengo una cuenta VoIP

¿De qué proveedor?

Se que estóy tras CG-NAT pero tengo levantado un tunel l2tp entre mis routers para saltárme la limitación y poder recibir y enviar llamadas.

Explicate mejor. Detalles, dibujo, etc. Porque ahí está el probema.

🗨️ 13
Solospam

¿De qué proveedor?

Realmente eso importa? lo digo porque da un poco igual que sea telsome o voiphome no?

Explicate mejor. Detalles, dibujo, etc. Porque ahí está el probema.

Mira el router de la aldea tiene la IP 192.168.101.1 y esta se conecta por un tunel 10.101.10.2 en protocolo l2tp para salir con la IP publica asociada a la ddns que responde a la IP 172.16.1.1 que está en otro router mikrotik a 65 km de distancia sin CG-NAT (red Movistar)

🗨️ 12
kotBegemot

Realmente eso importa? lo digo porque da un poco igual que sea telsome o voiphome no?

Por saber si lo conozco o no. Algunos lo pasan todo por su SBC y de otros te llega el RTP diréctamente desde el SBC de su proveedor.

Así que el teléfono tiene una IP 192.168.1.x y el registro SIP se hace con la IP pública que está mas allá del tunel.

¿Cómo decides qué va por el tunel y qué no? Me explico: ¿Podría ser que en el mikrotik aldeano envias al tunel solo lo que va a tu proveedor de Voz IP y todo lo demás se va directamente a internet ?

🗨️ 7
Solospam

¿Cómo decides qué va por el tunel y qué no?

Va todo por tunel, eso hace que la conexión baje a unos 15Mb simétricos mas que suficiente para cualquier cosa que se requiera de internet

ADSL en la aldea es de 3Mb/0,3Mb según mi vecino

🗨️ 6
Solospam
🗨️ 3
Solospam
🗨️ 1
andressis2k

En los routers MikroTik (en todos los que hagan NAT en tu ruta). IP > Firewall > Service ports: desactiva SIP. Después, reinicia el MikroTik (o borra en la pestaña Firewall > Connections todas las relacionadas con tu IP y el servidor VoIP)

Se supone que el NAT Helper ayuda… pero en VoIP, me he encontrado con muchos problemas así, y se resuelven desactivando en el MikroTik y que sea el softswitch / PBX quien se pelee

🗨️ 3
Solospam

El SIP ALG está desactivado desde el momento 0

🗨️ 2
Nombre de usuario
1

Lo que no me parece normal es poder hacer llamadas pero no poder recibirlas

1- Actualiza el fw: grandstream.com/support/firmware

2- Haz un "Factory Reset"

3- Desactiva desde Accounts → SIP Settings → Basic Settings: "Support SIP Instance ID" "NO"

4- Añade solamente los datos basicos del proveedor VoIP: "SIP Server" "Outbound Proxy:Port" "SIP User ID " "Authenticate ID" y "SIP Authentication Password"

5- Reinicia

Se puede hacer en el telefono, pero desde su interface web es mas rapido.

🗨️ 4
Solospam

No me deja subir el archivo .bin por ningún lado

imagen.webp
🗨️ 1
Solospam
1

Finalmente el problema se ha solucionado, tan fácil como esto

imagen.webpimagen.webp

Después de insistir a la empresa VoIP abrió una incidencia y pusieron la línea en revisión, el problema al parecer venía dado a que el llamante usaba una encriptación diferente al llamado y por eso no se establecía correctamente la conversación, limitando las opciones de codificación a la que utiliza el llamado el sistema funciona de forma correcta.

Problema resuelto

🗨️ 2
kotBegemot
1

No es encriptación, sino codificación. Tus llamadas no están encriptadas.

Lo hubiéramos sacado viendo la negociación SDP.

🗨️ 1
Solospam

Ni idea, es un tema que no controlo para nada… relleno 4 campos y VoIP funciona, y lo importante es que la empresa VoIP se portó y solucionó el problema después de darle la brasa un rato largo

Gracias a todos los que aportasteis una posible solución