BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

Fibra
💡

Configuración VLAN 1074 para switch Netgear GS105E

Curro1
3

Os paso unas capturas de cómo hay que configurar el switch Netgear GS105E para poder conectarlo a la ONT, para utilizar vuestro router neutro favorito en lugar del ZTE:

VLAN Configuration en Netgear GS105EConfiguración VLAN en Netgear GS105EConfiguración VLAN Membership en Netgear GS105EConfiguración VLAN Port PVID en Netgear GS105E

En mi caso, no he podido conectar el router ZTE tras mi router neutro TP-Link TL-WDR4900, ya que el ZTE no coge línea de teléfono, así que, para hacerlo por la vía fácil, opté por conectarlo directamente al switch, aunque consuma 2 IPs públicas por el momento (ya lo revisaré: tendré que ver si necesita apertura de puertos para el SIP, es una incompatibilidad con el ALG del TP-Link, o qué). Si me da mucho la vara el ZTE, lo cambio por un ATA Linksys y a rular (ya tengo la clave de la voz IP, y me imagino cómo configurarlo, con el identificador del ZTE y la cuenta).

Para configurar el GS105E, poned una IP fija al equipo, como por ejemplo, 192.168.0.3, sin puerta de enlace (vacía). Tras configurarlo se vuelve a la IP anterior o automático.

Instalar el software del switch (Prosafe Utility, WinPcap, Adobe Air), que accederá a 192.168.0.239, con password password por defecto la 1ª vez.

Al cargar el software, seleccionar el switch GS105E (se marca en amarillo), y pulsar Apply. La clave es password por defecto.

Puede que dé un error: Aceptar (Ignorar).

Lo que tenéis que configurar, está en la pestaña "VLAN", seleccionar debajo "802.1Q" y "Advanced".

En "VLAN Configuration", poner el "Advanced 802.1Q VLAN" en Enable (cuando esté todo bien configurado, ha de quedar como he indicado arriba).

Ahora ha de quedar como "VLAN 01" los puertos 03, 04, 05 únicamente, y como "VLAN 1074" el 01 y 02 (a menos que quieras el 03 para pinchar el router de Jazztel en paralelo, por si tampoco te funciona el conectarlo tras tu router neutro).

(Debajo, en la bandita morada, introducir en la casilla "VLAN ID" el valor 1074 y pulsar "ADD" para añadir.)

Si tenéis que poner el ZTE conectado también al switch, se usarán como VLAN 01 el 04 y 05 únicamente, y el 1074 para 01, 02, 03.

Añado: en el puerto 1 (Tagged) del switch conectamos el ONT, y en el puerto 2 (Untagged) el router neutro sin soporte de VLAN (que entra por el puerto WAN del router).

En el menú de configuración del ZTE, en el perfil de WAN, seleccionando en el desplegable la WANConnection, hay que desmarcarle la casilla de VLAN y aplicar el cambio, si va a estar conectado tras el switch o router neutro.

La navegación va más ágil con mi router neutro que con el ZTE, y el ping ha bajado.

En cuanto a los tests de velocidad, ya me salen más estables (salen rayas totalmente rectas en horizontal), y me da +195Mbits de subida (probado contra Adamo-Barcelona desde Sevilla):

Test de velocidad

El switch lo compré por Amazon, que me desviaba a una tienda en Lituania… xD. Unos 38€ con portes por agencia (tardó menos de una semana en llegar).

Cuidado con las revisiones del modelo GS105E, que hay varias, y desconozco si las otras soportan la VLAN.

Tengo el TL-WDR4900 desde que tenía Ono, ya que para al menos 200Mb, se nota una NAT por hardware si usas 2 P2P a la vez, y la navegación es más ágil que con los routers con NAT por software (la inmensa mayoría).

txuspe

¡Gracias por compartirlo! ¿Cuánto obtienes en testvelocidad.eu con esta nueva configuración?

🗨️ 1
Curro1

Esa siempre me salió hecha un churro desde Sevilla, desde cualquier ISP, con cualquier router (o directamente con IP pública), y cualquier equipo.

Test de Velocidad

Y sale totalmente distinta de una máquina a otra, o según se reintente.

De todas formas, he de reconocer que con el ZTE no salía así ni de coña (salía mucho peor).

En mi caso, tengo tuneados los valores de conexión, y ya he comprobado por ejemplo, que puedo subirle a tope por sFTP a otro amigo con 50M, subiendo solo 1 archivo a la vez, cosa que antes de tunear no podía (necesitaba varias subidas en paralelo, ya que no podía subir a más de 2~2'4MB/s por conexión).

Curro1

Ya nos han puesto "servicios autogestionados" para la línea de fibra:

- Voz: ocultar número, marcación rápida/abreviada, no molestar, restricción de llamadas entrantes + salientes, desvíos de llamada.

- Acceso remoto (DDNS): Ej: usuario1.ddns.jazztel.es

Está muy bien, aunque sigue faltando la restricción de llamadas a móviles.

🗨️ 3
Filiprino

Anda coño, ¿DDNS?

🗨️ 1
BocaDePez
BocaDePez

Estos de Jazztel son unos cachondos :D

Curro1

Una observación bastante graciosa sobre el funcionamiento del DDNS de Jazztel usándolo con 2 routers a la vez, conectados al switch que abre la vlan 1074:

Pues que no es usable a ratos: como cada router tiene una IP pública distinta, un rato apunta la DDNS hacia la IP pública asignada a un router, y otro rato hacia la otra IP del ZTE xD. Supongo que según validen sesión en el dhcp escogerá el último, a saber.

Total, que me voy concienciando de comprar otro ATA (que admita cambiar el identificador), o usar otra DDNS.

Curro1

Me he pedido en Amazon USA un ATA un tanto particular, un Obihai OBi110, para poder utilizar desde un mismo ATA 2 cuentas a la vez, Jazztel fijo + FreeVoipDeal/HotVoip, y recibir llamadas de ambas en el mismo ATA por el mismo teléfono analógico (cosa que no hacen los Linksys/Cisco) desde el fijo de Jazztel y desde otros usuarios de Betamax voip.
El SPA3102 de que dispongo, permite tener varias cuentas y ser configurado para Jazztel creo, pero solo recibe llamadas desde una de las cuentas.

Cuando me llegue y atine a configurarlo para Jazztel fibra, junto con Betamax, elaborarle un DialPlan (llamadas a fijos por Jazztel y móviles e internacional por Betamax), ya colgaré las capturas de cómo configurarlo, por si a alguien le pudiera interesar.
En fin, solo en llegarme, puede tardar 3-4 semanas, así que, paciencia.

De todas formas, no me está dando ningún problema el hecho de tener conectado el router ZTE en paralelo junto a mi router neutro, usando el ZTE de ATA para el teléfono únicamente. De hecho, el ZTE permite configurar una cuenta de otro proveedor de voz-ip, aunque eso ya requiere de pincharle otro teléfono en la 2ª salida rj11, ya que no tiene para configurarle un DialPlan para que discrimine qué cuenta usar en base al número que se ha marcado.

🗨️ 3
asmartin

Hola Curro.

Te usará la cuenta SIP asociada al puerto FXS que uses en cada momento ¿no?, es decir podrás tener 2 cuentas SIP, una para cada teléfono en cada puerto FXS. Ya tú asocias el puerto FXS a la cuenta SIP en la configuración del teléfono del router.

Así es en el ZyXEL P-2812HNU-F1, del que por cierto han puesto una actualización de la hoja de datos hace unos días (se huele una actualización de firmware inminete :D )

🗨️ 1
Curro1

Sí, igual que lo que actualmente hago con el spa3102, pero con la diferencia de que se permite recibir llamadas desde ambas cuentas hacia una misma salida rj11 (también lo hace el ZTE), y utilizar el DialPlan para determinar a través de qué cuenta sale una llamada, en base al número marcado, o si se restringe y evita.

Con el spa3102 se permiten hacer cosas curiosas, como llamar gratis desde una JazzcardMóvil a tu fijo Jazztel, que te descuelgue el spa3102, y te redirija hacia una cuenta Sip el nº que luego marques (estilo nodo, con PIN), pero ahí ya no me meto.

Por cierto, así son los menús del OBi110 que he encargado.. xD.

Curro1

Pues el OBi-110 no registra bien: le falta el campo "Auth ID", por lo que no funciona la cuenta.

Para quien tenga un ATA Linksys/Cisco, sí tiene ese campo, y funciona, tal y como explican por aquí: www.adslzone.net/postt359120-75.html

Curro1
1

Configuración de la cuenta del fijo de Jazztel en CSipSimple (Android):

Observación importante: solo funciona desde vuestra conexión de casa (no bajo el 3G de Jazztel-Móvil):

Teniendo habilitado el modo Experto,

- Ajustes -> Agente de usuario: ZXHN H298N/V1.1.4_JAZZT15
(Si no se pone correctamente, rechazará cualquier comunicación)

- Multimedia -> Codecs -> Rápida (wifi) -> PCMA + PCMU + G729 + G726-32

Y ahora, desde donde sale el dialer, pulsar la llave de abajo a la izquierda (cuentas), para añadir una nueva, pulsar el + (Añadir) y escoger "Advanced"

Nombre de la cuenta: Fijo (o el que queráis)

Identificador de llamada: +349xxxxxxxx (vuestro fijo con el +34 delante)

Servidor: ims.jazztel.net

Nombre de usuario: +349xxxxxxxx (vuestro fijo con el +34 delante)

ID de authentificación SIP: xxxxxxxxxxxxxxx@ims.jazztel.net (las xxxx son el nº de la fibra xD. Ver los datos en el menú SIP del ZTE).

Contraseña: (a extraerla del archivo de configuración .bin del ZTE)

Servidor proxy: 212.xxx.xxx.xxx (el mismo que os aparezca para vuestra cuenta en el ZTE: 212.10'6.212.22 en mi caso)

Si queréis recibir llamadas, en el menú de Ajustes -> Red -> Activar lo que queráis en "Para las llamadas entrantes"

Stun: no he puesto nada, ni lo he marcado

Habilitar ICE: lo he dejado habilitado por el momento, y va bien

La cuenta funciona estando encendido el ZTE, pero hay que recordar, que para recibir llamadas, el último dispositivo que haya iniciado sesión en la cuenta, es quien se lleva la llamada entrante del momento.

Quien necesite extraer la contraseña de su cuenta, por aquí pusieron un método: www.adslzone.net/postt359120.html

La VoIP es necesaria tanto si se quiere retirar el router como si se quieren utiliza teléfonos IP.

Antes de nada, hay que obtener los datos SIP. Lo haremos exportando la configuración del propio router: primero guardamos el archivo.

Segundo, descargamos este programa:
aluigi.altervista.org/mytoolz/offzip.zip

Hay que tener el archivo de configuración (config.bin) y el programa en la misma carpeta, además hay que crear una carpeta llamada off dentro de ésta, que es donde el programa pondrá los archivos... Debe estar algo así:

(carpeta) off
(archivo) config.bin
(archivo) offzip.exe

Una vez con eso, ejecutamos la consola (símbolo de sistema), nos desplazamos hasta el directorio y ponemos en consola: offzip -a config.bin off 0

Y ya nos aparecen los archivos dentro de la carpeta que creamos previamente.

Dentro de la carpeta "off" aparecerán varios archivos. Uno de ellos contiene el password de la cuenta voz-ip.
Aparecerá tal que así:

DM name="AuthUserName" val="+349xxxxxx"/
DM name="AuthPassword" val="xxxxxx"/
🗨️ 1
Curro1
1

He probado la cuenta SIP del fijo bajo una adsl de Jazztel (ajena a mi contrato), y la línea funciona perfectamente bajo otra adsl... :D

Lo curioso es que no funcione bajo Jazztel móvil (quizás sí que funcione bajo otro operador, configurando la conexión como IP pública real como permite EroskiMóvil por ejemplo para PC con APN pc.eroskimovil.es, quién sabe xD).
Desconozco cuál es el APN de JazztelMóvil para IP pública real: se nota que la que dan es compartida (mi móvil no responde al ping, sino otro cacharro).

BocaDePez
BocaDePez

Hola estoy realizando dicha configuración con el netgear SG116Ev2, recién adquirido. Pero debido a mi inexperiencia creo que no he sabido interpretar lo que es un switch.

Me explico.

Tengo la casa totalmente cableada y tiene varias plantas. El otg y todo el cableado esta en el sotano. Mi intención era al poner un switch de 16 puertos poder poner el router neutro (en mi caso un time capsule) en otra planta y el resto de los puertos (14) en Vlan 1, que me sirvieran para suministrar por cable internet a toda la casa. El problema es si no me equivoco, necesito conectar nuevamente con otro cable el router de Lan a otro puerto del switch para tener internet. Cosa que no puedo hacer.

Existe alguna configuración en el switch para que reinyectar internet al resto de puertos.

gracias

BocaDePez
BocaDePez

Duda,

Porque el puerto 1 lo tienes con una T (Tagged) y el 2 con una U (Untagged)? Que conectas en cada uno de ellos? Lo he probado de todas las formas y no me da IP ni en mi PC sin router ni en un router Netgear R7000.

Alguna idea?

Estoy intentando hacer lo mismo con un switch D-Link DGS-1210-28P y no hay manera.

Gracias!

Saludos,

🗨️ 1
Curro1

Puerto 1 (Tagged): al ONT
Puerto 2 (Untagged): al puerto WAN del router neutro (sin soporte de vlan, por eso está como "Untagged", para que abra y elimine la vlan)
Puerto 3 (Untagged): el router de Jazztel, habiéndole desactivado previamente el soporte de vlan en su configuración

El router neutro ha de tener el puerto WAN en modo "DHCP", para que sea capaz de obtener una IP pública.

Yo lo tuve funcionando perfectamente con un TP-Link wdr4900 (que se me colgaba cada unos 4 días). Le ponía como Untagged el 2 y 3, para conectarle el TP-Link y el ZTE a la vez al switch (para tener teléfono, ya que el ZTE no quería funcionar tras mi TP-Link, quizás por alguna limitación del firmware que tenía en ese momento).

BocaDePez
BocaDePez

Gracias Curro,

He probado eso y no quiere funcionar...

Tanto conectando un Router como mi PC en DHCP en el puerto 2.

El PVID hay que forzar-lo en los dos casos al 1074? Por defecto mi switch al poner tagged o un tagged ahora no lo tengo delante te lo pone, pero en el otro caso no. En cualquier caso lo he puesto a 1074 como tu y nada...

Alguna idea?

Muchas gracias por contestar estoy desesperado.

🗨️ 5
Curro1

En mi caso se ponen ambos en 1074 para que el switch entienda que es la misma red, ya que puede manejar otra de forma separada sin que se mezcle (la 1 que pone arriba por ejemplo, no se mezcla con la 1074). También se podrían poner todas como 1074, no creo que pase nada si luego no hay cacharros conectados.

Si no te deja marcar el puerto 2 Untagged como 1074, lo mismo no entiende que ha de sacar por ahí el tráfico de la boca 1 Tagged 1074, o el switch ese tiene otra forma distinta de interpretarlo, con otra configuración.

Perdón, escribo desde el móvil.

Curro1

Ah! una observación: ayer viernes-12 cambiaron algo los de Jazztel, y al menos en mi zona, me cuesta obtener una IP pública tanto en el propio router de Jazztel conectado directamente al ONT, como mi router Asus (con soporte de vlan). Tengo que apagar todos los equipos y encender primero el ONT (en tu caso switch detrás), y el router, y aún así, lo mismo tengo que intentarlo varias veces seguidas (5-10). Puede que a ti te esté ocurriendo lo mismo. El reenchufar el ONT es importante, o jamás obtiene IP.

A saber qué se han cargado ahora, que su servidor dhcp no me asigna IP pública normalmente.
Menos mal que no tengo que reiniciar nunca el router Asus, que si no.....
La última vez lo reinicié porque la DDNS de Jazztel me estaba dando problemas (que ahora la asignan al router de Jazztel (incluso requiere de hacer una llamada para que sea estable xD), en lugar de a las solicitudes dhcp que entren por el ONT).

🗨️ 3
BocaDePez
BocaDePez

a ver si no va a llegar bien la señal al ONT, llama a soporte de fibra y que revisen los valores

a mi con Orange, tengo siempre que enchufar el ONT, esperar a que coja linea y una vez tenga, encender el router. si no lo hago asi hay que esperar a que el router reintente la conexión para que tenga IP. es parecido cuando tienes un modem ADSL y router neutro

🗨️ 2
Curro1

OK, gracias por la aclaración.

En mi caso, el ONT aparenta coger la línea del tirón en cuanto lo enchufo, aunque lo mismo me está engañando y ahora tarda un rato más, no me extrañaría (que estos de Jazztel tienen la misma manía que los de Ono: flashear los cacharros sin permiso, y lo mismo meten bugs nuevos o los dejan inestables y con fallos nuevos).

Probaré a esperar un rato más la próxima vez, a ver si así coge ya IP pública del tirón, o tendrá que seguir reintentando varias veces.

Una vez que coge IP, la conexión es totalmente estable, por lo que descarto que sea problema de señal.

En mi caso me guardan la IP pública asociada a la Mac por una semana, lo cual hasta me viene bien para evitarme historias con el ftp/vpn y la ddns (que ya no es tan estable la ddns de Jazztel como antes, ahora cogiéndose por el router de Jazztel).

🗨️ 1
BocaDePez
BocaDePez
BocaDePez
BocaDePez

Solo comentaros, que la ONT de Jazztel no me esta dando IP a ningún dispositivo que no sea el Router ZTE.

Y la configuración del switch es la correcta, los dispositivos intentan negociar pero no se la da.

Teneis idea de si esta "casando" las ONT con los Routers?

🗨️ 1
Curro1

A mí me cuesta bastante obtener una IP, pero por igual en el ZTE que en el Asus xD.
Ahora tengo que reiniciar unas cuantas veces el ONT+Router que ponga, ambos a la vez.

Lo mismo han hecho algún cambio, y ahora cuesta obtener IP. Me recuerda a las pifias constantes que hacía Ono, que cada vez que iba bien, les daba por tocar algo para fastidiar a algunos (yo al menos me tuve que tragar varios cambios algo chungos).

De todas formas, si en tu caso solo va bien con el router ZTE, prueba a clonarle la Mac del puerto WAN y ponerlo en el router neutro, a ver si una vez obtenida IP en el ZTE, le puedes pegar el cambiazo por el otro router con la misma Mac.

BocaDePez
BocaDePez

Buenas. Tengo un router neutro Netgear nighthawk R7000 y flasheado con DD-WRT a la ultima versión con soporte para configuraciones de Vlans. Quisiera substituir el ZTE tan malo que nos dan por este router y ponerlo como principal (RED FTTH JAZZTEL->ONT->NETGEAR R7000>ZTE), tal y como explicas tu, pero en vez de el switch Netgear mi router R7000. Mi conexión es la misma que la tuya (FTTH 200/200Mbps de Jazztel). Mi pregunta es la siguiente ¿La configuraciones que nos aportas solo sirve para switches o también se puede introducir en el DD-wrt de mi router. Lo he intentado pero me pierdo un poco en como configurar las vlans en este firmware. Gracias de antemano.

🗨️ 1
Curro1

Esa configuración es para un switch en concreto. Para poner cualquier otro router, ya tienes que probar configuraciones.

Por ejemplo, en mi router neutro Asus RT-AC68U, para conectarlo directamente al ONT, tengo que escoger el crear una configuración manual para la WAN (aunque curiosamente esté dentro del apartado LAN-IPTV), y configurarle las VLAN de esta forma:

- Seleccionar configuración ISP: Manual (Para poder editar libremente la configuración de VLAN)

- Internet: VID: 1074 / Prio: 0
- Lan Port 4: VID: 0 / Prio: 0 (o sea, sin configurar)
- Lan Port 3: VID: 0 / Prio: 0

El "IGMP proxy", el "IGMP snooping", y el "UDP Proxy (Udpxy)" están deshabilitados.

Y luego, editar la configuración del router ZTE para desactivarle la casilla de VLAN y conectarle la boca WAN a cualquier boca del router neutro. En mi caso tuve que ponerle al ZTE otro rango de red, 192.168.3.1, porque se negaba a coger IP por dhcp del router neutro, generando él un rango igual.

jeivi2

He recibido el switch Netgear GS105ev2 pero no puedo configurarlo. En el momento que conecto el switch con el ordenador y abro el Prosafe Utility me dice "No switch exists in the local area network". Lo he intentado de varias maneras pero no hay forma.-

¿Alguna ayuda?

🗨️ 10
Curro1

(EDITO: Perdón, el GS105ev2 no lo conozco, desconozco si se configurará igual que el v1).

Echa un vistazo al primer mensaje: prueba a ponerle provisionalmente una IP fija al equipo desde el que lo vas a configurar, del mismo rango de subred de la que usa por defecto el switch, para poder acceder la 1ª vez a configurarlo.

Para configurar el GS105E, poned una IP fija al equipo, como por ejemplo, 192.168.0.3, sin puerta de enlace (vacía). Tras configurarlo se vuelve a la IP anterior o automático.

Instalar el software del switch (Prosafe utility, winpcap, adobe Air), que accederá a 192.168.0.239, con password "password" por defecto la 1ª vez.

Es posible que el switch que te hayan dado ya venga configurado por alguien, y le haya puesto otros valores raros, a saber. Mira a ver si tienes para resetearlo, si no puedes acceder como se describe arriba.

🗨️ 8
jeivi2

Ya lo he solucionado,,,pero ¿Cómo desmarco la casilla de VLAN del ZTE h218n? Es que no la encuentro....

🗨️ 7
Curro1

Si los menús son similares a los del h298n:

Tiene un menú desplegable con los perfiles, y hasta que no selecciones el de WanConnection o algo así, no te lo muestra.

Echa un ojo aquí. Fíjate en el desplegable "Connection Name", que permite escoger. Creo recordar que simplemente tenías que seleccionar allí el perfil que estaba configurado (salía un perfil vacío por defecto, ojo).

Si no encuentras la opción, conéctalo directamente al ONT y llama al 1565, pidiendo que te desactiven la VLAN 1074 del router.

Importante: antes de tocar, dale a salvar la configuración del router en un archivo, por si tuvieras que recargarlo más adelante.

🗨️ 6
jeivi2
🗨️ 5
Curro1
🗨️ 4
jeivi2
🗨️ 3
jeivi2
🗨️ 2
Curro1
🗨️ 1
BocaDePez
BocaDePez
jeivi2

Ya está solucionado. Intenté conectar el switch en un Macbook Pro virtualizado en "Parallels" con Windows 7 y no reconocía el switch. Después lo probé en un HP con Windows XP original y ya reconoció el switch.-