BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

Configuracion OpenWRT BB + TP Link + WifiClientesR

mutilo7

Hola. Empiezo un nuevo tema, dedicado sólo a la configuración en OpenWRT para poder conectarse a traves del router a una red wificlientesR:

Me guié por varios tutoriales: uno, dos, tres.

Los datos de la red son estos:

Nombre de la red: wificlientesR
Método EAP: TTLS
Autenticación de fase 2: MSCHAPV2
Identidad: "mi_usuario"
Identidad anónima: wificlientesR
Contraseña: "mi_contraseña"

1.- Tengo instalado Openwrt BB 14.07, una versión con wpad incluído.

2.- En Interfaces elimino WAN y WAN6. En Wifi elimino las redes que había y busco la WIFICLIENTESR.

3.- Introduzco los datos de la red, guardo, reinicio y se conecta, pero apenas permanece un minuto conectado, y se desconecta:

Sun Mar  6 19:01:03 2016 daemon.notice netifd: wwan (1112): Received SIGTERM
Sun Mar  6 19:01:26 2016 kern.info kernel: [  107.620000] wlan0: authenticate with xx:xx xx:xx:xx:xx
Sun Mar  6 19:01:26 2016 kern.info kernel: [  107.640000] wlan0: send auth to xx:xx xx:xx:xx:xx (try 1/3)
Sun Mar  6 19:01:26 2016 kern.info kernel: [  107.650000] wlan0: authenticated
Sun Mar  6 19:01:26 2016 kern.info kernel: [  107.670000] wlan0: associate with xx:xx xx:xx:xx:xx (try 1/3)
Sun Mar  6 19:01:26 2016 kern.info kernel: [  107.670000] wlan0: RX AssocResp from xx:xx xx:xx:xx:xx (capab=0x1411 status=0 aid=1)
Sun Mar  6 19:01:26 2016 kern.info kernel: [  107.680000] wlan0: associated
Sun Mar  6 19:01:26 2016 daemon.notice netifd: Network device 'wlan0' link is up
Sun Mar  6 19:01:26 2016 daemon.notice netifd: Interface 'wwan' has link connectivity
Sun Mar  6 19:01:26 2016 daemon.notice netifd: Interface 'wwan' is setting up now
Sun Mar  6 19:01:27 2016 daemon.notice netifd: wwan (1168): udhcpc (v1.23.2) started
Sun Mar  6 19:01:27 2016 daemon.notice netifd: wwan (1168): Sending discover...
Sun Mar  6 19:01:30 2016 daemon.notice netifd: wwan (1168): Sending discover...
Sun Mar  6 19:01:33 2016 daemon.notice netifd: wwan (1168): Sending discover...
Sun Mar  6 19:02:03 2016 daemon.notice netifd: Network device 'wlan0' link is down
Sun Mar  6 19:02:03 2016 daemon.notice netifd: Interface 'wwan' has link connectivity loss
Sun Mar  6 19:02:03 2016 kern.info kernel: [  143.770000] wlan0: deauthenticated from xx:xx xx:xx:xx:xx (Reason: 23=IEEE8021X_FAILED)
Sun Mar  6 19:02:03 2016 daemon.notice netifd: wwan (1168): Received SIGTERM

Despues probé a hacer una configuración más fina a través de Putty:

1- Modifico /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option path 'platform/qca953x_wmac'
        option htmode 'HT20'
        option disabled '0'
        option channel '1'
        option txpower '19'
        option country 'US'

config wifi-iface
        option network 'wwan'
        option ssid 'wificlientesR'
        option device 'radio0'
        option mode 'sta'

2- Creo /etc/wpa_supplicant.conf y le añado:

ctrl_interface=/var/run/wpa_supplicant
eapol_version=1
ap_scan=1
fast_reauth=1
network={
        scan_ssid=1
        ssid="wificlientesR"
        key_mgmt=WPA2-EAP
        pairwise=CCMP AES
        proto=WPA2
        eap=TTLS
        phase2="MSCHAPv2"#Tambien probé con PAP
        identity="USUARIO"
        anonymous_identity="wificlientesR"
        password="CLAVE"
}

3- Reinicio, pero así ya ni se conecta.

¿Qué es lo que estoy haciendo mal? ¿Estoy configurando algo donde no debería? Probé de más formas pero no consigo nada...

Un saludo

BocaDePez
BocaDePez

Prueba a dejar anonymous_identity en blanco y de cambiar el option country a ES

🗨️ 8
mutilo7

Perdón, option country 'ES' ya lo tenia ES. Aunque elimine anonymous_identity="wificlientesR" tampoco se conecta.

¿Es correcto el archivo /etc/wpa_supplicant.conf el que tengo que editar? ¿Será otro, en otra ubicación? ¿O tengo que poner en alguún otro archivo que use los datos que hay en ese?

🗨️ 7
BocaDePez
BocaDePez

Has realizado la configuracion desede lucí?

🗨️ 6
mutilo7

La primera configuración la realizo desde LuCi:

En Network>Interfaces elimino WAN y WAN6. En Network>Wifi elimino las redes que había.

En Network>Wifi le doy a SCAN y selecciono WIFICLIENTESR. La configuro con los datos del primer post.

En ese momento se conecta, pero al cabo de un minuto se desconecta. En System Log aparece esta linea: wlan0: deauthenticated from xx:xx xx:xx:xx:xx (Reason: 23=IEEE8021X_FAILED)

vukits, yo estoy usando wpad, que contiene hostap + wpa_supplicant, en el mismo paquete, debería de funcionar igual, no? ¿Cual es la ubicación exacta de la configuración de wpa_supplicant?

🗨️ 5
vukits
🗨️ 4
mutilo7
🗨️ 3
BocaDePez
BocaDePez
🗨️ 2
mutilo7
🗨️ 1
mutilo7
vukits

perdona por no contestar, estaba líado.

seguimos en este hilo, que el anterior está saturado :P.

aquí un tío se ha conectado a eduroam con este wpa_supplicant.conf (rellena también el config/wireless por si acaso) .. y el hombre ha usado wpa_supplicant

wpa_supplicant config works without issues, and here is how it looks like:

ctrl_interface=/var/run/wpa_supplicant
fast_reauth=1
network={
ssid="eduroam"
key_mgmt=WPA-EAP
eap=TTLS
anonymous_identity="anonymous@uni-greifswald.de"
identity="username"
password="password"
ca_cert="/root/deutsche-telekom-root-ca-2.crt"
phase1="peaplabel=0"
phase2="auth=PAP"
}
🗨️ 1
vukits

ctrl_interface=/var/run/wpa_supplicant
eapol_version=1

# EAP fast re-authentication
# By default, fast re-authentication is enabled for all EAP methods that
# support it. This variable can be used to disable fast re-authentication.
# Normally, there is no need to disable this.

fast_reauth=1

#*******Configuração para eduroam***************************
# Esta configuração poderá necessitar de alteração
# de acordo com a instituição, pois ao contrario
# do que é divulgado, as configurações são diferentes
# em cada universidade/politecnico
#***********************************************************
ap_scan=1
network={
ssid="eduroam"
scan_ssid=1
key_mgmt=WPA-EAP
pairwise=CCMP
group=CCMP
eap=TTLS
proto=WPA2
phase2="auth=PAP"
anonymous_identity="anonymous@ucm.es"
identity="...."
password="...."
}

he conseguido que me asocie con wpa_supplicant.conf

lo suyo sería obtener ip..

te cuento el martes