BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

Conexiones de Red entre Windows XP y Windows NT 4.0

verdees

Hola, antes de nada, decir que he intentado buscar en el foro algo que se asemejara a mi problema, pero no he encontrado la herramienta de busqueda. Así que disculpas de antemano en el caso de que esta cuestión esté ya respondida.
El problema es el siguiente: tengo una red con unos 30 ordenadores con Windows Nt 4.0 con service pack 5. El mantenimiento en cuanto a software de dichos ordenadores al que estoy autorizado se limita simplemente a clonarlos con una imagen preestablecida, sin posibilidad de que la modifique, ni nada por el estilo; me explico, los ordenadores tienen que tener ese SO por narices, y no puedo ni actualizarlo ni tan siquiera modificarlo.
No obstante, tengo otro ordenador en el que sí tengo total libertad de actuación, y le he instalado el windows XP. He ejecutado windows update y tengo las últimas actualizaciones hasta la fecha. En el mismo equipo, tengo instalado una misma copia del NT antes mencionado en otra partición.
El problema es que no tengo acceso desde entorno de red a los demás equipos de la sala; sin embargo puedo conectarme a sus discos compartidos por el comando NET USE y no me da ningún problema. Con eso me evito casi cualquier cosa en lo que se refiere a conectarme desde mi pc a cualquier otro de la sala, pero el problema viene a la inversa. Los demás pcs no se pueden conectar a las carpetas que tengo compartidas, puesto que mi equipo no aparece en su "entorno de red" nada más que cuando arranco con el NT. Esto es un engorro, puesto que no tengo drivers de NT para la impresora, y cuando alguien quiere imprimir algo en A3 tengo que andar cambiando de sistema operativo varias veces.
¿Cómo podría hacer para que mi equipo fuese visible desde los otros pcs cuando está ejecutando el XP?
La configuración IP está bien, no obstante en las propiedades de las conexiones del NT me aparecen cosas que no me cuadran con las disponibles para instalar en el XP.

En la conexión de red del XP tengo instalados los siguientes elementos:
-Cliente para redes de Microsoft
-Programador de paquetes QoS
-Compartir Impresoras y Archivos para Redes Microsoft
-Protocolo TCP/IP

En la configuración de la conexión de los NT, además del protocolo TCP/IP, aparecen los siguientes servicios:
-Configuración de RPC
-Estación de Trabajo
-Examinador de equipos
-Interfaz NetBIOS
-Servidor.

Supongo que me falta algún servicio que sea equivalente a los del NT; he probado a instalar en el XP el "Protocolo de transferencia compatible con NWlink/.../NetBios" pero eso me ocasionó que dejara de funcionarme lo de conectarme por NET USE y no me arregló el otro problema.

Espero que me haya explicado bien, y si alguien me puede ayudar, le doy las gracias de antemano.

Este tema está cerrado a nuevas respuestas. Abre un nuevo tema para retomar la conversación.
KATOR

El Xp lo tienes metido en el dominio??

Chao.

JoeDalton

Tienes servidor wins?
Tiene puestas wins el windows xp?
ten en cuenta que con 2000/xp los nombre se resuelven por dns, seguramente sea ese tu problema, que no es capaz de resolver nombres.

Lo del dominio que dice Kator, tb compruebalo, y si está fuera del dominio, tienen que concidir usuario/contraseña para acceder, además, si el xp no tiene contraseña no puede acceder a recursos y no es accesible como recurso.

Saludos.

🗨️ 3
Polanko2k

Pero si que se veria como equpio, lo primero en lo que he pensado es en lo de los usuarios/contraseñas, pero lo raro es que no se ve ni el equipo en el entorno de red (el problema con el user/pass lo daria al intar entrar a ese ordenador).

Sobre lo del wins, tiene instalado el protocolo NetBIOS, asi que no deberia darle problemas...

Asegurate de que estan en el mismo grupo de trabajo, y mira si desde otro equipo puedes acceder mediante la IP (inicio -> ejecutar -> \\Ip_del_XP), si asi entras sera un problema del protocolo.

Tambien podrias instalar el service pack 6 (el ultimo, creo). Un saludo.

🗨️ 2
JoeDalton

incluso tengo mis dudas de que pudiera ser el firewall de xp, aunque no haya wins, o bien trabajarían por el archivo lmhosts, o bien haciendo broadcast, de estar activado tengo mis dudas que responda los broadcast.

🗨️ 1
Polanko2k

Con el firewall del XP configurado por defecto no puedes hacer absolutamente nada, podria ser eso tambien. propiedades avanzadas de tu conexion y quitas la opcion de proteger tu ordenador.

BocaDePez
BocaDePez

en una pequeña red, se puede usar el administrador de red de windows xp para poder administrar la red dese una pc, que controle el trafico a la red, impresora, antivirus e seridor?????

verdees

Bueno, respecto a lo del Wins en efecto, está desactivado y utiliza la opción de habilitar la búsqueda de lmhosts. Así es como está el NT 4 de la otra partición y funciona.
El firewall del XP está desactivado.
Otra cosa curiosa es que con el xp encendido no responde a los pings, es como si no estuviese, así que me da que va a ser lo del dominio.
A ver cómo lo arreglo, por que no tengo npi de cómo va eso.

Muchas gracias a todos.

🗨️ 4
KATOR

Boton derecho en mi PC, propiedades, nombre de equipo, boton ID de Red, sigue el asistente y te pedira el administador y el password (del dominio o servidor), el nombre de la maquina (IP) y el nombre del dominio, reinicias y lo tienes en el dominio.

Chao.

JoeDalton

si no responde a los pings... chungo...
el tema de los wins, los equipos resuelven por broadcast (si tienes muchos te recomiendo que instales un servidor wins, disminuye el tráfico de red) seguramente los equipos al hacer broadcast, xp no responde, mira a ver no tengas alguna otra aplicación filtrando el tráfico del equipo (el cliente vpn de cisco tiene el statut firewall que no permite conexiones entrantes contra tu máquina, no siendo necesario que estés conectado por vpn para que esté habilitado) así que puede que tengas algú software similar.

Te recomiendo que...
- Resuelvas el tema del ping.
- Pruebes a acceder con \\ip\recurso

Una vez que tengas comunicaciones contra ese equipo ya te buscarás la vida para hacer que los demás 'lo vean'

Saludos.

🗨️ 2
KATOR

No me habia dado cuenta, pero si la maquina no responde al ping, mal asunto.

Has comprobado que la IP este dentro del rango de la red?

Has comprobado las DNS, la puerta de enlace.

Lo primero que tienes que resolver es la conectividad de la maquina con la red, empieza por la tarjeta de red, latiguillo, etc.

Una vez de que tengas ping lo demas es mas sencillo

Chao.

🗨️ 1
Polanko2k

una aclaracion, las dns y la puerta de enlace no afectan a que una maquina, ya que las dns son para la resolucion de nombres i la puerta de enlace...

Si fuera el cable o algo fisico desde windows NT tampoco contestaria a los pings... nose, prueva reinstalando el protocolo tcp/ip, por decirte algo.

Si das con la solucion, cuentalo k me interesa, un saludo.

verdees

Si, la configuración IP en cuanto a DNS y puerta de enlace está exactamente igual en los dos SO. Como he dicho, tengo dos SOs en el mismo equipo, cuando arranco el NT no hay problemas, tengo acceso a todo, pero con el XP no. Eso descarta cualquier problema de cableado.
He mirado en el NT, y no está unido a ningún dominio, y he estado pensando, que si el XP no va tal vez sea por que los administradores que están por encima de mi no quieren que vaya otra cosa que no sea el NT que ellos tenían montado.
Me explico, es una sala de acceso público de la universidad, y yo estoy allí por una beca. Como mi escuela está al lado de la facultad de informática, algunos alumnos venían de allí y se ponían a hacer "prácticas de hacking", arrancaban con el Knoppix ese y hacían lo que les daba la gana en la red.

Así que a ver si voy un día por la mañana y hablo con los jefes, y se lo comento, por que a mi ya me sobrepasa.

Lo que me parece rarísimo es lo de los pings, pues sin embargo, desde el equipo con el XP sí me responden los demás al ping, y ahí si no me equivoco, no interviene el dns para nada...
Bueno, muchas gracias por todo otra vez, y un saludo

🗨️ 7
KATOR

Has probado a compartir alguna carpeta del XP???

Ten en cuenta que el 2k ya las comparte por defecto de forma administrativa, el XP no.

Mira a poner una carpeta compartida en el XP y le haces un ping a ver si te contesta.

Chao.

🗨️ 6
MaestroJedi

Windows XP también comparte los discos duros que tengas en modo Administrativo, bajo los nombres C$, D$, etc etc

Se puede desactivar, pero de forma predeterminada lo hace también (yo desde luego, aunque tengo contraseña de Administrador, paso de tenerlo habilitado...).

Saludos

🗨️ 3
KATOR

Por lo menos en dos equipos que tengo conectados en red con XP, no se comparten, ni se ven, si no compartes alguna carpeta o unidad.

He estado leyendo, y no veo por ningun lado que el XP comparta unidades o carpetas con propositos administrativos.

Ahora mismo estoy probando y si dejo de compartir, no veo la otra maquina, ni siquiera hace ping.

A lo mejor tienes razon, pero yo no lo veo claro.

Chao.

🗨️ 2
JoeDalton
🗨️ 1
KATOR
verdees

Si, ese no es el problema, tengo un disco duro compartido y varias carpetas del otro.
Me acabo de dar cuenta que en el xp no tengo creadas cuentas de usuarios restringidos, pero aún así... ¿no debería responder a los pings igual?

Los permisos de las carpetas, sin embargo, están en control total para todos los usuarios

🗨️ 1
JoeDalton

soluciona el problema de los pings... y a partir de ahí miramos lo otro... fijo que tienes ahí un software firewall filtrando tráfico... incluso te diría que entraras en modo seguro con funciones de red y comprobaras conectividad (ping) con otras máquinas, desde y hacia esa máquina.

saludos.