BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

Fibra

Conexión PPPoE da Timeout waiting for PADO packets en Movistar fibra con pfSense

tonhitux

Hace tiempo que tengo el HGU de Movistar en modo brigde y uso un equipo con pfSense para gestionar mi red.

En general todo va bien hasta que tengo que actualizar el pfSense y reiniciar (o se va la luz). A veces la interfaz PPPoE se conecta si más y a veces tarda horas y horas en conectarse. Cuando no consigue conectar, los logs de PPP muestran un error de "Timeout waiting for PADO packets".

Según he estado leyendo, esto significa que la OLT no está respondiendo a los paquetes de inicio de conexión que envía el pfSense, lo cual quiere decir que el problema está en la OLT y no en mi firewall. Sin embargo, cuando vuelvo a poner el HGU en modo "normal", la conexión se establece en cuestión de pocos segundos siempre.

He tenido este problema en pfSense, OPNsense e IPFire.

¿A alguien más le ha pasado? ¿Hay alguna manera de evitarlo?

BocaDePez
BocaDePez

¿Tienes el pfsense virtualizado?

Yo tengo la misma configuración que tú, con pfsense virtualizado, y me funciona todo perfectamente. Tuve que desactivar las opciones de hardware offloading de las interfaces de red, eso sí. (system > advanced > networking)

🗨️ 1
tonhitux

Hola.

Yo no lo tengo virtualizado pero sí tengo esas opciones desactivadas.

SrPolilla

Tengo una instalación con Opnsense y un HGU y lo que tengo configurado es la IP del firewall en la DMZ del router y no he tenido ningún problema (ni con actualizaciones ni con cortes de electricidad).

Quizás no es la mejor opción pero me ahorra quebraderos de cabeza.

rbetancor
1

La OLT no tiene nada que ver, porque la OLT no es quien gestiona las sesiones PPPoE.

Ese problema se suele presentar con algunos modelos de HGU de forma aleatoria, solo se soluciona reiniciando el HGU, parece cachear algo y se queda tonto.

BocaDePez
BocaDePez
1

Hay cuatro modelos de HGU, y no lo indicas.

Si es el MitraStar GPT-2541GNAC, del fw b54 en adelante, el modo bridge(semi) es algo inestable.

Baja a la version 38_2, que se puede encontrar por inet.

Si es cualquier otro modelo, actualiza a la ultima version disponible.

🗨️ 2
BocaDePez
BocaDePez

¿Has conseguido poner en Bridge el GPT-2741GNAC y que funcione? He probado en 2 domicilios distintos y no ha habido manera…

tonhitux

Buenas,

Unos meses después, he instalado el firmware 38_2 y el problema sigue.

El único modo de reconectar cuando reinicio o apago la máquina con pfsense es hacer reset de fábrica en el HGU y volver a ponerlo en modo bridge.

tonhitux

Tengo el modelo: GPT-2541GNAC en modo bridge funcionando con los problemas ocasionales que expongo en este hilo…

La versión del software es: ES_g3.5_100VNJ0b54_7_CA

🗨️ 1
vukits

¿Por qué no le programas al HGU un reinicio diario de madrugada?