Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

hosting en interdominios
193 lecturas y 26 respuestas
  • Cerrado

    6

    ¿Comtrend HG536+ bloquea puertos abiertos en NAT?

    Tengo un comtrend hg536+ de jazztel 20Mg pero me es imposible hacer funcionar el Realvnc desde el exterior.

    En NAT redirijo el puerto (configurado en el RealVnc) a la direccion de red (configurada fija) de mi equipo donde tengo en ejecución el RealVnc

    Al conectar con la dirección publica de Internet obtengo siempre - failed to connect: Connection refused (10061)

    Si pruebo con la dirección privada de mi red funciona perfectamente desde el mismo ordenador, desde otro y desde el movil con wifi.

    He probado a activar el firewal del router y desactivarlo pero no funciono.

    En avanced setup Wan tengo:

    VPI/VCI Con. ID Category Service Interface Protocol Igmp Nat Firewall QoS State Remove Edit
    8/35 1 UBR pppoe_8_35_2 ppp_8_35_1 PPPoE Disabled Enabled Disabled Enabled Enabled

    Con mi anterior operador un cable modem y un linksys no tenia ningun problema.

    El firewall del karspesky que uso he probado a tenerlo desactivado.

    Si compruebo los puertos que tengo en NAT desde Internet me dicen que están cerrados. Sin embargo el lphant se abre con id alta con su regla del Nat y id baja al quitarla.

    Yo pienso que es del router que no redirige las reglas de Nat. Al menos la del RealVnc. Y que pueda ser algo que tenga que desactivar o activar. ¿Pero cual?

    Tengo instalado la ultima versión (creo) que aparece mas arriba del firmware la:

    A101-302JAZ-C03_R18.A2pB021g.d15h

    Ahora mismo estoy bloqueado. En Internet no he encontrado la solución.

    Alguna cosa para probar. Gracias.

    Saludos

    Este tema es antiguo y puede contener información obsoleta. Abre un nuevo tema para publicar tu mensaje.
    1
      • Cerrado

        6

        He probado con el tcp y udp abiertos y sigue el problema.…

        He probado con el tcp y udp abiertos y sigue el problema.

        Tambien se conecta bien en la red local desde el mismo ordenador, desde otro ordenador de la red y desde el movil por wifi.

        Lo de hacer un tunel ssh se me escapa de mis conocimientos.

        Ya no es que funcione usando otro metodo. Es la duda que tengo de saber porque no funciona. Porque debería funcionar, no?

        ¿Alguien me puede confirmar si le funciona en este router el realvnc desde la ip externa?

        He probado desde el sistema operativo Vista que lo tengo en otra particion del ordenador y tambien sigue el mismo problema.

        Asi que me da que pensar que pueda seguir siendo algo mal configurado en el router. Le instale el ultimo firmware con la configuracion de fabrica.

        Ya no se que mas puedo probar, otro router adsl pero no dispongo de el (me sacaria de dudas).

        Gracias de todas formas.

          • Cerrado

            6
            Bueno, al final creo haber dado con la solución. Este router…

            Bueno, al final creo haber dado con la solución. Este router (según como esta configurado) no acepta las conexiones desde cualquier ordenador de mi red privada al intentar acceder desde la dirección publica (87.217.xxx.xxx) de Internet. Si uso la dirección privada (192.168.xxx.xxx) de mi red conectaban sin problemas.

            Yo las pruebas que hacia era desde el móvil por wifi, desde el mismo ordenador y desde otro ordenador en red, por que con mi anterior router (wrt54g) siempre me habían funcionado estas pruebas sin problemas. Si estaba bien configurado conectaba.

            Al final me he dado cuenta al desactivar en el móvil la wifi, e intentar conectar desde la red del móvil que es diferente a la del Adsl, y ver como se conectaba.

            Vaya comida de cabeza me he pegado, pero bueno al final se encontró la solución.

            Así que gracias a todo el que me ha ayudado y haber si le sirve este post a algún otro para resolver sus dudas.

            Saludos. Cjms

            • Cerrado

              [Editado Ari 16/03/10 14:35]

              BocaDePez BocaDePez
              6
              oye podrías explicarme bien como lo has hecho, intento hacer…

              oye podrías explicarme bien como lo has hecho, intento hacer lo mismo que tu para controlar el pc desde el movil pero no lo consigo tio!

              • Cerrado

                6
                Este tema ya es antiguo, además de que las soluciones deben…

                Este tema ya es antiguo, además de que las soluciones deben aportarse para todos los usuarios y en el foro: es un poco descortés pedir la solución a un problema en privado cuando puede beneficiar a otros si se deja en público :)

                Tengo que cerrar este tema por reflote, pero si continuas con tus dudas puedes abrir un tema nuevo, referenciando a este, con tu consulta :)

                Saludos y cierro por reflote

            • Cerrado

              BocaDePez BocaDePez
              6
              El Comtrend, al igual que la mayoría de routers ADSL que dan…

              El Comtrend, al igual que la mayoría de routers ADSL que dan los proveedores, no tiene NAT Loopback.

              Eso quiere decir, que toda conexión iniciada desde la LAN a la IP pública, aparecerá siempre como originada en la interfaz eth0: y no en la ppp:

      • Cerrado

        6

        Respondere en orden: Lo que escucha en el puerto 14900 es el…

        Respondere en orden:

        Lo que escucha en el puerto 14900 es el realvnc ejecutandose.

        Tengo solo una ip en el pc. Al pasar los datos me equivoque y donde pone athlondual tenia que poner athlonduo. Osea asi:

        TCP athlonduo:14900 athlonduo:0 LISTENING

        TCP athlonduo:14900 athlonduo:1194 ESTABLISHED

        TCP athlonduo:1194 athlonduo:14900 ESTABLISHED

        Que yo sepa desactivo el karpesky entero, he probado con otro ordenador a desinstalarlo y probar. Y despues a activar el propio de xp y permitir el puerto y sigue todo igual. Que yo sepa no tengo ningun firewall mas.

        Despues de un Netstat -an

        Solo con el RealVnc Server abierto

        TCP 0.0.0.0:14900 0.0.0.0:0 LISTENING

        Despues de crear una conexion desde dentro con el mismo ordenador:

        TCP 0.0.0.0:14900 0.0.0.0:0 LISTENING

        TCP 192.168.1.100:1274 192.168.1.100:14900 ESTABLISHED

        TCP 192.168.1.100:14900 192.168.1.100:1274 ESTABLISHED

        El real vnc server me da la siguiente informacion para conectarme y lo tengo configurado para que escuche la 14900

        address:192.168.1.100::14900

        URL: http://192.168.1.100::14900

        Y al dar un test que aparece en el RealVnc me dice:

        Connection test succeeded.

        Your VNC server and network are correctly configured to accept connections over the Internet.

        However, please note that your server appears to be behind a NAT router with IP address 87.218.234.49. If you are connecting from outside your LAN, then you will need to use this IP address.

        Desde donde obtengo la ip publica que accede al router, el cual tengo la siguiente regla en NAT

        RealVNC Listen 14900 14900 TCP 14900 14900 192.168.1.100

        y al intentar conectar con el vnc viewer con esta direccion:

        87.218.234.49:14900

        me responde esto

        failed to connect:connection refused (10061)

        Y esto lo hacia antes con otro router sin problemas. Creo que todo lo hago bien. A no ser que tenga algun servicio en Xp desactivado. O se bloquea en el router o en el xp. Hago algo mal.

        Gracias

          • Cerrado

            6
            En red local conecto sin problemas. La ip externa ya me ha…

            En red local conecto sin problemas.

            La ip externa ya me ha cambiado. Tendre mas cuidado para otra vez.

            He estado probando la pagina de shieldsUP y obtengo esto

            En el 14900 sin funcionar RealVNC la aplicacion me da Closed

            En el 14900 funcionando el RealVNC me da Open

            En el 14901 (por ejemplo) que no tengo nada sobre el en la NAT me da Stealth

            Segun esto puedo pensar que el router hace su trabajo pero hay algo que bloquea la conexion.

            Me da que pensar que estaria en el sistema operativo. Pienso bien o sigue pudiendo ser del router.

            Voy a probar abriendo con un nuevo usuario en xp. Ta luego y gracias.

            • Cerrado

              BocaDePez BocaDePez
              6
              Cuando dices "red local" ... ¿nos estamos refiriendo a otro…

              Cuando dices "red local" ... ¿nos estamos refiriendo a otro PC diferente en red LAN con ese?

              Porque una conexión desde el PC a sí mismo no es concluyente ...

            • Cerrado

              En el 14900 funcionando el RealVNC me da Open pues vaya :( ..…

              En el 14900 funcionando el RealVNC me da Open

              pues vaya :( .. el puerto sí que funca bien.

              si eso, haz un tunel ssh y ya está :D

              saludos

        • Cerrado

          BocaDePez BocaDePez
          6

          Perdón por partir mi respuesta en tres ... estoy tonto. En la…

          Perdón por partir mi respuesta en tres ... estoy tonto.

          En la web de ShildsUP! cuando haces el chequeo, si el router NO está escuchando en el puerto, te aparece un mensaje en verde que pone Stealth (oculto).

          Si el router está escuchando en el puerto, pero la aplicación por detrás no está contestando, te aparece un mensaje en morado que pone Closed

          Si el router está escuchando en el puerto y la aplicación contestando, te aparece un mensaje en salmón que pone OPEN!

        • Cerrado

          BocaDePez BocaDePez
          6

          Muchas gracias por proporcionar tanto detalle. Se echan en…

          Muchas gracias por proporcionar tanto detalle. Se echan en falta la mayoría de las veces usuarios como tú.

          Es raro lo que pasa, porque el procedimiento es correcto. Por cierto, no deberías decir tu IP externa en público nunca, aunque sea dinámica.

    • Cerrado

      BocaDePez BocaDePez
      6

      ¿Cómo va a bloquearlo? Si lo rediriges en la sección NAT es…

      ¿Cómo va a bloquearlo? Si lo rediriges en la sección NAT es para que quede abierto. Algo raro tienes que estar haciendo.

      Prueba un momentín a cerrar el lphant, y reconfigurar el VNC con el puerto del lphant, ya que ese puerto sí va bien.

      Si no funciona, deberás empezar a buscar fantasmas en otra parte.

      • Cerrado

        6

        No se me había ocurrido el cambiar por los del lphant pero…

        No se me había ocurrido el cambiar por los del lphant pero tampoco ha funcionado.

        La única info que encontré es de esta pagina:

        bandaancha.eu/tema/561647/firewall-comtrend-ct-536

        Un comentario de una persona en el post:

        "Yo he activado el firewall y todo me funciona como siempre, incluso el emule (id alta)... y eso q pone q estan todos los puertos bloqueados para entrada de datos... pero nose..."

        Se me olvidaba he actualizado el router a una versión mas nueva:

        A101-302JAZ-C03_R21.A2pB021g.d15h

        • Cerrado

          BocaDePez BocaDePez
          6

          Francamente ese hilo de hace 4 años, que es de cuando…

          Francamente ese hilo de hace 4 años, que es de cuando apareció el aparato, poco tiene que ver hoy en día.

          Una vez que programas la redirección del puerto en "Virtual Servers" ... ¿salvas la configuración y se reinicia el router?

          • Cerrado

            6
            Si salvo la configuracion y reinicio. Tarda 2 min + o - Se…

            Si salvo la configuracion y reinicio. Tarda 2 min + o -

            Se que es antiguo el post pero es lo unico que he llegado a encontrar relacionado.

            Probando los puertos si estan abiertos a traves del scan de puertos de internautas.org me da que todos los puertos que tengo seleccionados en la Nat que estan cerrados. Si ademas compruebo el 80 y el 21 me los da abiertos.

            Al comprobar con la aplicacion Simple Port Tester los puertos de la Nat y el 80 y el 21 me dice que estan todos "is online and can be reached".

            Sigo perdido.

                • Cerrado

                  BocaDePez BocaDePez
                  6
                  Pues es que no sé qué decirte, de verdad, porque en todos los…

                  Pues es que no sé qué decirte, de verdad, porque en todos los routers es siempre igual, y más simple que el mecanismo de un chupete, como se suele decir.

                  Lo único es cerciorarse que la IP privada a la que hemos redirigido los paquetes sea realmente la IP que tiene el PC en ese momento, y que el programa tenga el puerto a la escucha en esa interfaz específica, o en todas (0.0.0.0); eso lo podemos ver con un netstat -a comprobando que el puerto está en LISTENING correctamente.

                  Si los chequeos no van después, es que algo lo corta en medio: el cortafuegos de Windows o alguna suite antivirus de terceros.

                  • Cerrado

                    6
                    Pues el puerto sin conectar nada me aparece asi: TCP…

                    Pues el puerto sin conectar nada me aparece asi:

                    TCP athlondual:14900 athlonduo:0 LISTENING

                    Y al conectar dentro de mi red privada obtengo esto:

                    TCP athlondual:14900 athlonduo:0 LISTENING

                    TCP athlondual:14900 athlonduo:1194 ESTABLISHED

                    TCP athlondual:1194 athlonduo:14900 ESTABLISHED

                    Nose si aclara algo la situacion.

                    He probado tambien desde otro ordenador. Desinstalar el karpesky. Nada. Activar el firewall de windows y permitir el puerto que uso. Nada. Otra cosa. tengo xp servipack 3 con todas las actualizaciones instaladas. Nose si puede influir.

                    De todas formas gracias por el interes.

                    • Cerrado

                      BocaDePez BocaDePez
                      6
                      Estoooo ... tienes 2 IPs en el mismo PC. Saca los valores…

                      Estoooo ... tienes 2 IPs en el mismo PC. Saca los valores numéricos, porfa ... con netstat -an

                    • Cerrado

                      BocaDePez BocaDePez
                      6
                      Lo que veo ahí es que tienes algo escuchando en el puerto…

                      Lo que veo ahí es que tienes algo escuchando en el puerto 14900 en todas las interfaces. No sé si ese puerto es el que tienes configurado para el RealVNC, ya que por defecto creo que era el 5900. Aunque da igual el número que elijas, siempre que sea el que aparezca redirigido en el router, a la IP de la máquina.