Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

hosting en interdominios
77 lecturas y 20 respuestas
  • Cerrado

    Comtrend CT-351 en Red Hat Linux 9

    Estoy intentando poner en marcha este modem para mi conexión ADSL 1Mb de Jazztel.

    He encontrado esta guía de instalación que me cuadra mucho: http://perso.wanadoo.es/seralvil/adsl/imprimir.htm.

    Me he bajado la última versión que he encontrado de los drivers del amigo Albert Herranz:

    eagle-driver-1.0.4-12.rh9.i386.rpm
    kernel-module-eagle-1.0.4-12.rh9_2.4.20_8.athlon.rpm

    Bien, el problema surge porque yo tengo un PC Athlon con kernel 2.4.20-8bigmem, pero no existe el módulo correspondiente a este kernel.

    Igualmente, he probado a instalarlo, y me sale un aviso muy claro de que el paquete que instalo no es para el kernel que tengo, aunque acaba instalándose igualmente.

    Y cuando conecto el módem se encienden los dos leds, Connection y Data, cosa muy rara, y en el fichero /var/log/messages veo que el modem ha sido detectado en el puerto USB, y luego estos mensajes muy negativos:

    kernel:usb.c : USB device 3 (vend/prod 0x1110/0x9022) is not claimed by any active driver
    /etc/hotplug/usb.agent: ... no modules for USB product 1110/9022/5000

    Con esto no me queda claro si el problema es que los drivers no sirven para el modem en cuestión o si es que el módulo instalado no corresponde a mi kernel.

    Supongo que es esto último, y no tengo ni idea de una posible solución. ¿Es factible cambiar de kernel y pasar al 2.4.20-8 simplemente? ¿O tendré que esperar a que esté disponible el driver para el kernel 2.4.20-8bigmem?

    Este tema es antiguo y puede contener información obsoleta. Abre un nuevo tema para publicar tu mensaje.
    1
      • Cerrado

        BocaDePez BocaDePez
        6

        hola. soy nuevo y he intentado utilizae el ueagle-atm y no…

        hola. soy nuevo y he intentado utilizae el ueagle-atm y no logro compilarlo porque llama a un irectorio llamado build en el direcotio del kernel. me podeis decir que debo hacer para hacerlo funcionar?
        gracias

    • Cerrado

      BocaDePez BocaDePez
      6

      soy nuevo en debian y me aparece el siguiente error cuando…

      soy nuevo en debian y me aparece el siguiente error cuando ingreso eaglectrl -d

      Can't find any post-firmware devices.
      But I've been able to find a pre-firmware one.
      Wow .. eagle-usb driver should have transform this in post-firmware...

      si alguien me puede ayudar se lo agradezco. :-(

    • Cerrado

      BocaDePez BocaDePez
      6

      como os va tenngo plobemilla como poder abrir yo purtos…

      como os va tenngo plobemilla como poder abrir yo purtos ct-351 por caridad gracias

    • Cerrado

      BocaDePez BocaDePez
      6

      Hola a todos, he seguido todos los consejos que dáis en este…

      Hola a todos, he seguido todos los consejos que dáis en este hilo para configurar una conexión coin este módem en una fedora 4. Llego a que el módem esté operacional, pero al ejecutar el comando startadsl, se queda colgado. La luz de conection está bien y el módem está operativo, pero no consigo que se conecte.
      Al intentar ejecutar eaglectrl -d me dice que el dispositivo está ocupado.

      Un saludo y muchas gracias de antemano.

    • Cerrado

      [Editado 8/01/05 10:43]

      Hola!!! yo he instalado este mismo modem que tu en varios…

      Hola!!! yo he instalado este mismo modem que tu en varios pc's pero en distros Debian, echale un ojo a este link que esta lleno de howto's y drivers de distintos colores:

      http://personal.telefonica.terra.es/web/adslusb/

      Ayer mismo, tuve un pequeño parto con expediente X incluido en la Debian de una amigo donde no me quedó más remedio que bajar el codigo de la ultima version del driver de eagleusb (la 2.0) y compilarla a mano, lo encontrarás aqui:

      http://www.eagle-usb.org/

      La pagina esta en francés, yo no tengo ni idea del idioma pero lo encuentras rapido y la instalacion es sencilla:

      ./configure
      make uninstall
      make clean (estos dos para eliminar otras versiones del driver)
      make
      make install

      y todo como una seda.

      Buena suerte y cuentanos.

      • Cerrado

        Hago el resumen de lo que he conseguido, no sé si mucho o…

        Hago el resumen de lo que he conseguido, no sé si mucho o poco, al menos he aprendido bastante...

        Lo primero que he hecho es cambiar de kernel, ya que he visto que el "bigmem" es sólo para sistemas con más de 4 GB, lo cual no es mi caso. No he tenido que hacer grandes virguerías: el kernel ya estaba compilado en mi PC y sólo ha sido cuestión de actualizar la configuración de arranque (Grub).

        Entonces, he probado a reinstalar el módulo eagle para el kernel, y al reconectar el módem en /var/log/messages ya he visto cosas más bonitas como "New USB ADSL device detected", etc., pero los dos leds se encendían y luego se apagaban para siempre.

        De manera que he pasado al plan B: bajarme los fuentes (de la página francesa) y seguir los pasos para la compilación e instalación.

        He desinstalado los dos paquetes RPM, eagle-driver y kernel-module-eagle, pues entiendo que quedarían instalados para nada, como residuos, si sigo este método de instalación. ¿Me equivoco?

        Entonces, he seguido todos los pasos, pero he modificado a manubrio el fichero eu_config_bash para que contuviera una línea correspondiente a mi proveedor: Jazztel. Los datos los he encontrado por ahí: VPI = 8, VCI = 35, ENC = PPPoA VC, etc.

        Así, he podido realizar la configuración con eagleconfig. Por cierto, vaya mejunje de lenguas este script: francés, inglés, español...

        Después de este paso me da la sensación de que el modem ha quedado sincronizado, porque el led "Connection" ha quedado encendido y además en /var/log/messages se ve algo así como: "Modem operational !!" y "Ethernet device eth1 created".

        Sin embargo, el siguiente y último paso, startadsl, ha fallado: el script se ha quedado colgado mientras lo ejecutaba. He visto en el messages que hacía N intentos de conexión pero le salía siempre algo así como: "LCP : Timeout sending Config-Requests".

        He reiniciado el PC, una y sucesivas veces, pero el led del modem nunca ha vuelto a estar encendido.

        He intentado configurar gráficamente la red, he creado nuevamente la eth1 y he indicado que se activase al inicio, pero ni modo, parecía que sí pero nunca se activaba esta interfaz.

        Otra cosa que he hecho es eliminar la ppp0, que era un residuo de cuando intenté hace tiempo (sin éxito) configurar mi conexión Alehop con módem de 56K.

        No sé, tal vez lo próximo que intente es, ya sin la interfaz ppp0, lanzar nuevamente ambos scripts. Para entendernos de forma simplista:

        * eagleconfig -> que el modem sincronize a nivel físico (led Connection encendido)

        * startadsl -> establecer la conexión PPP enviando mis credenciales

        ¿Qué te parece, FishMouth? ¿Es correcto lo que digo? ¿Tienes alguna idea de qué está pasando?

        Muchas gracias por la ayuda.

        • Cerrado

          Hmmmmm... veo que con Red Hat la historia se va por otros…

          Hmmmmm... veo que con Red Hat la historia se va por otros derroteros. Como te dije yo he instalado este modem solo en Debian y derivadas, en ninguna de ellas tuve que tocar nada de la configuración de la red ni de modems ni de conexiones ppp, eagle-usb una vez compilado y cuando lo ejecutas carga el modulo del modem y lo hace funcionar, sabes que esta todo ok cuando se enciende la luz de Conexión para indicar que sincroniza, tipeo startadsl y luego la luz de datos parpadea cuando hay trafico.
          El único problema raro que tuve fue en una ubuntu dode me faltaba el pppoe que instalé con apt-get, pero luego, fino como la seda.
          No se, quizá sea algo de la configuración de jazztel que le has introducido al modem, me pareció ver por algun foro que para poner el vpi y vci había alguna historia extraña, si te fijas, la conexión ES01 que es la de dinamica de telefonica, pone como VCI un 20, y como ya sabes telefonica tiene 32, quizá vaya por ahi la historia, en la web que te pasé hay unos foros, echales un ojo que seguro que allí esta el tema.

          Suerte y cuentanos que tal!

          • Cerrado

            ¡Eureka! FishMouth, me has dado la buena pista: 20 es en…

            ¡Eureka!

            FishMouth, me has dado la buena pista: 20 es en hexadecimal lo que 32 es en decimal. He visto que, en efecto, los valores de VPI y VCI en el fichero 'eu_config_bash' venían en hexa. De hecho, ya había en el fichero de marras una entrada genérica para varios proveedores españoles exactamente con los datos que yo tenía entendidos para Jazztel. Es el ES03.

            O sea, primera conclusión: si tienes una conexión ADSL 1 Mb de Jazztel, con modem y dirección IP dinámica, has de elegir el provedor ES03 cuando te pregunte el script 'eagleconfig'. Así lo he hecho y ha funcionado: el led "Connection" se ha quedado encendido, ¡al fin!

            He comprendido que lo hace este script, una vez recopilados todos los datos relativos al tipo de conexión, los parámetros de PPP como usuario y password, etc, es cargar el driver y, luego, cargar el DSP en el dispositivo, con lo cual el modem queda ya operativo. Crea para acabar la interfaz ficticia eth1, que queda asociada con el dispositivo modem.

            Luego, he ejecutado sin problemas el script 'startadsl', éste arranca el demonio pppd y crea dinámicamente la interfaz ppp0, vamos, que establece la conexión punto a punto y ya tenemos acceso a internet.

            Lo malo es que al reiniciar el equipo la conexión no se restablece (aunque 'eagleconfig' me había preguntado si quería, pero no parece tener efecto). Los pasos que hay que seguir para conectarse de nuevo son:

            # eaglectrl -d -> cargar el driver, el DSP y crear la eth1, vamos, poner operativo el modem

            # startadsl -> lo dicho antes, crear la interfaz ppp0 y ya tenemos conexión a internet

            Sólo me falta investigar cómo automatizar estas tareas durante el arranque del sistema, lo dejo para mañana.

            Saludos.

            • Cerrado

              BocaDePez BocaDePez
              6
              Para cerrar el tema, explico cómo me lo he montado para que…

              Para cerrar el tema, explico cómo me lo he montado para que el módem y la conexión ADSL se inicialicen al arrancar el ordenador.

              He creado un script que he puesto en el directorio /usr/local/sbin (ha de ser uno que esté en el PATH), con el siguiente contenido:

              #!/bin/bash
              # Script de conexión automática a internet mediante el modem ADSL Comtrend
              # Pedro Vera, 14/01/2005

              echo -n "Envío del código DSP al módem..."
              eaglectrl -d >/dev/null 2>/dev/null
              echo " hecho"

              echo -n "Esperamos a que el modem esté sincronizado"
              while [ "`eaglestat | grep Modem`" != "Modem is operational" ] ; do sleep 1 ; echo -n "." ; done
              sleep 3
              echo " hecho"

              echo -n "Creación de la conexión PPP..."
              startadsl
              echo " hecho"

              exit 0

              Además, hay que incluir una línea que invoque este script en el fichero /etc/rc.d/rc.local para que se ejecute durante la última fase de arranque, después de inicializar todos el resto de servicios.

              • Cerrado

                Yo tuve que añadir a startadsl la opción -s que hace que se…

                Yo tuve que añadir a startadsl la opción -s que hace que se use ifconfig, en vez de ifup/ifdown, para poner en marcha la red.

                ...

                #echo -n "Creacion de la conexión PPP..."
                startadsl -s
                echo " hecho"

                ...

              • Cerrado

                BocaDePez BocaDePez
                6
                Estoy empezando con linux, así que de esto entiendo muuuuy…

                Estoy empezando con linux, así que de esto entiendo muuuuy poco

                ¿Cómo se hace el script?

                Copio el código que has escrito y lo guardo ¿dónde? y ¿con qué extensión?

                ¿Y supuestamente cada vez que se inicie mi linux, configura mi modem para que funcione?

                • Cerrado

                  6
                  La carpeta donde tienes que instalarlo es: usr/local/sbin…

                  La carpeta donde tienes que instalarlo es:

                  usr/local/sbin

                  Quizá deberías plantear la cuestión más específica sobre cómo hacer el script en el foro de GNU, Linux, BSD para que te digan qué extensión debes utilizar y de qué manera cargarlo luego correctamente.

                  Para que funcione el módem tras arrancar debes configurar correctamente fstab en el directorio etc/

                  Saludos.

                  • Cerrado

                    BocaDePez BocaDePez
                    6
                    Te quiero hacer una pregunta ya que hablas de configuar el…

                    Te quiero hacer una pregunta ya que hablas de configuar el fstab en el directorio /etc.
                    Yo he montado linux fedora core 2 y estando en sesion como root, quiero mirar que hay en /etc/fstab y me dice permiso denegado y no se porque si estoy como root.
                    Me podrías decir porque me sale eso?
                    Muchas gracias de antemano, es que no tengo conocimiento de linux.
                    Evi.

        • Cerrado

          BocaDePez BocaDePez
          6

          Unas preguntas quizá insignificantes, pero pueden serte de…

          Unas preguntas quizá insignificantes, pero pueden serte de utilidad:

          1º) ¿A qué puerto USB tienes conectado el módem ADSL? sda, sda1, sdb, sdb1?

          2º) Si usas lsmod, se carga usb-storage?Comprueba /var/log/messages.

          3º) Monta el dispositivo en /etc/fstab con "vfat" en vez de usar "auto" y usa defaults,user,noauto 0 0.

          4º) Has concedido privilegios totales de Root al puerto USB de lectura, escritura, ejecución, etc.? Muchas veces, sólo el administrador puede usar el dispositivo USB y tienes que concederle privilegios totales al User que utilices normalmente. Para grupo de usuarios emplea "Users".

          Saludos.

    • Cerrado

      [Editado 7/01/05 14:55]

      6

      Es muy posible que puedas encontrar toda la información que…

      Es muy posible que puedas encontrar toda la información que necesitas para configurar correctamente tu módem ADSL USB, aquí:

      http://www.bandaancha.st/foros.php?temid=360314

      que está en el Hilo principal sobre Drivers, manuales y tutoriales sobre todos los tipos y modelos de módems ADSL USB bajo configuraciones de todos los diferentes S.O.´s. situado en el foro ."General Módem ADSL".

      Saludos.

      P.D: De todas formas, si no consigues solucionar el problema, derivo el tema al foro "GNU/Linux | BSD", donde posiblemente puedan ofrecerte una aclaración más detallada. Acláramelo, gracias.

      • Cerrado

        Pues me temo que voy a tener que preguntar en foros más…

        Pues me temo que voy a tener que preguntar en foros más específicos de Linux, ya que los drivers y la información que he encontrado en el link que me das ya está exprimida y nunca aparece el caso del kernel que tengo instalado: 2.4.20-8bigmem.

        Gracias.

        • Cerrado

          Como soy neófito en Linux, hago una pregunta tal vez…

          Como soy neófito en Linux, hago una pregunta tal vez estúpida...

          ¿La idea podría ser obtener los fuentes del driver y recompilarlo en mi máquina?