Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

ADSL

Comtrend 536+ y servidor Web con apache ¿Como?

magozi

Hola,
Pues me gustaria servir las paginas web que tengo en mi equipo y no soy capaz de configurar el router para que me salgan. Si pongo la ip en el navegador 192.168.1.xxx aparece sin problemas, pero cuando pongo el dominio www.xxxxxx.es no aparece.
Si alguién puede ayudarme o indicarme un hilo donde buscarlo, pues muy agradecido.
Saludos.

Este tema está cerrado a nuevas respuestas. Abre un nuevo tema para retomar la conversación.
quilloquepasa

Supongo que habrás empleado DynDNS o No-ip y redireccionado el puerto 80 en el router hacia tu Ip local. ;-)

🗨️ 8
magozi

Bueno tengo un dominio que compre en cdmon y alli me actualizan la ip dinamica que tengo.
Luego tengo esto en NAT:
NAT -- Virtual Servers Setup

Virtual Server allows you to direct incoming traffic from WAN side (identified by Protocol and External port) to the Internal server with private IP address on the LAN side. The Internal port is required only if the external port needs to be converted to a different port number used by the server on the LAN side. A maximum 32 entries can be configured.

Server Name External Port Start External Port End Protocol Internal Port Start Internal Port End Server IP Address Remove
eMule 4662 4662 TCP 4662 4662 192.168.1.128
eMule 4672 4672 UDP 4672 4672 192.168.1.128
web 80 80 TCP 80 80 192.168.1.129

No se si es lo correcto.

Cuando pongo el nombre del dominio www.xxxxxx.es me aparece la pantalla de conexion para el router.

🗨️ 7
BocaDePez
BocaDePez

Eso te pasa al intentar abrir la web desde la LAN, verdad? Normal, porque en ese caso no te sirven de nada las reglas que has mapeado ya que para llegar a tu ip pública lo haces sin salir del router, accediendo desde la wan no debería haber ningún problema. Mira un tracert desde mi PC a mi IP pública:

C:\>tracert 87.218.188.11X

Traza a la dirección 11X.188.218.87.dynamic.jazztel.es [87.218.188.11X]
sobre un máximo de 30 saltos:

1 1 ms
Traza completa.

Y otro a otra IP pública del mismo rango:

C:\>tracert 87.218.188.11Y

Traza a la dirección 11Y.188.218.87.dynamic.jazztel.es [87.218.188.11Y]
sobre un máximo de 30 saltos:

1 2 9 ms 8 ms 8 ms 1.188.218.87.dynamic.jazztel.es [87.218.188.1]
3 28 ms 27 ms 27 ms 117.188.218.87.dynamic.jazztel.es [87.218.188.11Y]

Traza completa.

Confirma con algún amigo que desde su casa puede acceder correctamente a tu página, que seguro que se puede sin problemas.

🗨️ 4
BocaDePez
BocaDePez

Upsss, se me ha olvidao una Y, jaja... Da igual.

magozi

Esto me sale en mi equipo que esta conectado al router con cable ethernet. Ahora al poner el dominio me sale la pagina de usuario y pass para entrar en el router.
He hecho un tracert como tu y mi ip sale como la tuya . en otra del mismo rango antes de las tuyas me sale la 1 192.168.1.1 y las otras 2 como las que tu has puesto.
mira la web es www.espabilao.es, y no quiero sonrisitas con el nombre de la web

🗨️ 2
BocaDePez
BocaDePez
🗨️ 1
magozi
Frank242

A mí me pasaba como a ti y lo que hice fue configurar el Apache para que escuche en el puerto 8080.

Luego en el Router tal y como lo tienes cambia el Internal Port Server en vez de 80 a 8080.

Así lo tengo yo y hasta el momento ningún problema. Eso sí, si quieres acceder al servidor desde tu red te tocará poner como URL http://192.168.1.x:8080

A ver si te vale.

🗨️ 1
Raulito

Sigue siendo el mismo problema.

La cuestión es que él quiere acceder desde su red local poniendo el dominio, en vez de la ip local.

Raulito

No se puede, al menos con los firms de Jazztel. Creo que con los de Netcomm sí, al menos a mi me funciona.

Probablemente sea una opción que sólo está en el código base 306.

🗨️ 2
BocaDePez
BocaDePez

Pues yo tengo el firm original y me funciona perfectamente..

🗨️ 1
BocaDePez
BocaDePez

A ver, si te refieres al acceso al puerto 80 desde fuera, a mi me funciona... desde la WAN

Desde la LAN se accede al router, no al servidor web, no se si te refieres a esto como que no funciona, en ese caso estamos de acuerdo...