Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

hosting en interdominios
116 lecturas y 17 respuestas
  • Cerrado

    BocaDePez BocaDePez
    6

    Compartir conexion a inet en monopuesto con router 3com

    Buenas, a ver si algun alma caritativa me echa una mano ;)

    Tengo una red de 3 pc's conectados entre si con el router 3com, actualmente en multipuesto con dhcp.

    Esta configuración funciona perfectamente, pero necesito pasarlo a monopuesto a ser posible con dhcp.
    El pc que haria de servidor tendria WinXP, los otros dos son win98se y WinXP.
    No quiero instalar un proxy, por lo que me gustaria poder configurar la conexion compartida a internet que lleva el XP.
    He probado de todas las maneras y no me funciona.
    El winXP no es capaz de configurar la conexion compartida, cuando lo he intentado siempre ha dejado todo configurado de manera que ni siquiera se veian entre si, porque las ip's de las otras dos maquinas no estaban en el rango de la ip publica de mi ADsl, que es la ip de la makina server..

    Asi pues mi problema se reduce a saber como compartir la conexion a internet teniendo el router en monopuesto, pasarlo a monopuesto no me da problemas, incluso con un proxy hace unos dias tuve funcionando todo perfectamente, con sygate, pero este programa ya no me funciona como antes cuando instalé winXP en el servidor...

    Si me podeis echar una mano me iria de perlas!, ya me he leido todo lo que he encontrado por internet sobre esto y no hay manera..

    Gracias..

    Este tema es antiguo y puede contener información obsoleta. Abre un nuevo tema para publicar tu mensaje.
    1
    • Cerrado

      Hola, yo creo que el problema está en el dhcp, por eso no se…

      Hola, yo creo que el problema está en el dhcp, por eso no se ven tus equipos, tal y como lo tienes ahora, deberías de comprobar las ips que tiene cada una de las ips, y ver de dónde las han obtenido.

      Creo que la mejor opción sería deshabilitar el dhcp del router, asígnarle la ip pública al xp a mano (es decir, coger los datos que te da el IPCONFIG /ALL que son los mismo que te da el proveedor, ip, net mask, gateway... etc...).
      Yo si no me equivoco, la conexión compartida, te pide que los clientes se conecten a través de dhcp y les da una ip (a través de dhcp y es del tipo 192.168.0.x si no recuerdo mal) pues con los 2 o 3 pcs restantes hazlo. Creo en que el problema está en que cuando se conectan cogen la ip del dhcp del router, no del xp, con lo que no llegan ni a verse, ni a conectar ni a na de na.

      Mira a ver... espero que te sea de ayuda.

      Saludos.

      • Cerrado

        BocaDePez BocaDePez
        6

        Muchas gracias por vuestras respuestas ;) Entiendo lo que me…

        Muchas gracias por vuestras respuestas ;)
        Entiendo lo que me comentais, pero los intentos que yo habia realizado tambien habian sido sin dhcp en el router, la configuracion del servidor, que tiene XP, la habia hecho a mano picando todos los datos.

        Asi pues, queda el XP en monopuesto sin dhcp en el router funcionando perfectamente.
        A partir de ahi en teoria solo tendria que poner todo automatico en las otras makinas no?
        El equipo que actua de servidor de dhcp, lo hace de manera automatica? Eso no lo entiendo muy bien, como saben los otros dos pc's que tienen que coger la ip de la makina que tiene direccion fija?

        Gracias por la ayuda ;)

        • Cerrado

          Si el server tiene solo 1 targeta de red y por tanto 1 sola…

          Si el server tiene solo 1 targeta de red y por tanto 1 sola ip no deberías de hacer eso, ... pq de consegurlo si tu ip publica es

          (Nota para jeikers: es una ip inventada ahora mismo)

          213.96.120.24

          es posible q el servidor dhcp asigne a los demas equipos

          213.96.120.25
          213.96.120.26,...

          y esas ips no son de redes privadas, ...

          no entiendo pq pasar eso a monopuesto, ...

          • Cerrado

            BocaDePez BocaDePez
            6
            Pasar a monopuesto es porque me interesa que funcionen todas…

            Pasar a monopuesto es porque me interesa que funcionen todas las funcionalidades de msn messenger, para utilizar peoplecall y demás programas que requieren una configuración en monopuesto para poder ir del todo correctamente. Es la unica manera que hay no?
            Puesto que en multipuesto, con NAT no puedo ni hacer conversacion de voz, tampoco funciona cuseeme,y asi una larga lista de cosas .
            Por favor, si puedes ayudarme a configurarlo en monopuesto te estaria muy agradecido de que me explicases como hacerlo.
            ¿He de comprar otra tarjeta de red?
            No seria lo mismo que asignar dos ip's al server?
            Que problema hay en tener direcciones consecutivas a la mia publica en la red local? Como mucho me pasaria que esas ip's aunke existiesen en inet, solo veria las mias privadas verdad?

            Gracias ;)

            • Cerrado

              BocaDePez BocaDePez
              6
              Y no es posible de alguna manera, asignar dos ip's al server…

              Y no es posible de alguna manera, asignar dos ip's al server y que una de ellas realice la funcion de servidor de dhcp para las otras makinas?

                • Cerrado

                  BocaDePez BocaDePez
                  6
                  Perdona que te moleste otra vez ;) Asi pues necesita otra…

                  Perdona que te moleste otra vez ;)
                  Asi pues necesita otra tarjeta de red..
                  No es lo mismo aplicar dos ip's al server con una tarjeta de red, que tener 1 ip por cada tarjeta de red?

                  Lo curioso es que con windows me, y con sygate, si que me funcionaba todo perfectamente.
                  Asi pues , creo que se podria llegar a hacer sin otra tarjeta de red, no crees?
                  Sygate no me funciona en el XP :( , sino lo habria dejado asi, puesto que las otras makinas con poner todo automatico, navegaban perfectamente y accedian a todos los recursos de la red como si estuvieses a traves de NAT.
                  Se te ocurre algo para evitar comprar la tarjeta?
                  Si la compro (lo digo porque lo haria esta tarde mismo)
                  Como se enteran las makinas y el windows, que tarjeta de red a de ser servidora de dhcp para los otros pc's ?

                  Muchas gracias por tu ayuda

                  • Cerrado

                    En respuesta a esta pregunta: "Como se enteran las makinas y…

                    En respuesta a esta pregunta:
                    "Como se enteran las makinas y el windows, que tarjeta de red a de ser servidora de dhcp para los otros pc's ?"

                    Pues se enteran porque tu desactivas el servidor DHCP del router, con lo que únicamente queda el servidor DHCP de la conexión compartida a internet. Una de las tarjetas (la que va a recibir el acceso a internet) pues va a tener IP estática, con los datos de tu conexión, tu ip pública y máscara de red, etc... que te dio tu proveedor, con lo que no va a hacer petición DHCP.

                    Y la segunda tarjeta de red, yo según lo veo es imprescindible, ten en cuenta que el pc con winxp es el que tiene que enrutar al resto hacia internet.

                    De todas formas, podrías decir cómo lo tenías configurado en winMe como decías, para que te funcionara bien? A ser posible con detalle.

                    • Cerrado

                      BocaDePez BocaDePez
                      6
                      Bueno, lo primero explicarte como tenia configurado con winme…

                      Bueno, lo primero explicarte como tenia configurado con winme para que funcionase:

                      1 tarjeta de red para cada pc
                      el router 3com en monopuesto sin dhcp
                      pc servidor con la ip publica de internet con winme , sygate instalado.
                      Los demas pc's con todo automatico en el tcp/ip
                      usaba el hub del 3com.
                      La instalacion del sygate la que viene predeterminada, no tuve que hacer nada
                      Los tres pc's navegaban y tenian red local.

                      Esto se jodió al meter el win XP, porque sygate se ralla que te cagas con las ip's y no se empana de que es cada una.

                      Respecto a mi problema:

                      Acabo de comprar segunda tarjeta de red para el servidor(servidor le llamo yo al que tiene el monopuesto funcionando)

                      La configuracion que voy a hacer va a ser la siguiente:

                      Router en monopuesto sin dhcp.
                      Todos los parametros tcp/ip picados a mano en el servidor.
                      He usado un hub que tenia, asi que al router solo llega el cable del servidor. Asi pues, una tarjeta de red, solo se utiliza para ir al router.
                      Para la segunda tarjeta de red, voy a ponerle una ip estatica, y los demas pc's con todo automatico, espero que asi funcione el dhcp, aunke no lo tengo claro...
                      Esta tarjeta segunda, va conectada al hub, al cual le llegan los cables de los pc's 2 y 3.

                      Como sabe el windows que tiene que compartir conexion a traves de la segunda tarjeta de red??? Eso no lo entiendo, tan listo es? jajajjaja al fin y al cabo la subred que va al hub tendrá otro rango de ip's , no tengo como de la subred del router y el servidor, pasa internet a otra subred que es la segunda tarjeta y los otros dos pc's, explicadme por favor si sabeis...

                      Bueno, pues nada mas, gracias por vuestra paciencia y vuestra ayuda ;))

                      • Cerrado

                        Podrias reenunciar esto? al fin y al cabo la subred que va al…

                        Podrias reenunciar esto?

                        al fin y al cabo la subred que va al hub tendrá otro rango de ip's , no tengo como de la subred del router y el servidor, pasa internet a otra subred que es la segunda tarjeta y los otros dos pc's, explicadme por favor si sabeis...

                        Weno ... de todas formas te explico mi idea:

                        No es obligatorio usar dhcp de esta forma, ... podrías poner ip fija en los 2 pcs "cliente" y en la 2ª targeta de red, ...

                        Pones como getaway en los "clientes" la ip del "servidor", ... la conexión compartida a inet tendría q hacer el resto.

                        Se supone q el router se comunica con el pc servidor por la targeta 1 y los demás equipos desconocen esta comunicación puesto q están en otra subred.

                        El equipo servidor está haciendo de router (otro mas? xDD) para los otros 2.

                        Si no quieres usar la conexión compartida yo te aconsejo el programa winroute: http://www.winroute.com q viene haciendo lo mismo.

                        • Cerrado

                          BocaDePez BocaDePez
                          6
                          aish, que mal escribo, queria decir, que no entiendo como la…

                          aish, que mal escribo, queria decir, que no entiendo como la conexion a internet pasa de una subred a otra.
                          He visto que en winXP se puede crear un puente entre conexiones, eso me seria util? Es necesario? o el "genial" asistente de configuracion de red del XP lo hace todo el solito?
                          Voy a hacer ahora mismo lo que me decís, pondré ip's fijas para las otras dos makinas, y conexion compartida desde el XP.
                          Esta tarde lo he probado, pero desde que he instalado la segunda tarjeta de red, no he conseguido que funcione el monopuesto, sin embargo el multipuesto si, que cosas mas raras no? Sabeis el motivo? Cambio muchas veces la configuracion del router y siempre me funciona, lo hago bien y no entiendo lo que pasa... Tras configurar el monopuesto, funcionan los pings a la ip publica, que es la ip del server, a la ip esa que se calcula, la .129 que nunca se como se llama, y a la ip del router, la 192.168.0.1. Asi que supongo que funcionando estos tres pings, la configuración del router es la correcta, y la del XP casi seguro que tambien..
                          Sobretodo os quiero dar las gracias por contestar a mis mensajes, no sabeis el favor que me estais haciendo, porque me estoy volviendo loco con este tema! es que joer, hasta crear una BBS con su correo de fidonet era mas facil! XDD
                          Ahora volveré a intentarlo, sino me funciona ya no os molesto mas, me opero el cerebro y punto ..

                          • Cerrado

                            BocaDePez BocaDePez
                            6
                            Bueno, he tenido que rendirme, pero volveré al ataque, la…

                            Bueno, he tenido que rendirme, pero volveré al ataque, la compra de la segunda tarjeta de red no me ha servido para nada, no he conseguido hacer funcionar la historia con dos subredes ;((, bueno, tendré una de recambio !!

                            He cambiado a monopuesto, puesto que lo necesitaba, pero he tenido que mandar a la mierda al XP, me he instalado Winme en el servidor, he dejado una tarjeta de red, he usado de hub el 3com para las otras makinas, y he instalado sygate, las otras dos makinas, estan con toda la configuración de tcp/ip automatica, y asi funciona de maravilla, lo que me lleva a pensar que la segunda tarjeta de red, incluso en XP era innecesaria, pero como soy un torpe y no se como hacerlo, pues a joderse toca..
                            La instalación de sygate es totalmente automatica, instalar y a rular internet en todas las makinas, es realmente una buena opcion por si alguien me lee y tiene el mismo problema, puesto que la configuracion en los clientes es totalmente automatica, no hace falta ni decirle la puerta de enlace ;))

                            Eso si, me jode volver a winme y renunciar al XP, aunke de todas formas existe una incompatibilidad entre el chipset via de mi placa, la webcam 5 usb y el XP, que huevos verdad? Pues si, me tendré que comprar tambien una controladora usb adicional, ya se que no viene a cuento, pero es que estoy de mu mala leche :((

                            Gracias por vuestra ayuda.

                            Myckie

                            • Cerrado

                              El caso es que eso es más raro que un perro verde, te lo…

                              El caso es que eso es más raro que un perro verde, te lo puedo asegurar.
                              Por cueriosidad, cómo tienes configurado el sysgate? qué ip coge el pc con winme (el que se supone que llevaba xp, supongo que la ip pública no?) y el resto de los pcs? qué ip cogen? quien les da esa ip?

                              Perdona por ser tan preguntón... pero es ya algo personal! jajajajaja :-D

                              De todas formas me parece muy extraño lo que comentas que no te funcione con las 2 tarjetas de red, el SO, en el fonde debería de ser lo de menos.

                              • Cerrado

                                BocaDePez BocaDePez
                                6
                                Vamos a ello : Sygate esta configurado totalmente automatico…

                                Vamos a ello :

                                Sygate esta configurado totalmente automatico tal como se instaló, está utilizando la ip 192.168.0.1, que curiosamente es la ip del router, la que utilizo para entrar a la configuracion via web, la ip del bicho vamos.¿coincidencia? yo no tengo ni puta idea.

                                El monopuesto del router no está con dhcp, la ip que tiene el winme es la ip publica, la puerta de enlace es la ip esa que se calcula (no me acuerdo como se llama) que usualmente acaba en .129.
                                Las otras makinas tienen TODO automatico, ni siquiera esta especificada puerta de enlace y acceden a todos los recursos de inet como si a traves de NAPT se tratara.
                                Esas dos makinas tiene una Win98se y la otra WinXP.
                                Estos pc's cogen una ip del rango 192.168.0.X

                                Eso si, pasa algo muy raro, el sygate actua desde luego, porque sino no funcionaria la historia, pero en el log del sygate, donde te permite ver todas las peticiones de las otras makinas....no aparece nadaaaa!!!
                                Quizas la cosa funcione de casualidad, no lo se, pero funciona perfectamente.

                                Respecto a lo de las dos tarjetas de red, quizas necesite mas tiempo para probar y probar porque mis conocimientos no dan para mucho y entre las dos tarjetas de red y la conexion compartida a inet, aparecian alli en red, tropecientasmil cosas.....

                                Myckie

                                • Cerrado

                                  A ver, vamos a ir paso por paso Sygate esta configurado…

                                  A ver, vamos a ir paso por paso

                                  Sygate esta configurado totalmente automatico tal como se instaló, está utilizando la ip 192.168.0.1, que curiosamente es la ip del router, la que utilizo para entrar a la configuracion via web, la ip del bicho vamos.¿coincidencia?

                                  Vamos a ver, aquí hay algunas cosas que no me cuadran, el tema de la instalación del sygate, pues ni flowers, porque no lo he usado nunca, pero bueno. Lo que dices de que usas para acceder a la configuración del router la ip 192.168.0.1 me ha llamado la atención. Cuando tienes el router en monopuesto con 1 único pc enchufado, debería de accederse a la configuración a través de la ip que calculas.

                                  Eso si, pasa algo muy raro, el sygate actua desde luego, porque sino no funcionaria la historia, pero en el log del sygate, donde te permite ver todas las peticiones de las otras makinas....no aparece nadaaaa!!!

                                  Lo que más me llama la atención es lo que comentas del sygate, que no puedes ver los logs, o que en ellos no aparece nada.

                                  La sensación que me da, aunque es como todo, si no lo veo no me lo creo, pero por los datos que das da la sensación de que el sygate está de palo (has probado a desactivarlo a ver si el resto de los pcs acceden a internet? o si el pc está apagado?)
                                  El caso es como si en el router tuvieras 2 lan locales, 1 con el rango de la ip pública, y otra con el rango 192.168.0.x y me da la sensación que los pcs están saliendo a internet a través del router, y que los pcs con winme se ven con los otros 2, a través de que el router enlaza esas direcciones.

                                  Lo que tienes que tener en cuenta, es que, para que un pc pueda enlazar 2 redes, necesita como mínimo 2 tarjetas de red, una para cada una de las redes, y si tu pc con winme sólo tiene una con una dirección 195.100.109.100 por ej... no va a poder comunicarse con los pcs con la 192.168.2.x y no se por qué me da la sensación que los pcs que tienes dentro de ese rango de direcciones 192.168... está saliendo por el router, no lo tengo muy claro, es una teoría, pero me llama la atención que el log del sygate no marque nada. Prueba también a hacer una traza, con el comando TRACERT ip_de_internet para ver por qué ip están saliendo los pcs. O a hacer una traza entre pcs; ej tracert pc0 (suponiendo que pc0 sea el pc con winme desde el pc que tiene win98 por ej).

                                  Lo más curioso, es que estoy mareando la perdiz por algo que funciona, pero en fin... yo soy así de curioso :-P

                                  Por cierto Sharkr0lz, qué opinas de esto? mayday mayday... jajajaja, me estoy volviendo loco. :-P

                                  • Cerrado

                                    BocaDePez BocaDePez
                                    6
                                    Ufff, me estoy empezando a liar! jejejejje Cuando apago el…

                                    Ufff, me estoy empezando a liar! jejejejje
                                    Cuando apago el sygate , la conexion no funciona en los otros pc's, he probado meter filtros y historias de estas que lleva sygate...y... NO ACTUAN!, comorl? Como coño funciona la red aki?

                                    Esta tarde desde casa te pasaré si te interesa pantallazos de mi configuración totalmente detallada vale?

                                    Quizas hoy si tengo tiempo, volveré a probar montar la historia con las dos tarjetas de red.

                                    Pero te perjuro que ahora mismo funciona perfectamente, que al router se accede por la 192.168.0.1, y que la puerta de enlace es la .129 en el pc servidor, asi como su ip es la ip publica .

                                    En el router tengo en el remote sites, por alli metida la 192.168.0.1 siguiendo en manual de rosh para configuracion monopuesto, este manual especifica que esto sea asi, asi con en el apartado dhcp and lan settings tengo la ip calculada , la .129

                                    TEngo dhcp desactivado, y no se que mas contarte, esta tarde te lo explico al detalle...
                                    Lo que tambien es seguro es que sygate reparte direcciones del rango 192.168.0.x a las otras makinas...
                                    Porque sygate pilla la ip del router? es coincidencia?
                                    Tienes razon en todo, pero sobretodo en el hecho de que los otros pc's no han de poder ver al mio, debido a que estan en otra subred, tienen ips de otro rango.... No se, no entiendo nada, ahora mismo me voy al super a comprar un libro ANAYA de iniciacion a las redes DOMESTICAS... :(

                                    Yo lo que quiero montar es lo siguiente:

                                    Mi megapc, con dos tarjetas de red, una subred para el router y mi pc, otra subred para mipc y los otros dos pc's.
                                    Por lo que la subred 2 tendria que tener una ip distinta a la ip del router (192.168.0.1) y distinta al rango de la ip publica de mi makina . Verdad?
                                    Como se enlazarian esas dos subredes, para que la conexion a internet pasase de la primera subred, a la segunda subred?

                                    Bueno, si no os rallo ya mucho a ver si os animais a ayudarme ;))

                                    Gracias

      • Cerrado

        Otra vez dalton tiene razón, ... por que, ... yo creo que…

        Otra vez dalton tiene razón, ... por que, ... yo creo que está intentando usar 1 targeta de red por cada equipo (3) en lugar de 2 en el servidor (4).

        El servidor tiene que conectar al router por un lado y a los 2 equipos restantes (a través de un hub o en otra subred distinta en el mismo hub) por otro.

        Una solución para arreglar eso sería desactivar el dhcp del router. poner 2 ips fijas al equipo en monopuesto:

        1 q sería la publica

        y 2, (la de los otros equipos) en una ip q no le permitiera ver al router, esto hará que el servidor dhcp haga que dichos equipos tampoco vean el router. ¿cutre ... verdad?

        2' Enchufar un switch o hub extra en la targeta de red q va a los 2 equipos aislando así a estos del servidor dhcp del router.

        xDDDDDD

        Si las cosas si se hacen como tienen q ser, ... mejor. En ese caso se tendría q usar multipuesto, ... no hay razón para no usarlo.