Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

hosting en interdominios
278 lecturas y 8 respuestas
  • Cerrado

    BocaDePez BocaDePez
    6

    Cómo puedo direccionar mi I.P. fija (pública) a una I.P. interna?

    Hola Tengo un router 3Com 812 y contratada una ADSL con I.P. Fija.

    Mi cuestión viene en que he comprado una NetCam que va conectada directa al router y la cual, mediante su propio programa le he asignado una IP (Ej. 192.168.0.122), la cuestión es que, al igual que cuando estoy en la red (LAN) pongo esa IP en mi navegador y veo las imágenes que me ofrece la NetCam, me gustaría saber configurar mi router para que poniendo la I.P. Fija que me ha asignado telefónica, es decir, la pública, la que desde cualquier ordenador "externo" conectado a Internet accedo al panel de control del propio router, pero en este caso que acceda a la NetCam.

    Resumiendo, poniendo mi IP Fija Ej. 213.95.86.227 desde cualquier ordenador externo conectado a Internet, que en vez de salirme el OfficeConnect del router me salga la imágen de la NetCam.

    Gracias

    Este tema es antiguo y puede contener información obsoleta. Abre un nuevo tema para publicar tu mensaje.
    1
    • Cerrado

      BocaDePez BocaDePez
      6

      Para hacer lo que pretendes, tienes que: 1. Desviar el puerto…

      Para hacer lo que pretendes, tienes que:

      1. Desviar el puerto de escucha del configurador web del router a otro puerto distinto del TCP 80, por ejemplo, ponerlo a la escucha en el puerto TCP 8000.
      Para hacerlo, aplicas estos comandos:

      disable network service httpd
      set network service httpd socket 8000
      enable network service httpd
      save all

      y recuerda que, a partir de esto, para acceder a la configuración del router, deberás poner en la barra del navegador (suponiendo que la IP privada del router sea 192.168.0.1. Si no es esta, deberás poner la que tengas):

      http://192.168.0.1: 8000

      **************************

      2. Mapear el puerto público TCP 80 hacia la IP privada de la cámara web. Si esta IP de la cámara es, como dices, 192.168.0.122, los comandos serían:

      disable vc nombre_vc
      add pat tcp vc nombre_vc public_port 80 private_address 192.168.0.122 private_port 80
      enable vc nombre_vc
      save all

      Esto suponiendo que tu versión de firmware sea la 2.0 o mayor. Si tu firmware es menor del 2.0, debes cambiar lo de pat por nat
      Para saber que firmware tienes:

      show system

      Para saber el nombre_vc (que normalmente es internet), debes escribir el comando:

      list vc

      • Cerrado

        BUENO, ANTE TODO GRACIAS POR TU AYUDA, ESTABA ALGO PERDIDO Y…

        BUENO, ANTE TODO GRACIAS POR TU AYUDA, ESTABA ALGO PERDIDO Y AHORA CON LO QUE ME HAS ESCRITO ESTOY ALGO MÁS "ENCONTRAO"... PERO NO DEL TODO.. ;-)

        HE HECHO LO QUE ME HAS ESCRITO EN TU RESPUESTA, PERO SIGUE SIN FUNCIONAR. HACIÉNDOLO, AHORA ENTRO CON MI "(I.P.PUBLICA):8000" AL ROUTER, PERO CON SOLO "HTTP://(I.P.PUBLICA)" NO VOY A LA I.P. INTERNDA DONDE ESTÁ LA NETCAM, INCLUSO HE ABIERTO LOS PUERTOS 160 Y 1600 QUE SON LO QUE UTILIZA LA NETCAM PARA VIDEO, PERO... NADA, NO SÉ MUY BIENDONDE PUEDE ESTAR EL ERROR.

        ME HE LEIDO LOS MANUALES DE LA CÁMARA QUE ES LA "VEO OBSERVER" (NO ES EL MODELO INALAMBRICO), Y QUE SE PUEDE VER EN WWW.VEO.COM, DE HECHO AHÍ HAY NETCAM's MONTADAS EN FUNIONAMIENTO COMO EJEMPLO. LA VERDAD ES QUE LEYENDO EL MANUAL ME DICE MÁS O MENOS LO QUE TU (EN EL CASO DE "ABRIRLA AL MUNDO" A TRAVÉS DE NUESTRO ROUTER)

        .... ESTOY ALGO "QUEMAO". SI PUEDES ECHARME UNA MANO ME SERÍA DE GRAN AYUDA.

        SALUDOS

        • Cerrado

          BocaDePez BocaDePez
          6

          Me he estado mirando el Manual de tu cámara y usa,…

          Me he estado mirando el Manual de tu cámara y usa, efectivamente:

          Puerto TCP 80 para acceso a la “homepage” de la videocámara.
          Puerto TCP 1600 para autentificación con nombre usuario!contraseña

          Y, para usuarios de router en multipuesto, recomienda redirigir estos puertos en el router y explica, además, como se hace esto en varios modelos de router.

          **************************************************

          Bien, para mi está claro que lo que te ocurre es que tienes filtrado el puerto web (TCP 80) y por ello no te funciona el tema. Recuerda que los filtros PREVALECEN sobre los mapeos y que, por lo tanto, si hay un filtro que impide el acceso por el puerto TCP 80, automáticamente queda inutilizado el mapeo de dicho puerto.

          Solución: ELIMINA DICHO FILTRO.
          Pasos a seguir:

          1. Ver filtros activos con:
          list filters

          2. Ver contenido del filtro o filtros con:
          show filter nombre_del_filtro
          Si observas que algún filtro “capa” el puerto web (tcp 80), deberás borrarlo con:
          delete filtro [ì]nombre_del_filtro[/i]
          save all

          • Cerrado

            BocaDePez BocaDePez
            6
            Creo que etamos cerca, pero no acabo de configurarlo. Cierto…

            Creo que etamos cerca, pero no acabo de configurarlo.

            Cierto que había pensado, al igual que tu, en el asunto de los filtros, pero ya lo he borrado todos, no hay ninguno, por lo tanto el puerto 80 debe estar abierto sin ningún tipo de problema, no sé ahora que es lo que puede ocurrir.

            Como ya lo he pensado todo y voy algo pez en la configuración del router (aunque estoy aprendiento muchísimo ahora), mi pregunta es... podría tener algo que ver que en el apartado Defatul Workstation tengo pueta la I.P. 0.0.0.0 ... digo yo... ;-) porque ya no sé por donde tirar.

            El caso es que ahora cuando pongo mi I.P. pública no me sale nada (dice que no encuentra) a no ser que le ponga el ":8000" al final, que es el puerto que le hemos marcado, así que "olfateo" el final del problema pero aún hay algo que bloquea que mi I.P. pública redireccione a la I.P. privada asignada a la NetCam.

            A ver como salgo de esta !!

            Gracias por la ayuda que me estas prestando

            • Cerrado

              BocaDePez BocaDePez
              6
              mi pregunta es... podría tener algo que ver que en el…

              mi pregunta es... podría tener algo que ver que en el apartado Defatul Workstation tengo pueta la I.P. 0.0.0.0 ... digo yo... porque ya no sé por donde tirar.

              No tiene nada que ver. Es correcto que lo tengas así, eso no dificulta ninguna redirección de puertos.

              El caso es que ahora cuando pongo mi I.P. pública no me sale nada (dice que no encuentra) a no ser que le ponga el ":8000" al final, que es el puerto que le hemos marcado, así que "olfateo" el final del problema pero aún hay algo que bloquea que mi I.P. pública redireccione a la I.P. privada asignada a la NetCam.

              Supongo que que cuando dices que pones la IP pública te refieres a que lo haces DESDE FUERA DE TU RED INTERNA, es decir, DESDE UN ORDENADOR DE INTERNET. Lo digo porque, desde tu propia red, el router no puede redirigir el puerto a la webcam.

              • Cerrado

                Siiiiiiiiiii !!!!!! Graciasssssss !!!! funciona..... joer, al…

                Siiiiiiiiiii !!!!!! Graciasssssss !!!! funciona..... joer, al final lo hemos hecho funcionar, la verdad es que es como estabamos comentando en los últimos mensajes. Hay que tener en cuenta que no estén bloqueados los puertos que utiliza la cámara (el 80 sobretodo) y seguir los pasos que aquí hemos estado escribiendo... la verdad... empezaba a desesperarme.

                Bueno, estoy por hacer un manual y mandárselo al webmaster de la página para que lo publique, creo que es un tema interesante para hacer con un router y una NetCam el que hemos tratado. Por cierto, la NetCam (la Veo Observer) la he cambiado, entre otras porque aunque tenia sonido, sensor de movimiento, capacidad de manajarla remotamente, zoom, etc... tenia algunos problemas que para uso "a granel" fallaba, y es que sólo permitia la visualización de un usuario por sesión (aunque se pueden crear tres clases diferentes de usuarios) y que tenia incompatibilidades en otros sistemas operativos como Mac o Linux, aún así para uso particular (no de vista a "público") me parecia una buena cámara... bueno ahora la he sustituido por otra (sigue el mismo procedimiento de instalación I.P.) .... si hay algo iré informando.

                Nos estamos viendo, entraré a este foro para informarte si interesa "el tema".

                Un abrazo

                • Cerrado

                  BUENO, OS DIGO A TODOS COMO HA QUEDADO.... ENTRAR EN…

                  BUENO, OS DIGO A TODOS COMO HA QUEDADO....

                  ENTRAR EN WWW.ONDA.WS Y VEREIS LO QUE PRETENDIA HACER Y COMO HA QUEDADO

                  GRACIAS A TODOS