BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

Cisco 877w y DHCP de ONO

ironum

Hola llevo tiempo intentando conectar un puerto ethernet de este router a un cablemodem, pero no hay forma de que funcione con el cliente dhcp uso "ip address dhcp" en la Vlan2 conectada a un FastEthernet en modo access, en el debug dhcp detail siempre sale el mensaje "DHCP: Received a BOOTREP pkt Not for us..: xid: 0x...", he montado un servidor dhcp en el pc y funciona sin problema por lo que el fallo no se cual es. Gracias.

vukits

cuando conectas una nueva mac al cablemodem, hay que restearlo.. ¿has hecho eso? :P

saludos

🗨️ 3
ironum

Si, he hecho mil pruebas incluso spoof de la mac por si tenian filtradas las de cisco y da el mismo fallo siempre:

DHCP: Received a BOOTREP pkt Not for us..: xid: 0x...%Unknown DHCP problem.. No allocation possible

🗨️ 2
vukits

te seré sincero, soy ignorante en este tema, LoL

aun así, he buscado en gugel y aqui he visto dos cosas: que un tío mete entre el router y el cablemodem un switch :P ... y un otro tiene la sig. configuración para el puerto al cablemodem:

 interface FastEthernet0/0

 description External Network

 ip address dhcp

 ip accounting output-packets

 ip nat outside

 ip flow ingress

 no ip mroute-cache

 duplex auto

 speed auto

 no cdp enable

 crypto map cmap

 end
🗨️ 1
ironum

También he buscado por todas partes probado configuraciones y he leido y releido foros y documentación de cisco pero no he conseguido solucionarlo aún. El servidor dhcp que usa ONO es cisco no se si podría tener algo que ver en este problema. De todas formas es un poco extraño que funcione bien con cualquier servidor dhcp menos con el de ONO.

Un saludo y gracias

ironum

Dejo aquí la configuración del router por si a alguien se le ocurre algo, gracias.

 Current configuration :

 !

 version 12.4

 no service pad

 service timestamps debug datetime msec

 service timestamps log datetime msec

 no service password-encryption

 !

 hostname cisco

 !

 boot-start-marker

 boot-end-marker

 !

 logging message-counter syslog

 logging buffered 51200

 !

 no aaa new-model

 !

 !

 !

 dot11 syslog

 ip source-route

 !

 !

 !

 !

 ip cef

 no ip domain lookup

 ip domain name cisco

 no ip dhcp-client broadcast-flag

 no ipv6 cef

 !

 multilink bundle-name authenticated

 !

 !

 !

 !

 no spanning-tree vlan 1

 no spanning-tree vlan 2

 username x privilege 15 secret 5 x

 !

 !

 !

 archive

 log config

 hidekeys

 !

 !

 !

 !

 !

 interface ATM0

 no ip address

 shutdown

 no atm ilmi-keepalive

 !

 interface FastEthernet0

 !

 interface FastEthernet1

 switchport access vlan 2

 mac-address 0002.xxxx.xxxx

 !

 interface FastEthernet2

 !

 interface FastEthernet3

 !

 interface Dot11Radio0

 no ip address

 shutdown

 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

 station-role root

 !

 interface Vlan1

 description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$

 ip address 192.168.1.X 255.255.255.0

 ip tcp adjust-mss 1452

 !

 interface Vlan2

 ip address dhcp client-id FastEthernet1 hostname PC1

 !

 ip forward-protocol nd

 ip http server

 ip http authentication local

 ip http secure-server

 ip http timeout-policy idle 60 life 86400 requests 10000

 !

 !

 !

 no cdp run

 !

 !

 !

 !

 !

 control-plane

 !

 !

 line con 0

 login local

 no modem enable

 line aux 0

 line vty 0 4

 privilege level 15

 login local

 transport input ssh

 !

 scheduler max-task-time 5000

 end
🗨️ 6
BocaDePez
BocaDePez

¿Has probado a utilizar la VLAN 1 en el puerto que va a ONO en vez de la VLAN 2?

No creo que sea eso pero "porsiacaso"

Saludos

🗨️ 1
ironum

Si lo he probado pero sin éxito. Gracias

imakoki

¿Has probado a reinicar el cablemodem? y no me refiero a desconectarlo si no ha resetearlo. Los cablemodem no tienen configuracion como un router. Como ono asocia la MAC con la conexion, hasta que no pasa un periodo largo con el cablemodem apagado o hasta que no fuerzas a que se resetee no puedes conectar otro equipo. Normalmente tienen un botoncito de reset detras, lo aprieteas dorante 15 o 30 segundos y lo sueltas. Tras esto suele asignar ip al nuevo equipo.

Yo vengo de AUNA y en epoca en que tenia cablemodem (ya hace tiempo que no), tenia que andar con estas historias si cambiaba el pc, o si ponia un router, etc ;)

He encontrado referencias a estas situciones con routers cisco, pero a mi me habia pasado con cualquier dispositivo, al cambia uno por otro, siempre que trabajen en capa 3, vamos que cojan ip ;)

Respecto al tema de la VLAN1 o la 2 no debería haber diferencia alguna.

Un saludo,
imakoki

🗨️ 3
vukits

dijo que lo había hecho.. hasta con mac spoof :P

🗨️ 2
imakoki

ok, entiendo que con el mac spoof lo que hizo fue "ponerle al pc" la mac del cisco, ¿no? y con esa tambien le pillaba ip el pc. Vaya putada. Quizas algun bug de la IOS que provoque este problema... ¿?

ironum, ¿siempre has configurado el ip address dhcp con los parametros? No se si entiendo lo que se supone que hace el comando tal cual lo pones tu, ¿quizas hacer que el pc pille la ip de ono? No lo he probado nunca :P ;)

¿has probado a poner simplemente "ip address dhcp" sin nada mas? Yo lo que haria es conectar las fastethernet0 a ono. Poner ahi el "address dhcp", y la pones como "ip nat outside". Luego en la vlan2 le configuraria la red donde voy a conectar los pcs y se le pone el ip nat inside. Luego configuras el ip nat inside source list 100 interface fastethernet0 overload con la access-list 100 ip permit any any. Con eso la ip de ono deberia quedar en la fastether0, la vlan2 seria la red interna y los pcs para salir a internet harian PAT usando la ip de ONO (la de la fastethernet0).

De todas formas antes de calentarte la cabeza prueba simplemente a poner simplemente "ip address dhcp" en la vlan2 y a ver si la vlan2 adequiere la ip de ono. si te funciona pues igual mejor hacerlo entonces como te decia en el parrafo anterior ;)

Un saludo ;)
imakoki

🗨️ 1
ironum
BocaDePez
BocaDePez
1

Hola

Yo sufrí esto con un Cisco 877W y el problema es el siguiente:

hay cierta versión del bootstrap en estos routers (877 y 877W) (ojo, no del IOS, hablo del bootstrap) que no inicializa correctamente el hardware de las interfaces fastethernet y durante la carga del IOS estas se comportan como un switch (las 5, la WAN incluida). Por lo que durante ese tiempo tramas de tu LAN llegan directamente al cablemodem y éste se "aprende" una MAC de uno de los dispositivos de la LAN, en lugar de la MAC del router.

De ahí que si enciendes el cablemodem más tarde, esto no ocurre y todo funciona bien.

Solución: bajate el ultimo bootstrap para el 877 y actualizalo. Es lo que hice yo (usuario de 877W con ONO)

Saludos

🗨️ 2
jsoto

Hola, he seguido vuestro hilo y despues de actualizar la rom a la versión C870_RM_ALT.srec.123-8r.YI6 en un cisco 877 no consigo que el servidor dhcp de ono me asigne mi ip fija. Siempre me devuelve una 84.x.x.x en vez de 62.x.x.x como es mi caso. Tengo esta version de la ios "c870-advipservicesk9-mz.124-22.T.bin" y la misma configuración que el amigo "ironum". También he probado a resetear el cable-modem pero ni con esas.

Te agradecería me describieras el escenario sobre el que tu has podido conseguir que ono te asigne la ip fija con un cisco 877.

muchas gracias

🗨️ 1
ironum

Buenas, gracias por la ayuda y perdón por el retraso. Ya he actualizado el bootloader a la version 6 antes funcionaba con la 4. Tambien el IOS y la version 18 del modem.

BOOT

ROM: System Bootstrap, Version 12.3(8r)YI6

IOS

Cisco IOS Software, C870 Software (C870-ADVIPSERVICESK9-M), Version 12.4(24)T3, RELEASE SOFTWARE (fc2)

MODEM

Init FW: init_AMR_4.0.018.bin
Operation FW: AMR-E-4.0.018.bin
FW Source: external
FW Version: 4.0.18

Por ahora parece que no se escapan paquetes en el arranque al actualizar el boot. Durante el verano haré pruebas con ono y ya os iré contando.

Saludos