Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

Fibra/Cable

Cisco 877 e ip fija con ONO

jsoto

Hola, despues de consultar las normas de este foro creo que es conveniente abrir un nuevo hilo.

He estado siguiendo en muchos foros los problemas de configuración de router cisco conectados a un cable modem para que se les asigne la ip fija contratada. En mi caso sigo sin poder conseguirlo. He probado con otros routers y despues de clonar la mac de la interface wan de mi router ono draytek va sin problemas. El caso es que con routers cisco de la serie 1700 e incluso un 877 no funciona. Siempre me asigna una ip dinámica.

en este hilo se comenta que es necesario actualizar la rom pero despues de actualizar la rom a la versión C870_RM_ALT.srec.123-8r.YI6 en un cisco 877 no consigo que el servidor dhcp de ono me asigne mi ip fija. Siempre me devuelve una 84.x.x.x en vez de 62.x.x.x como es mi caso. Tengo esta version de la ios "c870-advipservicesk9-mz.124-22.T.bin" y la misma configuración que el amigo "ironum". También he probado a resetear el cable-modem pero ni con esas.

Te agradecería me describieras el escenario sobre el que tu has podido conseguir que ono te asigne la ip fija con un cisco 877.

muchas gracias

superllo

En ese caso era que el DHCP no funcionaba, ¿tienes una IP fija contratada?

🗨️ 12
jsoto

Hola superllo, tengo contratada una ip fija 62.x.x.x. En mi caso funciona pero ono le da siempre una ip del rango 84.x.x.x que son dinámicas. Con otros router cuya administración es web va de maravilla. El caso es que necesito hacerlo funcionar en un cisco 877.

muchas gracias por la contestación

🗨️ 5
yomimmo
0

El problema es que su IP esta ligada a la MAC del router, si el Cisco no tiene la opcion de clonar la MAC del antiguo router no podra hacerlo.

🗨️ 4
BocaDePez
BocaDePez

Hola yomimmo, en teoria la ios de los routers cisco tiene el comando mac-address xxxx.xxxx.xxxx para cambiar la MAC de cualquier interface.

Si lees el hilo verás que si es posible y es mi caso necesario para que le asigne la ip fija ligada a la MAC de la interface WAN de mi router Draytek de ONO.

muchas gracias por la contestación

🗨️ 3
superllo
🗨️ 2
jsoto
🗨️ 1
jsoto

Hola ahora estoy probando con un cisco 1720 y el problema es que no me asigna ninguna ip. Os muestro la version, configuracion, interface y respuesta del servicio dhcp

sh version

Cisco Internetwork Operating System Software
IOS (tm) C1700 Software (C1700-K9O3SY7-M), Version 12.3(25), RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2008 by cisco Systems, Inc.
Compiled Mon 28-Jan-08 18:26 by alnguyen

ROM: System Bootstrap, Version 12.0(1)XA1, RELEASE SOFTWARE (fc1)

Router uptime is 41 minutes
System returned to ROM by reload
System image file is "flash:c1700-k9o3sy7-mz.123-25.bin"

......

cisco 1720 (MPC860T) processor (revision 0x101) with 40635K/8517K bytes of memory.
Processor board ID JAD03120737 (2212345177), with hardware revision 0000
MPC860T processor: part number 0, mask 32
Bridging software.
X.25 software, Version 3.0.0.
1 Ethernet/IEEE 802.3 interface(s)
1 FastEthernet/IEEE 802.3 interface(s)
32K bytes of non-volatile configuration memory.
16384K bytes of processor board System flash (Read/Write)

sh run

Building configuration...

Current configuration : 674 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
memory-size iomem 25
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
no aaa new-model
ip subnet-zero
!
!
!
ip cef
ip audit po max-events 100
!
!
!
!
!
!
!
!
interface Ethernet0
no ip address
shutdown
half-duplex
!
interface FastEthernet0
mac-address xxxx.xxxx.xxxx
ip address dhcp
ip nat outside
speed auto
!
ip classless
ip route 0.0.0.0 0.0.0.0 FastEthernet0
no ip http server
no ip http secure-server
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
end

sh interfaces f0

FastEthernet0 is up, line protocol is up
Hardware is PQUICC_FEC, address is xxxx.xxxx.xxxx (bia yyyy.yyyy.yyyy)
Internet address will be negotiated using DHCP
MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 100Mb/s, 100BaseTX/FX
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:05, output 00:00:08, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
241 packets input, 62589 bytes
Received 234 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog
0 input packets with dribble condition detected
258 packets output, 39796 bytes, 0 underruns
41 output errors, 0 collisions, 3 interface resets
0 babbles, 0 late collision, 0 deferred
41 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out

debug dhcp de

*Mar 1 00:31:11.127: DHCP: Try 11 to acquire address for FastEthernet0
*Mar 1 00:31:11.143: DHCP: allocate request
*Mar 1 00:31:11.143: DHCP: new entry. add to queue
*Mar 1 00:31:11.143: DHCP: SDiscover attempt # 1 for entry:
*Mar 1 00:31:11.143: Temp IP addr: 0.0.0.0 for peer on Interface: FastEthernet0
*Mar 1 00:31:11.143: Temp sub net mask: 0.0.0.0
*Mar 1 00:31:11.147: DHCP Lease server: 0.0.0.0, state: 1 Selecting
*Mar 1 00:31:11.147: DHCP transaction id: 155B09
*Mar 1 00:31:11.147: Lease: 0 secs, Renewal: 0 secs, Rebind: 0 secs
*Mar 1 00:31:11.147: Next timer fires after: 00:00:02
*Mar 1 00:31:11.147: Retry count: 1 Client-ID: cisco-xxxx.xxxx.xxxx-Fa0
*Mar 1 00:31:11.147: Hostname: Router
*Mar 1 00:31:11.147: DHCP: SDiscover: sending 296 byte length DHCP packet
*Mar 1 00:31:11.147: DHCP: SDiscover 296 bytes
*Mar 1 00:31:11.147: B'cast on FastEthernet0 interface from 0.0.0.0
*Mar 1 00:31:14.143: DHCP: SDiscover attempt # 2 for entry:
*Mar 1 00:31:14.143: Temp IP addr: 0.0.0.0 for peer on Interface: FastEthernet0
*Mar 1 00:31:14.143: Temp sub net mask: 0.0.0.0
*Mar 1 00:31:14.143: DHCP Lease server: 0.0.0.0, state: 1 Selecting
*Mar 1 00:31:14.143: DHCP transaction id: 155B09
*Mar 1 00:31:14.143: Lease: 0 secs, Renewal: 0 secs, Rebind: 0 secs
*Mar 1 00:31:14.143: Next timer fires after: 00:00:03
*Mar 1 00:31:14.143: Retry count: 2 Client-ID: cisco-xxxx.xxxx.xxxx-Fa0
*Mar 1 00:31:14.143: Hostname: Router
*Mar 1 00:31:14.143: DHCP: SDiscover: sending 296 byte length DHCP packet
*Mar 1 00:31:14.147: DHCP: SDiscover 296 bytes
*Mar 1 00:31:14.147: B'cast on FastEthernet0 interface from 0.0.0.0
*Mar 1 00:31:17.143: DHCP: SDiscover attempt # 3 for entry:
*Mar 1 00:31:17.143: Temp IP addr: 0.0.0.0 for peer on Interface: FastEthernet0
*Mar 1 00:31:17.143: Temp sub net mask: 0.0.0.0
*Mar 1 00:31:17.143: DHCP Lease server: 0.0.0.0, state: 1 Selecting
*Mar 1 00:31:17.143: DHCP transaction id: 155B09
*Mar 1 00:31:17.143: Lease: 0 secs, Renewal: 0 secs, Rebind: 0 secs
*Mar 1 00:31:17.143: Next timer fires after: 00:00:03
*Mar 1 00:31:17.143: Retry count: 3 Client-ID: cisco-xxxx.xxxx.xxxx-Fa0
*Mar 1 00:31:17.143: Hostname: Router
*Mar 1 00:31:17.143: DHCP: SDiscover: sending 296 byte length DHCP packet
*Mar 1 00:31:17.147: DHCP: SDiscover 296 bytes
*Mar 1 00:31:17.147: B'cast on FastEthernet0 interface from 0.0.0.0
*Mar 1 00:31:18.143: DHCP: Received a BOOTREP pkt Not for us..: xid: 0x1124
*Mar 1 00:31:20.143: DHCP: QScan: Timed out Selecting state%Unknown DHCP problem.. No allocation possible
*Mar 1 00:31:31.631: DHCP: Waiting for 55 seconds on interface FastEthernet0

saludos

🗨️ 5
Sammi

Como conectes muuuuuchas MAC´s diferentes al modem, la cabecera no almacena mas y tendrás que esperar a que elimine las que tiene memorizadas. No se si será este tu problema.

Sobre que no te asigne la ip contratada a la mac que has modificado en el otro cisco... algún problema debe tener ese router porque no se restringe que conectes, mientras que sea la MAC que has dado de alta va listo.

🗨️ 4
jsoto

Hola NeXus, tengo ahora mismo conectado al CM un router Buffalo WZR-RS-G54 con la mac de la wan inicializada correctamente y va perfecctamente, me obtiene la ip fija correctamente pero no sé que pasa con los routers cisco que a los de Ono no les gusta.

No creo que sea por exceso de mac´s en la cabecera del CM. de todos modos ¿hay alguna forma de vaciarla para eliminar posibles causas?

🗨️ 3
Sammi
🗨️ 2
jsoto
🗨️ 1
Sammi
omg78

Hola jsoto y a todos,

Ya sé que hace más de 1 año que no habeis vuelto a escribir sobre esto, pero... ¿Lograste hacer funcionar eso?

Yo estoy en las mismas: No consigo hacer que ONO me logre asignar mi IP fija contratada mediante DHCP.

No soy ningún gurú en networking, y lo máximo que he conseguido es poner el router Cisco EPC3825 en bridge-mode (siguiendo este tutorial) y colocar detrás un PC con un FreeBSD y 2 tarjetas de red para que haga de router físico; y lo único que he conseguido es que me asigne cualquier otra IP pública y dinámica de ONO por DHCP, menos la que tiene que ser (la contratada).

He especificado en /etc/dhclient.conf que quiero utilizar la MAC de mi CM (que previamente he confirmado con los técnicos de ONO que es la que tienen allí asignada a mi IP fija), y además por si fuera necesario, he spoofeado la misma MAC del CM en la re0, y lo hace correctamente.

El problema? Pilla cualquier IP menos la que tiene que pillar.

¿Finalmente cómo solucionaste el problema si es que pudiste hacerlo?

Si alguien más se le ocurre algo o puede ayudarme, le estaré muy agradecido.

Saludos cordiales,

🗨️ 5
BocaDePez
BocaDePez

Hola Omg78:

Logre hacerlo funcionar con un router cisco 1811 con la instrucción "mac-address xxxx.xxxx.xxxx" para clonar la mac del router que te da ONO (nunca la del cable modem).

Con el cisco 877 fue imposible.

Te copio la versión del hardware cisco 1811

--------

Cisco IOS Software, C181X Software (C181X-ADVIPSERVICESK9-M), Version 12.4(6)T11                                                                                                                                , RELEASE SOFTWARE (fc2)
Technical Support:cisco.com/c/en/us/support/index.html
Copyright (c) 1986-2008 by Cisco Systems, Inc.
Compiled Thu 06-Mar-08 20:56 by khuie

ROM: System Bootstrap, Version 12.3(8r)YH12, RELEASE SOFTWARE (fc1)

rONO uptime is 1 hour, 46 minutes
System returned to ROM by power-on
System restarted at 16:55:18 PCTime Thu May 6 2010
System image file is "flash:c181x-advipservicesk9-mz.124-6.T11.bin"

This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
pepd.cloudapps.cisco.com/legal/export/pepd/Search.do

If you require further assistance please contact us by sending email to
export@cisco.com.

Cisco 1811 (MPC8500) processor (revision 0x400) with 118784K/12288K bytes of memory.
Processor board ID XXXXXXXXXXXXXXX, with hardware revision 0000

10 FastEthernet interfaces
1 Serial interface
1 terminal line
31360K bytes of ATA CompactFlash (Read/Write)

Configuration register is 0x2102
-----------------

y las lineas que debes añadir en tu interface de red

interface FastEthernet0
 mac-address hex1.hex2.hex3                   (son 3 grupos en hexadecimal de 4 caracteres y se corresponden a la mac del router ONO)
 ip address dhcp client-id FastEthernet0

---------------

espero que te sirva de ayuda

saludos
🗨️ 4
omg78

Hola, muchas gracias por contestar.

Realmente la idea es tratar de no tener que comprar ningún router o appliance físico adicional, y sí utilizar en este caso una máquina física con una solución tipo Vyatta, etc.

Pero en vista de que no cogía la IP fíja contratada ni de lejos, fué cuando me dió por bajar al máximo nivel de sencillez, y tratar de hacerlo funcionar todo con un FreeBSD (que domino algo más), para posteriormente y en caso de conseguirlo, tratar de obtener el mismo resultado con algo tipo Vyatta, pfsense, etc.

No obstante, me guardo tu configuración de Cisco, en el caso de que tampoco consiga hacerlo funcionar, y me vea obligado a tener que comprar de segunda mano un router como el tuyo en eBay.

Por cierto que hay algo que me ha llamado muchísimo la atención: Dices que no hay que meter la MAC del CM sino la del router?!

Eso que comentas tendría absolutamente toda su lógica, puesto que el comportamiento de lo que quiero hacer es el correcto, pero induce a pensar ya que la propia MAC que estás metiendo no debe ser la correcta...

... Pero como luego llamé a ONO varias veces, y me dijeron que la MAC a especificar era la del CM (nunca me hablaron de la MAC del router), repitiendome caracter a caracter cual es la que ellos tenían allí dada de alta, es lo que hace que no me cuadre.

Hay una cosa que está clara, y es que jamás he probado a hacer las pruebas con la MAC del router. Sólo lo he hecho todo con la MAC del CM.

Entiendo que tú especificaste tu MAC del router y por fin fué como te funcionó, no?

Un saludos y muchísimas gracias.

🗨️ 3
omg78

Hola de nuevo,

Nada, he probado con la MAC del router (no la del CM), y hasta incluso con la MAC de la LAN del cablemodem-router "all-in-one" de Cisco (Modelo EPC3825), y *NADA*.

Es decir, funcionar funciona pero al 90%. Cojo IP (una diferente cada vez, y en varios rangos), pero no consigo coger la IP fija que tengo contratada.

Estoy desesperado... ¿Qué estoy haciendo mal? Es una chorrada absoluta esto y me está dando una guerra...

🗨️ 2
d3m0v
🗨️ 1
omg78