Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

ADSL

Cisco 857 con vodafone

manubonito

Hola,

Estoy intentando hacer que funcione y no hay manera, el led de CD se queda fijo asi que sincroniza y todo se levanta pero no consigo que me de la IP de forma dinamica y no puedo navegar, pongo la configuracion y los datos que he sacado del router de vodafone.

De momento me conformo con que funcionen los datos, la voz ya veremos.

userName="hg556.acs.autocfg@instalacion" password="instalacion"

VOZ VPI/VCI 0 34 encapsulacion llc/snap routing (IP over ATM) IPoA 172.x.x.x 255.255.255.0

DATOS VPI/VCI 0 44 datos encapsulacion llc/snap bridging MAC encapsulation routing (MER) ip dinamica

DNS

212.166.132.101

212.166.132.104

A ver si alguien que lo haya conseguido me puede echar un cable.

Gracias!

Router#sh run

Building configuration...

Current configuration : 1282 bytes

!

version 12.4

no service pad

no service timestamps debug uptime

no service timestamps log uptime

service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

enable secret 5

!

no aaa new-model

!

resource policy

!

ip subnet-zero

!

!

ip cef

ip name-server 212.166.132.101

ip name-server 212.166.132.104

vpdn enable

!

!

interface ATM0

no ip address

no atm ilmi-keepalive

pvc 0/44

protocol pppoe

!

dsl operating-mode auto

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface Vlan1

ip address 192.168.0.200 255.255.255.0

ip nat inside

ip virtual-reassembly

!

interface Dialer1

mtu 1492

ip address negotiated

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

ppp authentication pap callin

ppp pap sent-username hg556.acs.autocfg@instalacion password 7 060F0132584F0518061E1D05

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

!

no ip http server

no ip http secure-server

ip nat inside source list 1 interface Dialer1 overload

!

access-list 1 permit 192.168.0.0 0.0.0.255

!

control-plane

!

!

line con 0

no modem enable

line aux 0

line vty 0 4

password 7

login

!

scheduler max-task-time 5000

end

BocaDePez
BocaDePez

En el mio aparece:

Obtain an IP address automatically

DHCP Class Identifier:dslforum.org

No se si tiene eso algo que ver. no estoy familiarizado con este tipo de DHCP.

De todas formas, viendo que la IP de Vodafone es "fija", has provado a configurarlo con ip estatica pasándole la IP, Máscara y la puerta de enlace manualmente?

Quizá funcione.

🗨️ 1
BocaDePez
BocaDePez

el DHCP Class, es clave de todo.Con esta config deberia valer.

interface ATM0

no ip address

ip nat outside

ip virtual-reassembly

ip route-cache flow

no ip mroute-cache

no atm ilmi-keepalive

dsl operating-mode auto

max-reserved-bandwidth 100

hold-queue 224 in

!

interface ATM0.34 point-to-point ----->>Interfaz de VOIP

mtu 1500

ip address x.x.x.x 255.255.255.0

ip nat outside

ip virtual-reassembly

pvc 0/34

encapsulation aal5snap

!

!

interface ATM0.44 point-to-point

ip address dhcp hostname dslforum.org

ip nat outside

ip virtual-reassembly

atm route-bridged ip

pvc 0/44

encapsulation aal5snap

!

manubonito

DHCP es para que te asigne la IP automaticamente, segun me han dicho en el soporte tecnico de vodafone es dinamica, en esta linea le digo al router que lo haga asi

ip address negotiated

Nadie tiene un cisco con adsl de vodafone?

🗨️ 2
BocaDePez
BocaDePez

no, si eso lo tengo claro... lo que pasa es que Vodafone te dice que es dinámica la IP pero en realidad es fija. Es más... desde que estoy con ellos tengo siempre la misma IP.

Acabo de comprobar si funciona poniendo IP fija, y si que funciona. Estoy enviando este mensaje con la nueva configuración y va perfecto.

Así que intenta a ver si te funciona. Para sacar la Mascara tendrás que conectarte por telnet y obtenerlo mediante ifconfig. No la he encontrado en la web de configuración.

El problema te vendrá con la voz. No la hice funcionar ni configurandolo manualmente en el router de Vodafone.

BocaDePez
BocaDePez
1

No, Cisco es caro y su software es rancio y vetusto.

Algunos tenemos un MikroTik con RouterOS; es mucho más barato, ofrece mejor capacidades y menor consumo de energía.

Aquí te lo dejo: mikrotik.com/product/RB751G-2HnD

manubonito

con ip estatica sigue sin funcionar

pongo una salida, parece que esta todo bien pero no consigo navegar

#sh dsl interface atm 0

ATM0

Alcatel 20190 chipset information

ATU-R (DS) ATU-C (US)

Modem Status: Showtime (DMTDSL_SHOWTIME)

DSL Mode: ITU G.992.5 (ADSL2+) Annex A

ITU STD NUM: 0x03 0x2

Chip Vendor ID: 'STMI' 'BDCM'

Chip Vendor Specific: 0x0000 0xA1F1

Chip Vendor Country: 0x0F 0xB5

Modem Vendor ID: 'CSCO' 'BDCM'

Modem Vendor Specific: 0x0000 0x0000

Modem Vendor Country: 0xB5 0xB5

Serial Number Near: FCZ1019235T

Serial Number Far:

Modem Version Near: 12.4(4)T2

Modem Version Far: v10.03.113

Capacity Used: 76% 100%

Noise Margin: 8.0 dB 9.5 dB

Output Power: 19.0 dBm 12.0 dBm

Attenuation: 38.0 dB 23.0 dB

Defect Status: None None

Last Fail Code: None

Watchdog Counter: 0xE6

Watchdog Resets: 0

Selftest Result: 0x00

Subfunction: 0x00

Interrupts: 332991 (0 spurious)

PHY Access Err: 0

Activations: 3

LED Status: ON

LED On Time: 100

LED Off Time: 100

Init FW: embedded

Operation FW: embedded

FW Version: 2.542

DS Channel1 DS Channel0 US Channel1 US Channel0

Speed (kbps): 0 7157 0 886

Cells: 0 35 0 843042

Reed-Solomon EC: 0 47 0 0

CRC Errors: 0 0 0 0

Header Errors: 0 0 0 0

Interleave Delay: 0 4 0 2

LOM Monitoring : Disabled

DMT Bits Per Bin

000: 0 0 0 0 0 0 0 6 9 B A B B C C C

010: C C C C C C C B B B B B A A A A

020: 0 2 2 5 5 6 6 7 7 7 7 7 8 8 8 8

030: 9 8 9 9 9 9 9 9 9 9 9 9 9 9 9 9

040: 9 A A 9 9 A 9 2 A 9 9 9 9 9 9 9

050: 9 9 9 9 9 9 9 9 9 9 9 9 9 9 9 9

060: 9 9 9 9 9 9 9 9 9 9 9 9 9 9 9 9

070: 9 9 9 8 9 8 8 8 8 8 8 7 7 2 4 5

080: 6 7 7 6 4 0 2 5 5 7 7 7 7 7 8 8

090: 7 7 7 7 7 7 7 7 7 5 2 2 0 7 7 7

0A0: 7 7 7 7 7 7 7 7 7 5 2 0 2 5 7 7

0B0: 7 7 7 7 7 6 6 7 7 7 7 7 7 7 7 7

0C0: 2 7 7 7 7 7 7 7 7 7 7 5 4 2 5 6

0D0: 7 7 7 7 7 7 7 7 7 7 7 0 5 5 7 5

0E0: 6 7 7 6 6 7 7 7 6 7 6 7 7 6 5 5

0F0: 5 6 5 6 5 6 6 6 6 6 6 6 6 6 5 6

100: 6 7 7 6 5 6 6 6 7 7 7 6 6 5 6 6

110: 7 7 7 7 7 7 6 7 6 6 5 6 5 7 7 7

120: 6 7 7 7 4 6 7 6 5 6 6 6 3 2 5 5

130: 6 6 7 7 7 7 7 5 7 6 7 7 7 6 6 2

140: 5 6 6 6 6 6 2 2 0 4 2 5 4 5 1 5

150: 4 5 2 5 5 4 0 2 0 2 0 0 2 2 3 2

160: 0 0 2 2 1 0 1 0 2 0 2 4 4 2 2 0

170: 3 3 3 0 0 2 4 4 4 4 4 4 4 4 4 4

180: 4 4 2 2 2 4 4 4 4 4 3 3 2 3 3 3

190: 3 3 2 2 2 3 3 2 2 3 2 2 2 2 2 2

1A0: 2 2 0 2 2 2 2 2 2 2 2 2 2 2 2 1

1B0: 2 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

1C0: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

1D0: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

1E0: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

1F0: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

DSL: Training log buffer capability is not enabled

vukits
1

Ah, pero ¿Vodafone te deja usar tu propio router ADSL y además te da los datos del VoIP ??

Eso es nuevo.. hasta hace semanas, era exactamente lo contrario

manubonito

los datos los he sacado del router de vodafone, en el servicio tecnico me los han dado mal, con errores no se si intencionadamente, me da igual la verdad.

que yo sepa con cualquier operador puedes usar el router que quieras, yo de momento me conformo con que funcione la adsl

🗨️ 8
vukits

con cualquier operador puedes usar el router que quieras

esta frase es incorrecta ..

BocaDePez
BocaDePez

Con Vodafone no. Dado que usan la Huawei DHCP technology. Esto es que comprueban la MAC del router que sea el que tiene que ser. Lo siento pero esta compañía es así de cotia

🗨️ 6
BocaDePez
BocaDePez
1

De traca, señores de la zona franca. Son ustedes rancios y tacaños.

Los que en su día creyeron en Comunitel como una empresa viable deben estar revolcándose de frustración en sus camas.

🗨️ 5
Alex B

Teniendo un cisco debería saber trabajar con la consola.....

Basta con hacer un ifconfig con el HW address de la interfaz WAN (el modem) del huawei que tenga en su casa y llistos.

El truco mas antiguo que hay :D.

Entonces por lo que comenta arriba los equipos en la central tambien son huawei?

🗨️ 4
BocaDePez
BocaDePez
🗨️ 3
Alex B
🗨️ 2
BocaDePez
BocaDePez
BocaDePez
BocaDePez
manubonito

entonces no se puede usar otro router?

yo uso cisco porque quiero practicar para las certificaciones y si lo tengo con la adsl siempre conectado es mas facil que lo use, no porque sea el mejor fabricante para particulares.

🗨️ 32
BocaDePez
BocaDePez
-1

No, no se puede.

vukits

configura el CISCO como router neutro... (ponle WAN IP 192.168.0.253 ) y conecta su puerto WAN a un puerto del switch del de Vodafone..

y en el huawei pon la dirección WAN (192.168.1.253) del CISCO como DMZ Host .. reinicia el router de Vodafone..

y ya podrás practicar todo lo que tú quieras ;)

🗨️ 1
BocaDePez
BocaDePez
1

Por ese sistema he tenido yo un neutro Netgear mucho tiempo, en realidad funciona perfectamente hasta sin poner el DMZ.

Alex B

Si utilizas la consola y fuerzas la mac a la del que previamente habrás conseguido del huawei sí, si se puede.

🗨️ 28
BocaDePez
BocaDePez

Eso como ya ha comentado Vukits no funciona. Yo probé hasta cambiando la bootbase de un Zyxel con la MAC modificada para que tuviera la misma que la del Huawei y no va.

🗨️ 27
Alex B

Seguro??

Deberia funcionar si configuras tu router que utilize MER y con la mac del huawei.

No hace falta cambiar la bootbase, simplemente, con ethtools del busybox y el comando ifconfig le dices que dirección mac tenga la wan.

En el peor caso podría ser debido a el servicio dhcpc sea personalizado, pero eso lo puedes sacar de cualquier binario de los huawei y intentar hacerlo ejecutar en el cisco o con el código fuente creo que está el código fuente del dhcpc, compilarlo con crosscompiling para tu cisco.

Un saludo.

🗨️ 26
BocaDePez
BocaDePez
🗨️ 25
Alex B
-1
🗨️ 24
BocaDePez
BocaDePez
1
🗨️ 23
Alex B
-1
🗨️ 22
BocaDePez
BocaDePez
🗨️ 21
Alex B
-1
🗨️ 20
BocaDePez
BocaDePez
🗨️ 19
BocaDePez
BocaDePez
🗨️ 11
BocaDePez
BocaDePez
🗨️ 10
BocaDePez
BocaDePez
🗨️ 9
BocaDePez
BocaDePez
🗨️ 8
bios
🗨️ 7
BocaDePez
BocaDePez
🗨️ 2
bios
🗨️ 1
BocaDePez
BocaDePez
BocaDePez
BocaDePez
🗨️ 3
bios
🗨️ 2
BocaDePez
BocaDePez
-1
🗨️ 1
bios
Alex B
🗨️ 6
BocaDePez
BocaDePez
🗨️ 5
Alex B
🗨️ 4
BocaDePez
BocaDePez
🗨️ 3
BocaDePez
BocaDePez
🗨️ 2
BocaDePez
BocaDePez
🗨️ 1
BocaDePez
BocaDePez
manubonito

pues menuda kk, yo juraria que eso no es legal, almenos no deberia serlo

utiliza MER (MAC encapsulation routing), he intentado colarle la MAC del router vodafone en la configuracion del DHCP pero no hay opcion

🗨️ 1
vukits

muchos usuarios han clonado la MAC .. funciona durante unos minutos y luego la conexión se cae ;)

BocaDePez
BocaDePez

si, para configurarlo desde el portatil lo tengo conectado como un PC al router vodafone, pero era por la gracia de que funcionase la ADSL, ya veo que no va a poder ser

para practicar un poco en serio uso el GNS3

gracias de todas formas y un saludo

🗨️ 1
BocaDePez
BocaDePez

Alguien lo ha conseguido finalmente ???

Yo tengo varios cisco 87x con rfc1483b (encapsulado MER) con líneas de ya.com y funcionan de fábula (red albura, creo).

Sé que el circuito del adsl directo es 0/44 con mer, pero no hay manera.... en el dhcp se queda negociando y nada.

JupiterJones

Hola,

Yo conseguí conectarme con un DLink DSL-2740B C2, aunque tuve que tocar el firmware (encontré un bug).

Os adjunto un link en este foro.

Además, en su momento encontré en el foro de vodafone un moderador del foro que posteó los datos de conexión de Vodafone. Lo importante era que "El CPE debe enviar un hostname", es decir el modem router debe enviar un hostname.

Lo de clonar las MACs, no me parece mala idea aunque yo no lo necesité.

En su momento, haciendo pruebas conecté un modem DLink DSL-320B monopuerto y mi portátil a este (con Windows 7... y hostname) y también conseguí conectar.

También recuerdo que en una de las pruebas dejé el router sin conexión DHCP durante un rato conectado, y al cabo del rato cogió IP (el router tiene un LED que indica cómo está la conexión, y por ello me dí cuenta).

Suerte!

🗨️ 1
BocaDePez
BocaDePez

interface Dialer1

mtu 1492

ip address negotiated

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

ppp authentication pap callin

ppp pap sent-username hg556.acs.autocfg@instalacion password 7 060F0132584F0518061E1D05

estas poniendo user name el que se usa para entrar en la maquina que configura el router