Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

hosting en interdominios
127 lecturas y 14 respuestas
  • Este tema es antiguo y puede contener información obsoleta. Abre un nuevo tema para publicar tu mensaje.
    1
      • Cerrado

        Hola a todos retomando el tema (configuración de IP fija en…

        Hola a todos retomando el tema (configuración de IP fija en telefonica) y según me indicó (creo) BocaDePez ja,ja.. y despues de poner router#erase startup-config (para borrar todo) a continuación en el modo router(config)# le metí todo esto (algunas cosas las pone el router por su cuenta):
        !
        version 12.3
        no service pad
        service timestamps debug uptime
        service timestamps log uptime
        no service password-encryption
        !
        hostname NOMBRE
        !
        enable secret PASSWORD
        !
        username USUARIO password MY PASSWORD
        no aaa new-model
        ip subnet-zero
        no ip domain lookup

        !
        no voice hpi capture buffer
        no voice hpi capture destination
        !
        interface Loopback0
        ip address MI IP FIJA MASCARA (SUMINISTRADA POR TLELF.)
        !
        interface Ethernet0
        ip address 10.0.0.1 255.255.255.0 (MI IP RED INTERNA+MASCARA)
        ip nat inside
        no ip mroute-cache
        no cdp enable
        hold-queue 100 out
        !
        interface Virtual-Template1
        ip unnumbered Loopback0
        no peer default ip address
        !
        interface ATM0
        no ip address
        no ip mroute-cache
        no atm ilmi-keepalive
        dsl operating-mode auto
        !
        interface ATM0.1 point-to-point
        ip unnumbered Loopback0
        ip nat outside
        pvc 8/32
        inarp 1
        no ilmi manage
        oam retry 2 4 5
        encapsulation aal5snap
        !
        !
        ip nat pool pool1 MI IP FIJA MI IP FIJA netmask 255.255.255.0
        ip nat inside source list 1 pool pool1 overload
        ip classless
        ip route 0.0.0.0 0.0.0.0 ATM0.1
        no ip http server
        !
        access-list 1 permit 10.0.0.0 0.0.0.255 (MI IP RED INTERNA-1+MASCARA)
        no cdp run
        !
        voice-port 1
        !
        voice-port 2
        !
        voice-port 3
        !
        voice-port 4
        !
        !
        line con 0
        exec-timeout 120 0
        line vty 0 4
        exec-timeout 0 0
        login local
        !
        scheduler max-task-time 5000
        !
        end
        ********
        Le toca copiarlo en NVRAM Hacemos Router#copy running-config startup-config y despues reiniciamos con la nueva configuración Router#reload. Despues de encender el LED CD y alternativamente RXD y TXD se apagan los dos ultimos y queda encendido solo el CD en modo terminal indica lo siguiente (esta un poco resumido):
        System Bootstrap, Version 12.2(1r)XE2, RELEASE SOFTWARE (fc1)
        TAC Support: http://www.cisco.com/cgi-bin/ibld/view.pl?i=support
        Copyright (c) 2001 by cisco Systems, Inc.
        C827-4v platform with 49152 Kbytes of main memory

        program load complete, entry point: 0x80013000, size: 0x699ed4
        Self decompressing the image : #################################################
        ############################################################################# [O
        K]

        Restricted Rights Legend

        Use,.....
        Cisco ..................48128K/1024K bytes of memory.
        Processor .................CPU rev number 5
        Bridging software.
        4 POTS Ports
        1 Ethernet/IEEE 802.3 interface(s)
        1 ATM network interface(s)
        128K bytes of non-volatile configuration memory.
        12288K bytes of processor board System flash (Read/Write)
        2048K bytes of processor board Web flash (Read/Write)

        *Mar 2 02:53:10.231: %LINEPROTO-5-UPDOWN: Line protocol on Interface VoIP-Null0
        , changed state to up
        *Mar 2 02:53:21.631: %LINK-3-UPDOWN: Interface Ethernet0, changed state to up
        *Mar 2 02:53:21.631: %PQUICC-1-LOSTCARR: Unit 0, lost carrier. Transceiver prob
        lem?
        *Mar 2 02:53:22.631: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0,
        changed state to down
        *Mar 2 02:53:22.847: %LINK-3-UPDOWN: Interface ATM0, changed state to down
        *Mar 2 02:53:23.847: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0, changed state to down
        *Mar 2 02:53:27.659: %LINK-5-CHANGED: Interface ATM0, changed state to administ
        ratively down
        *Mar 2 02:53:27.903: %SYS-5-RESTART: System restarted --
        Cisco Internetwork Operating ............................
        ..........Copyright (c) 1986-2004 by cisco Systems, Inc.
        Compiled ............................................
        *Mar 2 02:53:27.907: %SNMP-5-COLDSTART: SNMP agent on host Router is undergoing a cold start
        *Mar 2 02:53:28.747: %LINK-5-CHANGED: Interface Ethernet0, changed state to adm inistratively down.
        Os puedo asegurar que la linea está bien (funcina con un modem USB), haber si me podeis indicar que está mal.
        Perdon por el ladrillo y Saludos para todos.

        • Cerrado

          Vamos a ver. Entra al router , Te pones en modo EXEC con el…

          Vamos a ver.

          Entra al router ,
          Te pones en modo EXEC con el comando enable (te pedira el password)

          Ahora entras en modo de configuracion global con configure terminal

          Entras en configuracion especifica de atm0 interface atm0

          Ejecutas no shutdwon y sales con exit

          Entras en configuracion especifica de atm0.1 con interface atm0.1

          Igual, no shutdown y exit

          Pulsa Ctrl+Z y haces un copy run start

          Un saludo.

          Vale, ahora prueba a ver si puedes hacer desde tu pc, un ping a la direccion IP que has configurado como publica. Sigues sin navegar, desde modo EXEC haz un sh protocol y lo pegas aqui.

          Un saludo.

          • Cerrado

            funciona el ping a 10.0.0.2 pero sigue lost carrier, pero le…

            funciona el ping a 10.0.0.2 pero sigue lost carrier, pero le he metido esta otra:
            no service pad
            service timestamps debug uptime
            service timestamps log uptime
            no service password-encryption
            !
            hostname Cisco827
            enable secret ttdadmin
            username ORION password ttdadmin
            !
            mi polling-interval 60
            no mmi auto-configure
            no mmi pvc
            mmi snmp-timeout 180 !
            ip subnet-zero
            no ip domain-lookup
            !
            interface Ethernet0
            no shutdown
            ip address 10.0.0.1 255.255.255.0
            ip nat inside
            no ip mroute-cache
            no cdp enable
            hold-queue 100 out
            !
            interface ATM0
            no shutdown
            no ip address
            ip access-group 106 in
            no ip route-cache
            no ip mroute-cache
            no atm auto-configuration
            no atm ilmi-keepalive
            no atm ilmi-enable
            bundle-enable
            dsl operating-mode auto
            hold-queue 208 in
            !
            interface ATM0.1 point-to-point
            ip address x.x.x.x mascara (ip fija y mascara)
            no shutdown
            ip nat outside
            pvc 8/32
            !inarp 1*** esto lo he deshabilitado (no se para que sirve)
            no ilmi manage
            oam retry 2 4 5
            encapsulation aal5snap
            !
            ip nat inside source list 101 interface ATM0.1 overload
            ip nat inside source static tcp 10.0.0.5 139 x.x.x.x 139 extendable (x.x.x.x sustituido ip fija) no se para que sirve y si está bien
            ip nat inside source static tcp 10.0.0.5 138 x.x.x.x 138 extendable (x.x.x.x sustituido ip fija) no se para que sirve y si está bien
            ip nat inside source static tcp 10.0.0.5 137 x.x.x.x 137 extendable (x.x.x.x sustituido ip fija) no se para que sirve y si está bien
            ip classless
            ip route 0.0.0.0 0.0.0.0 ATM0.1
            no ip http server
            ip pim bidir-enable
            !
            access-list 101 permit ip any any
            access-list 106 deny tcp any any eq 139
            no cdp run
            !
            line console 0
            exec-timeout 120 0
            stopbits 1
            line vty 0 4
            access-class 23 in
            exec-timeout 120 0
            password (my pasword)
            login
            length 0
            !
            scheduler max-task-time 5000
            end
            Despues de esto me da ATM0 is up, line protocol is up ,Ethernet0 is up, line protocol is down
            %PQUICC-1-LOSTCARR: Unit 0, lost carrier. Transceiver problem?
            Saludos ha todos.

            • Cerrado

              BocaDePez BocaDePez
              6
              Por que no quitas la lista 106 del interfaz atm0, estás…

              Por que no quitas la lista 106 del interfaz atm0, estás denegando todo.

              Prueba primero que te funciona sin access-list.

              La lista correcta debería ser:

              access-list 106 deny _lo que sea_
              access-list 106 permit ip any any

              La úlitma instrucción implicita en cualquier access-list es:
              deny any any.
              En la configuración que has pegado, deniegas cualquier tráfico de entrada en el atm0.

              Haz también lo que te han dicho del no shutdown en cada interfaz, y repitelo cada vez que borres la config, porque ese, también es otro comportamiento por defecto.

              %PQUICC-1-LOSTCARR: Unit 0, lost carrier. Transceiver problem?

              Donde está conectado el router? a un switch? un hub?

              Comprueba que no hay problemas de negociación entre switch y router.

              Has pruebas conectando un pc directamente, a ver que pasa.

              -mjuliaq

              • Cerrado

                Ya arregle el problema, tenia mal el cable de Red,ahora tengo…

                Ya arregle el problema, tenia mal el cable de Red,ahora tengo todos los interfaces "up", solo tengo un pequeño problema co conecto con internet, esto es de locos.
                Le metí esta una sencilla tipo bridge (para un solo Pc sin Nac ni nada) haber si rulaba:
                **********
                no service pad
                service timestamps debug datetime msec
                service timestamps log datetime msec
                no service password-encryption
                !
                hostname PiazoRouter
                !
                enable secret ME c...
                !
                username S.P.M. password ME c...
                no aaa new-model
                ip subnet-zero
                !
                bridge irb
                !
                interface Ethernet0
                ip address 10.0.0.1 255.0.0.0
                ip nat inside
                no shutdown
                no cdp enable
                hold-queue 100 out
                !
                interface ATM0
                no shutdown
                no ip address
                no atm ilmi-keepalive
                pvc 8/32
                encapsulation aal5snap
                !
                dsl operating-mode auto
                bridge-group 1
                hold-queue 208 in
                !
                interface BVI1
                no shutdown
                ip address (IP FIJA) (MASCARA)
                ip nat outside
                !
                ip nat inside source list 1 interface BVI1 overload
                ip classless
                no ip http server
                !
                access-list 1 permit 10.0.0.0 0.0.0.255
                no cdp run
                bridge 1 protocol ieee
                bridge 1 route ip
                !
                line con 0
                exec-timeout 120 0
                line vty 0 4
                exec-timeout 0 0
                login local
                !
                scheduler max-task-time 5000
                !
                end
                ******
                En el PC he puesto:
                Direccion IP 10.0.0.2
                Mascara de subred 255.0.0.0
                Puerta de enlace predeterminada 10.0.0.1
                Y las direcciones del servidor DNS las que tenia y que funcionaban con el USB.
                Haber si se os ocurre algo.
                Saludos y gracias.

            • Cerrado

              Prueba a meterte otra vez y ... enable configure terminal…

              Prueba a meterte otra vez y ...

              enable
              configure terminal
              interface eth0
              no shutdown

              Si sigue dando ese error de que pierde la portadora ... igual esta averiado el router :S

              Un saludo.

    • Cerrado

      BocaDePez BocaDePez
      6

      Por supuesto, lo que esta entre corchetes lo debes cambiar…

      Por supuesto, lo que esta entre corchetes lo debes cambiar por los valores que te correspondan.

      La pata ethernet tendra por ip la 192.168.1.1/24, hara NAt paar todos los PC's que haya en esa red y estará configurado para que el pc que tenga por Ip la 192.168.1.2 sea maquina por defecto para las conexiones entrantes.
      (Casi como si estuviera en monopuesto)

      Acuerdate de que los PC's tengan como ip del gateway por defecto la del router (192.168.1.1).

      Si encima quieres DHCP, por eso si que te cobro... :P

      ! ****** Con esto borrarás toda las guarrerias que hayas hecho con la configuración***
      erase startup-config
      ! ****** Así reinicias el cacharro para que realmente tengas la configuración limpia ***
      reload

      ! ****** Aqui empieza la configuracion que debes meter ***

      hostname [PeasoMaquina]

      enable secret [UnaPasswordParaConfigurarElCacharro]
      username [UnUsuarioParaAccederAlcacharro] password [UnaPasswordParaAccederAlCacharro]
      ip subnet-zero

      interface Ethernet0
      ip address 192.168.1.1 255.255.255.0

      interface ATM0
      no ip address
      no atm ilmi-keepalive
      dsl operating-mode auto

      interface ATM0.1 point-to-point
      bandwidth 512
      ip address [LaIpFijaQueTeDioTelefonica] [La Mascara]
      pvc 8/32
      protocol ip inarp
      encapsulation aal5snap

      ip classless
      ip route 0.0.0.0 0.0.0.0 ATM0.1
      ip nat inside source static 192.168.1.2 interface atm0.1

      ****** Con esto haces que la configuración que has metido se guarde ***
      copy running-config startup-config

    • Cerrado

      BocaDePez BocaDePez
      6

      Espero que te sirva ! version 12.1 no service pad service…

      Espero que te sirva

      !
      version 12.1
      no service pad
      service timestamps debug uptime
      service timestamps log uptime
      no service password-encryption
      !
      hostname Router
      !
      !
      !
      !
      !
      !
      ip subnet-zero
      no ip domain-lookup
      !
      !
      !
      !
      interface Loopback0
      ip address 255.255.255.0
      !
      interface Ethernet0
      ip address 192.168.0.1 255.255.255.0
      ip nat inside
      no ip mroute-cache
      !
      interface Virtual-Template1
      ip unnumbered Loopback0
      no peer default ip address
      !
      interface ATM0
      no ip address
      no ip mroute-cache
      atm ilmi-keepalive
      bundle-enable
      dsl operating-mode auto
      !
      interface ATM0.1 point-to-point
      ip unnumbered Loopback0
      ip nat outside
      pvc 8/32
      inarp 1
      no ilmi manage
      oam retry 2 4 5
      encapsulation aal5snap
      !
      !
      ip nat pool pool1 netmask 255.255.255.0
      ip nat inside source list 1 pool pool1 overload
      ip classless
      ip route 0.0.0.0 0.0.0.0 ATM0.1
      no ip http server
      !
      access-list 1 permit 192.168.0.0 0.0.0.255
      no cdp run
      !
      line con 0
      logging synchronous
      transport input none
      stopbits 1
      line vty 0 4
      login
      !
      scheduler max-task-time 5000
      end

        • Cerrado

          BocaDePez BocaDePez
          6

          No se que es fast step, pero abres el hyperterminal y le…

          No se que es fast step, pero abres el hyperterminal y le haces un copy/paste.

          yo lo configuro por telnet cuando ya lo tengo habilitado

      • Cerrado

        BocaDePez BocaDePez
        6

        Estos comandos no han salido bien: interface Loopback0 ip…

        Estos comandos no han salido bien:

        interface Loopback0
        ip address (ip fija) 255.255.255.0

        ip nat pool pool1 (ip fija) (ip fija) netmask 255.255.255.0