Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

hosting en interdominios
40 lecturas y 9 respuestas
  • Cerrado

    Cambio de DNS en Router U.S. Robotics 8000-02

    Tengo un problema y necesito vuestra ayuda, veamos os explico:

    Salgo a internet mediante el Router "U.S. Robotics Broadband Router 8000-02" (conocido, no? XD) que conecta 3 máquinas, 2 Windows XP y 1 Linux (la mía) y el problema es el siguiente:
    Con esto de los problemas de navegación que se ha comentado aquí por culpa de las DNS me dí cuenta que yo también soy uno de los afectados. La DNS primaria que me asigna ONO no responde al ping (supongo que a eso se debe la lentitud de carga de las páginas), luego la solución es cambiar las DNS por otras que funcionen correctamente. Hasta ahi todo claro. Mi problema es que creo que deberia cambiar las DNS en el Router ya que en mi caso (Linux), he probado a cambiarlas en /etc/resolv.conf pero al reiniciar la conexión para aplicar los cambios vuelven a cargarse las de ONO, es decir, las que pilla el Router y el archivo vuelve a quedar con las DNS que tiene el Router. De modo que no es muy difícil llegar al a conclusión que las DNS las debo cambiar en el Router, pero ¿cómo?

    He entrado a la página de configuración de él (http://192.168.123.254) y me he paseado mil veces por todas las opciones que dispone y no encuentro la manera de poner las DNS manualmente. Tengo el servidor DHCP habilitado (obviamente para que pille la IP de ONO) pero supongo que ahi deberia haber alguna opción para poner las DNS manuales o automáticas (estilo propiedades TCP/IP de Windows) pero no la hay.

    ¿Alguna sugerencia? Igual me equivoco y no es preciso cambiar las DNS en el Router y simplemente cambiándolas en tu máquina ya usas esas DNS pero en mi caso, por mucho que cambie las DNS en /etc/resolv.conf vuelven a ponerse las que tiene el Router. Venga chic@s, ayudadme los que podáis porque necesito conectar mediante el Router y la navegación con estas DNS es insoportable (también suponiendo que el problema venga de ahi...)

    Gracias de antemano.

    Salu2!

    Este tema es antiguo y puede contener información obsoleta. Abre un nuevo tema para publicar tu mensaje.
    1
    • Cerrado

      BocaDePez BocaDePez
      6

      yo hoy he mandado el mio con 5 dias para que me lo cambien…

      yo hoy he mandado el mio con 5 dias para que me lo cambien por otro cuando lo apago al encederlo se ha ido todo le doy al ing del router y no enlaza me han dicho en usr que le cambie el firware a las 2.5 pero lo hago y el router ni caso directamente en usr nme han dicho que lo cambie por otro ¿que narizes pasa con el firware 2.7 porque supungo que el nuevo que me manden vendra con el 2.7

    • Cerrado

      BocaDePez BocaDePez
      6

      Yo también tengo, desgraciadamente un router "U.S. Robotics…

      Yo también tengo, desgraciadamente un router "U.S. Robotics Broadband Router (Model # 8000-02)".
      Y lo único que puedo decir de el es que es una PUTA MIERDA.
      Al principio no daba problemas, pero ultimamente pierde la configuración cuando le da la gana.
      Es el último producto de U.S.Robotics que compro.

      • Cerrado

        [Editado 28/11/04 20:16]

        ¿que versión del firmware tiene?, ¿la 2.5? ¿la 2.7? ¿pierde…

        ¿que versión del firmware tiene?, ¿la 2.5? ¿la 2.7?

        ¿pierde la configuración o la conexión?

        ¿podría ser problema de la fuente de alimentación (transformador) del router?

        "Al principio no daba problemas" ¿cuanto tiempo te ha ido bien?

    • Cerrado

      [Editado 16/11/04 00:22]

      Gracias InoculateIt, pero no encuentro dicho fichero. No…

      Gracias InoculateIt, pero no encuentro dicho fichero. No aparece en esa ruta y lo he buscado por todo /etc y no aparece. También he buscado la cadena "MODIFY_RESOLV_CONF_DYNAMICALLY" con grep y tampoco aparece. Por si te dice algo, uso MDK y no hay forma de encontrar algo que deshabilite la asignación automática de las DNS. He probado incluso a modificar los permisos de /etc/resolv.conf para que ni root pueda escribir en el fichero pero al reiniciar la red vuelve a escribir como si nada y vuelve a dejar las DNS que le da el Router.

      Si sabes alguna otra alternativa te agradeceria que me respondieses. Venga y a ver si alguien más me lee y se le ocurre algo. Gracias de nuevo.

      Salu2!

    • Cerrado

      Mira a ver si tienes el siguiente fichero:…

      Mira a ver si tienes el siguiente fichero:

      /etc/sysconfig/network/config

      Si lo tienes y en él aparece la siguiente opción:
      MODIFY_RESOLV_CONF_DYNAMICALLY="yes"

      cámbialo por:
      MODIFY_RESOLV_CONF_DYNAMICALLY="no"

    • Cerrado

      BocaDePez BocaDePez
      6

      He estado ojeando yo el mío y parece que no se puede. Yo creo…

      He estado ojeando yo el mío y parece que no se puede. Yo creo que más bien es un problema de configuración de tu linux, que tiene activado el ser cliente de DHCP. Busca para quitarlo.

      Txytx

    • Cerrado

      BocaDePez BocaDePez
      6

      No tengo mucha idea, pero puedes probar a desactivar el…

      No tengo mucha idea, pero puedes probar a desactivar el servicio DHCP del ruoter y asignar a los pcs una ip fija (se puede hacer desde el router). El router sigue cogiendo ip dinámica del cablemódem y las ips de los pc serán fijas. Luego en cada pc indicas la ip que le corresponde y supongo que ya podrás asignar las DNS que quieras.

      Saludos.