BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

Fibra

Cambiar Router ZTE 298Q por Xiaomi Mi Router AX1800 WiFi 6

rufote

En el post "Puerto 25 con DNS dinámico inalcanzable desde Internet" con el router ZTE298Q indico las razones por las que quiero cambiar el router por uno neutro que recomendaban en este Foro y que teoricamente soporta VLAN. Mantengo la ONT inicial y enchufo el puerto WAN del router a la ONT, le configuro la cuenta PPoE que Digi ya proporciona, configuro que el puerto WAN está en la VLAN 20 y arreando…

Y aqui está el problema, que no veo donde definir que la WAN está en la VLAN 20…en el router nuevo.

¿Alguna idea? ¿Alguien lo ha hecho ya?

Gracias y saludos.

SOLUCIÓN

Moisitor

Buenas, el AX1800 es global o chino? Si es global, creo recordar que la VLAN se configuraba en la primera configuración que le hagas en modo PPPoE. Si tienes el chino (torre negra) deberás ponérsela a través de la edición de un archivo llamado network. Eso si antes deberás habilitarle temporalmente el acceso ssh. Hay manuales al respecto por ahí.

El AX3600 si se que tiene seguro para poner la VLAN en la versión global cuando haces la primera configuración PPPoE.

rufote

Gracias. Trataré de probarlo. Es la versión global con miwifi_rm1800_firmware_6718d_1.0.34.bin y no recuerdo que al indicar que iba a usar PPPoE hubiera ninguna casilla para indicar el VLAN ID…Lo volveré a mirar y lo comento.

vukits
imagen.webp

sigue los siguientes pasos:

  1. conecta el router Xiaomi al de Digi, en modo normal (puerto WAN)… DHCP y tal…
  2. actualizar el firmware desde la interfaz del Xiaomi.
  3. Resetea el Xiaomi a ajustes de fábrica
  4. ya te debería aparecer la opción VLAN, con el firmware actualizado

para más info, consulta la F.A.Q

rufote

Al ver la versión que sale cuando consultas para hacer un update sale el Versión 3.0.34 , que es global.

Hasta donde he visto no se precisa flashear con ninguna versión que tenga un bug para tener acceso ssh y modificar las definiciones de interfaces…

El router permite configurar la WAN con PPPoE (con los datos que me ha proporcionado Digi) y luego tiene los siguientes input tipo check box:

  • Autoconfigure (autoexplicativo)
  • Configuracion manual (autoexplicativa)
  • Special ISP mode (?) - algunos dicen que con Digi hay que marcarlo, pero qué es?
  • MTU viene con 1480 pero en algunos sitios pone otro valor, creo que 1490 o por ahi…es el Maximum Transmission Unit creo recordar…
  • Name (Nombre je je je…) que supongo es donde hay que poner la información de interfaz y VLAN ID, aunque no se como.

He probado poniendo solo 20 y nada de nada, aunque también he visto que las interfaces se definen como eth1.20 …LO he probado y nada.

De hecho estoy dudando que los datos de PPPoE que me enviaron por email no son correctos…

Alguien puede aclararme como se nombran las VLAN en el AX1800 con versión global?

Gracias.

🗨️ 3
vukits

te he puesto el enlace y la captura de pantalla de un usuario que lo ha configurado.

Ruego hagas lo mismo, porque no me entero dónde te está dando fallo.

¿Qué paso te falla?

Pon capturas de pantalla

🗨️ 2
rufote

Me faltaba resetear el router…Trataba de configurarlo sin resetear previamente pues tengo mucho redireccionamiento de puertos y era una lata tener que volver a meterlos… Pensé que se podría hacer,pero no…Luego todo ha funcionado como decías y ya tengo un router propio muy económico con la misma ONT Huawei que me instaló Digi.

Muchísimas gracias por la ayuda

Por mi parte creo que se puede cerrar el hilo. Saludos

🗨️ 1
vukits

Me faltaba resetear el router…Trataba de configurarlo sin resetear

es un fallo de diseño común de los Xiaomi.

me alegro de que ya te funcione ;)

BocaDePez
BocaDePez
1

También tengo un Xiaomi ax1800 y como ha indicado vukits poniendo 20 en el 802.1Q TAG funciona perfectamente.

Pero ese setting solo se configura en el primer inicio del router desde reset de fábrica.

🗨️ 1
rufote
1

Asi es como funciona ciertamente!!! Gracias y saludos.