BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

Fibra/Cable

Caída PPPoE de fibra Vodafone con router Mikrotik RB4011

esthergb

Desde hace menos de un mes tengo contratado Vodafone con FTTH directa. Lo primero que hice es cambiar el router que me instaló Vodafone (Sercom H500-T) por un Mikrotik RB4011. Cree la VLAN 100 y sobre esta levanté el PPPoE con los datos que saque del Sercom con Wireshark. En principio todo funcionaba bien, tuve conexión enseguida y con la velocidad contratada.

Sin embargo, cada poco tiempo se cae el PPPoE y automáticamente reconecta en cuestión de pocos segundos. Aunque la caída es mínima, afecta a conexiones que tengo abiertas, sesiones que se cierran, etc…

He probado a ajustar el keepalive timeout e incluso el MTU, pero nada parece funcionar y las caídas son cada vez mas frecuentes, llegando a caer cada pocos minutos.

Temo que si llamo al soporte no me atiendan por no usar su router, por lo que acudo a la sabiduría de este foro.

¿Alguien ha tenido el mismo problema o sabría decirme por donde pueden ir los tiros?

NachoSH

Tendrás que poner el H500 de nuevo a ver si también notas las desconexiones primero…

BocaDePez
BocaDePez

Lo primero mira a ver si hay una actualizacion de firmware para ese router

Lo segundo baja el "keep-Alive" al mínimo

Lo tecero prueba con el router de la operadora a ver si siguen las caidas, tal y como te ha comentado @NachoSH

Lo mas probable es que la operadora no te de sopporte con ese router.

MickDiaz

Exactamente me ocurria lo mismo pero con un RB 1100AHx2

Mi solución fue irme a Movistar con ONT Nokia, muy a mi pesar al principio, pero funciona. Nunca habia conseguido con Vodafone un mes entero sin caerse.

Vodafone es una castaña para poner equipos que no son los suyos.

Y sus equipos… casi 5 minutos para reaprovisionar tras un reinicio.

De coña.

esthergb

Hola,

gracias por todas las respuestas, en cuando tenga un rato probaré a volver al router de Vodafone (cosa que no me hace gracia)

La configuración del Mikrotik no es muy complicada, es crear la VLAN y levantar el PPPoE

La ONT es un modulo SFP de Zisa, por lo que se configura en el puerto SFP

Vengo de Movistar con prácticamente la misma configuración y como dice @ByMick todo funcionaba sin problemas, pero ahora no puedo echar atrás por la permanencia de Vodafone :(

Os dejo la configuración como se me ha pedido, destacar que tal y como dije en el primer mensaje, he probado varias configuraciones del keepalive-timeout, MTU y MRU

P.D. No tengo TV, por lo que no se configura nada al respecto. El VoIP al ir por la VLAN de internet funciona sin problemas con un servidor Asterisk

/interface vlan
add interface=sfp-sfpplus1 name=sfp-internet vlan-id=100

/interface pppoe-client
add add-default-route=yes disabled=no interface=sfp-internet keepalive-timeout=10 max-mru=1492 max-mtu=1492 name=vodafone password=XXXXXXXX use-peer-dns=yes user=ONH0000XXXXXX@vodafone

/interface list
add name=Internet

/interface list member
add interface=vodafone list=Internet

/ip firewall filter
add action=accept chain=input connection-state=new in-interface-list=Internet protocol=icmp
add action=reject chain=input connection-state=invalid,new in-interface-list=Internet reject-with=icmp-host-unreachable src-address-list=!whitelist

/ip firewall nat
add action=masquerade chain=srcnat out-interface-list=Internet
BocaDePez
BocaDePez
1

Si te tienes que comer la permanencia hazle un script que te tire la conexion de madrugada, cuando no te enteras.

BocaDePez
BocaDePez
1

fakeale la mac addres a ver que tal, en los microtik tienes una opcion de que un puerto tenga la mac que quieras, y le pones la mac del mierdcomm 500. Deberia de ir bien, otra cosa es que Vodafone tire todos los dias la PPPoE por que les da la gana, tambien en otra opcion para que los que quieren IP fija o semi fija pasen por caja.

esthergb

Hola,

el problema no es que se caiga una vez al día, es que en un mismo día se puede llegar a caer hasta 10 o 15 veces,

y lo gracioso es que tengo contratada la IP Fija

He probado a clonar la mac, a ver que tal.

esthergb

Bueno,

pues tras haber probado con el router de Vodafone las últimas 24 horas, ningún corte.

Con el Mikrotik, incluso clonando la mac del Sercom, el PPPoE se cae cada muy poco tiempo.

Me da que me están tirando ellos al detectar que no es su equipo

🗨️ 4
BocaDePez
BocaDePez

Debe ser algún detalle de configuración (vete a saber cual). La única información "hardware" que le llega a Vodafone es la MAC (nivel 2 de la capa OSI), no se me ocurre ahora mismo ningún otro dato dato que puedan tener ellos sobre tu equipamiento.

apocalypse

Los problemas con el PPPoE en MikroTik son conocidos. Actualiza a la última versión y prueba más configuraciones.

🗨️ 1
esthergb

Hola,

puedes darme más información sobre los problemas conocidos?

He activado el debug y esto es lo que me muestra los logs en el momento de la caída:

Jan 12 01:34:45 172.16.0.1 pppoe,ppp,debug,packet  vodafone: rcvd LCP EchoReq id=0x4f
Jan 12 01:34:45 172.16.0.1 pppoe,ppp,debug,packet     <magic 0x80cd4b16>
Jan 12 01:34:45 172.16.0.1 pppoe,ppp,debug,packet  vodafone: sent LCP EchoRep id=0x4f
Jan 12 01:34:45 172.16.0.1 pppoe,ppp,debug,packet     <magic 0x107b50e8>

Jan 12 01:34:48 172.16.0.1 pppoe,ppp,debug,packet  vodafone: rcvd LCP ConfReq id=0x8a
Jan 12 01:34:48 172.16.0.1 pppoe,ppp,debug,packet    <mru 1492>
Jan 12 01:34:48 172.16.0.1 pppoe,ppp,debug,packet    <magic 0x23d0d606>
Jan 12 01:34:48 172.16.0.1 pppoe,ppp,debug,packet    <auth  chap>
Jan 12 01:34:48 172.16.0.1 pppoe,ppp,debug vodafone: LCP received ConfReq in opened state: restarting
Jan 12 01:34:48 172.16.0.1 pppoe,ppp,debug vodafone: LCP closed
Jan 12 01:34:48 172.16.0.1 pppoe,ppp,debug vodafone: CCP lowerdown
Jan 12 01:34:48 172.16.0.1 pppoe,ppp,debug vodafone: BCP lowerdown
Jan 12 01:34:48 172.16.0.1 pppoe,ppp,debug vodafone: BCP down event in starting state
Jan 12 01:34:48 172.16.0.1 pppoe,ppp,debug vodafone: IPCP lowerdown
Jan 12 01:34:48 172.16.0.1 pppoe,ppp,debug vodafone: IPCP closed
Jan 12 01:34:48 172.16.0.1 pppoe,ppp,debug vodafone: IPV6CP lowerdown
Jan 12 01:34:48 172.16.0.1 pppoe,ppp,debug vodafone: IPV6CP down event in starting state
Jan 12 01:34:48 172.16.0.1 pppoe,ppp,debug vodafone: MPLSCP lowerdown
Jan 12 01:34:48 172.16.0.1 pppoe,ppp,debug vodafone: MPLSCP down event in starting state
Jan 12 01:34:48 172.16.0.1 pppoe,ppp,debug,packet  vodafone: sent LCP ConfReq id=0xc2
Jan 12 01:34:48 172.16.0.1 pppoe,ppp,debug,packet    <mru 1492>
Jan 12 01:34:48 172.16.0.1 pppoe,ppp,debug,packet    <magic 0x436ebb9b>
Jan 12 01:34:48 172.16.0.1 pppoe,ppp,debug,packet  vodafone: sent LCP ConfAck id=0x8a
Jan 12 01:34:48 172.16.0.1 pppoe,ppp,debug,packet    <mru 1492>
Jan 12 01:34:48 172.16.0.1 pppoe,ppp,debug,packet    <magic 0x23d0d606>
Jan 12 01:34:48 172.16.0.1 pppoe,ppp,debug,packet    <auth  chap>
Jan 12 01:34:48 172.16.0.1 pppoe,ppp,debug,packet  vodafone: rcvd LCP TermReq id=0x36
Jan 12 01:34:48 172.16.0.1 pppoe,ppp,debug,packet  vodafone: sent LCP TermAck id=0x36
Jan 12 01:34:48 172.16.0.1 pppoe,ppp,debug vodafone: LCP lowerdown
Jan 12 01:34:48 172.16.0.1 pppoe,ppp,debug vodafone: CCP close
Jan 12 01:34:48 172.16.0.1 pppoe,ppp,debug vodafone: IPCP close
Jan 12 01:34:48 172.16.0.1 pppoe,ppp,debug vodafone: BCP close
Jan 12 01:34:48 172.16.0.1 pppoe,ppp,debug vodafone: IPV6CP close
Jan 12 01:34:48 172.16.0.1 pppoe,ppp,debug vodafone: MPLSCP close
Jan 12 01:34:48 172.16.0.1 pppoe,ppp,info vodafone: terminating...
Jan 12 01:34:48 172.16.0.1 pppoe,debug,packet sfp-internet: sent PADT to 00:00:9B:00:10:A1
Jan 12 01:34:48 172.16.0.1 pppoe,debug,packet     session-id=0x0001
Jan 12 01:34:48 172.16.0.1 pppoe,ppp,debug vodafone: LCP lowerdown
Jan 12 01:34:48 172.16.0.1 pppoe,ppp,debug vodafone: LCP down event in starting state
Jan 12 01:34:48 172.16.0.1 pppoe,ppp,info vodafone: disconnected
Jan 12 01:34:48 172.16.0.1 pppoe,ppp,info vodafone: initializing...
Jan 12 01:34:48 172.16.0.1 pppoe,ppp,info vodafone: connecting...
Jan 12 01:34:48 172.16.0.1 pppoe,debug,packet sfp-internet: sent PADI to FF:FF:FF:FF:FF:FF
Jan 12 01:34:48 172.16.0.1 pppoe,debug,packet     session-id=0x0000
Jan 12 01:34:48 172.16.0.1 pppoe,debug,packet     host-uniq=0x6c004b00
Jan 12 01:34:48 172.16.0.1 pppoe,debug,packet     service-name=vodafone
Jan 12 01:34:48 172.16.0.1 pppoe,debug,packet     ppp-max-payload=1492
Jan 12 01:34:48 172.16.0.1 pppoe,debug,packet sfp-internet: rcvd PADO from 00:00:9B:00:10:A1
Jan 12 01:34:48 172.16.0.1 pppoe,debug,packet     session-id=0x0000
Jan 12 01:34:48 172.16.0.1 pppoe,debug,packet     service-name=vodafone
Jan 12 01:34:48 172.16.0.1 pppoe,debug,packet     ac-name=RSRVAL01
Jan 12 01:34:48 172.16.0.1 pppoe,debug,packet     host-uniq=0x6c004b00
Jan 12 01:34:48 172.16.0.1 pppoe,debug,packet     ac-cookie=60 cb 2c 2b a3 60 5c a4 4e 67 6d 71 67 5b 31 1f
Jan 12 01:34:48 172.16.0.1 pppoe,debug,packet     ppp-max-payload=1492
Jan 12 01:34:48 172.16.0.1 pppoe,debug,packet sfp-internet: sent PADR to 00:00:9B:00:10:A1
Jan 12 01:34:48 172.16.0.1 pppoe,debug,packet     session-id=0x0000
Jan 12 01:34:48 172.16.0.1 pppoe,debug,packet     host-uniq=0x6d004b00
Jan 12 01:34:48 172.16.0.1 pppoe,debug,packet     service-name=vodafone
Jan 12 01:34:48 172.16.0.1 pppoe,debug,packet     ac-cookie=60 cb 2c 2b a3 60 5c a4 4e 67 6d 71 67 5b 31 1f
Jan 12 01:34:48 172.16.0.1 pppoe,debug,packet     ppp-max-payload=1492
Jan 12 01:34:48 172.16.0.1 pppoe,debug,packet sfp-internet: rcvd PADS from 00:00:9B:00:10:A1
Jan 12 01:34:48 172.16.0.1 pppoe,debug,packet     session-id=0x0001
Jan 12 01:34:48 172.16.0.1 pppoe,debug,packet     service-name=vodafone
Jan 12 01:34:48 172.16.0.1 pppoe,debug,packet     host-uniq=0x6d004b00
Jan 12 01:34:48 172.16.0.1 pppoe,debug,packet     ppp-max-payload=1492
Jan 12 01:34:48 172.16.0.1 pppoe,ppp,debug vodafone: LCP lowerup
Jan 12 01:34:48 172.16.0.1 pppoe,ppp,debug vodafone: LCP open
Jan 12 01:34:48 172.16.0.1 pppoe,ppp,debug vodafone: LCP timer
Jan 12 01:34:48 172.16.0.1 pppoe,ppp,debug,packet  vodafone: sent LCP ConfReq id=0xc3
Jan 12 01:34:48 172.16.0.1 pppoe,ppp,debug,packet    <magic 0x38349a93>
Jan 12 01:34:48 172.16.0.1 pppoe,ppp,debug,packet    <mru 1492>
Jan 12 01:34:48 172.16.0.1 pppoe,ppp,debug,packet  vodafone: rcvd LCP ConfAck id=0xc3
Jan 12 01:34:48 172.16.0.1 pppoe,ppp,debug,packet    <magic 0x38349a93>
Jan 12 01:34:48 172.16.0.1 pppoe,ppp,debug,packet    <mru 1492>
Jan 12 01:34:49 172.16.0.1 pppoe,ppp,debug vodafone: LCP timer
Jan 12 01:34:49 172.16.0.1 pppoe,ppp,debug,packet  vodafone: sent LCP ConfReq id=0xc4
Jan 12 01:34:49 172.16.0.1 pppoe,ppp,debug,packet    <magic 0x38349a93>
Jan 12 01:34:49 172.16.0.1 pppoe,ppp,debug,packet    <mru 1492>
Jan 12 01:34:49 172.16.0.1 pppoe,ppp,debug,packet  vodafone: rcvd LCP ConfAck id=0xc4
Jan 12 01:34:49 172.16.0.1 pppoe,ppp,debug,packet    <magic 0x38349a93>
Jan 12 01:34:49 172.16.0.1 pppoe,ppp,debug,packet    <mru 1492>
Jan 12 01:34:51 172.16.0.1 pppoe,ppp,debug vodafone: LCP timer
Jan 12 01:34:51 172.16.0.1 pppoe,ppp,debug,packet  vodafone: sent LCP ConfReq id=0xc5
Jan 12 01:34:51 172.16.0.1 pppoe,ppp,debug,packet    <mru 1492>
Jan 12 01:34:51 172.16.0.1 pppoe,ppp,debug,packet    <magic 0x38349a93>
Jan 12 01:34:51 172.16.0.1 pppoe,ppp,debug,packet  vodafone: rcvd LCP ConfAck id=0xc5
Jan 12 01:34:51 172.16.0.1 pppoe,ppp,debug,packet    <mru 1492>
Jan 12 01:34:51 172.16.0.1 pppoe,ppp,debug,packet    <magic 0x38349a93>
Jan 12 01:34:51 172.16.0.1 pppoe,ppp,debug,packet  vodafone: rcvd LCP ConfReq id=0xb7
Jan 12 01:34:51 172.16.0.1 pppoe,ppp,debug,packet    <magic 0xb644d134>
Jan 12 01:34:51 172.16.0.1 pppoe,ppp,debug,packet    <mru 1492>
Jan 12 01:34:51 172.16.0.1 pppoe,ppp,debug,packet    <auth  chap>
Jan 12 01:34:51 172.16.0.1 pppoe,ppp,debug,packet  vodafone: sent LCP ConfAck id=0xb7
Jan 12 01:34:51 172.16.0.1 pppoe,ppp,debug,packet    <magic 0xb644d134>
Jan 12 01:34:51 172.16.0.1 pppoe,ppp,debug,packet    <mru 1492>
Jan 12 01:34:51 172.16.0.1 pppoe,ppp,debug,packet    <auth  chap>
Jan 12 01:34:51 172.16.0.1 pppoe,ppp,debug vodafone: LCP opened
Jan 12 01:34:51 172.16.0.1 pppoe,ppp,debug,packet  vodafone: rcvd CHAP Challenge id=0x1
Jan 12 01:34:51 172.16.0.1 pppoe,ppp,debug,packet     <name RSRVAL01>
Jan 12 01:34:51 172.16.0.1 pppoe,ppp,debug,packet     <challenge len=40>
Jan 12 01:34:51 172.16.0.1 pppoe,ppp,debug,packet  vodafone: sent CHAP Response id=0x1
Jan 12 01:34:51 172.16.0.1 pppoe,ppp,debug,packet     <name ONH0000XXXXXX@vodafone>
Jan 12 01:34:51 172.16.0.1 pppoe,ppp,debug,packet     <response len=16>
Jan 12 01:34:52 172.16.0.1 pppoe,ppp,debug,packet  vodafone: rcvd CHAP Success id=0x1
Jan 12 01:34:52 172.16.0.1 pppoe,ppp,debug,packet     CHAP authentication success
Jan 12 01:34:52 172.16.0.1 pppoe,ppp,info vodafone: authenticated
Jan 12 01:34:52 172.16.0.1 pppoe,ppp,debug vodafone: IPCP lowerup
Jan 12 01:34:52 172.16.0.1 pppoe,ppp,debug,packet  vodafone: sent IPCP ConfReq id=0x67
Jan 12 01:34:52 172.16.0.1 pppoe,ppp,debug vodafone: IPCP open
Jan 12 01:34:52 172.16.0.1 pppoe,ppp,debug,packet     <addr 0.0.0.0>
Jan 12 01:34:52 172.16.0.1 pppoe,ppp,debug,packet     <ms-dns 0.0.0.0>
Jan 12 01:34:52 172.16.0.1 pppoe,ppp,debug,packet     <ms-dns 0.0.0.0>
Jan 12 01:34:52 172.16.0.1 pppoe,ppp,debug vodafone: IPV6CP open
Jan 12 01:34:52 172.16.0.1 pppoe,ppp,debug vodafone: MPLSCP open
Jan 12 01:34:52 172.16.0.1 pppoe,ppp,debug vodafone: CCP lowerup
Jan 12 01:34:52 172.16.0.1 pppoe,ppp,debug vodafone: BCP open
Jan 12 01:34:52 172.16.0.1 pppoe,ppp,debug vodafone: CCP open
Jan 12 01:34:52 172.16.0.1 pppoe,ppp,debug,packet     <magic 0x38349a93>
Jan 12 01:34:52 172.16.0.1 pppoe,ppp,debug,packet  vodafone: sent LCP EchoReq id=0x0
Jan 12 01:34:52 172.16.0.1 pppoe,ppp,debug,packet     <data len=1484>
Jan 12 01:34:52 172.16.0.1 pppoe,ppp,debug,packet  vodafone: rcvd IPCP ConfReq id=0x1f
Jan 12 01:34:52 172.16.0.1 pppoe,ppp,debug,packet     <addr 87.235.0.10>
Jan 12 01:34:52 172.16.0.1 pppoe,ppp,debug,packet  vodafone: sent IPCP ConfAck id=0x1f
Jan 12 01:34:52 172.16.0.1 pppoe,ppp,debug,packet     <addr 87.235.0.10>
Jan 12 01:34:52 172.16.0.1 pppoe,ppp,debug,packet  vodafone: rcvd IPCP ConfNak id=0x67
Jan 12 01:34:52 172.16.0.1 pppoe,ppp,debug,packet     <addr 46.26.XX.XXX>
Jan 12 01:34:52 172.16.0.1 pppoe,ppp,debug,packet     <ms-dns 212.166.132.108>
Jan 12 01:34:52 172.16.0.1 pppoe,ppp,debug,packet     <ms-dns 212.166.132.96>
Jan 12 01:34:52 172.16.0.1 pppoe,ppp,debug,packet  vodafone: sent IPCP ConfReq id=0x68
Jan 12 01:34:52 172.16.0.1 pppoe,ppp,debug,packet     <addr 46.26.XX.XXX>
Jan 12 01:34:52 172.16.0.1 pppoe,ppp,debug,packet     <ms-dns 212.166.132.96>
Jan 12 01:34:52 172.16.0.1 pppoe,ppp,debug,packet     <ms-dns 212.166.132.108>
Jan 12 01:34:52 172.16.0.1 pppoe,ppp,debug,packet     <magic 0xb644d134>
Jan 12 01:34:52 172.16.0.1 pppoe,ppp,debug,packet  vodafone: rcvd LCP EchoRep id=0x0
Jan 12 01:34:52 172.16.0.1 pppoe,ppp,debug,packet  vodafone: rcvd IPCP ConfAck id=0x68
Jan 12 01:34:52 172.16.0.1 pppoe,ppp,debug,packet     <addr 46.26.XX.XXX>
Jan 12 01:34:52 172.16.0.1 pppoe,ppp,debug,packet     <ms-dns 212.166.132.108>
Jan 12 01:34:52 172.16.0.1 pppoe,ppp,debug,packet     <ms-dns 212.166.132.96>
Jan 12 01:34:52 172.16.0.1 pppoe,ppp,debug vodafone: IPCP opened
Jan 12 01:34:52 172.16.0.1 pppoe,ppp,info vodafone: connected
BocaDePez
BocaDePez
-1

Prueba a clonar la MAC del equipo original y pasarla al Mikrotik.