Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

ADSL

Un Bug permite cambiar la pass Admin en HG553 y HG556a

BocaDePez
BocaDePez
1

Un posible Bug en los routers de vodafone HG553 y HG556a, permite cambiar la contraseña de los usuarios admin, support y vodafone.

Para cambiar la contraseña basta con invocar en un navegador una de las siguientes líneas:

  • Para admin: 192.168.0.1/password.cgi?sysPassword=nuevaPass
  • Para support: 192.168.0.1/password.cgi?sptPassword=nuevaPass
  • Para vodafone: 192.168.0.1/password.cgi?usrPassword=nuevaPass

Si lo hacemos para el usuario admin y queremos que la nueva contraseña sea bandaancha pondremos la siguiente URL en el navegador

192.168.0.1/password.cgi?sysPassword=bandaancha
  1. Pulsamos enter y el navegador nos pedirá que nos identifiquemos y lo haremos con la única cuenta que conocemos vodafone/vodafone.
  2. Después reiniciaremos el navegador y podremos entrar como admin/bandaancha.
  3. Aparecerá en el navegador el menú admin del router.

Normalmente para cambiar la contraseña el router muestra la página password.html en el menú del usuario admin y todas las validaciones sobre la misma se realizan en el navegador con el javascript que contiene la página.

Cuando este código determina que la contraseña es correcta y se puede cambiar invoca a la CGI: password.cgi que se ejecuta en el router.

Nosotros hemos invocado directamente a la cgi y aunque pide que nos identifiquemos, esta no ha verificado que la hemos llamado con el usuario admin o support.

Agradecería que me confirméis que habéis podido cambiar la password de admin en vuestros routers.

Muchas Gracias.


Nota: el autor de este hilo ha pedido permanecer en el anonimato, por lo que los datos del autor de este post son falsos.

JavierM1

Absolutamente sublime, muchísimas gracias.

Funciona en el router nuevo de vodafone, el 556

Llevaba meses queriendo entrar como admin, simplemente por curiosidad, sin tener que hacer lios.

WiLZy

Gracias por la aportación, ¿alguien más ha probado?

🗨️ 17
takeo1994

A funcionado a la primera ya estoy entrando como administrador eres la leche de verdad funciona perfectamente.

🗨️ 14
WiLZy

Genial :), gracias.

🗨️ 13
takeo1994

Lo que copiado ya pero

debería borrar este porst por que como vodafone se de cuenta, lo solucionaremos.

🗨️ 12
WiLZy
🗨️ 8
BocaDePez
BocaDePez
🗨️ 6
BocaDePez
BocaDePez
🗨️ 5
takeo1994
🗨️ 4
BocaDePez
BocaDePez
🗨️ 3
takeo1994
🗨️ 2
BocaDePez
BocaDePez
🗨️ 1
electronics
🗨️ 2
BocaDePez
BocaDePez
🗨️ 1
BocaDePez
BocaDePez

A la primera y perfecto, muchisimas gracias. Ojo y no toqueis demasiado si no sabeis lo que haceis, este router tiene miga... Por fin mi propia contraseña, ver el Syslog, el cortafuegos, etc etc

BocaDePez
BocaDePez

Si, funciona, gracias ?

BocaDePez
BocaDePez

router hg556a

No me funciona.

Pongo la direccion en el navegador y me redirecciona a :

192.168.0.1/password.html

Y ahi no muestra nada, y he probado y no se ha cambiado la pass.

🗨️ 3
BocaDePez
BocaDePez

No hagas click en el enlace, sino que escribe a mano la dirección (o copia y pega), cambiando donde dice "nuevaPass" por tu contraseña, das a enter, hace el cambio de la pass por la que has indicado y te redirecciona a la url que has puesto.

192.168.0.1/password.cgi?sysPassword=nuevaPass

Suerte.

HaOx

A mi tampoco no me muestra nada pero funciona, se cambia la contrasenya del admin.

🗨️ 1
WiLZy

¿Has probado lo del post de arriba?

192.168.0.1/password.cgi?sysPassword=nuevaPass

BocaDePez
BocaDePez

Lo acabo de probar con un 556a y funciona perfectamente.

MUCHISIMAS GRACIAS!!!!! :D

Tenia ganas de poder hacer lo que me diera la gana con MI router.

BocaDePez
BocaDePez

Si no se desactiva el acceso por HTTP desde el exterior se corre un gravisimo riesgo de que cualquier persona pueda hacerse con el control de nuestros routers y acceso a nuestra red local.

Si en vodafone no actualizan pronto el firmware de los routers lo mas prudente es cambiar todas nuestras claves de acceso al router y desactivar las casillas "WAN" de la sección "Administracion -> Control de acceso -> Servicios".

🗨️ 4
electronics

En principio no debería haber riesgo de acceso desde la WAN, pues el router sólo permite el acceso desde el exterior a unas IP's determinadas (las de servicio de Vodafone). Las que figuran en "Access Control - IP Addresses".

🗨️ 2
WiLZy

Coincido con lo que comenta electronics, de todos modos ¿alguien podría confirmarlo?

🗨️ 1
BocaDePez
BocaDePez

Tienes razón, el acceso está capado excepto para las redes de gestión de VF

BocaDePez
BocaDePez

exacto no es correcto quitar ese acceso sino cuando soliciten soporte no se podra acceder al router aunque sino se puede acceder igual lo reseteamos y con eso vuelve a la configuracion original pero hace lento el proceso de soporte.

BocaDePez
BocaDePez

Muchas Gracias. Funciona al 100%.

BocaDePez
BocaDePez

Probado en hg553 funciona, muchas gracias

BocaDePez
BocaDePez

Qué se podía esperar de los INCONMPETENTES de Robafone.

Menuda sanción les metía yo.

BocaDePez
BocaDePez

Buenas y que pasara cuando vodafone actualice el firmware desde su central??

🗨️ 1
WiLZy

Si cambias la password de todos los usuarios o bien desactivas el acceso por WAN no podrán acceder al router.

BocaDePez
BocaDePez

Yo lo acabo de probar y ha funcionado. Gracias!!

BocaDePez
BocaDePez

hola a todos, si se cambia la clave de admin, los de robafone se dan cuenta o pueden decir algo si tienes alguna vez problemas?????

por cierto si lo hago podre cambiar para poder conectarme por vpn al curro??? ahora mismo no me lo permite el router

🗨️ 4
bios

Si tienes una incidencia, pueden negarse a darte soporte si el router se ha "manipulado"

Para configurar una VPN, no hay necesidad de entrar como admin

🗨️ 3
BocaDePez
BocaDePez
1

OK, pues si alguien me puede decir como hacerlo, porque cuando intento conectarme con el openvpn desde mi conexion vodafone me da todo el tiempo fallo de conexion. en cambio si lo pruebo con la wifi de mi vecino que me dio para probar, si que me deja conectarme. y en principio no tiene nada que ver puertos y demas porque en el router de mi vecino no hemos tocado nada.

gracias.

🗨️ 2
BocaDePez
BocaDePez

Alguien sabe como puedo configurar el router para poder, descargar y que se guarde en el usb mientra esta el ordenadores apagado

BocaDePez
BocaDePez

Los puertos para acceso VPN tienes que avisar directamente a SAT Vodafone. o en todo caso entrar como administrador en HG553 por lo menos.

BocaDePez
BocaDePez

A mi lo único que me sale, cuando entro como admin es la opcion wireless mac filter, ningún otro menú ni nada parecido, ¿cómo se accede al resto de opciones?.

mil gracias

mgoreiro

Probado con dos HG556a cambiada en ambas (y por fin he podido activar el DynDNS).

robertoroque

Agradecería que me confirméis que habéis podido cambiar la password de admin en vuestros routers.

CONFIRMADO

BocaDePez
BocaDePez

Confirmado

BocaDePez
BocaDePez

A mí no me ha funcionado. He intentado entrar con usuario admin y poniendo la clave que puse, pero no funciona.

BocaDePez
BocaDePez

yo lo he hecho y funciona; ahora que tengo acceso como admin,¿hay algo que pueda hacer/tocar/cambiar para que el Jdownloader pueda reiniciar modem/cambiar la IP? (yo antes estaba con Movistar y me linea era IP dinámica )

gracias

🗨️ 1
bios

Tu IP es estática (aunque dinámica por contrato)

BocaDePez
BocaDePez

Con el router 556a he podido cambiar la constraseña de admin y usuario pero no la de support. ¿Alguna solución?

🗨️ 1
PsicoSaxx

Desde el mismo router yo tampoco podía, pero usé el bug que viene explicado aqui arriba para poner la password (por ejemplo 1234), y una vez cambiada por este método ya la puedes cambiar desde el router.

Vamos, que mi problema era que no sabía la password por defecto que trae el usuario support....

Espero haberme explicado.

BocaDePez
BocaDePez

Perfecto. Realizado con portatil con Windows 7 y via WIFI. Grandisimo aporte. Muchas gracias.

BocaDePez
BocaDePez

Confirmado en un 556a

Gracias

BocaDePez
BocaDePez

funciona. 556a

Muchas gracias.

BocaDePez
BocaDePez

Yo creo que el post principal esta sin pulir.

No ha dicho que hay que desactivar todas las WAN para que Vodafone no pueda entrar.

Si quereis soporte basta con reiniciar el router a valores de fabrica, llamar, pedir soporte, colgar el telefono una vez terminado el soporte y volver ha hacer el truco.

Otra cosa que veo en todos los que dicen que les va, es que no han dicho la version del firmware que estan utilizando pues esto SERIA IMPORTANTE SABERLO.

BocaDePez
BocaDePez

Funcionaaa muchas gracias! por fin es MI router :D

Tengo esta version de firmware V100R001C10B050SP01 hay alguna mejor para meterle?

Gracias

🗨️ 1
GerardoIT

No sé si es mejor o no, pero hay una versión dando vueltas por allí:

Descargar el siguiente archivo: broadband.vodafone.ie/download/files/HG556a_B025.zip
Esta versión Irlandesa es la V100R001C08B025, solo en ingles, en los nuevos de última entrega lleva la
versión V100R001C10B031SP03 que mejora algunos problemas que sufría la versión V100R001C02B027
en cuanto a carga de algunas páginas e imágenes, y funciona todo igual.

Si la actualizas luego nos cuentas qué tal. Vale?

BocaDePez
BocaDePez

Confirmo que funciona. Que alivio, no tener que abrir el router ni conectar el cable serie para acceder a la consola.

Muchas gracias.

BocaDePez
BocaDePez

me funcionan todos los usuarios menos el de support. Lo he intentado hasta desde el user admin pero no me deja, igual porque no introduzco la contraseña anterior, la original.

GerardoIT

Confirmo que me funciona para los 3 usuarios.

Tengo este router desde hace más de 1 año y el firmware es V100R001C10B050SP01

fisico

En el nuevo firmware B061 habéis probado a ver si funciona. Yo quiero poner esta versión porque además de ser la última debe corregir el fallo de que cada x tiempo el router se vuelve tonto y pierde internet, a mi un par de veces a la semana me lo hace.

(link roto)

🗨️ 5
BocaDePez
BocaDePez

Funciona también en la 061, acabo de comprobarlo.

🗨️ 3
fisico

Una vez que actualizas tienes que volver hacer el proceso o si ya lo hicistes con el anterior firmware no hace falta repetir este proceso de nuevo para entrar como admin.???

Gracias, por la info.

🗨️ 2
superllo

Yo he actualizado y mantiene los usuarios que tenías antes con sus contraseñas.

fisico

Actualizado y no he tenido que hacer el proceso otra vez para entrar como administrador.

GerardoIT

No lo he hecho aún el cambio, pero suena alentador hacerlo leyendo lo que ha comentado allí un usuario:

Aunque no lo he probado exhaustivamente de momento he sacado estas conclusiones, aunque puedo equivocarme porque son sólo de unas horas, con respecto al anterior firmware:

  • Velocidad de descarga: la misma.
  • Ping: igual.
  • El valor real de la MTU para conexiones PPPoE: Sigue igual, mostrando en las páginas que lo analizan, el valor 1440 o 1400 cuando lo correcto debería ser 1492, no lo han corregido.
  • El problema de que la velocidad de descarga en los indirectos (quizás no todos) no es la esperada, a pesar de que los valores de la línea sean buenos: Igual que ocurría con el firmware anterior, no lo han solucionado. Está claro que para Vodafone los indirectos somos usuarios de segunda.
  • Firewall: la prueba en grc.com da los mismos resultados, siguen cerrando los puertos de forma explícita en lugar de hacerlos invisibles ("stealth", más seguro).
  • UPnP: sigue sin haber opción para habilitarlo. Parece mentira que una opción como esta que la tiene cualquier router de dos duros y no esté disponible todavía.
  • WiFi: Parece que va mejor. En un ordenador el chipset es Atheros, este nunca ha dado ningún problema. Otro tiene un adaptador wifi con chipset Intel, de vez en cuando se bloqueaba el wifi y el router, pero no el teléfono. De momento éste último no se ha bloqueado, aunque es una conclusión precipitada pues como ya he dicho el bloqueo sólo era de vez en cuando.
  • Quizás sea una apreciación subjetiva personal, pero me da la impresión de que la respuesta es más rápida, es decir que cuando pincho un enlace o accedo a una página web el comienzo de la carga es inmediato. Con el firmware anterior parecía que el router se quedaba por un instante "pensando".
  • No han corregido el error de presentación de los valores de atenuación (en la interfaz de administración de usuario), que aparecen intercambiados subida y bajada.
Aunque, en principio, ya se hayan solucionado los problemas con el WiFi y la respuesta del router parece más rápida, esta actualización me ha decepcionado. Habiendo pasado casi año y medio desde el último firmware, pensé que ya definitivamente se solucionaría el problema de los indirectos descrito en el cuarto punto, pero no es así.
BocaDePez
BocaDePez

Probado en un comtrend de jazztel y fucniona perfectamente.

Saludos.

BocaDePez
BocaDePez

Hola, a dia de hoy no funciona, no?. A mi luego de configurar la password, me sale una página password.html en blanco, y luego de cerrar y abrir el explorador, cuando le pongo user: admin y su password, se queda en un loop pidiéndola. En un momento salió el mensaje que tenia que ser contraseña no cifrada, me tuve que bajar el gpedit de Internet (tengo Windows 7 Starter, y aunque configuré la política para que no la cifre, sigue sin aceptarla. Alguien me puede sugerir algo? . Gracias por adelantado

🗨️ 1
BocaDePez
BocaDePez

Lo he puesto por varios lados pero....

1-Desconectar dsl y bajar firm a HG556aV100R001C10B061SP01.bin

2-Cambiar pass con 192.168.0.1/password.cgi?sysPassword=nuevaPass

3-Cerrar WAN/IPs vdf/etc.

4-Guardar config.

5-Poner el Firm que quieras, restablecer config y conectar dsl

Fin.

iptcuba

buenas, y disculpen la reiterada pregunta tengo un

Modello:EchoLife HG553
Vers. hard.:HG55MAGV VER.A
Vers. soft.:HG553V100R001C02B055SP01
Numero di Serie:301968K8C269113

pero no me deja cambiar el passwd, y he hecho lo que ustedes dicen, me puede alguien decir con que otro passwd de "ADMIN " logro poder modificar el AP, espero una respuesta gracias