BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

Fibra FTTH

Servidor Plex ha empezado a hacer buffering de repente con Cartago Telecom

eminem2k3

Desde hace una semana un servidor de Plex que he estado usando desde hace años me ha empezado hacer buffering pero solo en mi casa y en otras casas con la misma compañía de internet (es una local, Cartago Telecom). Con 4G y en otras casas con otras compañías va perfecto como siempre.

He probado otro servidor de Plex y me pasa lo mismo, buffering cada 2x3 salvo que baje mucho la calidad de imagen o use red móvil.

¿Se os ocurre algo? Nos estamos calentando la cabeza el dueño del server y yo y no llegamos a ningún lado.

Es todo muy raro y desesperante.

Pentagonin

Cambiese de compañía. Todo arreglado.

PD: si es empresa local, debe conocer al dueño y técnicos. Que rebajen el capado al streaming privado, porque muchas veces sólo se autoriza el oficial.

eminem2k3

Lo raro es que hasta el lunes iba perfecto. Coincide con que fueron comprados por otra compañía. Lo que quiero es llamarles con conocimiento de causa y amenazar con irme.

🗨️ 1
CMov

Llama o escribe un correo, sin necesidad de amenazar. Los locales, aún siendo "grandes" no suelen aplicar ningún tipo de restricción dentro de su red.

Quizá el problema esté en uno de los proveedores de tránsito y salvo aviso, suelen ser problemas que pasan desapercibidos.

marcelg

Hola, yo tambien tengo ese problema con plex y el NAS, si veo el video desde el Plex a veces se hay pausas continuas, si lo veo desde el kodi, esto no pasa, un incordio.

eminem2k3

Mi compañía me dice que han actualizado los router y que por eso en todas las casas va mal. Que le diga el puerto a abrir y la IP de destino que supongo que será la del proveedor de Plex,?

🗨️ 1
Bramante

han actualizado los router y que por eso en todas las casas va mal

¿Han actualizado y va peor? Brillante.

Que le diga el puerto a abrir y la IP de destino que supongo que será la del proveedor de Plex,?

¿Dónde está hospedado el servidor que mueve Plex?

Por defecto, Plex usa el puerto 32400 TCP pero quien tiene que tener el puerto accesible es el servidor, no el cliente.

eminem2k3

No creo que sea cosa del servidor (me pasa con dos diferentes). He comprado que el puerto 32400 lo tengo cerrado según una web que he visto. El servidor va bien pues tengo familiares usándolos y yo mismo en otras casas.

🗨️ 1
Bramante

Pero, ¿estás hospedando tú ese servidor?

eminem2k3

No. Son servidores externos.

🗨️ 1
Bramante

Entonces, tú no tienes que tener abierto ningún puerto en especial.

Cuando tú intentes reproducir algo, tú como cliente apuntarás al 32400 del servidor (si el que maneja el servidor, ha configurado otro, él se lo guisará y él se lo comerá), pero saldrás con otro puerto aleatorio que no te afecta.

¿Estás llegando a ese servidor directamente o vía relay?

eminem2k3

Sorry. No entiendo lo de directo o relay. Pero insisto que me pase con dos servidores distintos y habiendo ido bien siempre. No es raro? Al resto de gente que lo usa les va bien

🗨️ 1
Bramante

Al resto de gente que lo usa les va bien

Si pones la mano en el fuego porque en la parte del servidor no ha cambiado nada, te toca buscar qué ha podido cambiar en tu extremo para que ahora aparezca buffering donde antes no lo había.

¿Qué podría estar creando el problema?:

  • Problemas de red I: Caída muy seria de la velocidad de tu conexión que realmente esté creando el problema (este extremo lo suele indicar Plex avisándote de que la conexión no da de sí y que bajes calidad).
  • Problemas de red II: El servidor está teniendo algún problema por el que los clientes no pueden acceder directamente y el tráfico se redirige al relay, que tiene muy limitada la velocidad.
  • Archivos no reproducibles directamente por el cliente y necesitan ser recodificados en el servidor: El servidor va justito para transcodificar el contenido y/o hay más clientes de lo que el servidor puede mover.
eminem2k3

Pongo la mano por que fuera de casa con red móvil y en otras casas con fibra de otra compañia me va

perfecto. La compañía me reconoce que han actualizado routers justo cuando empezaron los problemas y como solucion me dice de abrir el puerto asociado a plex que es el 32400 que lo tengo cerrado pero me pide la IP del servidor a lo que ambos me cuentas que no tienen sentido…

Como va el tema de abrir puertos? Tengo un EG8145V de Huawei.

🗨️ 1
Bramante
1

La compañía me reconoce que han actualizado routers

Puede que yo peque de exceso de escepticismo, pero a mí me suena a cuento chino.

me dice de abrir el puerto asociado a plex que es el 32400

Si te vas a quedar más tranquilo abriendo el puerto, hazlo, pero ya te he comentado que ese puerto lo ha de tener abierto el servidor, no tú.

Como va el tema de abrir puertos?

Operadora local y con ese router, apuesto doble o nada a que estás detrás de CG-NAT y abrir puertos en el router te va a dar el mismo resultado que rascarte el pie derecho.

Que te confirme tu operadora si estás detrás de un CG-NAT.

Si quieres probar lo de abrir puertos, aquí se trató el tema.

juankihd

El problema es que haces NAT en tu router.

Plex Server > Contenido> NAT > Router ISP > Plex Cliente.

En ese envío de tráfico se pierden paquetes o no llega directamente al plex cliente.

Fijate si estás detrás de un CG-NAT que suele ser lo habitual.

En cambio si no pasas por un CG-NAT lo que pasa que tu router no hace que el tráfico vaya hacia tu IP del plex cliente.

Prueba a hacer reenvío de puertos de un servicio hacia tu IP así le pones en tabla de routing donde debe ir el servicio.

En cambio si tú Plex server está en Local es otra cosa.

🗨️ 5
lhacc
-1

Esto no tiene nada que ver con el problema.

🗨️ 4
juankihd

En qué sentido.

Puedes darme un poco más de info.

Gracias!

🗨️ 1
lhacc
-2

La nat que hace en su router, o si está en cgnat, no debe repercutir en absoluto a la hora de acceder a servidores externos.

juankihd
Captura de pantalla 2023-01-23 a las 14.58.01

El trafico tiene un origen y destino.

si A → B

pero B no recibe el flujo, estos paquetes se estan dropeando en algun lugar o se pierden por X motivos.

el buferring viene por:

  • Trascodificación porque el dispositivo que recibe el contenido no es capaz de reproducir, por eso se convierte en tiempo real a audio que se pueda reproducir.

Este no creo que sea el problema porque si otros pueden y no cambio su televisor o dispositivo, no tiene que hacer trascoding.

  • No llegan los paquetes de A (server) a B destino (plex cliente).
  • El ISP este filtrando paquetes con algun tipo de DPI (deep packet inspection) asi que sabe el contenido que se mueve, lo bloquea o le da una prioridad mucho más baja, por lo que se va al traste los paquetes.

El dueño del plex server que intente hacer traceroute a tu router y ver que llega al destino.

Otra prueba puede ser que abras puertos en tu router y que el dueño del server ataque ese puerto, si publicas algun contenido el tendra que verlo.

Ej:

IP:61020 (http server)

Que ataquen tu IP publica a ese puerto.

En tu router tendras que hacer un forward de Public_IP:61020 →IP_interna:61020

🗨️ 1
lhacc
-1

No hace falta abrir puertos para conectar a un servidor externo. Sólo hace falta abrirlos si alguien se tiene que conectar a ti, pero no es el caso de Plex.

eminem2k3

Me estoy desbordando ya con le tema. Entre que no entiendo la mitad y no sé por dónde tirar…

Me jode por que uso Plex a saco

🗨️ 1
lhacc

Aunque sea como solución temporal, prueba a instalar la VPN gratuita warp y a acceder al servidor plesk desde tu ordenador y mira si se resuelve el problema. https://1.1.1.1/

eminem2k3

Probaré lo que me digáis. Pero es que los dos servidores me dicen que lo de la IP y los puertos que me pide mi compañía es una gilipollez, nunca ha sido necesario.

Tengo vista otra compañía pero me dicen que si funcionan con CG-NAT y tienen permanencia y me da miedo cambiarme y seguir igual.

vukits

Nos estamos calentando la cabeza el dueño del Server y yo y no llegamos a ningún lado.

por lo que comentas, los servidores no son tuyos, son de alguien.

Ten en cuenta de que el peering y las rutas varían entre ISP e ISP.

eminem2k3

Exacto los servidores son de personas ajenas a mi. Ninguno de los dueños sabe por dónde tirar por que nunca les ha pasado nada similar al resto de usuarios les va bien. En el principal que está mi familia también, no tienen problemas y como puse antes, si me voy a casa de un familiar con otra compañía perfecto. En casa de mis suegros que tienen la misma compañía que yo funciona mal también.

El otro proveedor de internet que tengo disponible me saca de CG-NAT si lo solicito.

🗨️ 1
vukits

en tema de rutas… es complicado que el usuario final tenga algún tipo de influencia sobre el ISP.

por eso las compañías de streaming tienen CDN que hacen peering directo con varios ISP

eminem2k3

He vuelto a llamar a la compañía me ha cambiado a otra IP pública o no se que. Resultado, sigo igual.

🗨️ 8
lhacc
0

¿Has probado lo de warp que te he dicho?

🗨️ 7
eminem2k3

Probado y funciona bien con Warp aparentemente. Que puede significar? Mi compañía me dijo que me llamaría y no sé nada de ellos.

🗨️ 6
lhacc

Que hay un problema de velocidad entre tu ISP y el ISP donde está el servidor de plex.

🗨️ 5
lhacc
🗨️ 3
lhacc
🗨️ 1
eminem2k3

Lo de warp cuando llegue a casa.

eminem2k3

Ya está pedido el cambio a otra compañía. Espero no tener el mismo problema…

Usamos cookies propias y de terceros para que funcione la web, medir visitas y orientar anuncios según intereses. Saber más y configurar