Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

hosting en interdominios
539 lecturas y 25 respuestas
  • Bridge ADSL con telefónica y router Zyxel Prestige 643

    Hola,

    Tengo un router Zyxel Prestige 643, sin wifi con Telefónica.

    He intentado tanto con este Zyxel como con un 3com 812 configurar el router como Bridge, para tener ADSL y a través de un router adicional entre el Zyxel y la LAN hacer circular el tráfico de red e Internet. Sin éxito pese a los varios intentos.

    He leído este manual (muy currado por cierto): http://piezas.bandaancha.st/p643/html ya que no conocía la IP,etc. Del router Zyxel y tuve que configurarlo por puerto serie inicialmente. Siguiendo esos pasos e información de Internet, aparte del sentido común lo puse en Brigde y conectado a otro router (marca netgear) que soporta dos WAN, solo una está conectada pero bueno...

    Lo que trato de hacer es lo siguiente:

    [INET/ISP]<=>[ZYXEL BRIDGE]<=>[ROUTER]<=[LAN] os dejo aquí un diagrama más gráfico: http://www.subirimagenes.com/otros-reddual-535673.html

    Los datos facilitados por telefónica (IP fija) son estos:

    IP WAN: 213.96.10.AAA
    Mask: 255.255.255.192
    Gateway: 213.96.10.129

    Gestión ???
    IP: 213.96.10.ZZZ
    Mask: 255.255.255.192

    DNS retevision: 62.81.16.197 (por ejemplo)

    En el router Zyxel he seguido estos pasos:

    1. Acceder via Telnet.
    2. Deshabilitar ROUTE IP.
    3. Deshabilitar ROUTE IPX.
    4. Habilitar Bridge (ON).

    A continuación, en el menú 4 ("Internet Access Setup) la cosa queda así:

    Menu 4 - Internet Access Setup

    ISP's Name= VC
    Encapsulation= RFC 1483
    Multiplexing= VC-based
    VPI #= 8
    VCI #= 32
    Service Name= N/A
    My Login= N/A
    My Password= N/A
    Single User Account= No
    IP Address Assignment= N/A
    IP Address= N/A
    ENET ENCAP Gateway= N/A

    Todo correcto a priori. Dudo con el SUA y el ENET ENCAP, pero no es necesario en principio.

    En el menú "3" la cosa quedaría así:

    Menu 3.2 - TCP/IP and DHCP Ethernet Setup

    DHCP Setup
    DHCP= Server <= Creo que debería estar DESHABILITADO, no se si en bridge se ignora.
    Client IP Pool Starting Address= 192.168.0.X
    Size of Client IP Pool= 50
    Primary DNS Server= 192.168.0.Y
    Secondary DNS Server= 192.168.0.YY
    Remote DHCP Server= N/A
    TCP/IP Setup:
    IP Address= 192.168.0.10 <= cualquiera
    IP Subnet Mask= 255.255.255.0
    RIP Direction= None
    Version= N/A
    Multicast= None
    IP Policies=
    Edit IP Alias= N

    A continuación salgo, presionando 99 y se supone que todo está guardado correctamente en el router Zyxel.

    El caso es que el router intermedio, parece que hace bien el bridge cuando le pongo la IP estática externa, e incluso dejando el DHCP que se configure PERO, no hay ADSL, algo no está funcionando bien. De hecho, probé con otro 3com típico de Ya.com (que no puedo usar) y puse mi Linux con la IP WAN y funcionó correctamente (con DHCP en otra línea con ip dinámica para probar).

    En principio todo parece correcto... pero no logro poner un bridge y que los PC's en la LAN puedan navegar a través del nuevo router.

    Seguro que aquí hay gente con más experiencia en el tema que puede darme algún consejo, que agradeceré bastante, parece una tontería pero no acaba de funcionar bien y fastidia un poco, lo he intentado varias veces y he buscado información en Internet pero no he encontrado nada concluyente.

    Lo dicho, los comentarios, consejos... serán bienvenidos.
    un saludo y MUCHAS gracias en cualquier caso.

    Este tema lleva más de 6 meses inactivo. Es recomendable que abras un nuevo tema para retomar la conversación.
    1
    • BocaDePez BocaDePez
      6

      hola, tengo este router Zyxel 643, he visto estas ideas en…

      hola,

      tengo este router Zyxel 643, he visto estas ideas en Internet:

      descargasoscar.dyndns.tv

      descargasoscar.dyndns.tv/programas.jsp

      Tengo claro que es compatible pero no se si he de conocer configuraciones especificas.

      Gracias.

    • 18

      En la configuración Bridge, de entrada, veo varios fallos:…

      En la configuración Bridge, de entrada, veo varios fallos:

      Multiplexing= VC-based

      Eso tiene que ser:

      Multiplexing= LLC-based

      Luego, donde pones:

      IP Address Assignment= N/A
      IP Address= N/A

      Tienes que poner:

      IP Address Assignment= Static

      IP Address= 213.96.10.AAA

      Siendo 213.96.10.AAA tu IP pública fija.

      Así lo tendrás "de verdad" en modo bridge con tu IP estática.

      Luego el tema de la conexión al otro router Netgear (no conozco este router) pero se supone que no es un router ADSL sino uno del tipo neutro.

      • Hola Tot, gracias por tu respuesta. Lo del LLC-Based creo que…

        Hola Tot, gracias por tu respuesta.

        Lo del LLC-Based creo que estaba así al copiar los datos de la config, después de reiniciar algunas cosas... probé con LLC pero lo reconfirmaré ahora a ver.

        Lo de la IP Address assigment, si está en N/A no me deja cambiarlo, salvo que active el SUA (YES)... de hecho, no va a ser el Zyxel quien tenga la IP pública (entiendo) sino el router Netgear o cualquier otro que se ponga detrás como un PC con Linux, o incluso una máquina Windows.

        Entiendo pues, que no es el bridge quien necesita la IP WAN,etc. sino el router que viene después que además hace NAT para que los otros PC's en la LAN puedan salir a internet poniendo como gateway el router que no tiene conectividad de ADSL por si solo.

        Corrígeme si me equivoco que me parece que no es el caso, lo del "de verdad" noto que tiene alguna connotación que se me escapa... y teniendo en cuenta que bridge != monopuesto, no se si va por ahí la cosa.

        Cualquier aportación adicional es bienvenida.

        • 12

          Bueno, ahora que lo pienso, si tienes IP estática, no debes…

          Bueno, ahora que lo pienso, si tienes IP estática, no debes poner el router en modo bridge porque eso es para conexiones con IP dinámica PPPoE.

          Lo suyo, con IP estática es configurar el Zyxel en monopuesto. De esta forma, el que tiene la IP WAN es el ordenador o el router que esté detrás del Zyxel.

          Para la configuración del Zyxel en monopuesto he encontrado esto:

          http://www.aselcom.com/electronica/ZyXel/SEGURIDAD/zyxel/Configuraci%C3%B3n%20Monopuesto%20Routers%20ZyXEL.pdf

          Suerte.

          • Hola, Muchas gracias por la respuesta y el PDF :) Estuve…

            Hola,

            Muchas gracias por la respuesta y el PDF :)

            Estuve probando algo parecido a lo que se indica en el PDF pero con un 3com 812 y fue la odisea... y no funcionaba, pero ahí si pudo haber error en los parámetros.

            Tengo bastante claro que hay que usar RFC 1843 (Bridge mode LLC-based con Telefónica).

            En teoría, salvo limitación del hardware es posible hacer un Bridge con el Zyxel (aunque parece que no es el caso)... en principio, si el Zyxel tiene la IP WAN no la debería tener mi PCo router detrás, si lo pongo en monopuesto y no en Bridge... Zyxel será el que tenga la IP Externa hacia Internet y no el router Netgear ¿o te refieres a que AMBOS tendrán la IP WAN?¿un "bridge" simulado?

            No se, parece que lo del monopuesto es una warrada más que nada... incluso si funcionase, la idea es tener un bridge que es lo simple a priori. Haré más pruebas en un rato.

            ¿alguien tiene algún consejo o nota al respecto?

            Una vez más gracias por los comentarios.

            • 12
              Para el cálculo de la IP del router (IP Address) puedes…

              Para el cálculo de la IP del router (IP Address) puedes seguir estas instrucciones:

              Por ejemplo, si nuestros datos son:
              IP pública: 213.145.182.157
              Máscara pública: 255.255.255.192
              Para calcular la IP de lan del router, usaríamos la calculadora científica de windows y el operador AND y haríamos:
              213 AND 255 = 213
              145 AND 255 = 145
              182 AND 255 = 182
              157 AND 192 = 128
              A este último grupo de 3 cifras (128) le sumamos 1, con lo que nos da: 129 y este será el último grupo de cifras de la IP de lan del router. Finalmente, la IP de lan del router será:
              213.145.182.129
              Como podemos observar la IP de lan del router es igual a la IP pública en sus tres primeros grupos de cifras, solo varía el último grupo, que se calcula tal como se ha explicado.

              • OK, lo he establecido en monopuesto el Zyxel, y el Netgear…

                OK, lo he establecido en monopuesto el Zyxel, y el Netgear pilla la IP WAN,etc. del Zyxel.

                No es la idea que tenía (bridge) pero si funciona lo mismo da.

                No he conectado el Zyxel al ADSL ahora porque no puedo, en cualquier caso la tabla de enrutado queda así, el 0.0.7.1 me resulta sospechoso pero vaya... 213.96.10.? es el gateway -1 y la IP del Gateway ISP es ?+1, la IP WAN no aparece en la tabla se entiende.

                WAN1 0.0.0.0 0.0.0.0 213.96.10.?+1 0 Up
                LAN 192.168.0.0 255.255.255.0 192.168.0.252 0 Up
                WAN1 213.96.10.? 255.255.255.192 0.0.7.1 0 Up

                saludos.

                • En monopuesto tal y como indica el PDF parece que funciona…

                  En monopuesto tal y como indica el PDF parece que funciona correctamente.

                  La máscara ahora queda en algo más normal:
                  Iface Name Destination Mask Gateway Metric Active
                  WAN1 0.0.0.0 0.0.0.0 213.96.10.XXX 0 Up
                  LAN 192.168.0.0 255.255.255.0 192.168.0.252 0 Up
                  WAN1 213.96.10.128 255.255.255.192 213.96.10.??? 0 Up

                  No he logrado hacer el bridge puro, aunque en realidad si lo hacía pero por alguna razón la conectividad hacia Internet no funcionaba por algo, alguna cosa fallaría en el Netgear o no lo se... tal vez tenia que configurar y/o reiniciar mejor los PC's al realizar las pruebas por el tema de los caches DNS/ARP,etc. Pero vaya, en principio el bridge era lo lógico y no ha funcionado, el monopuesto simulando el bridge sí.

                  Resumiendo: el modo BRIDGE debería funcionar *seguro*, por algo no acaba de ir pero el monopuesto es equivalente pero en plan más chapuza porque hay doble ruteo al final.

                  MUCHAS GRACIAS Tot.

                    • BocaDePez BocaDePez
                      6
                      Hola Gustavo, Como "bridge" propiamente y como se conoce un…

                      Hola Gustavo,

                      Como "bridge" propiamente y como se conoce un modo bridge puro no pude hacerlo (pese a que parecía obvio y debería funcionar, insisto en que no se que hacía mal o porque no funcionaba).

                      Luego, en monopuesto como suele decirse en lugar de bridge aunque no sea exactamente lo mismo si lo logré gracias a los comentarios de bandaancha y algún PDF. ¿Es así como lo quieres, en monopuesto? Verás como lo hice arriba en cualquier caso no tiene mucho misterio en realidad, consulta el PDF y adapta las IP's a tu red.

                      Para que te hagas una idea estos son los datos del router que queda detrás del zyxel una vez está en modo transparente, debes preguntar a Telefónica o tu compañía los datos que no tengas.

                      IP Address 213.96.xxx.yyy
                      Subnet Mask 255.255.255.192
                      Default Gateway 213.96.xxx.129
                      DHCP Server 213.96.xxx.129

                      Con los Zyxel nuevos telefónica te da un CD o DVD para configurar tu router, en uno de los modos con un nombre más bien poco intuititvo (no lo recuerdo ahora) te configura el router en modo puente y asigna al router via DHCP la IP que le toca.

              • Sí, lo he calculado haciendo suma lógica de 10100011 y…

                Sí, lo he calculado haciendo suma lógica de 10100011 y 11000000 que da 129. Gracias por confirmarlo.

                Veo que en el router Zyxel como sugieres en monopuesto (según el PDF también) el menú 11 "Remote Node Profile" me queda así, lo que me llama la atención es que aquí el Route IP está activo y el Bridge en No. De ahí que parece una solución un poco "warra", comparado con el concepto de "Bridge". Si lo cambio a Bridge Yes, muchas opciones no estan accesibles que es lo que se espera.

                Rem Node Name= VC Active= Yes
                Route= IP
                Bridge= No

                Encapsulation= RFC 1483 Edit PPP Options= N/A
                Multiplexing= LLC-based Rem IP Addr= 0.0.0.0
                Incoming: Edit IP/IPX/Bridge= No
                Rem Login= N/A
                Rem Password= N/A
                Outgoing: Session Options:
                My Login= N/A Edit Filter Sets= No
                My Password= N/A Idle Timeout(sec)= N/A
                Authen= N/A PPPoE Service Name= N/A
                Schedule Sets= N/A

                Por cierto, en el menú 1 tengo que deshabilitar el Bridge imagino también para hacer lo que comenta en el PDF:

                System Name= TELEFONICA
                Location= Somewhere
                Contact Person's Name= netlink

                Route IP= Yes
                Route IPX= No
                Bridge= No


                ¿correcto?

                Cuando pruebe todo esto comentaré si ha funcionado.

                  • Ok, por cierto, nota MUY importante: Conecto el Zyxel a la…

                    Ok, por cierto, nota MUY importante:

                    Conecto el Zyxel a la linea ADSL, el Netgear está conectado al Zyxel en su puerto WAN (del Netgear) no el puerto ethernet. (la clavija es la misma)

                    [ZYXEL] <-> WAN1 netgear <-> LAN

                    ¿Esto es correcto o con el monopuesto tengo que configurarlo a un puerto Ethernet como si fuese un PC? ahora si que ya dudo de cosas que seguro son detalles básicos.

                    El model del netgear es un dual-wan 4 puertos ethernet y dos WAN sin wifi.

                      • Sí Sí era paranoia simplemente. Acabo de configurarlo y…

                        Sí Sí era paranoia simplemente.

                        Acabo de configurarlo y conectarlo al ADSL y ¡FUNCIONA!

                        La tabla de ruteo es ahora más normal además, he probado con un PC en la LAN y parece que navega bien.

                        En fin, lo suyo (aparte es más sencillo) hubiera sido ponerlo en Bridge mode y ya está... pero en monopuesto funciona la cosa así que de momento lo voy a dejar así. En otro router que tengo el bridge me va bien con un PC con Linux en dhcp (es otra línea de ADSL con IP dinámica) y es realmente inmediato.

                        Tot, gracias por el PDF y tus comentarios... han sido de gran ayuda, inicialmente lo hice con un 3com pero no funciono porque tenia los datos de telefónica (gateway del ISP) incorrectos supongo.

                        MUCHAS GRACIAS.

            • 12
              Hola de nuevo, Como puedes ver, en el enlace que te he…

              Hola de nuevo,

              Como puedes ver, en el enlace que te he puesto, en la configuración en monopuesto con IP estática, se activa el server DHCP del Zyxel y ahí es donde se pone la IP pública (IP WAN), configurando el pool de direcciones DHCP con una sola IP.

              De esta forma logramos que el Zyxel, actuando como servidor de DHCP, asigne al router o al PC que cuelgue de él, la IP pública.

              Por supuesto, el router que cuelgue del Zyxel debe estar configurado, en su parte wan, con obtener la IP por DHCP.

              Te pongo la imagen de la configuración del Zyxel donde se configura el servicio DHCP del mismo:

              Como puedes ver, la IP pública (80.224.5.178 en el ejemplo de la imagen) es la que inicia el pool de direcciones que asignará el servicio DHCP del Zyxel y este pool solo contiene la IP pública.

              Como máscara (IP Subnet Mask en la imagen) pones tu máscara pública: 255.255.255.192

              Como IP del router (IP Address en la imagen) se pone la dirección que se calcula por la clásica fórmula:

              IP de lan del router = (IP pública AND Máscara pública) + 1

              • De acuerdo, capto la idea. Como comentario: Inicialmente en…

                De acuerdo, capto la idea.

                Como comentario:

                Inicialmente en un bridge puro la IP LAN del router Zyxel queda en 192.168.0.1 o similar, y no tiene IP externa, por lo que no queda accesible desde un PC directamente conectado a Internet (ADSL) con la IP WAN salvo que se use un IP alias.

                Si hay otro router en medio, si que queda accesible el router Zyxel en bridge desde la LAN.

            • 12
              Yo creo que, si quieres que te funcione el tema con tu IP…

              Yo creo que, si quieres que te funcione el tema con tu IP estática, no te queda más remedio que configurar el router tal como dice en el enlace que te he puesto.

              Con esta configuración, si pones el Netgear detrás, deberás poner la IP WAN en el Netgear ya que, en la configuración monopuesto, el Zyxel tiene una IP LAN. Fíjate que la IP WAN no se pone en el Zyxel cuando se configura en monopuesto.

              Un saludo

              • Lo que veo en el PDF es que tiene una IP que aunque no es una…

                Lo que veo en el PDF es que tiene una IP que aunque no es una ip típica de las privadas (192.168. 10.10 ...) tampoco es la IP WAN pública del ADSL sino otra dirección de red pública del ISP, en el ejemplo del PDF: 80.224.5.178 es la IP WAN, y en el Zyxel indica 80.224.5.177, mask 255.255.255.240 como IP LAN (entiendo que es el gateway del ISP ?? página 5 3er párrafo)

                Sí, básicamente así está en el modo bridge:

                Router Zyxel con IP LAN sin NAT ni DHCP
                Router Netgear con IP WAN con NAT (DHCP no es importante, pero deshabilitado, configuro yo los PC's en la LAN)

                De todas formas lo voy a probar, a ver si en el monopuesto tal y como comenta el PDF funcionase... aunque toda la historia que hace con el DHCP,etc. Es un poco extraña y tal, debería ser más evidente supongo de cara al usuario sobre todo.

    • Pues yo no tengo ni idea, una vez intenté hacer eso de…

      Pues yo no tengo ni idea, una vez intenté hacer eso de ponerlo en modo bridge en un Zyxel 660hw pero no pude. De todas formas te envío esto al foro de routers de ADSL a ver si allí te lo solucionan.

      Ale

      • De acuerdo, gracias. Haciendo más pruebas consigo que el WAN…

        De acuerdo, gracias.

        Haciendo más pruebas consigo que el WAN status del router intermedio se quede UP y con los datos de telefónica (STATIC) aparentemente el bridge está bien hecho... pero no hay conectividad, es decir, el bridge está up y parece que conectado, el router también, pero Internet para los PC's de la LAN no va... y el NAT está puesto.

        Es un poco desesperante, creo que lo hago bien pero algún detalle tonto está haciendo que no funcione... de hecho probando en otra red ADSL y un PC con Linux... no tengo problema, también porque uso DHCP (que en la linea con el Zyxel no porque no puedo).

        ¿Alguien tiene ese router funcionando en bridge con cualquier router? (en una LAN normal)