Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

ayuda urgente con amaxnew!!!!!!

  • Cerrado

    ayuda urgente con amaxnew!!!!!!

    Hace cuestion de un año llego a mis manos un maxinew y va divino.Despues de navegar por estos foros me entro el gusanillo, me lance y he hice uno para mi novia y ¡¡oh divino!!, funcionó.Ahora lo he intentado con el amaxnew (esto es una droga) pero no ha sido tan divino.Y aqui es donde tengo el problema y necesito ayuda de alguien que este mas puesto que yo en esto.Pues eso he montado el amax comprovando todas las conexiones una a una segun soldaba y el circuito esta correcto.Continue con la programacion del pic 16f84a /04 con un programador te20es(que yo he montado), Ic-prog y todo bajo win98.antes de programarlo para el amax tenia que probar si el te20 funcionaba y para ello programe primero el pic para mi maxi,intercambie los pic y correcto,prueva superada el te20 funciona.vuelvo a coger el pic, lo borro,compruevo que esta en blanco y programo el pic para el amax.la configuracion del Ic-prog que utilice fue esta:

    PROGRAMACION DEL 16F84-XX CON ICPROG 1.4

    Sin conectar todavía el T20 al puerto serie del ordenador hay que insertar el PIC en el
    zócalo del programador. Es muy importante fijarse en la muesca que tiene el PIC y que debe
    de coincidir con la que tiene el zócalo del programador, pues esto indica la orientación de
    la entrada de voltaje y la masa.

    A continuación os detallo la configuración que debe tener el Icprog para programar el PIC:

    * Seleccionado en Ajustes/Tipo Hardware: - JMD programmer - Puerto (com1 o com2) -
    - Retardo (entre 5 y 15, si falla ir probando de menos a mas) - Interface: Direct I/O -
    - (para xp windows api)

    * Seleccionado en Ajustes/Opciones: - Programación/Verificar durante la programación -
    - Idioma/Español -Miscelánea/Normal - I2C Habilitar MCLR junto a Vcc Debe estár deshabilitado,
    en Ajustes/Smartcard(phoenix)deshabilitado

    El resto de opciones no nos interesan para nuestro proyecto, así que las dejaremos como están.
    Ahora que ya tenemos configurado el Icprog para programar el pic, debemos seleccionar el
    modelo del PIC:

    Ajustes/Dispositivos/Microchip PIC/Mas y seleccionar 16F84 (para maxis) ó 16F84A (para el cubo)
    según cual estemos utilizando. Cargamos el archivo HEX con el Icprog con Archivo/Abrir datos y
    cargamos el archivo HEX.

    En la parte derecha veremos diferentes casilla y opciones que
    deberán estar de la siguiente forma:

    El Oscilator, selecciona la opcion HS (High Speed) En los Bits
    configuración: Desactiva las tres casillas (WDT, PWRT y CP).

    Antes de pasar a programar definitivamente, debemos borrar el PIC para evitar posibles fallos y
    para eso seleccionamos Comando/Borrar todo o pulsamos en el botón que tiene tiene un PIC y
    encima una especie de lapiz con punta roja. Al pulsar en él nos saldrá un mensaje diciéndonos
    "dispositivo borrado". Ahora ya podemos pasar a programar: seleccionamos Comando/programar
    todo o pulsamos en el botón que tiene un PIC con un rayo encima. Nos saldrá una barra de
    proceso en la que indica el progreso de la grabación y después el progreso de la verificación.

    Si todo ha ido bien, veremos un mensaje que pondrá "verificación correcta". Ya tenemos nuestro
    PIC grabado.

    Esta configuracion la consegui aqui.Aunque mi version es la 1.0.5.0.Una vez hecho esto el amax no hacia ni muuu.totalque prove a poner el oscilador en XT como hacia para el maxi, y tampoco.Luego cambie el cristal de cuarzo de 8Mhz,Bueno lo intercambie con el del maxi y estaba bien.
    Y aqui me he quedao.que no se que hacer.LO que si he detectado es una cosa extraña a mi parecer en el condensador de 330pF´que tiene forma de lenteja,viene escrito B 331K,¿eso no significa 331 kilopicofaradios o lo que es lo mismo 331 nanofaradios?Po ya digo aqui me he quedao y no se por donde seguir.Os agradeceria que me ayudaseis.Si no es a traves del foro yo soy de sevilla,si ha alguien no le importa hecharme una manita...LA NECESITOOOOOO!!!!

    Por cierto mi e-mail: mededikoc@supercable.es

    Este tema es antiguo y puede contener información obsoleta. Abre un nuevo tema para publicar tu mensaje.
    • Cerrado

      creo q se te ha pasado por alto un pequeño detalle!!! q te…

      creo q se te ha pasado por alto un pequeño detalle!!! q te hace pensar q el hex q le estas metiendo al 16f84 es el que hace q el amaxnew funcione?
      aparte por mi propia experiencia, aunq el maxi es "manual" y te tienes q levantar el amax funciona peor ...
      hay por ahi un par de modificaciones al maxi para trabajar con video puro y conseguir un ajuste automatico del pote,aun no lo he probado pero la peña dice q funciona!

      • Cerrado

        el hex que trengo es el unico que he encontrado.mire en…

        el hex que trengo es el unico que he encontrado.mire en varias webs y en todos estaba el mismo.pero he encontrado el fallo.¡¡¡¡Vaya gambazo!!!habia intercambiado el condensador de 100pF por uno de 100nF.Pero tampoco me ha servido de mucho,¡¡No se ve una mierda!!!La mayoria de los canales suigen teniendo u7n poco de distorsion horizontal,como unas rayas raras que salen intermitentemente.En algunos canales las corrijo tocando la sintonia fina del televisor,pero no me vale por que no se mantiene.Y como ver bien dos y los otros tres que se veran tienen nieblaLo de la distorsion majoro levemente cuando cambie la tension de 9V a 12V.Si a alguien se le ocurre algo por favor que responda.Pero vamos que visto lo visto prefiero seguir levantandome a darle a la ruletita.por cierto otra consulta Me han dicho que el potenciometro de 25K se puede sustituir por uno de 22K,vamos me lo dijo el de la tienda.El caso es que tambien he provado ponerle el de 25K, fui ha comprallo esta mañana y resulta que cuando lo meti en el polimetro me marcava 22K.¿Raro, no? :-?