BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

Falta Inputstream.adaptative al reproducir Netflix en Kodi

Solospam

Al final me compré un Intel Nuc y le instalé Debian 11 y Kodi.

Actualicé a última versión y para ver Netflix me pide Widevine CDM.

Actualmente, pese a que busco por todos lados y con varios buscadores (incluso Google) no encuentro como instalar Widevine en Kodi de Debian 11. Con locale he actualizado el CDM (supuestamente) del Firefox. ¿Alguien puede indicarme por donde tirar?

El problema paso a paso

Entro en kodi, entro en mi serie favorita. Entro en el capitulo que me interesa y me salta este aviso

photo-5906843367021591159-y.webp

Le doy a ok y me suelta

photo-5906843367021591160-y.webp

Le doy a ok y me dice

photo-5906843367021591161-y.webp

Entonces me voy a InputStream Adaptative

photo-5906843367021591162-y.webp

y ahí está Widevine deshabilitado y sin forma de habilitarlo

photo-5906843367021591163-y.webp
Solospam

tengo Netflix descargado y funcionado, ahora tengo un problema con la licencia CDM que no soy capaz de instalarla en debian, las soluciones son todas para procesadores ARM o Android TV box

Black Hole

¿Tienes locate instalado en tu equipo para buscar ficheros? (Si no lo tienes instalalo con sudo apt install mlocate y luego sudo updatedb)

Si tecleas locate libwidewinecdm.so y te dice que ya está en la carpeta de tu perfil de Firefox, asegúrate de que en el Administrador de Complementos de Firefox, sección Plugins, el módulo de descifrado de contenido Widevine esté configurado en "Activar siempre" en las opciones de los 3 puntos…

🗨️ 3
Solospam
imagen.webp

Ahora dime qué tiene que ver firefox con kodi?, si el problema está en kodi como digo en el principal

🗨️ 2
Black Hole

No tengo ni puta idea 😅 No sé pa qué me meto si no tengo ni Netflix ni Kodi.

¿Por qué mencionaste Firefox en tu mensaje inicial? ¿Desde cuando locale actualiza nada si es para ver qué juegos de caracteres se usan en el sistema?

🗨️ 1
lhacc

Porque habrá querido decir locate, aunque no entiendo cómo se usa para actualizar nada :?

vukits

voy a instalar Kodi en mi Debian, y te comento

🗨️ 1
Solospam

date cuenta que si instalas Netflix y pones tu contraseña no sabes a quien se l aestas dando… por aquello de que no es una app oficial

Black Hole
1

A ver… la cosa de activar reproducción DRM en Firefox es para que el navegador te descargue la librería biblioteca libwidevinecdm.so en tu perfil de Firefox que vimos que ya la tenías en la ruta ~/.mozilla/firefox/<perfil_FF>/gmp-widevinecdm/<versión_WV>/libwidevinecdm.so que pegaste arriba (por ejemplo en Windows queda en %APPDATA%\Mozilla\Firefox\Profiles\<perfil_FF>\gmp-widevinecdm\<versión_WV>\widevinecdm.dll)

El paso siguente es copiar dicha librería biblioteca a la carpeta donde Kodi espera encontrarla: cp libwidevinecdm.so ~/.kodi/cdm

🗨️ 2
Solospam

no tengo carpeta ~/.kodi/CDM pero la creo y reinicio el sistema con el mismo resultado, kodi no funciona con Netflix

🗨️ 1
Black Hole

cdm en minúsculas y siempre suponiendo que la estructura de Kodi cuelga de la carpeta .kodi de tu $HOME. De todas formas, ¿qué error te aparece, para intentar seguir tirando del hilo?

Black Hole
1

Había visto un vídeo sobre el tema, que comentaba que por ejemplo la instalación por defecto de Kodi a partir de los repositorios oficiales de Ubuntu no funcionaba y que había que activar el repositorio PPA privado de los propios creadores de Kodi, para descargar el Inputstream Adaptative y el Inputstream Helper, que es el módulo que cambia entre diferentes versiones de Widevine cuando éstas se actualizan, por si acaso hay que cambiar a una anterior (pasó en una actualización el año pasado cuando equipos Android basados en la distribución LibreELEC dejaron de funcionar) pues guarda backups.

No sé si pasará exactamente lo mismo en Debian, si es que el Kodi de su repositorio no trae Inputstream Adaptative por defecto.

Es que al investigar anteayer, vi y leí un montón de cosas y ahora no recuerdo el enlace de YouTube en cuestión, si no, te lo hubiese puesto. A ver si lo encuentro […]

Vale. El vídeo es el siguiente y las instrucciones dicen que hay que desinstalar el Kodi actual y meter los siguientes paquetes:

sudo apt install software-properties-common
sudo add-apt-repository -y ppa:team-xbmc/ppa
sudo apt update
sudo apt install kodi kodi-inputstream-adaptive kodi-inputstream-rtmp

El primero de los paquetes software-properties-common lo necesita Ubuntu para gestionar bien los repositorios PPA. Puede que en Debian no lo necesites o ni siquiera exista.

Solospam
2

Solucionado. Tan fácil como descargarse:

sudo apt-get install kodi-inputstream-adaptive
sudo apt-get install kodi-inputstream-rtmp

Esto es para Debian o para Ubuntu.

🗨️ 2
Black Hole

Lo que te dije ayer 😏

🗨️ 1
Solospam

si, no se porque no me avisó de tu post…