BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

Ayuda configuración RED

BocaDePez
BocaDePez

Buenas, ante todo un saludo a todos aquellos que hacen posible mejorar nuestros conocimientos. la duda que tengo es la siguiente:

En el trabajo me encargaron montar una pc como servidor de archivos con windows server 2008, la cual solo servira para compartir archivos, ya esta todo configurado del siguiente modo:

Servidor conectado por cable ip 192.168.1.### (compartiendo archivos con los permisos necesarios)

cliente tipo 1 conectado por cable . IP 192.168.1.###

cliente tipo 2 conectado por wifi. IP 10.0.0.### (asignado por el router) TP-Link WR841HP)

Con el cliente tipo 1 no he tenido el ningun problema con el acceso a las carpetas compartidas pero mi duda surge en el cliente tipo 2 que esta conectado via wifi el cual no accede al servidor dado que no estan en la misma subred para lo cual agregue al servidor

Servidor conectado por cable ip 192.168.1.###

en opciones avanzadas agregue otra ip 10.0.0.###

con lo cual supuestamente debia poder acceder desde mis clientes tipo 2 al servidor, pero no se, si yo estoy en lo correcto o que otra solucion podria dar a este problema. ya que no puedo hacerlo, cabe hacer notar que todas las pc deben tener acceso a internet.

A ver si alguien me puede ayudar. gracias

BocaDePez
BocaDePez

Bueno, lo primero comentar que si un equipo solo va a servir para compartir archivos (según tus propias palabras), no necesitas pagar una carísima licencia de Windows Server, pero si ya está hecho, poco puedes hacer ya.

¿Quién ha decidido los direccionamientos de red? ¿Cuál es la razón que os ha llevado a escoger esos rangos diferenciados? ¿Seguridad?

El que pongas "###" en vez de la dirección real, no dificulta sino nuestras respuestas a tus consultas. Es una red privada y no pasaría nada por poner las IPs reales para que nos pudiesemos referir a ellas exactamente. De todas formas, que tú pongas una dirección IP de la clase A, no va a enrutar mágicamente los paquetes de un lado a otro.

Esa dirección 10.0.0.xxx del Windows Server, ¿se la has asignado a la misma interfaz de red que la previa de clase C 192.168.1.xxx?

¿Cómo están conectados físicamente el Windows Server y el router TP-Link WR841HP que dices que ofrece IPs a los equipos Wi-Fi? ¿Existe algún router o equipo intermedio entre ellos? ¿Qué dispositivo está asignando las direcciones a los clientes "tipo 1"?

🗨️ 6
BocaDePez
BocaDePez

Gracias por responder, lo de los # lo puse por seguridad pero en fin te doy los detalles,

La conexion a internet la tenemos via modem ADSL, para facilitarme el trabajo decidi asignar ip estatica a todas las computadoras exceptuando los clientes wifi.

Fisicamente los equipos estan conectados por cable a un switch de 16 puertos tplink , Servidor, pc cliente( 10 pc) y tambien el router TP-Link WR841HP

Servidor con IP 192.168.1.10

Clientes Tipo 1 conectados por cable rango de ip 192.168.1.11 a 192.168.1.20

Al router TP-Link WR841HP le asigne la ip 192.168.1.3

Todos los equipos y pc con puerta de enlace 192.168.1.1

Dado que el TP-Link WR841HP viene por defecto con la misma ip que la de mi puerta de enlace , tuve que cambiarla a 10.0.0.1

para evitar que entre en conflicto con mi puerta de enlace.

ahora para mis equipos cliente wifi deje la configuracion del router en DHCP, suponiendo que tengo 5 clientes wifi el router se encarga de asignar las ip a los clientes 10.0.0.101 por ejemplo.

ahora la ayuda que pido es que configuracion adicional debo hacer para que mis clientes wifi se conecten al servidor, obviamente trate de agregar una segunda ip al adaptador de red del servidor agregandola desde propiedades avanzadas del adaptador y demas 10.0.0.10 por lo que pude leer en algun articulo.

espero estar siendo algo mas especifico.

🗨️ 5
quilloquepasa

Configura el TP-Link en modo punto de acceso y solucionado el problema.

Un saludo.

🗨️ 3
BocaDePez
BocaDePez

Acabo de ver el manual del chisme static.tp-link.com/res/down/doc/TL-WR841HP_V3_UG.pdf y parece que es solo un "Gateway Access" que no tiene muchas posibilidades de configuración... por no haber, no viene que se pueda deshabilitar NAT.

El aparato no tiene ningún otro modo de funcionamiento que no sea punto de acceso.

Lo de ver a estas alturas de siglo que su interfaz WAN no es Gigabit, me ha dejado pensando que puede ser un cuello de botella si realmente se quiere usar como pasarela para PCs que necesiten transferir más allá de datos puntuales con un servidor de ficheros.

🗨️ 2
BocaDePez
BocaDePez
BocaDePez
BocaDePez

Bien. Tus explicaciones han servido bastante para aclarar el esquema.

Ahora mismo, si los clientes WiFi no consiguen ver al servidor, se puede deber a un par de causas. Lo primero que tengo que ver es qué tipo de aparato es el WR841HP y cuáles son su posibilidades de configuración, voy a intentar leer su manual si lo encuentro online.

Si el router hubiese activado NAT entre su interfaz WAN 192.168.1.3 y su interfaz WLAN, todo debería estar funcionando desde el primer momento, aunque todos los clientes WiFi "tipo 2" aparecerían ante el Windows Server como origen de la misma IP.

No sé si es que has configurado el TP-Link sin NAT, porque pretendes poder identificar en el Windows Server cuál es realmente el equipo remoto que hace la petición, sin que quede enmascarado por el router WiFi. Si este es el caso, la causa del problema es la ruta de vuelta: debes poner en el Windows Server (o en el router ADSL si quieres hacerlo extensible a todos los PCs cableados) una ruta estática a la red 10.0.0.0 con la máscara de subred que uses, a través de la dirección 192.168.1.3

Para hacerlo, tendrás que quitar la dirección IP de la red 10.x.x.x que tengas en el Windows Server.