Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

Fibra/Cable

Configuración de MikroTik con Vodafone fibra óptica

vcancela

Llevo tiempo intentando configurar un mikrotik con Vodafone ftth. He conseguido sniffar los datos del mi Sercomm-H500 y tengo estos datos , tanto de la TV , teléfono e internet.

Tengo varias configuraciones guardadas en el mikrotik en el que he logrado tener internet y teléfono , pero nunca he conseguido que la TV me funcione.

Es indispensable que pueda tener la TV funcionando por el mikrotik para poder deshacerme definitivamente del Sercomm de Vodafone.

Mi conexión que estoy probando es la siguiente:

ONT=> Cable de red de la ONT al puerto 1 (wan) del mikrotik. Aquí pongo un PPOE y consigo tener internet.

Después de esto intento configurar los puertos restantes como un bridge en mikrotik y añado las vlans .

Configuro los DHCP servers para la TV , pero no doy con la tecla para hacerla funcionar.

¿Alguién que tenga la configuración funcionando para mikrotik me podría ayudar a configurar la TV en mikrotik o bien pasarme un archivo de configuración que tenga la TV funcionando?

El teléfono no me importa tenerlo , no lo estoy utilizándolo.

Un saludo.

BocaDePez
BocaDePez

Que mikrotik tienes exactamente?

🗨️ 1
BocaDePez
BocaDePez

Hola,

Es un mikrotik CRS109-8G-1S-2Hnd-in de 8 puertos.

vukits

es que la TV es mucha tela.

¿la tienes por oTT o por IPTV?

🗨️ 5
BocaDePez
BocaDePez

La tengo normal , es decir, desde Router Sercom un cable de red conectado a decodificador de Vodafone.

🗨️ 4
BocaDePez
BocaDePez

¿Alguien que tenga esa configuración o me pueda ayudar a configurar el mikrotik?

BocaDePez
BocaDePez

Sí , es la 105.

Hay algo que no está bien en el mikrotik pero no logro saber por donde van los tiros.

🗨️ 1
vukits
piroxi

Hola @vcancela . Conseguiste avanzar con la configuración ?

🗨️ 2
Korvenwin

Si por favor, te ruego que nos indiques cómo configuraste el mikrotik para datos y VoIP.

Te estaríamos muy agradecidos.

🗨️ 1
BocaDePez
BocaDePez

Hola,

Perdonar por la tardanza pero no he conseguido hacerlo funcionar del todo como quería.

Lo máximo que he conseguido es tener conexión a internet , vozip en el teléfono. Pero la tele no he sido capaz de hacerla funcionar por lo tanto he vuelto a atrás.

Si alguién ha conseguido que funcione la tele sería estupendo.

Saludos.

IncubusNetworking
1

Buenos días comunidad, después de varios años primero con el router Asus y después del cambio de router Vodafone donde ahora te dan setup box donde ves TV mas aplicaciones que necesitan Internet, intente con un router Mikrotik (Asus ya no sirve para esto), ya que este permite configurar subinterfaces y redirigir tráfico, pude tener VOZ, TV e Internet con un solo dispositivo y quitarme el lastre de router de Vodafone.

Para la TV hay que rascar un poco más, se tiene que descargar el paquete Multicast para el mikrotik y configurar el IGMP, ya que es necesario para el forwarding de los paquetes de multicast de IPTV. En otro post indico como, solo entre para decirles que ayer en la noche después de probar muchas veces por fin lo conseguí.

El internet es sencillo es configurar el PPPoE con las claves que extragiste vía port mirroring en el router de Vodafone.

Saludos

🗨️ 2
BocaDePez
BocaDePez

Hola @vukits, claro, yo tuve el Asus + el H500S por un año, ya que cuando me cambiaron el setup box solo podia ver TV pero no tenia acceso ni a la guia ni a las aplicaciones ya que solo se podia conectar a la IP 105 que no tiene acceso a internet. Ahora me quite el H500S para siempre.

IncubusNetworking
3

@vcancela @vukits aquí les dejo un pequeño tuto de como conseguir tener Internet + IPTV de Vodafone en un router Mikrotik HEX de 5 puertos versión 6.47.8.

El ether1 lo uso como puerto WAN. Rrecordad que tenemos que configurar dos subinterfaces, una para la VLAN 100 (Internet y VoIP) y la VLAN 105 (IPTV) ambas en la misma interface:

/interface VLAN
add interface=ether1 name=INTERNET VLAN-id=100
add interface=LAN-Bridge name=LAN VLAN-id=20 # Interface Bridge para los puertos de LAN: 2-5
add interface=ether1 name=TIVO VLAN-id=105

Escogí la VLAN 10 pero eso es a gusto de cada quien.

Ahora la configuración de la interface bridge:

/interface bridge
add IGMP-snooping=yes name=LAN-Bridge

Activar el IGMP-Proxy para que no se inunde la red de paquetes multicast, que solo viaje los paquetes únicamente en los puertos que lo soliciten.

/interface bridge port
add bridge=LAN-Bridge interface=ether2
add bridge=LAN-Bridge interface=ether3
add bridge=LAN-Bridge interface=ether4
add bridge=LAN-Bridge interface=ether5

PPPoE:

/interface PPPoE-client

add add-default-route=yes disabled=no interface=INTERNET name=PPPoE-out1 password=EL QUE EXTRAJERON user=VFHXXXXXXX@Vodafone

IPTV-DHCP: Hay que crear el DHCP client para la interface VLAN 105 que en este caso la llame TIVO, la IP pública a diferencia del PPPoE la coge por DHCP.

/IP DHCP-client

add add-default-route=no disabled=no interface=TIVO use-peer-DNS=no 

use-peer-ntp=no

¡Importante! y creo que por eso la mayoría que intenta ver IPTV falla, la televisión va a través de paquetes multicast, es por ello que necesitamos enrutamiento IGMP, este paquete de configuración no viene por defecto en el Mikrotik, tienen que descargar el paquete de extras específico para la arquitectura del CPU, la del HEX es MMIPS, descomprimen y copian el paquete multicast en la carpeta "files" del mikrotik, basta con arrastrar el archivo a la carpeta, o pueden usar SCP.

/routing IGMP-proxy interface
add alternative-subnets=0.0.0.0/0 interface=TIVO upstream=yes
add interface=LAN-Bridge

DHCP SERVER, para dar las IPs a la red LAN:

POOL:

/IP pool
add name=LAN-Pool ranges=192.168.0.2-192.168.0.250
add name=TIVO-Pool ranges=192.168.0.251-192.168.0.253
/IP DHCP-server option
add code=12 name=TIVO value="'TIVO'"
/IP DHCP-server
add address-pool=LAN-Pool disabled=no interface=LAN-Bridge name=DHCP-LAN
/IP DHCP-server network
add address=192.168.0.0/24 DNS-server=8.8.8.8,8.8.4.4 (o el que le proveea el operador) 
gateway=192.168.0.1
add address=192.168.0.251/29 DHCP-option=TIVO gateway=192.168.0.1

DEFAULT-GATEWAY:

/IP address
add address=192.168.0.1/24 interface=LAN-Bridge network=192.168.0.0

FIREWALL:

/IP firewall filter
add action=drop chain=input in-interface=PPPoE-out1
add action=fasttrack-connection chain=forward connection-state=
established,related
add chain=forward connection-state=established
add chain=forward connection-state=related
add action=drop chain=forward connection-state=invalid
---
/IP firewall mangle
add action=set-priority chain=postrouting new-priority=4 out-interface=TIVO
add action=set-priority chain=postrouting new-priority=0 out-interface=
PPPoE-out1
---
/IP firewall NAT
add action=masquerade chain=srcnat dst-address=0.0.0.0/0 log=yes 
out-interface=PPPoE-out1 src-address=192.168.0.0/24 src-address-list=""
add action=masquerade chain=srcnat out-interface=TIVO
add action=dst-NAT chain=dstnat dst-address-type=local in-interface=TIVO 
to-addresses=192.168.0.251 # IP del SET UP BOX

RUTAS ESTÁTICAS:

/IP route
add distance=1 dst-address=10.X.X.0/24 gateway=TIVO pref-src=10.X.X.1 → DEFAULT GATEWAY DE LA IP PUBLICA PERTENECIENTE A LA INTERFACE VLAN 105 (TIVO)
add distance=1 dst-address=10.X.X.0/24 gateway=TIVO pref-src=10.X.X.1 → DEFAULT GATEWAY DE LA IP PUBLICA PERTENECIENTE A LA INTERFACE VLAN 105 (TIVO)
add distance=1 dst-address=10.X.X.0/24 gateway=TIVO pref-src=10.X.X.1 → DEFAULT GATEWAY DE LA IP PUBLICA PERTENECIENTE A LA INTERFACE VLAN 105 (TIVO)
add distance=1 dst-address=10.X.X.0/23 gateway=TIVO pref-src=10.X.X.1 → DEFAULT GATEWAY DE LA IP PUBLICA PERTENECIENTE A LA INTERFACE VLAN 105 (TIVO)
add distance=1 dst-address=10.X.X.0/24 gateway=TIVO pref-src=10.X.X.1 → DEFAULT GATEWAY DE LA IP PUBLICA PERTENECIENTE A LA INTERFACE VLAN 105 (TIVO)

Esta IP 10.X.X.0/24 se consigue entrando en el router de Vodafone como administrador en el apartado SettingsStatic Routing, no me he equivocado unas de las IPs es /23.

Creo que no me dejo nada más, pruébenlo y compartan que tal les fue. ¡Éxito!