Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

hosting en interdominios
541 lecturas y 7 respuestas
  • Cerrado

    BocaDePez BocaDePez
    6

    Ayuda configuración Cisco 837 con Telefonica. IP fija y Multipuesto

    Hola estoy pensando comprar este router, ya que el CT535 que me ha puesto telefónica no me convence.

    Mi problema es que no lo puedo conectar via consola a mi ordenador, ya que utilizo MacOS X, por lo que no puedo cargar ningún script.

    Sé que los router Cisco se pueden configurar via web a través del Cisco Router Web Setup, pero desconozco como hacerlo para configurarlo correctamente con IP fija y Multipuesto. Alguien podría echarme una mano.

    Gracias

    Este tema es antiguo y puede contener información obsoleta. Abre un nuevo tema para publicar tu mensaje.
    1
    • Cerrado

      BocaDePez BocaDePez
      6

      Hola, sólo quisiera daros las gracias a todos los que me…

      Hola, sólo quisiera daros las gracias a todos los que me habéis echado una mano. Al final he podido configurar el router utilizando el programa Cisco SDM, que de forma fácil y efectiva permite configurar via web todas las posibilidades que te brinda este fantástico router, incluyendo su firewall. Ha sido más fácil de lo que pensaba.

      Por cierto os posteo la configuración final, por si observáis algo raro.
      Espero vuestros comentarios.

      !version 12.3
      no service pad
      service tcp-keepalives-in
      service tcp-keepalives-out
      service timestamps debug datetime msec localtime show-timezone
      service timestamps log datetime msec localtime show-timezone
      service password-encryption
      service sequence-numbers
      !
      hostname cisco
      !
      boot-start-marker
      boot-end-marker
      !
      logging buffered 51200 debugging
      logging console critical
      enable secret 5 $1$ACS9$lZLhCBT0pgJcq7lnILdLo1
      !
      username cisco837 privilege 15 secret 5 $1$6Jyk$DoKKX.Tgg34p0c/p.ukNS.
      clock timezone PCTime 1
      clock summer-time PCTime date Mar 30 2003 2:00 Oct 26 2003 3:00
      no aaa new-model
      ip subnet-zero
      no ip source-route
      ip tcp synwait-time 10
      ip domain name cisco.com
      ip name-server XX.XX.XX.XX
      ip name-server XX.XX.XX.XX
      ip dhcp excluded-address XX.XX.XX.XX
      !
      ip dhcp pool sdm-pool1
      import all
      network XXX.XX.XX.XX 255.255.255.0
      dns-server XX.XX.XX.XX XX.XX.XX.XX.
      default-router XX.XX.XX.XX.
      !
      !
      no ip bootp server
      ip cef
      ip inspect name DEFAULT100 cuseeme
      ip inspect name DEFAULT100 ftp
      ip inspect name DEFAULT100 h323
      ip inspect name DEFAULT100 netshow
      ip inspect name DEFAULT100 rcmd
      ip inspect name DEFAULT100 realaudio
      ip inspect name DEFAULT100 rtsp
      ip inspect name DEFAULT100 smtp
      ip inspect name DEFAULT100 sqlnet
      ip inspect name DEFAULT100 streamworks
      ip inspect name DEFAULT100 tftp
      ip inspect name DEFAULT100 tcp
      ip inspect name DEFAULT100 udp
      ip inspect name DEFAULT100 vdolive
      ip inspect name DEFAULT100 icmp
      ip audit notify log
      ip audit po max-events 100
      ip ssh time-out 60
      ip ssh authentication-retries 2
      no ftp-server write-enable
      !
      !
      !
      no crypto isakmp enable
      !
      !
      !
      !
      interface Ethernet0
      description $FW_INSIDE$$ETH-LAN$$INTF-INFO-Ethernet 10/100$
      ip address XX.XX.XX.XX XXX.XXX.XXX.X
      ip access-group 100 in
      no ip redirects
      no ip unreachables
      no ip proxy-arp
      ip nat inside
      ip route-cache flow
      hold-queue 100 out
      !
      interface ATM0
      no ip address
      no ip redirects
      no ip unreachables
      no ip proxy-arp
      ip route-cache flow
      no atm ilmi-keepalive
      dsl operating-mode auto
      !
      interface ATM0.3 point-to-point
      ip address XX.XX.XX.XX XXX.XXX.XXX.X
      ip nat outside
      pvc 8/32
      encapsulation aal5snap
      !
      !
      ip nat inside source list 1 interface ATM0.3 overload
      ip classless
      ip route 0.0.0.0 0.0.0.0 80.36.153.1
      ip http server
      ip http authentication local
      ip http secure-server
      !
      !
      logging trap debugging
      access-list 1 remark INSIDE_IF=Ethernet0
      access-list 1 remark SDM_ACL Category=2
      access-list 1 permit XXX.XX.XX.0 0.0.0.255
      access-list 100 remark auto generated by SDM firewall configuration
      access-list 100 remark SDM_ACL Category=1
      access-list 100 deny ip XX.XX.XX.0 0.0.0.255 any
      access-list 100 deny ip host 255.255.255.255 any
      access-list 100 deny ip XXX.0.0.0 0.255.255.255 any
      access-list 100 permit ip any any
      access-list 101 remark auto generated by SDM firewall configuration
      access-list 101 remark SDM_ACL Category=1
      access-list 101 deny ip XXX.XX.XX.0 0.0.0.255 any
      access-list 101 permit icmp any host XX.XX.XX.XX echo-reply
      access-list 101 permit icmp any host XX.XX.XX.XX time-exceeded
      access-list 101 permit icmp any host XX.XX.XX.XX unreachable
      access-list 101 deny ip XX.XX.XX.XX.255.255.255 any
      access-list 101 deny ip XX.XX.XX.XX.XX..255.255 any
      access-list 101 deny ip XX.XX.XXX.0.0 0.0.255.255 any
      access-list 101 deny ip XX.XX.XXX..255.255.255 any
      access-list 101 deny ip host XXX.XXX.XXX.XXX. any
      access-list 101 deny ip host 0.0.0.0 any
      access-list 101 deny ip any any
      no cdp run
      !
      control-plane
      !
      banner login ^CAuthorized access only!
      Disconnect IMMEDIATELY if you are not an authorized user!^C
      !
      line con 0
      login local
      no modem enable
      transport preferred all
      transport output telnet
      line aux 0
      login local
      transport preferred all
      transport output telnet
      line vty 0 4
      privilege level 15
      login local
      transport preferred all
      transport input telnet ssh
      transport output all
      !
      scheduler max-task-time 5000
      scheduler interval 500
      !
      end

    • Cerrado

      BocaDePez BocaDePez
      6

      Hola de nuevo, os estoy dando el coñazo pero de verdad os…

      Hola de nuevo, os estoy dando el coñazo pero de verdad os agradezco vuestras indicaciones, ya que no tengo ni idea de trastear con los Cisco.
      Dicho, esto y suponiendo que no pueda configurar a través del navegador web, podría intentarlo a través de telnet.

      Os agradecería vuestros comentarios paso a paso.

      CONFIGURACIÓN CISCO 837

      1.-Activar telnet. (Al no tener Windows, sino MacOS X tengo que acceder a través de telnet y ethernet, ya que el Mac no tiene puerto de serie DB9)

      2.-Pasos activación telnet
      Router>enable
      Router#conf t
      Router#line vty 0 4
      Router#password clave_que_quieras
      Router#login

      Una vez activado la conexión telnet escribimos escribimos enable y nos solicitará que definamos una password.

      3.-Pegamos esta configuración:

      no service pad
      service password-encryption
      !
      hostname (nombre del router)
      !

      enable secret (password del enable)
      !
      !
      !
      !
      !
      ip subnet-zero
      no ip domain-lookup
      !
      !
      !
      !
      !
      !
      interface Ethernet0
      ip address (IP de la red) (mascara de la red)
      ip nat inside
      no ip mroute-cache
      no cdp enable

      interface ATM0
      no ip address
      no ip route-cache
      no ip mroute-cache
      no atm auto-configuration
      no atm ilmi-keepalive
      no atm address-registration
      no atm ilmi-enable
      bundle-enable
      dsl operating-mode auto
      hold-queue 208 in
      !
      interface ATM0.1 point-to-point
      ip address (ip que te da el proveedor) (mascara)
      ip nat outside
      no ip route-cache
      no ip mroute-cache
      pvc 8/32
      encapsulation aal5snap
      !
      !
      ip nat inside source list 101 interface ATM0.1 overload
      ip classless
      ip route 0.0.0.0 0.0.0.0 ATM0.1
      ip http server

      Pulsamos intro y escribimos Control-Z. Pulso intro y escribo write mem para salvar la configuración. Y LISTO.

      Os agradecería me comentárais si me dejo algo, falta algo o estoy metiendo la pata hasta el fondo. Muchísimas gracias a todos.

      Saludos

    • Cerrado

      BocaDePez BocaDePez
      6

      Hola, muchas gracias por tu respuesta. No obstante me…

      Hola, muchas gracias por tu respuesta. No obstante me preguntaba si también se podría configurar por web, (soy todo un neófito en este tema y eso de introducir un script.... me da algo de yu yu) como indica esta página.

      http://www.ifm.net.nz/cookbooks/827h/

      Sería posible sin problemas?
      Qué datos necesitaría para esa configuración con Telefónica? (Ip fija y Multipuesto).

      Gracias de nuevo

      • Cerrado

        A la configuracion por web sólo se puede entrar (como es…

        A la configuracion por web sólo se puede entrar (como es lógico) cuando tienes una Ip configurada en tu PC y en la ethernet del router. Además de tener el servicio http arrancado en el router y clave de administrador (enable) puesta.

        Cuando estés por consola poniendo ip a la ethernet, acuerdate de usar el comando "ip http server" y de no poner el contrario como te recomienda la config del compañero.

        No es prudente dejarlo puesto asi que cuando lo tengas configurado desactivalo.

        • Cerrado

          BocaDePez BocaDePez
          6

          Hola muchas gracias por vuestras indicaciones, aunque te…

          Hola muchas gracias por vuestras indicaciones, aunque te agradecería me aclararas lo siguiente:

          De fabrica este router trae activada la conexión por web, por lo que conectando convenientemente las conexiones y poniendo el ordenador en DHCP, podría conectarme sin problemas con el router a través de web, introduciento en el navegador http:/10.10.10.1

          Ahora bien, por lo que he leido en el manual el router puede detectar los parametros básicos para configurarse a través de quick setup, pero creo que esto es sólo para los que tienen una ip dinámica, En mi caso al tener una fija, desconozco si el router también puede detectarla y configurarlo convenientemente. El procedimiento de autoconfiguración se explica en la siguiente página:

          http://www.cisco.com/en/US/products/hw/routers/ps380/products_data_sheet09186a0080091cc5.html

          En ese caso cómo podría actuar para configurarlo, sin necesidad de utilizar el terminal, ni CLI.

          De nuevo gracias a todos y disculpad mi ignoracia

          Saludos

          • Cerrado

            Pues la verdad es que no lo sé, siempre entro por consola. Si…

            Pues la verdad es que no lo sé, siempre entro por consola. Si quieres, como ya sbes la IP ¿porque no pruebas el faststep? Es un programa gratuito de cisco para configurar la serie 800. Tal vez te sirva.

    • Cerrado

      BocaDePez BocaDePez
      6

      ¿Qué no puedes acceder a la consola??? Simplemente con buscar…

      ¿Qué no puedes acceder a la consola???

      Simplemente con buscar osC y telnet en google aparece esto:

      Use Finder to access terminal at /Applications/Utilities/Terminal.

      Aparte, esta configuración te debería valer:

      no service pad
      service password-encryption
      !
      hostname (nombre del router)
      !

      enable secret (password del enable)
      !
      !
      !
      !
      !
      ip subnet-zero
      no ip domain-lookup
      !
      !
      !
      !
      !
      !
      interface Ethernet0
      ip address (IP de la red) (mascara de la red)
      ip nat inside
      no ip mroute-cache
      no cdp enable

      interface ATM0
      no ip address
      no ip route-cache
      no ip mroute-cache
      no atm auto-configuration
      no atm ilmi-keepalive
      no atm address-registration
      no atm ilmi-enable
      bundle-enable
      dsl operating-mode auto
      hold-queue 208 in
      !
      interface ATM0.1 point-to-point
      ip address (ip que te da el proveedor) (mascara)
      ip nat outside
      no ip route-cache
      no ip mroute-cache
      pvc 8/32
      encapsulation aal5snap
      !
      !
      ip nat inside source list 101 interface ATM0.1 overload
      ip classless
      ip route 0.0.0.0 0.0.0.0 ATM0.1
      no ip http server