Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

Ayuda adsl+wireless (linksys)+linux

ghoz

Hola amigos,
tengo un problema de novato de Linux, supongo.
Resulta que tengo adsl 1 Mb con Jazztel. Con mi equipo con Winxp+tarjeta pci wireless linksys+router/modem wireless Linksys(wag54g) no he tenido problemas para conectarme a Internet.
El problema ha venido cuando he instalado linux (Suse 9.1) en el ordenador.
Al principio me costó un güevo configurar la tarjeta de red wirelesss pci. Tuve que instalar un programita: ndiswrapper para que reconociera el kernel el driver de la tarjeta; y luego tuve que configurar los parámetros.
Una vez resuelto este asunto, mi PC se "ve" con el router, porque me deja configurar el router vía inalámbrica (vía browser que es como se configura); pero NO TENGO ACCESO A INTERNET. Investigando me he enterado que es un problema de DNSs. H editado el fichero resolv.conf para poner las dns de jazztel, pero nada de nada.
Algún alma caritativa me puede decir qué y cómo tengo que configurar.
Muchisimas gracias

Este tema está cerrado a nuevas respuestas. Abre un nuevo tema para retomar la conversación.
MurdockDj

A ver, primero de todo, tienes que configurar el driver, por ejemplo cargando el modulo con modprobe o insmod.

Una vez cargado, establecer los parametros tcp/ip, desactivas la tarjeta de cable ethernet, y luego arrancas la tarjeta wireless indicandole el modo de conexión y el SSID.

Te pasteo parte de mi script:

#!/bin/bash
gateway=10.0.0.1
ip=10.0.0.2
broadcast=10.0.0.255
essid=my_accesspoint

ifconfig eth0 down
ifconfig eth1 down
ifconfig eth1 $ip netmask 255.255.255.0 broadcast $broadcast up
iwconfig eth1 mode managed
iwconfig eth1 essid $essid
route add -net default gw $gateway netmask 0.0.0.0 metric 1 eth1

y si necesitas encriptación WEP:

iwconfig eth1 key [1] AAAAAAAAAAAAAAAAAAAAAAAAAA
iwconfig eth1 key [2] BBBBBBBBBBBBBBBBBBBBBBBBBB
iwconfig eth1 key [3] CCCCCCCCCCCCCCCCCCCCCCCCCC
iwconfig eth1 key [4] DDDDDDDDDDDDDDDDDDDDDDDDDD

lo guardas en un .sh, y lo ejecutas con sh lanza_wifi.sh (por ejemplo)

A mi me funciona así, tengo una tarjeta prism II en un portatil medion con gentoo linux.

🗨️ 6
overpeer

Pongo yo tambien mi script :)

#!/bin/bash

# iwconfig
DEV=eth1 # Dispositivo inalambrico
ESSID="overpeer" # ESSID de la red
MODE=Managed # Modo de la red
KEY=laqueseaxD # Clave WEP
CHANNEL=6 # Canal usado en la red

# ifconfig
IP=192.168.1.25 # Direccion IP de la interfaz
MS=255.255.255.0 # Mascara de subred
BC=192.168.1.255 # Direccion de Broadcast
DG=192.168.1.1 # Ruta por defecto

DNS1=62.42.230.24 # Primer servidor de nombres
DNS2=62.42.63.52 # Segundo servidor de nombres

# Funciones

function inicio()
{
echo Iniciando

iwconfig $DEV essid $ESSID channel $CHANNEL key $KEY rate 54M

ifconfig $DEV $IP
route add default gw $DG
echo "nameserver $DNS1" > /etc/resolv.conf
echo "nameserver $DNS2" >> /etc/resolv.conf
}

function parada()
{
echo Parando Intel Pro 2200BG Linux Native Driver!

ifconfig $DEV down
}

function estado()
{
echo
echo "WLAN:"
iwconfig $DEV
echo
cat /proc/net/wireless
echo
echo "INTERFACE:"
ifconfig $DEV

}

case "$1" in

start)
inicio
echo;;
stop)
parada
echo;;
status)
estado
echo;;
*)
echo "Opcion Incorrecta"
echo "Uso: "
echo " start : Inicia Wireless"
echo " stop : Detiene Wireless"
echo " status: Muestra el estado";;
esac

Un saludo.

🗨️ 5
ghoz

Lo siento. No me he debido explicar bien. NO TENGO NI P..TA IDEA DE LINUX y lo que me respondeis de scripts no se ni meridianamente interpretarlo.
1º- La tarjeta PCI wireless la he instalado bien. Prueba de ello es que he conseguido que mi PC (que lleva esta tarjeta PCI wireless) se hable con mi router-modem wireless. Con lo cual hasta aqui todo biem

2º- Lo que no me funciona es el acceso a Internet. Me enteré de que el problema está en que hay que configurar los DNS primario y secundario. Edité el ficehero:
etc/resolv.conf, y puse lo siguiente:

nameserver 62.14.63.145 #DNS primario de Jazztel
nameserver 62.14.2.1 #DNS secundario de Jazztel

A pesar de haber hecho esto, sigo sin tener acceso a Internet.
¿que más tengo que hacer?

🗨️ 4
overpeer

la puerta de enlace quizas ??

route add default gw [puerta_de_enlace]

Un saludo.

🗨️ 3
ghoz
ghoz
🗨️ 1
BocaDePez
BocaDePez

Hola!

Yo tengo un problema igual....pero no en LINUX sino en WINXP....he tratado todo lo poco que sé, pero nada me da resultado.

Veo que ustedes son un poco expertos en el tema, me podrían dar una mano?