BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

ADSL

AR-5382u-A731-406CTL-T01_R08 en Comtrend AR-5387un

difusion

He conseguido que se ejecutara en el Comtrend AR-5387un uno de los firmwares libres que Ari publicó hace un tiempo para el AR-5381u, no obstante, existen una serie de problemas pendientes de solucionar:

  • Sin wireless
  • Numerosos errores en el log de inicio
  • Los LEDs no informan el estado del equipo

Para conseguir el arranque inicial de éste firmware es necesario resetear la nvram en el CFE, agregar nuevos valores de identificación de la board, y finalmente cargar el firmware mediante TFTP.

Adjunto parámetros de sincronismo en ADSL2+;

> adsl info --stats
adsl: ADSL driver and PHY status
Status: Showtime
Retrain Reason: 0
Last initialization procedure status: 0
Max: Upstream rate = 1090 Kbps, Downstream rate = 23740 Kbps
Bearer: 0, Upstream rate = 828 Kbps, Downstream rate = 10046 Kbps

Link Power State: L0
Mode: ADSL2+
TPS-TC: ATM Mode
Trellis: U:ON /D:ON
Line Status: No Defect
Training Status: Showtime
Down Up
SNR (dB): 23.9 19.5
Attn(dB): 16.5 8.3
Pwr(dBm): 19.5 12.0

ADSL2 framing
Bearer 0
MSGc: 92 28
B: 31 46
M: 1 1
T: 6 1
R: 16 10
S: 0.1097 1.9241
L: 3501 237
D: 511 32

Counters
Bearer 0
SF: 18723 18412
SFErr: 0 0
RS: 11008330 625623
RSCorr: 0 0
RSUnCorr: 0 0

Bearer 0
HEC: 9 0
OCD: 0 0
LCD: 0 0
Total Cells: 7152131 583651
Data Cells: 0 0
Drop Cells: 0
Bit Errors: 0 0

ES: 0 0
SES: 0 0
UAS: 21 21
AS: 302

Bearer 0
INP: 9.00 5.00
INPRein: 0 0
delay: 14 15
PER: 16.12 16.35
OR: 48.62 16.63

Bitswap: 0/0 0/0

Total time = 5 min 28 sec
FEC: 0 0
CRC: 0 0
ES: 0 0
SES: 0 0
UAS: 21 21
LOS: 0 0
LOF: 0 0
LOM: 0 0
Latest 15 minutes time = 5 min 28 sec
FEC: 0 0
CRC: 0 0
ES: 0 0
SES: 0 0
UAS: 21 21
LOS: 0 0
LOF: 0 0
LOM: 0 0
Previous 15 minutes time = 0 sec
FEC: 0 0
CRC: 0 0
ES: 0 0
SES: 0 0
UAS: 0 0
LOS: 0 0
LOF: 0 0
LOM: 0 0
Latest 1 day time = 5 min 28 sec
FEC: 0 0
CRC: 0 0
ES: 0 0
SES: 0 0
UAS: 21 21
LOS: 0 0
LOF: 0 0
LOM: 0 0
Previous 1 day time = 0 sec
FEC: 0 0
CRC: 0 0
ES: 0 0
SES: 0 0
UAS: 0 0
LOS: 0 0
LOF: 0 0
LOM: 0 0
Since Link time = 5 min 1 sec
FEC: 0 0
CRC: 0 0
ES: 0 0
SES: 0 0
UAS: 0 0
LOS: 0 0
LOF: 0 0
LOM: 0 0

Log de inicio;

CFE version 1.0.37-110.11-2 for BCM96328 (32bit,SP,BE)
Build Date: 2011-04-29 11:30:31 (lain@SW1-BCM-04)
Copyright (C) 2000-2009 Broadcom Corporation.

HS Serial flash device: name MX25L128, id 0xc218 size 16384KB
Total Flash size: 16384K with 4096 sectors
Chip ID: BCM6328B0, MIPS: 320MHz, DDR: 320MHz, Bus: 160MHz
Main Thread: TP0
Memory Test Passed
Total Memory: 67108864 bytes (64MB)
Boot Address: 0xb8000000

Board IP address : 192.168.1.1:ffffff00
Host IP address : 192.168.1.100
Gateway IP address :
Run from flash/host (f/h) : f
Default host run file name : vmlinux
Default host flash file name : bcm963xx_fs_kernel
Boot delay (0-9 seconds) : 1
Boot image (0=latest, 1=previous) : 0
Board Id (0-6) : 96328avng
Number of MAC Addresses (1-32) : 1
Base MAC Address : fa:ba:da:fa:ba:da
PSI Size (1-64) KBytes : 24
Enable Backup PSI [0|1] : 0
System Log Size (0-256) KBytes : 0
Main Thread Number [0|1] : 0
Serial Number : guifi.net
Default PSK key :
Voice Board Configuration (0-10) :

*** Press any key to stop auto run (1 seconds) ***
Auto run second count down: 0
Booting from latest image (0xb8800000) ...
Code Address: 0x80010000, Entry Address: 0x80014230
Decompression OK!
Entry at 0x80014230
Closing network.
Disabling Switch ports.
Flushing Receive Buffers...
0 buffers found.
Closing DMA Channels.
Starting program at 0x80014230
Linux version 2.6.30 (lucien@SW1-BCM-00) (gcc version 4.4.2 (Buildroot 2010.02-git) ) #1 Thu Feb 10 16:05:25 CST 2011
HS Serial flash device: name MX25L128, id 0xc218 size 16384KB
96328avng prom init
CPU revision is: 0002a075 (Broadcom4350)
Determined physical RAM map:
memory: 03f00000 @ 00000000 (usable)
Zone PFN ranges:
DMA 0x00000000 -> 0x00001000
Normal 0x00001000 -> 0x00003f00
Movable zone start PFN for each node
early_node_map[1] active PFN ranges
0: 0x00000000 -> 0x00003f00
On node 0 totalpages: 16128
free_area_init_node: node 0, pgdat 803849d0, node_mem_map 81000000
DMA zone: 32 pages used for memmap
DMA zone: 0 pages reserved
DMA zone: 4064 pages, LIFO batch:0
Normal zone: 94 pages used for memmap
Normal zone: 11938 pages, LIFO batch:1
Built 1 zonelists in Zone order, mobility grouping on. Total pages: 16002
Kernel command line: root=31:0 ro noinitrd console=ttyS0,115200
wait instruction: enabled
Primary instruction cache 32kB, VIPT, 4-way, linesize 16 bytes.
Primary data cache 32kB, 2-way, VIPT, cache aliases, linesize 16 bytes
RCU-based detection of stalled CPUs is enabled.
NR_IRQS:128
PID hash table entries: 256 (order: 8, 1024 bytes)
console [ttyS0] enabled
Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)
Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)
Memory: 59960k/64512k available (2846k kernel code, 4532k reserved, 698k data, 128k init, 0k highmem)
Calibrating delay loop... 319.48 BogoMIPS (lpj=159744)
Mount-cache hash table entries: 512
net_namespace: 1096 bytes
NET: Registered protocol family 16
Total Flash size: 16384K with 4096 sectors
registering PCI controller with io_map_base unset
registering PCI controller with io_map_base unset
bio: create slab at 0
SCSI subsystem initialized
usbcore: registered new interface driver usbfs
usbcore: registered new interface driver hub
usbcore: registered new device driver usb
pci 0000:00:09.0: reg 10 32bit mmio: [0x10002600-0x100026ff]
pci 0000:00:0a.0: reg 10 32bit mmio: [0x10002500-0x100025ff]
pci 0000:01:00.0: PME# supported from D0 D3hot
pci 0000:01:00.0: PME# disabled
pci 0000:02:00.0: reg 10 64bit mmio: [0x000000-0x003fff]
pci 0000:02:00.0: supports D1 D2
pci 0000:01:00.0: PCI bridge, secondary bus 0000:02
pci 0000:01:00.0: IO window: disabled
pci 0000:01:00.0: MEM window: 0x10f00000-0x10ffffff
pci 0000:01:00.0: PREFETCH window: disabled
PCI: Enabling device 0000:01:00.0 (0000 -> 0002)
PCI: Setting latency timer of device 0000:01:00.0 to 64
BLOG v3.0 Initialized
NET: Registered protocol family 8
NET: Registered protocol family 20
NET: Registered protocol family 2
IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
TCP established hash table entries: 2048 (order: 2, 16384 bytes)
TCP bind hash table entries: 2048 (order: 1, 8192 bytes)
TCP: Hash tables configured (established 2048 bind 2048)
TCP reno registered
NET: Registered protocol family 1
squashfs: version 4.0 (2009/01/31) Phillip Lougher
squashfs: version 4.0 with LZMA457 ported by BRCM
fuse init (API version 7.11)
msgmni has been set to 117
io scheduler noop registered (default)
pcieport-driver 0000:01:00.0: device [14e4:6328] has invalid IRQ; check vendor BIOS
PCI: Setting latency timer of device 0000:01:00.0 to 64
Driver 'sd' needs updating - please use bus_type methods
Driver 'sr' needs updating - please use bus_type methods
PPP generic driver version 2.4.2
PPP Deflate Compression module registered
PPP BSD Compression module registered
NET: Registered protocol family 24
bcm963xx_mtd driver v1.0
File system address: 0xb8800100
ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
PCI: Enabling device 0000:00:0a.0 (0000 -> 0002)
PCI: Setting latency timer of device 0000:00:0a.0 to 64
ehci_hcd 0000:00:0a.0: EHCI Host Controller
ehci_hcd 0000:00:0a.0: new USB bus registered, assigned bus number 1
ehci_hcd 0000:00:0a.0: Enabling legacy PCI PM
ehci_hcd 0000:00:0a.0: irq 50, io mem 0x10002500
ehci_hcd 0000:00:0a.0: USB f.f started, EHCI 1.00
usb usb1: configuration #1 chosen from 1 choice
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 1 port detected
ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
PCI: Enabling device 0000:00:09.0 (0000 -> 0002)
PCI: Setting latency timer of device 0000:00:09.0 to 64
ohci_hcd 0000:00:09.0: OHCI Host Controller
ohci_hcd 0000:00:09.0: new USB bus registered, assigned bus number 2
ohci_hcd 0000:00:09.0: irq 49, io mem 0x10002600
usb usb2: configuration #1 chosen from 1 choice
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 1 port detected
usbcore: registered new interface driver usblp
brcmboard: brcm_board_init entry
SES: Button Interrupt 0x1 is enabled
SES: LED GPIO 0x8009 is enabled
Serial: BCM63XX driver $Revision: 3.00 $
ttyS0 at MMIO 0xb0000100 (irq = 36) is a BCM63XX
ttyS1 at MMIO 0xb0000120 (irq = 47) is a BCM63XX
bcmxtmrt: Broadcom BCM6328B0 ATM/PTM Network Device v0.3 Feb 10 2011 16:01:37
Broadcom Logger v0.1 Feb 10 2011 15:59:19
Mirror/redirect action on
u32 classifier
input device check on
Actions configured
TCP cubic registered
Initializing XFRM netlink socket
NET: Registered protocol family 10
NET: Registered protocol family 17
NET: Registered protocol family 15
Initializing MCPD Module
Ebtables v2.0 registered
ebt_time registered
ebt_ftos registered
ebt_wmm_mark registered
802.1Q VLAN Support v1.8 Ben Greear
All bugs added by David S. Miller
VFS: Mounted root (squashfs filesystem) readonly on device 31:0.
Freeing unused kernel memory: 128k freed
init started: BusyBox v1.00 (2011.02.10-08:08+0000) multi-call binary

BusyBox v1.00 (2011.02.10-08:08+0000) Built-in shell (msh)
Enter 'help' for a list of built-in commands.

Loading drivers and kernel modules...

180
pktflow: module license 'Proprietary' taints kernel.
Disabling lock debugging due to kernel taint
Initialized fcache state
Broadcom Packet Flow Cache Char Driver v2.2 Sep 24 2010 18:42:19 Registered<242>
Created Proc FS /procfs/fcache
Broadcom Packet Flow Cache registered with netdev chain
Broadcom Packet Flow Cache learning via BLOG enabled.
Constructed Broadcom Packet Flow Cache v2.2 Sep 24 2010 18:42:19
bcmxtmcfg: bcmxtmcfg_init entry
CT_HOTPLUG_MONITOR
adsl: adsl_init entry
Broadcom BCM6328B0 Ethernet Network Device v0.1 Feb 10 2011 15:59:29
ETH Init: 180 tx BDs at 0xa395b000
ETH Init: 400 rx BDs at 0xa3a66000
ETH Init: 400 rx BDs at 0xa3a65000
######## ethsw_init_table:98 ####### switch_port_phyid[0]=1
######## ethsw_init_table:98 ####### switch_port_phyid[1]=2
######## ethsw_init_table:98 ####### switch_port_phyid[2]=3
######## ethsw_init_table:98 ####### switch_port_phyid[3]=4
######## ethsw_init_table:98 ####### switch_port_phyid[4]=24
/proc/buffer16 created
dgasp: kerSysRegisterDyingGaspHandler: bcmsw registered
===== Found Interface name mapping Fail: use default mapping =====
eth0: MAC Address: FA:BA:DA:FA:BA:DA
eth1: MAC Address: FA:BA:DA:FA:BA:DA
eth2: MAC Address: FA:BA:DA:FA:BA:DA
eth3: MAC Address: FA:BA:DA:FA:BA:DA
xxxx: MAC Address: FA:BA:DA:FA:BA:DA
xxxx Link UP 1000 mbps full duplex
message received before monitor task is initialized kerSysSendtoMonitorTask
PCI: Enabling device 0000:02:00.0 (0000 -> 0002)
PCI: Setting latency timer of device 0000:02:00.0 to 64
wl:srom strapped
wl:(srom strapped) probe/present=0
wl:srom not detected,using main memory mapped srom info(wombo board)
wl:loading /etc/wlan/bcm43225_map.bin
wl0: Broadcom BCMa8d8 802.11 Wireless Controller 5.100.96.0.cpe4.06L03.0
dgasp: kerSysRegisterDyingGaspHandler: wl0 registered
p8021ag: p8021ag_init entry
Broadcom 802.1Q VLAN Interface, v0.1
Initializing USB Mass Storage driver...
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
usbcore: registered new interface driver usbserial
USB Serial support registered for generic
usbcore: registered new interface driver usbserial_generic
usbserial: USB Serial Driver core
USB Serial support registered for GSM modem (1-port)
usbcore: registered new interface driver option
option: v0.7.2:USB Driver for GSM modems
usbcore: registered new interface driver hso
hso: 1.6-Option:USB High Speed Option driver

===== Comtrend Release Version A731-406CTL-T01_R08 =====

ip_tables: (C) 2000-2006 Netfilter Core Team
/proc/PSD_data created
Netfilter messages via NETLINK v0.30.
nf_conntrack version 0.5.0 (1008 buckets, 4032 max)
device eth0 entered promiscuous mode
#### Brctl_Port_Base_VLAN_config:60 ####
#### Brctl_Port_Base_VLAN_config:84 ####
######## bcm63xx_enet_open:1019 ####### dev->base_addr=0 phyport:0 0
ADDRCONF(NETDEV_UP): eth0: link is not ready
device eth1 entered promiscuous mode
#### Brctl_Port_Base_VLAN_config:60 ####
#### Brctl_Port_Base_VLAN_config:84 ####
######## bcm63xx_enet_open:1019 ####### dev->base_addr=1 phyport:0 1
ADDRCONF(NETDEV_UP): eth1: link is not ready
device eth2 entered promiscuous mode
#### Brctl_Port_Base_VLAN_config:60 ####
#### Brctl_Port_Base_VLAN_config:84 ####
######## bcm63xx_enet_open:1019 ####### dev->base_addr=2 phyport:1 2
ADDRCONF(NETDEV_UP): eth2: link is not ready
device eth3 entered promiscuous mode
#### Brctl_Port_Base_VLAN_config:60 ####
#### Brctl_Port_Base_VLAN_config:84 ####
######## bcm63xx_enet_open:1019 ####### dev->base_addr=3 phyport:2 3
ADDRCONF(NETDEV_UP): eth3: link is not ready
BcmAdsl_Initialize=0xC00C8104, g_pFnNotifyCallback=0xC00FAC64
pSdramPHY=0xA3FFFFF8, 0xFFFFFFFF 0xFFFFFFFF
WLmngr Daemon is running
optarg=0 shmId=0
wlevt_init@107: opened loopback socket 4
wlevt is ready for new msg...
*** PhySdramSize got adjusted: 0x7AB04 => 0x90698 ***
AdslCoreSharedMemInit: shareMemAvailable=457024
AdslCoreHwReset: pLocSbSta=83248000 bkupThreshold=1600
AdslCoreHwReset: AdslOemDataAddr = 0xA3F711A8
Version Number of EOC:406CTL-T01_R08
dgasp: kerSysRegisterDyingGaspHandler: dsl0 registered
XTM Init: 400 rx BDs at 0xa31c9000
XTM Init: 100 rx BDs at 0xa31cfc00
monitor task is initialized pid= 264
CT_ATCPOLL:error:19.589:getAvailableUsbDongleList:140:Can't open proc file /var/donglemap2

wireless button is pressing

wireless button is pressing
ssk:error:24.272:checkDongleState:191:Wan link(3G) went from up->down, send event msg
ssk:error:24.273:checkDongleState:221:3G WAN not configured
device wl0 entered promiscuous mode
device wl0 left promiscuous mode
device wl0 entered promiscuous mode
device wl0 left promiscuous mode
can't add wl0 to bridge br0: Invalid argument

wireless button is pressing
There is no Predefined DevicePin in CFE
WPS Device PIN = 10864111
Setting SSID: "COMTREND"
Setting SSID: "wl0_Guest1"
Setting SSID: "wl0_Guest2"
Setting SSID: "wl0_Guest3"
#### Enable WL ####
device wl0 is not a slave of br0
device wl0 entered promiscuous mode
device wl0 left promiscuous mode
device wl0 entered promiscuous mode
device wl0 left promiscuous mode
can't add wl0 to bridge br0: Invalid argument
Setting SSID: "COMTREND"
Setting SSID: "wl0_Guest1"
Setting SSID: "wl0_Guest2"
Setting SSID: "wl0_Guest3"
Error setting variable cur_etheraddr
Chanspec set to 0x2b01
device wl0 is not a slave of br0
device wl0 entered promiscuous mode
device wl0 left promiscuous mode
device wl0 entered promiscuous mode
device wl0 left promiscuous mode
can't add wl0 to bridge br0: Invalid argument

wireless button is pressing
Reaped 833
UPnP daemon is ready to run

wireless button is pressing
device wl0 is not a slave of br0
#### Disable WL ####

wireless button is pressing

wireless button is pressing
device wl0 entered promiscuous mode
device wl0 left promiscuous mode
device wl0 entered promiscuous mode
device wl0 left promiscuous mode
can't add wl0 to bridge br0: Invalid argument
Setting SSID: "COMTREND"
Setting SSID: "wl0_Guest1"
Setting SSID: "wl0_Guest2"
Setting SSID: "wl0_Guest3"
#### Enable WL ####
device wl0 is not a slave of br0
device wl0 entered promiscuous mode
device wl0 left promiscuous mode
device wl0 entered promiscuous mode
device wl0 left promiscuous mode
can't add wl0 to bridge br0: Invalid argument

BCM96328 Broadband Router
Login:

BocaDePez
BocaDePez

¡ ¡ ¡ COÑO ! ! !

Ari

Ostras :P Bueno, pues me alegro (aunque no es recomendable si solo tienes ese router) de que alguien se haya atrevido a probarlo con el 5387. Sobre lo que comentas (los problemas) ya informarás si los has solventado.

Mi experiencia en meter firms de un router a otro (siendo ambos comtrend, routers sufridos donde los haya) ha pasado por ratos bastante malos. Siendo poco descriptivos :D :) Eso sí, en la mayoría de los casos he usado el método de recuperación para los comtrend con bastante éxito. Eso sí, repito que el rato, o ratos, no han sido muy buenos :D

Mucha suerte en cualquier caso :)

Saludos

🗨️ 2
BocaDePez
BocaDePez

Yo solo me meto en esas historias cuando el router tiene un puerto TTL funcional y posibilidad de enviar el firmware por tftp :P

🗨️ 1
Ari

Muy refinado, para mi gusto :P Yo soy bastante más bestia (con cariño) :D ;)

Saludos

BocaDePez
BocaDePez

saludos compañero: Ari. dice

"Yo solo me meto en esas historias cuando el router tiene un puerto TTL funcional y posibilidad de enviar el firmware por tftp"

creo entender que has iniciado esto post, por lo cual si no tienes inconvenientes ninguno, queria hacerte una pregunta como has conseguido cambiar la identificacion para que entre este firmware que no corresponde a este router 5387un ???, esto es motivado por lo siguiente, he mirado dentro del router y tiene un numero de identificacion de la placa T00469D6B-G, he mirado por la red y dice que hay una placa identica y corresponde a un DLINk DSL2750U en el link que sale hay una imagen y es identico salvo que tiene una memoria creo de 64mg pero no la visualizo el hecho de que sea de ocho patillas y la del router contrem sea de 16 no importa pues son las dos spi y funciona identicamente eso si esta es de 128 mg, se podria intentar meter es firm haber que aporta ???

🗨️ 2
Ari

No, no he sido yo. Ha sido el compañero al que contesto que ni tan siquiera es el que ha empezado el tema, que es el que está haciendo las pruebas con ese firm ;)

Saludos

🗨️ 1
BocaDePez
BocaDePez

grs compañero por tu estundo trabajo y rapida respuesta,

pregunta crees que se puede adaptar este firmware de Dlink dsl 2750u a contrem ar5387un al ser identica placa base ???

BocaDePez
BocaDePez

Hola!!

He metido el firm directamente y se ha quedado frito!

Podrias ayudarme a recuperarlo?

Estoy tratando de conectarme de alguna manera por ssh con el putty, pero tp se que archivo subirle en caso de conseguirlo!

Muchas gracias!

🗨️ 5
Ari
1

No sé si has intentado el viejo método de recuperación, y si te estás refiriendo a qué firm subirle, pero en la wiki de BA, en la entrada para este router, tienes un firm oficial de Jazztel para el 5387 wiki.bandaancha.st/Comtrend_AR-5387un

Saludos

🗨️ 4
BocaDePez
BocaDePez

Hola

Gracias por tu respuesta.

Si te refieres al pulsar el boton del reset al arrancarlo durante 30 segs, acceder al 192... y meterle el archivo, no me deja. Responde al ping, pero no hace nada mas..

¿que otras maneras existen?

🗨️ 3
Ari
1

A mi alguna vez me ha pasado que no ha respondido, en principio, a ese método. A veces (eso sí, medía hora mínimo luchando con el router, sudando tinta en pleno mes de diciembre, y casi cargándome el botón de reset :P) he conseguido volverlo a la vida pulsando el botón de reset, mientras apago y enciendo el router de forma continuada, dejando un intervalo de un par segundos entre el apagado y el encendido.

Es un hard reset de los buenos y puede ser agotador, pero...a mi me ha funcionado en los casos más desesperados, menos en uno. Y me ha pasado más veces de las que me gustaría :)

Prueba así, y si no, tendrás que llamar a Jazztel y pedir uno nuevo :)

Saludos

🗨️ 2
BocaDePez
BocaDePez
🗨️ 1
Ari
1
BocaDePez
BocaDePez

Me podriais Conseguir El .BAT para cambiar IP automaticamente De este router?