Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

apt-get ya no me deja instalar nada

BocaDePez
BocaDePez

Llevo como una semana sin poder actualizar ni instalar nada con apt-get. Ejemplo:

# apt-get install vobsub2srt
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios aún no se han creado o se
han sacado de «Incoming».
La siguiente información puede ayudar a resolver la situación:
Los siguientes paquetes tienen dependencias incumplidas:
 gsettings-desktop-schemas : Rompe: gnome-settings-daemon (< 3.19.92) pero 3.14.2-3+deb8u1 va a ser instalado
                             Rompe: mutter (< 3.19.92) pero 3.14.4-1~deb8u1 va a ser instalado
E: Error, pkgProblemResolver::Resolve generó cortes, esto puede deberse a paquetes retenidos.

Parece que indica que existe conflicto de paquetería pero la verdad no sé cómo solventarlo. He probado con apt-get install -f sin resultado.

Utilizo Debian Jessie 8 Stable AMD64 bits.

rbetancor

Revisa como tienes la definición de los repos en /etc/apt/source.list

Puede que tengas las referencias como "stable" en vez de como "Jessie". La semana pasada se publicó Debian 9 y si tienes las referencias como "stable" tendrías que hacer un apt-get dist-upgrade para que pudieras resolver todas la dependencias nuevas y hacer el upgrade distro.

🗨️ 26
BocaDePez
BocaDePez

Muchas gracias, amigo. Era eso exactamente el problema: tenía dos repositorios referenciados con stable. Los cambié a jessie y he podido actualizar e instalar aplicaciones.

Por otra parte he probado lo que Vd. dice: he referenciado todos los repositorios a stable y sí, me aparecen unas 2,6 GB de paquetería Debian a instalar que supongo será la actualización a Debian 9, la nueva distribución Stable. Pero... no sé... Yo siempre he actualizado Debian desde cero (formateando e instalando con DVD-ROM). Tengo miedo a que ocurran conflictos graves que desbaraten el sistema y hagan perderse los contenidos del directorio del usuario, aplicaciones no compatibles, etc.

Un saludo y gracias de nuevo.

🗨️ 25
BocaDePez
BocaDePez

haz una copia y prueba

🗨️ 24
BocaDePez
BocaDePez

Bien. He actualizado a Debian 9 a través de apt-get, y aunque la instalación no ha indicado ningún error digno de reseñar, lo cierto es que al reiniciar el sistema ha pasado lo siguiente: me ha aceptado la contraseña de cifrado de la partición, después ha aparecido la pantalla de selección de usuario y contraseña; tras elegir mi usuario y escribir la contraseña, la pantalla parpadea y vuelve a la selección (como si no aceptara la contraseña, aunque no lo indica).

He pensado que podría ser algún problema con el controlador (Nvidia privativo) de la tarjeta gráfica y el controlador Nouveau. Así que accediendo al sistema a través del Recovery Mode he reinstalado el controlador, no sin antes indicarme el mismo que se habían producido algunos errores. El caso es que ahora ya no aparece entorno gráfico ninguno.

Por eso estoy escribiendo esto desde un USB-Live (Knoppix) mientras me descargo la imagen ISO de Debian 9 y así instalar desde cero.

Un saludo.

🗨️ 23
mceds
🗨️ 21
rbetancor
🗨️ 3
mceds
🗨️ 1
mceds
Serakon
pepejil
🗨️ 16
mceds
🗨️ 15
pepejil
🗨️ 14
rbetancor
🗨️ 7
mceds
🗨️ 5
rbetancor
🗨️ 4
mceds
🗨️ 3
rbetancor
🗨️ 2
mceds
🗨️ 1
rbetancor
pepejil
mceds
🗨️ 5
pepejil
🗨️ 4
mceds
🗨️ 3
BocaDePez
BocaDePez
🗨️ 2
pepejil
mceds
BocaDePez
BocaDePez

Debes de tener mal los supositorios.. digo, los repositórios.

BocaDePez
BocaDePez

siempre me dicen, windows malo pon linux...pero luego da mil problemas. yo quiero encender el pc y que lo haga todo el.

gracias, seguire como estoy

🗨️ 1
mceds

Es lo que tiene seguir consejos de imbéciles. Cada uno de los dos sistemas operativos tiene sus ventajas y sus inconvenientes, y han de ser explicados sin sectarismos. Si "encender el PC y que lo haga todo él" es tu principal prioridad, has escogido bien.