BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

apt-get dice que he retenido paquetes, pero no es cierto...

BocaDePez
BocaDePez

Estoy intentando actualizar Iceweasel (en Debian), pero apt-get dice que no es posible porque he retenido yo voluntariamente paquetes. Pero yo no recuerdo haberlo hecho:

usuario@debian:~$ sudo apt-get clean && sudo apt-get install -t experimental iceweasel
[sudo] password for usuario:
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios no han sido creados o han
sido movidos fuera de Incoming.
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
iceweasel : Depende: xulrunner-19.0 (>= 19.0-1) pero no va a instalarse
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.
usuario@debian:~$

Vaya, me he quedado en la versión 17.0 de Iceweasel. No puedo actualizar.

¿Cómo podría saber qué paquetes están retenidos y "soltarlos" o repararlos?

Muchas gracias.

Salud.

TLF

¿Qué te sale si pones "apt-get -f install"?

🗨️ 5
BocaDePez
BocaDePez

Me aparece lo siguiente, pero no está relacionado con Iceweasel, creo:

usuario@debian:~$ sudo apt-get -f install
[sudo] password for usuario:
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
0 actualizados, 0 se instalarán, 0 para eliminar y 5 no actualizados.
4 no instalados del todo o eliminados.
Se utilizarán 0 B de espacio de disco adicional después de esta operación.
Configurando libreoffice3.6-dict-an (3.6.0.4-104) ...

ERROR: unknown sub-command sync!
Use unopkg --help (short -h) to print all options.
ERROR: Registration of extensions failed!
dpkg: error processing libreoffice3.6-dict-an (--configure):
el subproceso instalado el script post-installation devolvió el código de salida de error 1
Configurando libreoffice3.6-dict-en (3.6.0.4-104) ...

ERROR: unknown sub-command sync!
Use unopkg --help (short -h) to print all options.
ERROR: Registration of extensions failed!
dpkg: error processing libreoffice3.6-dict-en (--configure):
el subproceso instalado el script post-installation devolvió el código de salida de error 1
Configurando libreoffice3.6-dict-es (3.6.0.4-104) ...

ERROR: unknown sub-command sync!
Use unopkg --help (short -h) to print all options.
ERROR: Registration of extensions failed!
dpkg: error processing libreoffice3.6-dict-es (--configure):
el subproceso instalado el script post-installation devolvió el código de salida de error 1
Configurando libreoffice3.6-dict-fr (3.6.0.4-104) ...

ERROR: unknown sub-command sync!
Use unopkg --help (short -h) to print all options.
ERROR: Registration of extensions failed!
dpkg: error processing libreoffice3.6-dict-fr (--configure):
el subproceso instalado el script post-installation devolvió el código de salida de error 1
Se encontraron errores al procesar:
libreoffice3.6-dict-an
libreoffice3.6-dict-en
libreoffice3.6-dict-es
libreoffice3.6-dict-fr
E: Sub-process /usr/bin/dpkg returned an error code (1)
usuario@debian:~$

Gracias por su respuesta.

Salud.

🗨️ 4
quilloquepasa
$ sudo dpkg --configure -a
$ sudo apt-get upgrade -f

Verifica no obstante los repositorios.

Saludos ;)

🗨️ 3
BocaDePez
BocaDePez

upgrade -f me arroja lo siguiente:

usuario@debian:~$ sudo apt-get upgrade -f
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Los siguientes paquetes se han retenido:
acroread-debian-files ia32-libs ia32-libs-gtk
0 actualizados, 0 se instalarán, 0 para eliminar y 3 no actualizados.

Pero, desde luego, yo no he retenido voluntariamente esos paquetes.

Si me dispongo a purgarlos, miren lo que me solicita:

usuario@debian:~$ sudo apt-get purge acroread-debian-files ia32-libs ia32-libs-gtk
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Los paquetes indicados a continuación se instalaron de forma automática y ya no son necesarios.
libfreeimage3 libraw5 lsb-core lsb-security pax ttf-liberation
Use 'apt-get autoremove' to remove them.
Los siguientes paquetes se ELIMINARÁN:
acroread* acroread-debian-files* acroread-escript* acroread-plugins*
googleearth* ia32-libs* ia32-libs-gtk* ia32-libs-xulrunner*
libwine-alsa-unstable* libwine-bin-unstable* libwine-capi-unstable*
libwine-cms-unstable* libwine-dbg-unstable* libwine-dev-unstable*
libwine-gl-unstable* libwine-gphoto2-unstable* libwine-ldap-unstable*
libwine-openal-unstable* libwine-oss-unstable* libwine-print-unstable*
libwine-sane-unstable* libwine-unstable* mozilla-acroread* nspluginwrapper*
skype* wine-bin-unstable* wine-unstable*
0 actualizados, 0 se instalarán, 27 para eliminar y 0 no actualizados.
4 no instalados del todo o eliminados.
Se liberarán 547 MB después de esta operación.
¿Desea continuar [S/n]?

¿Desinstalo todo lo que me pide?

Gracias.

Salud.

🗨️ 2
BocaDePez
BocaDePez