Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

hosting en interdominios
32 lecturas y 10 respuestas
  • Cerrado

    BocaDePez BocaDePez
    6

    Apache y 3Com: me vuelvo loco, lo juro

    Tengo montado un servidor con apache y no tengo cojones a redireccionar el puerto 80 del router a la máquina, siempre me sale la página de configuración del router.

    He probado a desactivar los remote sites (algo había leído), pero eso lo único que hace es tumbarme la conexión. ¿Alguien me puede echar una mano? ;-)

    Este tema es antiguo y puede contener información obsoleta. Abre un nuevo tema para publicar tu mensaje.
    1
    • Cerrado

      BocaDePez BocaDePez
      6

      Mira el problema es que al redireccionar el 80 a tu servidor…

      Mira el problema es que al redireccionar el 80 a tu servidor , eso solo no funciona, ya que el router necesita un puerto 80 que le estas quitando, para ello añade un puerto por ejemplo el 8080 a la IP privada de tu ROUTER y luego el 80 a tu servidor web. una vez puesto te explico, esto lo has de hacer exactametne como te digo:

      desactivas reemote sites, le das a modificar
      TE ESPERAS A K SE CARGUE LA PAGINA(MIRA LA BARRITA INFERIOR)

      activas remote sites y das a modificar
      TE ESPERAS A K CARGUE,

      y ya debe ir ( YO lo tengo asi).

      Si va, no te va o cualquier cosa, mandame un mail a jordy@telefonica.net y si va pues bien , si no va pues te mando imagenes de lo mio ok? saludos

    • Cerrado

      Cuando dices que metes tu ip, lo haces desde dentro de la red…

      Cuando dices que metes tu ip, lo haces desde dentro de la red local? Creo que deberias probar desde fuera xq si es asi es desde dentro es normal que te responda el router. Desde dentro de la red local deberias usar la direccion local del router.

      Si tienes un dominio comprado y quieras ver el servidor local desde dentro de la red poniendo ese dominio como url (por ejemplo para probar los vhost del apache), puedes hacer 2 cosas, una es tocar el fichero host del windows, la otra que yo uso es usar el router como dns y añadir una entrada estatica.

      En la config del router te vas DNS y activas sobre ENABLE DNS. En las 2 casillas de abajo pones las dns que usas habitualmente en el ordenador.
      Y luego pinchas sobre static dns y le das a add.
      Alli pones el dominio que quieras y la ip local de la maquina con apache.

      Creo que para que esto funcione tienes que reiniciar el router.

      Luego en el ordenador solo tienes que poner como servidor dns la ip local del router.

      Si tambien te pasa desde fuera de la red local, creo que tienes que reiniciar el remote site para que los cambios tengan efecto, no lo se seguro, pero lo puedes intentar. Una vez dentro del remote site en cuestion, arriba la primera casilla pone:

      - Enable remote site

      Pues la desactivas y pinchas modificar.

      Luego la activas y vuelves a modificar.

      *Creo que la principal conclusion es que para probar si funciona deberias mirarlo desde fuera de la red y reiniciar el remote site (no se si reiniciar es la palabra mas adecuada pero bueno).

      No se si ha quedado muy claro, creo que no xq me suelo explicar muy mal... pero si quieres alguna aclaracion no dudes en decirlo.

        • Cerrado

          [Editado 11/09/04 00:00]

          xq te hemos dicho un par de veces que no lo pruebes desde…

          xq te hemos dicho un par de veces que no lo pruebes desde dentro de la red local...

          a mi me funciona bien... la pagina tarda un huevo en cargar pero carga (fondo negro, seguro que no es el router ;D )

          bueno... ahora mismo no carga nada... pero la web del router tampoco...

    • Cerrado

      BocaDePez BocaDePez
      6

      Tengo el apache montado y funcionando, y tengo que…

      Tengo el apache montado y funcionando, y tengo que redireccionar el puerto 80 del router al servidor. La redirección ya la he creado en Remote sites > TCP Ports, pero como el que tiene tos y se rasca los cojones. Cuando meto mi ip me sale la web de configuración del router, no el servidor.

      ¿Qué más hay que hacer? Gracias! :)

      • Cerrado

        pues eso, nada del otro mundo, si la pruebas desde fuera de…

        pues eso, nada del otro mundo, si la pruebas desde fuera de tu red entonces si que te funcionara. Siempre que lo hagas dentro de la red te aparecera la pagina de configuracion del router. Si quieres probar a ver si te funciona desde tu red tendras que hacer que un ordenador fuera de tu red lo compruebo (p.e. un proxy). Asi que busca un proxy en el google que te permita navegar.

        Un saludo.