Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

amule

BocaDePez
BocaDePez

bueno estoy utilizando amule en linux, no se si en emule de window puede ocurrir lo mismo, a mi hasta ahora no me habia ocurrido esto

Se tratra de que agrego ficheros para descargar y todo bien, hasta que cierro el amule, cuando lo reinicio han "desaparecido" estos ficheros. Alguna vez todos, otra solo algunos de ello.
Pense que serian los que todavia no habian descargado nada, pero no es asi, tambien los que llevan algunos bytes descagados ya.
La verdad es que estoy desesparado y no se por que
Me podriais ayudar?

He ejecutado amule desde consola para ver los mensajes de salida.
Después he agregado a la lista de descargas la película "La naranja mecánica". Al hacerlo, la consola ha mostrado lo siguiente:

ERROR salvando archivo part: Failed to open part.met file (020.part.met ==> La.n aranja.mecanica.[DvDRip-Spanish].[XviD+Mp3].by.SDG.avi)
ERROR salvando archivo part: Failed to open part.met file (020.part.met ==> La.n aranja.mecanica.[DvDRip-Spanish].[XviD+Mp3].by.SDG.avi)
ERROR salvando archivo part: Failed to open part.met file (020.part.met ==> La.n aranja.mecanica.[DvDRip-Spanish].[XviD+Mp3].by.SDG.avi)

Después, con la película en la lista (que a pesar del error sí se ha agregado a la lista), he cerrado amule. Esto es lo que me ha devuelto la consola:

Shutting down aMule...
aMule dialog destroyed
Now, exiting main app...
aMule OnExit: Terminating core.
Saving PartFile 56 of 170ERROR salvando archivo part: Failed to open part.met fi le (020.part.met ==> La.naranja.mecanica.[DvDRip-Spanish].[XviD+Mp3].by.SDG.avi)
Saving PartFile 170 of 170
All PartFiles Saved.
aMule shutdown completed.

Cuando he vuelto a abrir amule la película ya no estaba en la lista (normal, no se había salvado su part)
Después he probado a reinstalar amule con:

sudo apt-get remove amule
sudo apt-get install amule

Pero sigue ocurriendo lo mismo ¿A alguien se le ocurre algo?

Este tema está cerrado a nuevas respuestas. Abre un nuevo tema para retomar la conversación.
CopyCAT79

No es problema del aMule, es problema del disco duro o del acceso al disco duro.
Prueba de verificar los permisos del disco duro o fallos en el mismo.

Suerte :)

🗨️ 2
BocaDePez
BocaDePez

La partición donde está la carpeta Temp es una partición ntfs con el driver instalado y configurado. He probado a crear y borrar un fichero dentro de la carpeta Temp y me deja hacerlo. Además, la partición tiene 50 Gigas libres.
En cuanto a fallos, no he visto nada anormal en su funcionamiento excepto eso...

La verdad es que no tengo ni idea de lo que es, los demás ficheros que tenía en la lista de descarga siguen descargándose. Son más de 150, lo sé, pero he llegado a tener muchos más sin este tipo de problema...

BocaDePez
BocaDePez

Bueno, tengo nuevos datos. Directamente me he pasado a consola. Es que me he fijado que cuando intento agregar un fichero nuevo, amule siempre me intenta crear el fichero 020.part.met, que es el primer xxx.part.met que no está siendo usado por otro archivo. Me he ido a consola a intentar crear el fichero manualmente:

$ > 020.part.met
bash: 020.part.met: Input/output error

Sin embargo, sí puedo crear el siguiente (hasta el 024 están todos libres)

$ > 021.part.met
$

Así que es muy raro, pero el problema va por ahí, no creo que sea nada de amule...

¿Alguien puede echarme una mano?

jmoraf

no creo que sea el caso, pero en el SO tambien hay un máximo de ficheros abiertos (enlace)