BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

Instalar Linux en Toshiba Satellite Z30 con disco duro NVMe

Solospam

Quisiera saber cuál es el método para actualizar la BIOS de un portátil desde el archivo .bin en vez de usar el .exe que viene para Windows.

Se trata de hacer un downgrade para poder instalar Linux en un Toshiba Satellite Z30 con este NVMe.

vukits

es cuanto menos peligroso…

yo he llegado a instalar un sistema operativo antiguo, con tal de poder actualizar la BIOS.

¿estás dispuesto a romper el portátil?

🗨️ 8
Solospam

¿estás dispuesto a romper el portátil?

Está claro que no… xD

🗨️ 1
vukits

pues si el .exe no funciona en tu S.O. actual, toca instalar uno más antiguo. (o el recomendado, vaya)

Solospam

Es para hacer un downgrade, siempre puedo probar en windows xp si me deja ejecutar el .exe y cambiar la bios… creo que en versiones antiguas de la bios venía la opción "AHCI" y en la actual no aparece… por lo que no puedo instalar Linux en ese portatil

🗨️ 5
vukits

la opción "AHCI" y en la actual no aparece… por lo que no puedo instalar Linux en ese portatil

quieto parao… ¿No has pensado en que la opción AHCI no aparece, porque ya sólo funciona en modo AHCI?

¿qué error te da el instalador Ñu/Linux? … hay muchas maneras de hacer una ñapa

🗨️ 4
Solospam

ilustrame! he intentado de to y no me reconoce el m2 sata de ninguna forma

🗨️ 3
vukits
🗨️ 2
Solospam
🗨️ 1
vukits
superllo

¿Y arrancando un Windows con el que viene en el Hirens Boot CD (XP en el antiguo, 10 en el nuevo) y viéndolo todo desde USBs?

🗨️ 2
Solospam
1

Dices de ejecutar la bios en un windows live?

🗨️ 1
superllo

Vale, que te han cambiado el título, en un principio solo decías de actualizar la BIOS, nada de downgrade. Te decía de que si en Linux no podías utilizar el actualizador oficial lo hicieras desde un Windows ejecutándose desde un LiveUSB.

Solospam

Según pdfmanuales.com/manuals/489312/toshiba-s…tml?page=135

En la pantalla de Utilidad TOSHIBA Setup, seleccione Advanced →System Configuration → Boot Mode → UEFI Boot (Arranque UEFI -predeterminado-)

Si establece el modo de arranque como CSM Boot (arranque CSM), el soporte de recuperación creado por Recovery Media Creator NO podrá realizar la restauración.

La actual bios no trae esa opción, y creo que si pongo "CSM Boot" activo si podré instalar Linux en el PC

🗨️ 24
vukits

ÑU/Linux hace tiempo que soporta arranque UEFI.

el Z30 está soportado por Arch Linux, y por extensión por Manjaro Linux

¿qué paso de la instalación de Manjaro Linux te falla, p.e.?

🗨️ 23
Solospam

He intentado instalar Debian y no me reconoce el disco duro… no he intentado instalar manjaro y mucho menos arch Linux ya que no se usarlos

🗨️ 4
vukits

Manjaro es bastante facilito y bonito y bueno.

(yo soy de Debian… pero bueno… son cosas mías :P )

🗨️ 2
Solospam
🗨️ 1
vukits
Erundino

Hola, si no te reconoce el disco duro podría servirte el procedimiento descrito en este link

Pido a todos disculpas ya que es mi primer mensaje logueado y aún no domino medianamente el editor de texto de los mensajes. Al usuario, que tengas suerte y no necesites flashear nada. Saludos.

Solospam

La versión actual me desactiva y preselecciones "UEFI boot" y no me deja seleccionar la otra opción que es la que me dejaría instalar Linux

photo5956214857902700277.webp
🗨️ 17
vukits

Linux soporta ambos modos legacy, y UEFI.

da igual cuál está puesto, debería poder instalarse.

🗨️ 14
Solospam
🗨️ 5
vukits
🗨️ 4
Solospam
🗨️ 3
vukits
🗨️ 2
nosoynadie
1
🗨️ 7
Solospam
🗨️ 6
vukits
🗨️ 4
Solospam
🗨️ 3
vukits
🗨️ 2
Solospam
🗨️ 1
vukits
vukits

porfa, pon captura de todas las secciones de BIOS. a lo mejor vemos algo interesante.

(fijate que la bios tiene una barra de desplazamiento)

🗨️ 1
Weikis336
1

Ten a mano una programadora de bios por si las moscas. Y ser lo suficientemente hábil con esos temas para rescatarla en caso de no rodar bien el invento

Maik-Spynet
3

Yo te mando un crucifijo, para que empieces a rezar y la cosa no se vuelva un pisapapeles. Mucho ánimo y nos cuentas.

Black Hole
1

A ver… dices por ahí arriba que el portátil tiene 5 años y necesitas meter una BIOS anterior para instalar un Linux ¿porque no te reconoce el NVMe?

¿No te das cuenta tú mismo que lo que dices no tiene ni pies ni cabeza? Si el Linux no te reconoce el hardware, ¿por qué va a hacerlo con una BIOS menor que la actual?

Antes de ponerte a (quizás) joder el equipo, ¿no deberías comentarnos qué sistema intentas instalar? ¿No será que ese Linux tiene un núcleo demasiado antiguo?

🗨️ 5
lhacc
-2

Este usuario es viejo conocido del foro. Desprende de esa frase lo que quieras.

🗨️ 1
Black Hole

Cierto, lo sé. Tal vez yo soy muchísimo más antiguo. ¿Acaso eso tiene algo que ver?

vukits

estamos en ello, estamos en ello.

🗨️ 2
Black Hole

Si está intentando instalar una Arch o un derivado como Manjaro, ese sistema se estrellaría si tiene habilitado por casualidad arranque seguro. Pero claro, también Manjaro es una "rolling release" y no sé si está usando la última del 3 de Enero o una anterior. Porque yo uso en mi equipo un Kernel 5.15.12 y reconoce mi NVMe… pero no es que sea algo nuevo, lo reconoce desde hace más de 1 año cuando estaba el Kernel 5.11, pero como Solospam ha empezado a hablar de Debian y sabemos que Debian no está precisamente a la última, pues de ahí la pregunta.

🗨️ 1
vukits

arranque seguro.

@Solospam, ¡desactiva el arranque seguro en la BIOS!… no sirve de gran cosa y sólo molesta.

PD: yo he tenido un Fedora que sí que funcionaba… per es verdad que aqui comentan que deshabilite

EmuAGR
3

Para el carro: Una BIOS jamás se downgradea por el motivo que citas. Probablemente estás intentando instalar un Linux aún más antiguo que el PC si no te reconoce el NVMe.

O… existe la posibilidad de que el NVMe esté funcionando en modo Intel Rapid Storage Technology (RST) como caché del HDD. A mí me venía un MSI en ese modo, y al intentar instalar SO no aparecía el disco en Linux.

🗨️ 1
Solospam

Debian 11.2 es lo que intento instalar…

BocaDePez
BocaDePez
  1. En el OP dices que es un NVMe sin embargo en un comentario dices que es M.2 SATA. Además en internet veo que utiliza mSATA que es parecido pero no es lo mismo. Y si no recuerdo mal por diseño mSATA no encaja en M.2.
  1. Es posible que el fabricante haya puesto el conector M.2 para ahorrar costes en toda la serie pero no esté activado en el chipset o físicamente (ya que son placas base propietarias) por lo tanto por mucho que actualizaras (no downgradearas) la BIOS no funcionaría nunca a no ser que el fabricante lo activara.
🗨️ 2
vukits

he estado editando el mensaje.

lo que está enlazado de disco de Amazon, ¿es msata o NVME? (o lo que sea: estoy bastante desactualizado)

🗨️ 1
Black Hole

El Western Digital Black SN850 es un módulo SSD NVMe. No solo eso, sino que además es PCI Express 4.0 y si el procesador y el chipset son compatibles PCI Express 4.0 (en Intel la 11ª y 12ª generaciones, y en AMD los Ryzen series 3000 y 5000) pues encima irá al doble de rápido que en un bus PCIe 3.0, llegando a la nada desdeñable cifra de 7000 MB/s

Artículo sobre formatos SSD con fotos de los conectores: https://www.pcpepper.com/sata-vs-msata-vs-ngff-m-2-vs-nvme-pcie-m-2-which-is-the-right-ssd-for-me/

Si el M.2 fuese SATA, tendría muescas en el lado opuesto, haciendo físicamente imposible meter un PCIe (NVMe), así que Solospam tiene los conceptos muy equivocados.

Black Hole

Si dices que el Windows instalado en ese equipo sí te está reconociendo el SSD NVMe de 1 TB sin problemas, ¿podrías pegar desde un Live de Linux con un núcleo suficientemente moderno (Manjaro 21.2.1 con kernel 5.15 o al menos Ubuntu 21.10 con kernel 5.13) la salida del comando lspci y del comando hwinfo --storage --disk (tal vez necesites instalarlo)?

11onzas

No debieras tener problemas con el toshiba.

Así instalo yo Mint en los nvme

  • En la BIOS desactiva Secure boot
  • Procede con la instalación
  • Elige crear tu las particiones
  • (importante) Crea una partición par el boot de 100 MiB en fat32 (punto montaje en /boot/efi)
  • Crea el resto de particiones que necesites
  • Lanza la instalación
🗨️ 4
Solospam

No me reconoce el disco duro…

🗨️ 3
11onzas

Has probado con Gparted ?

🗨️ 2
Solospam

He probado con el particionador del instalador de debian

🗨️ 1
11onzas
Nombre de usuario
1

Actualiza a la ultima BIOS, carga opciones por defecto.(Linux tiene soporte de UEFI/GPT y Secure Boot)

Tambien puedes verificar si hay actualizacion del firmware del disco NVMe.

Y prueba una distribucion con paquetes recientes, como Fedora: dl.fedoraproject.org/pub/alt/live-respins (WORK es Gnome)

Si no funciona eso, olvidate de Linux.

🗨️ 3
Solospam

Actualiza a la ultima BIOS, carga opciones por defecto.(Linux tiene soporte de UEFI/GPT y Secure Boot)

Está la última bios instalada

Y prueba una distribucion con paquetes recientes, como Fedora: dl.fedoraproject.org/pub/alt/live-respins (WORK es Gnome)

No se que tiene de malo debian 11.2 para probar que no detecta el disco duro y manjaro tampoco lo detecta

🗨️ 2
EmuAGR

A Debian le pasa que no trae drivers propietarios por defecto. En portátiles resulta un dolor de cabeza supremo. No deberían ser necesarios para el disco duro, pero a saber.

🗨️ 1
Solospam

Pero ubuntu si trae drivers propierarios y tampoco me deja instalarlo

skgsergio

Pregunta así empezando por lo básico… ¿Ese NVMe ha funcionado alguna vez en ese ordenador? En la BIOS/EFI suele haber algún sitio donde aparecen los discos, ¿aparece?

🗨️ 7
Solospam

Ese NVMe tiene windows instalado, en ningún sitio de la bios se hace referencia a él

🗨️ 6
skgsergio
1

Pues por todo lo que comentas no es un tema de boot en UEFI o Legacy, con secure boot o sin el… Tiene todos los sintomas que está el disco en modo RST/Optane/RAID y por eso no lo detecta… pero en algún sitio deberia venir la opcion.

Si te arranca Windows echa un ojo en el administrador de dispositivos, en controladores de almacenamiento y mira si te sale cargado algo de Controlador RST, o si por lo contrario sale el de NVM Express.

🗨️ 5
Black Hole
1

Un Linux que no soportase arranque seguro, como Arch y Manjaro, ni siquiera arrancaría el Live. Saldría un mensaje en modo texto impidiéndolo.

Ubuntu sí lo conseguiría a través de un controlador SHIMX64.EFI firmado por Microsoft específicamente para Canonical. No sé si también Debian tendría algo parecido.

Pero si no sale la interfaz /dev/nvme0 desde el Live podría ser porque esté en otro modo, Intel Rapid Storage o RAID como apuntas. Sin embargo no aparece nada parecido en las capturas de los menús de la BIOS que @Solospam proporcionó ayer. Una UEFI muy espartana, típica de ordenadores de marca. De todo lo presente, el único concepto que suena a estar relacionado es el de "SATA Interface Setting" que está puesto en "Performance", pero tampoco he visto algo parecido en otros equipos. Si tiene Intel Smart Response, el RAID está oculto.

🗨️ 3
vukits
skgsergio
🗨️ 1
Solospam

Este post se me pasó… mis disculpas

BocaDePez
BocaDePez
1

Hola.

Por el P/N me sale que es un Toshiba Satellite Z30-C-10K (tiendatoshiba.es/portatiles/2368-toshiba…8229882.html), el cuál también sale con el S/N desde la web de soporte de DynaBook (es.dynabook.com/support/consumerlaptops).

En las especificaciones técnicas pone que el disco que lleva, al menos de fábrica, parece ser un SSD M.2 de 128 GB, pero no indica si es SATA (generalmente tiene dos muescas) o PCIE (generalmente tiene una muesca).

Lo más parecido que he visto en la captura del lsblk de más arriba es el dispositivo que nombra como /dev/mmcblk0, que, en teoría, se debería corresponder a una tarjeta de memoria, ya que los NVME deberían aparecer nombrados como /dev/nvmex (con x=0,1,2,…).

El /dev/sda es desde donde se está ejecutando el Live de Manjaro, así que voy a suponer que es un dispositivo de almacenamiento USB.

Respecto a la "BIOS" (realmente es una UEFI), y teniendo en cuenta que hablamos de SSD (sea en formato M.2 u otro), mi recomendación sería ponerlo todo en UEFI y desactivar el Secure Boot.

No todas las distros Linux tienen soporte para Secure Boot y, salvo que se quiera usar Windows 11 sin tocar el registro o similar para deshabilitar ese requisito, tampoco es que sea necesario tenerlo activo.

Luego hay que formatear el disco en modo GPT y crear una partición de 256-512 MB en FAT32 para la partición EFI (el equivalente al MBR en el modo BIOS antiguo), la cual, en el caso de Linux, debe ser montada en /boot/efi. GParted sería mi recomendación para esta parte, aunque desde cualquier instalador (sea Windows o Linux) se puede hacer (lo del GPT no directamente en el caso de Windows, hay que usar diskpart).

Por el kernel que lleva Debian 11.2 no debería haber problemas con los NVME, con lo que mi sospecha es más bien de hardware, que ese WD no sea compatible con el equipo… que la controladora M.2 sea sólo SATA, por ejemplo. Si fuera ésto espero que no te hayas cargado nada eléctricamente.

Unas foto del SSD de 128 GB no vendrían mal, sobre todo de la zona de conectores. Y lo ídem del conector del SSD en el portátil.

Un saludo.

🗨️ 2
EmuAGR

Si le funciona con Windows no es problema de hardware. O es problema de configuración de BIOS/EFI o que el Debian 11.2 no se traga ese portátil por algún motivo.

🗨️ 1
Black Hole
1

El motivo parece apuntar a que todos los portátiles Toshiba modernos trabajan internamente con Intel Rapid Storage Technology (RST), que por ahora es incompatible con Linux y la UEFI es rara y no parece haber claramente un parámetro para desactivarlo. Aunque se han sugerido y preguntado varias cosas y Solospam no ha confirmado ninguna de ellas.

Además, habría que modificar Windows 10 para que siguiese funcionando sin tener que reinstalarlo, como apuntan en https://help.ubuntu.com/rst/, pero claro, antes que nada hay que averiguar cómo desconectarlo.

BocaDePez
BocaDePez
1

¿Y añadiendo de forma manual en el Grub del instalador de Debian el parámetro nvme_load=yes? (opción tecla "e" en el instalador).

Y si funcionara así creo que habría que añadir dicho parámetro de forma permanente en el /etc/default/grub y hacer un update-grub una vez instalado.

🗨️ 1
Black Hole

Ese parámetro se necesitaba en algunos núcleos de la serie 3, desde que apareció el soporte NVMe en el kernel 3.3, porque no siempre se detectaba la controladora NVMe y había que forzar la carga del módulo dinámico nvme.ko (los módulos dinámicos no se cargan en RAM si no se necesitan). Pero estaríamos hablando del año 2015, porque ya a mediados aparecieron los núcleos de la serie 4 que no precisaban de dicho "parche" en el Grub. Todas las distribuciones Linux que Solospam ha probado llevan núcleos de la serie 5, incluso el Debian 11.2 lleva un núcleo 5.10 que es de Diciembre de 2020 y ya tiene un añito, así que si no lo encuentra es que no existe un Block Device con dicha tecnología. Probablemente porque esté enmascarado tras un RAID interno de su controladora.

Solospam

Buscando info por internet me doy cuenta de que

imagen.webp

Y resulta que "RST" es incompatible con Linux, será que definitivamente este cacharro no va a poder instalar Linux de ninguna manera?

🗨️ 11
Black Hole

Pero si es lo que te venimos diciendo 2 días, que a ver si encuentras alguna opción de la UEFI para desactivar RST. ¿Lees nuestras respuestas?

🗨️ 7
Solospam

Si os leo, pero leer y entender no es lo mismo… no hay opciones en la bios para desactivar RST, puse todas las opciones de bios en este mismo hilo

🗨️ 6
Black Hole

Pregunta, no mordemos. Ya vi todas las pantallas y no había ninguna mención esplícita a RST, por eso sugerí que cambiases el parámetro SATA Interface Setting, a ver qué pasaba, a ver si arrancaba Windows 10 o daba un pantallazo azul (señal de que se habría desactivado) y puse un enlace para cómo cambiar después Windows 10 desde RST a AHCI. Pero lo crucial es averiguar cómo desactivar RST, porque la BIOS es rara y tal vez tuviese más combinaciones de teclas escondidas como ese CTRL+S

🗨️ 5
Solospam
🗨️ 4
Solospam
1
🗨️ 2
PANQUEMAO

No te gusta Hiper-V de Win 10 - 11? Ciertos distros los maneja muy bien, aislados del SO de MS.

🗨️ 1
Solospam

Pero come recursos, lanzar una VM desde el portatil aunque lo soporte no van muy finas…