BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

🗞️

El acceso a github lleva 5 días sin funcionar desde Movistar y no hay solución a la vista.

PezEnLaBoca

Al no poder acceder a raw.githubusercontent.com desde la red del trabajo (Movistar), he buscado y he visto que en

el foro de Movistar se comenta que lleva sin funcionar desde el jueves y sigue sin funcionar después de 5 días.

Desde casa (Digi) se accede sin ningún problema.

Nyare

A mi me funciona desde Movistar. Quizas solo afecte a una región o rango de IP origen concretos.

Por cierto, he comprobado un registro de una aplicación que conecta contra github.com y el día 6 conectó sin problemas. Lo mismo durante los ultimos días contra api.github.com

🗨️ 1
PezEnLaBoca

Con api.github.com tampoco había problema, el problema era con raw.githubusercontent.com y github.io. De hecho lo que me fallaba era un script que comprueba la versión con api.github.com y, si ve que hay una actualización, descarga desde raw.githubusercontent.com y esa parte llevaba sin funcionar desde el jueves.

Solospam

A mi me funciona desde o2

imagen.webp

Saludos

🗨️ 1
PezEnLaBoca

github.com funcionaba incluso antes, el fallo era de otras paginas de github (en mi caso se trataba de raw.githubusercontent.com, otros usuarios han reportado fallos de github.io, etc.).

PezEnLaBoca
1

A los 5 minutos de enviar el mensaje ya funcionaba, pero ha estado 5 días sin funcionar y la respuesta del equipo Movistar en su foro ha sido lamentable.

A mi no me ha afectado demasiado, pero hay gente que se ha visto muy perjudicada y me ha extrañado no encontrar nada en portada (creo que github que no funciona, edit: por lo menos parcialmente, 5 días merece la portada).

🗨️ 4
rbetancor
1

Ha estado funcionando perfectamente. Puede que el problema fuera exclusivamente desde ciertas direcciones o ciertas cuentas.

Usamos intensamente raw.githubusercontent.com y no hay ningún registro de errores de conexión desde hace meses.

El equipo de Movistar, con verificar que se trata de una paja mental de alguno, tiene de sobra, no tiene que andar emitiendo un informe a los cuatro vientos sobre … "a nosotros si nos funciona".

No están para ver si a la gente le funciona o no un servicio de terceros.

🗨️ 3
PezEnLaBoca
1

Revisa el hilo que he enlazado, era un problema en su enrutamiento, no en un "servicio de terceros" y sí están (o deberían estar) para comprobar que su red funciona. Que la dejen sin funcionar 5 días, aún que sea solo para determinadas zonas, no es ninguna paja mental.

🗨️ 2
rbetancor

Github, es un AS completo, "no peta la ruta al servidor de RAW", peta el acceso a github completo (que ya ha pasado otras veces).

Nosotros usamos intesamente github y como ya comenté no ha habido ningún problema de acceso, ni desde líneas Movistar, ni Orange, ni VF.

Del hilo que enlazas, lo único que saco en claro, es que la gente se pone repetir lo mismo una y otra vez, sin tener ni pajolera idea de lo que están haciendo. Y que se ve a mucha peña trabajando desde conexiones residenciales exigiendo un SLA que no tienen en sus contratos por ningún lado.

Puede que fuese un bucle en un par de routers, pero desde luego no afectó a TODA la red de Movsitar y O2.

🗨️ 1
Skid Row
1

Comprobado desde Movistar ahora mismo y acceso OK.

Sigo algún proyecto y no es que me conecte a diario, pero casi, no noté ningún fallo en las 2 últimas semanas.

PezEnLaBoca

Gracias, no lo había visto (normalmente solo sigo la portada y el foro Digi, se ve que solo merecen la portada algunos fallos masivos y no otros).

🗨️ 2
Josh

Llego hasta donde me permiten mis conocimientos. Investigué el tema pero pocas conclusiones saqué.

🗨️ 1
PezEnLaBoca

La conclusion es que Movistar tiene un problema (o por lo menos lo tienen los usuarios de Barcelona que necesitan acceder a github y otros sitios) y lleva ya 6 días sin solución. En el caso de Digi un fallo de pocas horas (que, por cierto, a mi no me afectó para nada) llegó a portada en un abrir y cerrar de ojos.

Ojo, no lo digo como reproche, lo digo porque ver el fallo en portada me sirve para determinar si es un problema puntual de mi linea o algo generalizado.

pjpmosteiro

Pues yo…debe ser cosa de un enrutador jodido, porque desde coruña tengo acceso… Raro.

Habia otro hilo que lo comentaba tambien.

kotBegemot
1

Tiene toda la pinta de ser un problema en la CDN de GitHub.

Ante este tipo de problemas, lo primero es ver que IP te resuelve en los casos en los que funciona y cuál en los casos que no.

Probablemente el DNS de la CDN te está localizando en otra red y te manda a un servidor que no está enrulado en la red en la que estás.

Mantener un CDN es algo muy complicado. Y cuánto más pequeña sea esta, más difícil es que lo sepa todo sobre los casos de cada región.

Probablemente lo hayan arreglado porque en las diferentes páginas que sirven tienen sondas para ver el comportamiento y hayan tenido un pico de errores que les ha puesto sobre la pista.

🗨️ 1
PezEnLaBoca

En todo caso la(s) IP(s) que no funcionaban desde el trabajo y sí desde casa eran las mismas (que tampoco quiere decir nada ya que con anycast pueden estar en ubicaciones distintas).

Sigo creiendo que el problema estaba en Movistar: dudo que github tardase 5 días en enterarse.

rafacab1

Yo ya lo comenté en el otro hilo que hay que ya han mencionado, en mi caso, con O2, puedo acceder pero hay veces que tarda un montón e incluso llega a dar timeout, pero una vez carga funciona sin problemas.

PezEnLaBoca

Vuelve a fallar, ya van 6 días.

$ ping -c 1 api.github.com
PING api.github.com (140.82.121.6) 56(84) bytes of data.
64 bytes from lb-140-82-121-6-fra.github.com (140.82.121.6): icmp_seq=1 ttl=42 time=36.2 ms
--- api.github.com ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 36.201/36.201/36.201/0.000 ms


$ ping -c 1 raw.githubusercontent.com
PING raw.githubusercontent.com (185.199.109.133) 56(84) bytes of data.
From 241.red-81-46-7.customer.static.ccgg.telefonica.net (81.46.7.241) icmp_seq=1 Time to live exceeded
--- raw.githubusercontent.com ping statistics ---
1 packets transmitted, 0 received, +1 errors, 100% packet loss, time 0ms

$ traceroute raw.githubusercontent.com
traceroute to raw.githubusercontent.com (185.199.109.133), 30 hops max, 60 byte packets
 1  _gateway (192.168.90.1)  0.321 ms  0.416 ms  0.384 ms
 2  206.red-81-46-38.customer.static.ccgg.telefonica.net (81.46.38.206)  10.542 ms  10.517 ms  10.525 ms
 3  161.red-81-46-44.customer.static.ccgg.telefonica.net (81.46.44.161)  5.133 ms  5.112 ms  5.012 ms
 4  29.red-81-46-45.customer.static.ccgg.telefonica.net (81.46.45.29)  4.783 ms  4.649 ms  4.588 ms
 5  46.red-80-58-81.staticip.rima-tde.net (80.58.81.46)  4.456 ms  4.503 ms  4.534 ms
 6  81.red-81-46-0.customer.static.ccgg.telefonica.net (81.46.0.81)  4.270 ms  3.723 ms  3.676 ms
 7  241.red-81-46-7.customer.static.ccgg.telefonica.net (81.46.7.241)  4.496 ms  4.801 ms  4.977 ms
 8  51.red-81-46-0.customer.static.ccgg.telefonica.net (81.46.0.51)  5.536 ms  5.585 ms  5.476 ms
 9  50.red-81-46-0.customer.static.ccgg.telefonica.net (81.46.0.50)  4.808 ms  5.359 ms  5.268 ms
10  241.red-81-46-7.customer.static.ccgg.telefonica.net (81.46.7.241)  6.209 ms  6.550 ms  4.609 ms
11  51.red-81-46-0.customer.static.ccgg.telefonica.net (81.46.0.51)  4.083 ms  5.938 ms  7.311 ms
12  50.red-81-46-0.customer.static.ccgg.telefonica.net (81.46.0.50)  4.585 ms  5.480 ms  5.888 ms
13  241.red-81-46-7.customer.static.ccgg.telefonica.net (81.46.7.241)  7.784 ms  7.771 ms  3.597 ms
14  51.red-81-46-0.customer.static.ccgg.telefonica.net (81.46.0.51)  4.485 ms  4.834 ms  5.073 ms
15  50.red-81-46-0.customer.static.ccgg.telefonica.net (81.46.0.50)  4.842 ms  5.645 ms  5.782 ms
16  241.red-81-46-7.customer.static.ccgg.telefonica.net (81.46.7.241)  6.522 ms  6.159 ms  5.701 ms
17  51.red-81-46-0.customer.static.ccgg.telefonica.net (81.46.0.51)  6.430 ms  5.064 ms  4.958 ms
18  50.red-81-46-0.customer.static.ccgg.telefonica.net (81.46.0.50)  4.103 ms  4.825 ms  4.993 ms
19  241.red-81-46-7.customer.static.ccgg.telefonica.net (81.46.7.241)  5.719 ms  4.708 ms  4.611 ms
20  51.red-81-46-0.customer.static.ccgg.telefonica.net (81.46.0.51)  5.415 ms  4.901 ms  4.845 ms
21  50.red-81-46-0.customer.static.ccgg.telefonica.net (81.46.0.50)  3.759 ms  3.711 ms  4.431 ms
22  241.red-81-46-7.customer.static.ccgg.telefonica.net (81.46.7.241)  4.117 ms  4.132 ms  4.327 ms
23  51.red-81-46-0.customer.static.ccgg.telefonica.net (81.46.0.51)  4.927 ms  6.782 ms  6.735 ms
24  50.red-81-46-0.customer.static.ccgg.telefonica.net (81.46.0.50)  5.869 ms  4.706 ms  4.851 ms
25  241.red-81-46-7.customer.static.ccgg.telefonica.net (81.46.7.241)  4.911 ms  4.978 ms  5.072 ms
26  51.red-81-46-0.customer.static.ccgg.telefonica.net (81.46.0.51)  4.182 ms  4.784 ms  4.707 ms
27  50.red-81-46-0.customer.static.ccgg.telefonica.net (81.46.0.50)  3.646 ms  3.852 ms  3.741 ms
28  241.red-81-46-7.customer.static.ccgg.telefonica.net (81.46.7.241)  3.659 ms  4.206 ms  3.916 ms
29  51.red-81-46-0.customer.static.ccgg.telefonica.net (81.46.0.51)  4.682 ms  5.349 ms  5.709 ms
30  50.red-81-46-0.customer.static.ccgg.telefonica.net (81.46.0.50)  5.404 ms  4.501 ms  4.324 ms

Bonito bucle.

(mismo resultado con las 4 direcciones de raw.githubusercontent.com)

🗨️ 2
rbetancor

Movistar FTTH

image.webp

0 Problemas para acceder a raw.githubusercontent.com

🗨️ 1
PezEnLaBoca

Sí, ahora tengo el mismo resultado (distintos nodos pero llega a su destino). He visto en el foro de Movistar que el problema había vuelto a presentarse ayer por la noche, yo me he enterado esta mañana cuando he visto el correo del script que había fallado.

Josh

@kotBegemot puedes comparar mis datos que si que me funciona con los de @PezEnLaBoca que no le funciona. A ver si se te ocurre alguna idea.

josh@iMac www % ping -c 1 api.github.com
PING api.github.com (140.82.121.5): 56 data bytes
64 bytes from 140.82.121.5: icmp_seq=0 ttl=50 time=36.521 ms

--- api.github.com ping statistics ---
1 packets transmitted, 1 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 36.521/36.521/36.521/0.000 ms

josh@iMac www % ping -c 1 raw.githubusercontent.com
PING raw.githubusercontent.com (185.199.109.133): 56 data bytes
64 bytes from 185.199.109.133: icmp_seq=0 ttl=56 time=13.005 ms

--- raw.githubusercontent.com ping statistics ---
1 packets transmitted, 1 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 13.005/13.005/13.005/0.000 ms

josh@iMac www % traceroute raw.githubusercontent.com
traceroute: Warning: raw.githubusercontent.com has multiple addresses; using 185.199.109.133
traceroute to raw.githubusercontent.com (185.199.109.133), 64 hops max, 52 byte packets
 1  192.168.1.1 (192.168.1.1)  2.975 ms  2.836 ms  2.665 ms
 2  39.red-81-46-38.customer.static.ccgg.telefonica.net (81.46.38.39)  6.585 ms  3.359 ms  3.198 ms
 3  209.red-81-46-68.customer.static.ccgg.telefonica.net (81.46.68.209)  9.724 ms  9.077 ms  10.357 ms
 4  25.red-81-46-69.customer.static.ccgg.telefonica.net (81.46.69.25)  9.551 ms  9.325 ms  9.121 ms
 5  85.red-80-58-96.staticip.rima-tde.net (80.58.96.85)  12.908 ms  9.294 ms  9.669 ms
 6  57.red-81-46-0.customer.static.ccgg.telefonica.net (81.46.0.57)  11.977 ms  9.519 ms  9.117 ms
 7  * * *
...
PezEnLaBoca

Yo creo que postear en bandaancha es terapéutico: vuelve a funcionar.

🗨️ 2
kotBegemot

¿Puedes poner los mismos datos ahora que te funciona?

🗨️ 1
PezEnLaBoca

Tengo que usar -T o -I (con udp todos los saltos después del 5 no los reporta)

$ traceroute -T  raw.githubusercontent.com
traceroute to raw.githubusercontent.com (185.199.109.133), 30 hops max, 60 byte packets
 1  _gateway (192.168.90.1)  0.297 ms  0.346 ms  0.310 ms
 2  206.red-81-46-38.customer.static.ccgg.telefonica.net (81.46.38.206)  1.747 ms  2.508 ms  2.835 ms
 3  161.red-81-46-44.customer.static.ccgg.telefonica.net (81.46.44.161)  5.220 ms  5.297 ms  5.200 ms
 4  29.red-81-46-45.customer.static.ccgg.telefonica.net (81.46.45.29)  5.214 ms  5.181 ms *
 5  1.red-80-58-78.staticip.rima-tde.net (80.58.78.1)  4.728 ms  4.850 ms  5.139 ms
 6  50.red-81-46-0.customer.static.ccgg.telefonica.net (81.46.0.50)  5.362 ms  3.397 ms  4.183 ms
 7  * * *
 8  cdn-185-199-109-133.github.com (185.199.109.133)  14.287 ms  13.017 ms  13.842 ms

Edit: las tres direcciones 185.199.109.133, 185.199.111.133 y 185.199.108.133 dan el mismo resultado, pero 158.199.110.113 es distinto

$ traceroute -T 185.199.110.133
traceroute to 185.199.110.133 (185.199.110.133), 30 hops max, 60 byte packets
1 _gateway (192.168.90.1) 0.457 ms 0.444 ms 0.451 ms
2 206.red-81-46-38.customer.static.ccgg.telefonica.net (81.46.38.206) 1.821 ms 2.690 ms 3.360 ms
3 161.red-81-46-44.customer.static.ccgg.telefonica.net (81.46.44.161) 6.255 ms 6.256 ms 6.199 ms
4 29.red-81-46-45.customer.static.ccgg.telefonica.net (81.46.45.29) 6.183 ms 6.196 ms 6.061 ms
5 46.red-80-58-81.staticip.rima-tde.net (80.58.81.46) 5.204 ms 5.123 ms 5.990 ms
6 81.red-81-46-0.customer.static.ccgg.telefonica.net (81.46.0.81) 5.296 ms 2.347 ms 2.848 ms
7 * * *
8 cdn-185-199-110-133.github.com (185.199.110.133) 13.479 ms 13.030 ms 13.177 ms