Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

hosting en interdominios
806 lecturas y 15 respuestas
  • BocaDePez BocaDePez
    6

    887VA + VDS2 Movistar, problema con layer 2

    Buenas a todos,

    ayer estuve trasteando un rato con un 887VA para conectarlo a nuestra línea VDS2 de 30Mb de Movistar (estábamos ya un poco cansados del Zyxel cutrefacto de marras...).

    El layer 1 (controller VDSL 0) levanta sin problemas, negocia correctamente (ITU 993.2, VDS2) y coge perfectamente los canales US ( 30 Mbit / sec ) y DS ( 1 Mbit/sec). En capa 1 parece estar todo en orden (si alguien lo necesita, puedo pegarle la salida de un "show controller vdsl 0" donde se muestran todos estos datos).

    El problema viene con el layer 2. Tanto el int ATM0 como el ATM0.1 (ver running-config que pego más abajo) están tirados (down). Me resulta curioso que sincronize perfectamente (capa 1, luz CD verde sólida en el router) y no sea capaz de levantar el interfaz ATM. Lo primero que se me viene a la cabeza es un error en el par vpi/vci, pero incluso con VDS2, Movistar parece seguir en los típicos 8/32, así que tampoco parece eso.

    La cuestión es que con esta config, cuando conectas la línea de teléfono al jack RJ11 del router, a los pocos segundos sincroniza y el controller VDSL 0 levanta, pero no hay manera de que ATM0 o ATM0.1 se muevan del estado "down".

    Si alguien puede echarle un vistazo a esta config y sugerirme algo, le estoy enormemente agradecido:

    !! Last configuration change at 18:32:30 UTC Mon Mar 31 2014version 15.3no service padservice timestamps debug datetime msecservice timestamps log datetime msecno service password-encryption!hostname xxxxx!boot-start-markerboot-end-marker!!enable secret 5 xxxxxenable password xxxxxx!no aaa new-modelno process cpu extended historyno process cpu autoprofile hogmemory-size iomem 10!ip cefno ipv6 cefvlan ifdescr detail!!license udi pid CISCO887VA-K9 sn xxxxxxxxxxx!!!!!!!controller VDSL 0!!!interface Ethernet0 no ip address shutdown!interface ATM0 description VDSL-MOVISTAR no ip address no ip route-cache no atm ilmi-keepalive hold-queue 224 in!interface ATM0.1 point-to-point no ip route-cache pvc 8/32 encapsulation aal5snap pppoe-client dial-pool-number 1 !!interface FastEthernet0
    switchport access vlan 2 no ip address no cdp enable!interface FastEthernet1 switchport access vlan 3 no ip address no cdp enable!interface FastEthernet2 no ip address shutdown no cdp enable!interface FastEthernet3 no ip address shutdown no cdp enable!interface Vlan1 no ip address shutdown!interface Vlan2 ip address 192.168.100.1 255.255.255.0 no ip redirects no ip proxy-arp ip nat inside ip virtual-reassembly in hold-queue 100 out!interface Vlan3 ip address 192.168.200.1 255.255.255.0 no ip redirects no ip proxy-arp ip nat inside ip virtual-reassembly in hold-queue 100 out!interface Dialer0 ip address negotiated no ip redirects no ip proxy-arp ip mtu 1492 ip nat outside ip virtual-reassembly in encapsulation ppp dialer pool 1 ppp authentication pap callin ppp pap sent-username adslppp@telefonicanetpa password 0 adslppp ppp ipcp route default no cdp enable!ip forward-protocol ndno ip http serverno ip http secure-server!no cdp run

    Este tema lleva más de 6 meses inactivo. Es recomendable que abras un nuevo tema para retomar la conversación.
    1
      • BocaDePez BocaDePez
        6

        Hola a todos he probado la configuración que habéis puesto…

        Hola a todos he probado la configuración que habéis puesto aquí y parece que todo lo hace bien incluso las luces pero los equipos conectados me dan problemas con los servidores dns no se si puede ser problema de ello o es que tengo puesto algún tipo de configuración que en realidad no vaya bien si hace falta decímelo y os pego una captura de la configuración a ver si veis algo mas que yo

        • BocaDePez BocaDePez
          6

          Bueno, en el hilo se está preguntando por un problema en capa…

          Bueno, en el hilo se está preguntando por un problema en capa 2 que fue solucionado. DNS ya es un protocolo de capa de aplicación (capa 7 en modelo OSI)...

          ¿Cuáles son esos problemas que dices tener? Ten en cuenta que la configuración manual de DNS que tenga el equipo final, tiene prioridad con respecto a otras suministradas automáticamente por DHCP.

          Hay veces que los PCs usan los routers (o más bien abusan) como DNS Relay, y hay routers que no dan abasto para ello. Yo prefiero que cada equipo se aguante su vela y cachee lo que necesite... que hoy en día a 8 euros el GB ya no es problema alguno el destinar varias docenas de megas al servicio de Cliente DNS.

          • Te pongo en antecedentes esta es la red de una universidad…

            Te pongo en antecedentes esta es la red de una universidad pequeña, les montamos un controlador wifi Motorola conectado al router ADSL que tenían antes y todo genial, el año pasado llamo un comercial de telefónica hablo con sabe dios quien porque nunca me lo han dicho y cambiaron las dos iADSL que tenían a movistar fusión con el maravilloso router que ellos ponen con lo cual la red de alumnos se colapsa cada vez mas y hay que estas apagando y encendiendo el router para que se desbloquee, ahora he puesto este cisco 887va-m he configurado el router con los parámetros que habéis puesto arriba y veo que la luz de ppp se me queda encendida fija y la cd también del dhcp se encarga el controlador Motorola pero cada vez que pruebo la conexión el portátil me dice que tiene un problema de dns en teoría las dns también las emite el Motorola a todos los equipos que se conectan por wifi pero yo no consigo navegar ni por wifi ni por cable y solo me dice Windows eso y ya no se si es realmente un problema de las dns o simplemente hay algo que no tengo bien configurado y en realidad no estoy saliendo a internet con el cisco

            • esta es una captura de todo lo que ahora mismo le tengo…

              esta es una captura de todo lo que ahora mismo le tengo configurado al cisco

              Cisco#show running-config
              Building configuration...

              Current configuration : 1647 bytes
              !
              version 15.2
              no service pad
              service timestamps debug datetime msec
              service timestamps log datetime msec
              no service password-encryption
              !
              hostname Cisco
              !
              boot-start-marker
              boot-end-marker
              !
              !
              enable secret 5 $1$cvsK$rC132qSG7JAd2y/vvEE0h.
              enable password cisco73
              !
              no aaa new-model
              memory-size iomem 10
              !
              !
              no ip routing
              !
              !
              !
              !
              !
              !
              no ip cef
              no ipv6 cef
              !
              !
              license udi pid CISCO887VA-M-K9 sn FCZ1810C24K
              !
              !
              !
              !
              !
              !
              !
              controller VDSL 0
              !
              !
              !
              !
              !
              !
              !
              !
              !
              !
              interface Ethernet0
              description VDSL-MOVISTAR
              no ip address
              no ip route-cache
              pppoe enable group global
              pppoe-client dial-pool-number 1
              !
              interface ATM0
              no ip address
              no ip route-cache
              shutdown
              no atm ilmi-keepalive
              !
              interface FastEthernet0
              no ip address
              !
              interface FastEthernet1
              no ip address
              !
              interface FastEthernet2
              no ip address
              !
              interface FastEthernet3
              no ip address
              !
              interface Vlan1
              ip address 192.168.10.1 255.255.255.0
              ip nat inside
              ip virtual-reassembly in
              no ip route-cache
              !
              interface Dialer0
              ip address negotiated
              ip access-group 100 in
              ip mtu 1492
              ip nat outside
              ip virtual-reassembly in
              encapsulation ppp
              dialer pool 1
              dialer-group 1
              ppp authentication pap callin
              ppp pap sent-username adslppp@telefonicanetpa password 0 adslppp
              ppp ipcp header-compression ack
              ppp ipcp dns request accept
              ppp ipcp address accept
              no cdp enable
              !
              ip forward-protocol nd
              no ip http server
              no ip http secure-server
              !
              ip nat inside source list 1 interface Dialer0 overload
              ip route 0.0.0.0 0.0.0.0 Dialer0
              !
              dialer-list 1 protocol ip permit
              !
              !
              !
              line con 0
              no modem enable
              line aux 0
              line vty 0 4
              password ciscocisco
              login
              transport input all
              !
              !
              end

              • Esta es la información que me ofrece ahora mismo el…

                Esta es la información que me ofrece ahora mismo el controlador vdsl

                Cisco#show controller vdsl 0
                Controller VDSL 0 is UP

                Daemon Status: Up

                XTU-R (DS) XTU-C (US)
                Chip Vendor ID: 'BDCM' 'BDCM'
                Chip Vendor Specific: 0x0000 0xA18E
                Chip Vendor Country: 0xB500 0xB500
                Modem Vendor ID: 'CSCO' ' '
                Modem Vendor Specific: 0x4602 0x0000
                Modem Vendor Country: 0xB500 0x0000
                Serial Number Near: FCZ1810C24K 887VA-M- 15.2(4)M
                Serial Number Far:
                Modem Version Near: 15.2(4)M
                Modem Version Far: 0xa18e

                Modem Status: TC Sync (Showtime!)
                DSL Config Mode: AUTO
                Trained Mode: G.993.2 (VDSL2) Profile 8b
                TC Mode: PTM
                Selftest Result: 0x00
                DELT configuration: disabled
                DELT state: not running
                Trellis: ON ON
                SRA: disabled disabled
                SRA count: 0 0
                Bit swap: enabled enabled
                Bit swap count: 0 0
                Line Attenuation: 0.0 dB 0.0 dB
                Signal Attenuation: 0.0 dB 0.0 dB
                Noise Margin: 7.2 dB 20.8 dB
                Attainable Rate: 39912 kbits/s 6584 kbits/s
                Actual Power: 18.3 dBm 4.8 dBm
                Per Band Status: D1 D2 D3 U0 U1 U2 U3
                Line Attenuation(dB): 21.5 59.9 N/A 10.2 49.1 N/A N/A
                Signal Attenuation(dB): 21.5 59.9 N/A 11.5 47.4 N/A N/A
                Noise Margin(dB): 7.1 7.4 N/A 22.2 20.6 N/A N/A
                Total FECC: 11967 0
                Total ES: 0 0
                Total SES: 0 0
                Total LOSS: 0 0
                Total UAS: 30 30
                Total LPRS: 0 0
                Total LOFS: 0 0
                Total LOLS: 0 0

                Full inits: 1
                Failed full inits: 0
                Short inits: 0
                Failed short inits: 0

                Firmware Source File Name (version)
                -------- ------ -------------------
                VDSL embedded VDSL_LINUX_DEV_01212008 (1)

                Modem FW Version: 130205_1433-4.02L.03.A2pv6C035j.d23j
                Modem PHY Version: A2pv6C035j.d23j
                Vendor Version: Ap6v35j.23j 68

                DS Channel1 DS Channel0 US Channel1 US Channel0
                Speed (kbps): 0 31488 0 1088
                SRA Previous Speed: 0 0 0 0
                Previous Speed: 0 0 0 0
                Reed-Solomon EC: 0 11967 0 0
                CRC Errors: 0 0 0 0
                Header Errors: 0 0 0 0
                Interleave (ms): 0.00 13.00 0.00 4.00
                Actual INP: 0.00 5.01 0.00 2.00

                Training Log : Stopped
                Training Log Filename : flash:vdsllog.bin

    • BocaDePez BocaDePez
      12

      Una búsqueda de Google (no soy experto en Cisco IOS): Q. Does…

      Una búsqueda de Google (no soy experto en Cisco IOS):

      Q. Does the Cisco 887V platform also support ADSL, ADSL2, and ADSL2+?
      A. The Cisco 887V platform supports only VDSL2 technology.

      Q. Does the Cisco 887V platform support both ATM and Ethernet Packet Transport Mode (PTM)?
      A. The platform supports only PTM.

      Por lo tanto, no hay VPI ni VCI que configurar, puesto que no hay circuitos virtuales ni capa de adaptación ATM (AAL5) detrás. Ni QoS ni elegir CBR, UBR o VBR, nada de todo eso.

      Esta es una configuración que aparece en una consulta en un foro de soporte de Cisco:

      !
      interface Ethernet0
      description $ETH-WAN$
      no ip address
      pppoe-client dial-pool-number 1
      no fair-queue
      interface Dialer0
      ip address negotiated
      ip access-group 100 in
      ip mtu 1492
      ip nat outside
      ip virtual-reassembly in
      encapsulation ppp
      dialer pool 1
      dialer-group 1
      ppp authentication pap callin
      ppp pap sent-username adslppp@telefonicanetpa password 0 adslppp
      interface ATM0
      no ip address
      shutdown
      no atm ilmi-keepalive
      ip nat inside source list 1 interface Dialer0 overload
      ip route 0.0.0.0 0.0.0.0 Dialer0

      • BocaDePez BocaDePez
        12

        Aquí estaba el "chow de cat chow"... ayer por la tarde…

        Aquí estaba el "chow de cat chow"... ayer por la tarde encontré esta misma plantilla buscando por google, y efectivamente, el tema es que VDSL2 sobre POTS utiliza eth0 (al menos en el 887 VA) y no ATM0. Tal y como dice el autor de ese mismo post, el temita es "tricky", sí...

        Un shutdown al ATM0, seguido de una asignación de eth0 al dial pool correcto, y todo echó a andar inmediatamente.

        En fin, pues que ya tenemos el 887 en pie y sin novedad... muchas gracias a todos por vuestras respuestas.

        un saludo,

    • BocaDePez BocaDePez
      6

      Ajunto versión "decente" de la configuración.... : !! Last…

      Ajunto versión "decente" de la configuración.... :

      !! Last configuration change at 18:32:30 UTC Mon Mar 31 2014version 15.3no service padservice timestamps debug datetime msecservice timestamps log datetime msecno service password-encryption!hostname xxxxx!boot-start-markerboot-end-marker!!enable secret 5 xxxxxenable password xxxxxx!no aaa new-modelno process cpu extended historyno process cpu autoprofile hogmemory-size iomem 10!ip cefno ipv6 cefvlan ifdescr detail!!license udi pid CISCO887VA-K9 sn xxxxxxxxxxx!!!!!!!controller VDSL 0!!!interface Ethernet0 no ip address shutdown!interface ATM0 description VDSL-MOVISTAR no ip address no ip route-cache no atm ilmi-keepalive hold-queue 224 in!interface ATM0.1 point-to-point no ip route-cache pvc 8/32 encapsulation aal5snap pppoe-client dial-pool-number 1
      !!interface FastEthernet0
      switchport access vlan 2 no ip address no cdp enable!interface FastEthernet1 switchport access vlan 3 no ip address no cdp enable!interface FastEthernet2 no ip address shutdown no cdp enable!interface FastEthernet3 no ip address shutdown no cdp enable!interface Vlan1 no ip address shutdown!interface Vlan2 ip address 192.168.100.1 255.255.255.0 no ip redirectsno ip proxy-arp ip nat inside ip virtual-reassembly in hold-queue 100 out!interface Vlan3 ip address 192.168.200.1 255.255.255.0 no ip redirects no ip proxy-arp ip nat inside ip virtual-reassembly in hold-queue 100 out!interface Dialer0 ip address negotiated no ip redirects no ip proxy-arp ip mtu 1492 ip nat outside ip virtual-reassembly in encapsulation ppp dialer pool 1 ppp authentication pap callin ppp pap sent-username adslppp@telefonicanetpa password 0 adslppp ppp ipcp route default no cdp enable!ip forward-protocol ndno ip http serverno ip http secure-server!no cdp run

        • BocaDePez BocaDePez
          6

          edit: donde puse "Segundos después de conectar el rj45,..."…

          edit: donde puse "Segundos después de conectar el rj45,..." quise decir en realidad "Segundos después de conectar el rj11" ... joder, hoy estoy que no doy una.

        • BocaDePez BocaDePez
          6

          Aquí está el pantallazo que muestra cómo "engancha"…

          Aquí está el pantallazo que muestra cómo "engancha" correctamente y negocia bien en capa 1 :

          #show controller vdsl 0

          Controller VDSL 0 is UP

          Daemon Status: Up

          XTU-R (DS) XTU-C (US)

          Chip Vendor ID: 'BDCM' 'BDCM'

          Chip Vendor Specific: 0x0000 0xA18E

          Chip Vendor Country: 0xB500 0xB500

          Modem Vendor ID: 'CSCO' ' '

          Modem Vendor Specific: 0x4602 0x0000

          Modem Vendor Country: 0xB500 0x0000

          Serial Number Near: FCZ1808704K 887VA-K9 15.3(3)

          Serial Number Far:

          Modem Version Near: 15.3(3)

          Modem Version Far: 0xa18e

          Modem Status: TC Sync (Showtime!)

          DSL Config Mode: AUTO

          Trained Mode: G.993.2 (VDSL2) Profile 8b

          TC Mode: PTM

          Selftest Result: 0x00

          DELT configuration: disabled

          DELT state: not running

          Trellis: ON ON

          SRA: disabled disabled

          SRA count: 0 0

          Bit swap: enabled enabled

          Bit swap count: 0 0

          Line Attenuation: 0.0 dB 0.0 dB

          Signal Attenuation: 0.0 dB 0.0 dB

          Noise Margin: 29.9 dB 31.0 dB

          Attainable Rate: 83624 kbits/s 15880 kbits/s

          Actual Power: 18.5 dBm -15.7 dBm

          Per Band Status: D1 D2 D3 U0 U1 U2 U3

          Line Attenuation(dB): 7.6 13.6 N/A 3.0 14.5 N/A N/A

          Signal Attenuation(dB): 7.6 13.6 N/A 4.3 14.2 N/A N/A

          Noise Margin(dB): 30.7 29.1 N/A 31.0 31.0 N/A N/A

          Total FECC: 121 0

          Total ES: 6 0

          Total SES: 6 0

          Total LOSS: 5 0

          Total UAS: 1446 1446

          Total LPRS: 0 0

          Total LOFS: 5 0

          Total LOLS: 0 0

          Full inits: 2

          Failed full inits: 0

          Short inits: 0

          Failed short inits: 0

          Firmware Source File Name (version)

          -------- ------ -------------------

          VDSL embedded VDSL_LINUX_DEV_01212008 (1)

          Modem FW Version: 130205_1433-4.02L.03.A2pv6C035j.d23j

          Modem PHY Version: A2pv6C035j.d23j

          Vendor Version: Ap6v35j.23j 68

          DS Channel1 DS Channel0 US Channel1 US Channel0

          Speed (kbps): 0 31488 0 1088

          SRA Previous Speed: 0 31488 0 1088

          Previous Speed: 0 31488 0 1088

          Reed-Solomon EC: 0 0 0 0

          CRC Errors: 0 1720 0 0

          Header Errors: 0 0 0 0

          Interleave (ms): 0.00 13.00 0.00 4.00

          Actual INP: 0.00 5.01 0.00 2.00

          Los parámetros son los esperados (DS 30 mbit/sec, US 1 mBit/sec) así que por aquí no veo problema.

          Respecto a lo que comentas del ATM: para ip fija (o más bien pseudo-fija), como es nuestro caso, movistar utiliza pppoe, así que definimos un subinterface (ATM0.1) como point-to-point, aquí copio/pego la configuración de los ATMx :

          interface ATM0

          description VDSL-MOVISTAR

          no ip address

          no ip route-cache

          no atm ilmi-keepalive

          hold-queue 224 in

          !

          interface ATM0.1 point-to-point

          no ip route-cache

          pvc 8/32

          encapsulation aal5snap

          pppoe-client dial-pool-number 1

          !

          Enganchamos un ppoe-client al ATM0.1, que es la configuración más común que he podido averiguar para el caso de movistar + pppoe. Por último, definimos el interface dialer en cuestión:
          interface Dialer0 ip address negotiated no ip redirects no ip proxy-arp ip mtu 1492 ip nat outside ip virtual-reassembly in encapsulation ppp dialer pool 1 ppp authentication pap callin ppp pap sent-username adslppp@telefonicanetpa password 0 adslppp ppp ipcp route default no cdp enable!ip forward-protocol ndno ip http serverno ip http secure-server

          El tema es el que comentaba. Segundos después de conectar el rj45, la luz CD queda en verde sólido, el controller VDSL0 sincroniza perfectamente (como se ve más arriba) pero... ATM0 y ATM 0.1 siguen en down, sencillamente no ocurre nada. No sé si es que tengo mal el par vpi/vci ( la documentación de CISCO lo cita como una de las principales causas cuando hay problemas en layer 2) o si es que estoy cagándola en algún otro sitio y no me he dado cuenta.
          Por último, adjunto un show interfaces de los ATMx , una vez que VDSL0 está up y sincronizado: (nota: como se ve, no hay un sólo paquete de tráfico... nada de nada).

          #show interfaces

          ATM0 is down, line protocol is down

          Hardware is MPC ATMSAR, address is 78da.6e4f.514e (bia 78da.6e4f.514e)

          Description: VDSL-MOVISTAR

          MTU 1600 bytes, sub MTU 1600, BW 4608 Kbit/sec, DLY 80 usec,

          reliability 255/255, txload 1/255, rxload 1/255

          Encapsulation ATM, loopback not set

          Keepalive not supported

          Encapsulation(s): AAL5

          4 maximum active VCs, 1024 VCs per VP, 0 current VCCs

          VC Auto Creation Disabled.

          VC idle disconnect time: 300 seconds

          Last input never, output never, output hang never

          Last clearing of "show interface" counters never

          Input queue: 0/224/0/0 (size/max/drops/flushes); Total output drops: 0

          Queueing strategy: Per VC Queueing

          5 minute input rate 0 bits/sec, 0 packets/sec

          5 minute output rate 0 bits/sec, 0 packets/sec

          0 packets input, 0 bytes, 0 no buffer

          Received 0 broadcasts (0 IP multicasts)

          0 runts, 0 giants, 0 throttles

          0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

          0 packets output, 0 bytes, 0 underruns

          0 output errors, 0 collisions, 291 interface resets

          0 unknown protocol drops

          0 output buffer failures, 0 output buffers swapped out

          ATM0.1 is down, line protocol is down

          Hardware is MPC ATMSAR, address is 78da.6e4f.514e (bia 78da.6e4f.514e)

          MTU 1600 bytes, BW 4608 Kbit/sec, DLY 80 usec,

          reliability 255/255, txload 1/255, rxload 1/255

          Encapsulation ATM

          Keepalive not supported

          0 packets input, 0 bytes

          0 packets output, 0 bytes

          0 OAM cells input, 0 OAM cells output

          AAL5 CRC errors : 0

          AAL5 SAR Timeouts : 0

          AAL5 Oversized SDUs : 0

          Last clearing of "show interface" counters never

          Dialer0 is up (spoofing), line protocol is up (spoofing)

          Hardware is Unknown

          Internet address will be negotiated using IPCP

          MTU 1500 bytes, BW 56 Kbit/sec, DLY 20000 usec,

          reliability 255/255, txload 1/255, rxload 1/255

          Encapsulation PPP, LCP Closed, loopback not set

          Keepalive set (10 sec)

          DTR is pulsed for 1 seconds on reset

          Last input never, output never, output hang never Last clearing of "show interface" counters 1d00h Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0 Queueing strategy: fifo Output queue: 0/40 (size/max) 5 minute input rate 0 bits/sec, 0 packets/sec 5 minute output rate 0 bits/sec, 0 packets/sec 0 packets input, 0 bytes 0 packets output, 0 bytes

    • BocaDePez BocaDePez
      6

      Edit : pido disculpas, parece ser que se me han ido los en la…

      Edit : pido disculpas, parece ser que se me han ido los en la configuración que he posteado, por alguna razón, y ahora es un completo coñazo para leerla. Espero no tengáis demasiados problemas para "abriros paso" por esa jungla, ya lo siento.