Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

hosting en interdominios
31 lecturas y 9 respuestas
  • Cerrado

    3Com, Lan, Ftp=problems.. XD

    Bueno.. tengo una lan de 2 pc´s montados en multipuesto sobre un 3com officeconnect y con terra... quiero abrir un ftp, lo consigo sólo sin NAT.. o sea sólo dando acceso a internet a 1 de los PC´s, Cuando activo NAT .. funcionan los 2.. pero no el FTP.. alguien es tan sumamente amable para guiarme y explicarme el qué y el cómo¿? .. gracias a todos de antemano.. salu2 varios.

    Este tema es antiguo y puede contener información obsoleta. Abre un nuevo tema para publicar tu mensaje.
    1
    • Cerrado

      Hola, me apunto a este hilo porque me pasa más o menos lo…

      Hola, me apunto a este hilo porque me pasa más o menos lo mismo.

      Estoy intentando poner un servidor FTP para los amiguetes.

      En la máquina uso WinME. Uso el Cerberus FTP server que está a mi juicio bien configurado porque en local funciona perfectamente. "Netstat -a" informa de los puertos abiertos adecuadamente por lo que doy por supuesto que está bien configurada la máquina y el servicio ftp.

      En el 3Com 812 con version 2.1.5 tengo abiertos los puertos 21, 10001, 10002, 10003, 10004 y 10005 redirigidos a la máquina en cuestión por aquello de que más arriba dice de abrir estos puertos en caso de usar PASV, que yo lo uso y está configurado.

      Al ser la v2.1.5, tengo NAT y tengo PAT. El NAT está desactivado y el PAT tiene abiertos los puertos TCP que dije antes y como default workstation la máquina que uso.

      Los filtros no impiden, si no al contrario, permiten el uso de conexiones al puerto 21.

      Los test de seguridad de por ahí (www.dslreports.com y grc.com) dicen que mi puerto 21 está abierto de patitas al mundo.

      O sea, que a mi parecer todo está listo para....

      ...que cuando ponga "ftp xxx.xxx.xxx.xxx" me salga el error "ftp: connect: 10061".

      Según lo que he visto por ahí resulta que la máquina (en esta caso el router) RECHAZA la conexión, es decir, no se trata de que el puerto NO esté abierto, si no que deliberadamente me RECHAZA la conexión...

      Alguien me echa un cabo???

    • Cerrado

      [Editado 23/07/03 14:21]

      Exacto.. idea es montar un servidor de FTP :-? cias. Tengo…

      Exacto.. idea es montar un servidor de FTP :-? cias.
      Tengo nat Configurado, el puerto 21 abierto e probado incluso con varios puertos 24, etc.. sólo me funciona el FTP si desactivo NAT.. PAT dando la IP interna workstation del PC dónde está el servidor FTP, pero así FTP, pero a la playa la conexión a la net del PC2.. what is problem¿?. cias

      • Cerrado

        BocaDePez BocaDePez
        6

        Lo primero es asegurarnos de que abres bien el puerto... Pon…

        Lo primero es asegurarnos de que abres bien el puerto... Pon el servidor e intenta conectarte, si no lo logras, es que no mapeas bien el puerto... (mira los manuales sobre el tema que hay en esta web o en adsl4ever).

        Si logras conectarte, pero luego no puedes bajarte ni subir nada, es que tienes problemas con el FTP Pasivo... Te puedo dar la solución para el BulletProof (casi todos los servidores de Windows son parecidos):

        SetUp-> IP Multi IP Settings -> Activa Passive Mode IP y pon tu IP pública y a continuación el rango de puertos que podrá asignar (no pongas más de 3 o 4 a menos que vayas a tener n conexiones simultáneas, en cuyo caso abre tantos como conexiones vayas a poner, por ejemplo abre del 10000 al 10003). Ahora vete a la configuración del router y pasa los puertos que hayas puesto hacia tu PC, es decir, el 10000, 10001, 10002 y 10003 TCP.

        Si no funciona, dime que falla para probar más cosas...

        • Cerrado

          a ver.. te explico: Desde la lan .. poniendo la IP interna…

          a ver.. te explico: Desde la lan .. poniendo la IP interna desde el PC que no tiene el servidor FTP consigo entrar sin problema en él.. por lo tanto los puertos están correctamente mapeados, lo que no consigo es entrar desde el exterior, desde wan, tengo un servidor dns de los gratuitos y funciona correctamente. pero todo esto desde la lan.. lo único ke me falla es el acceso desde el exterior.. espero tus sugerencias y gracias de antemano >;)~

          • Cerrado

            BocaDePez BocaDePez
            6
            Vamos a ver, que desde la LAN puedas entrar no quiere decir…

            Vamos a ver, que desde la LAN puedas entrar no quiere decir nada, me temo :(, aunque tuvieras el cable del ADSL desenchufado podrías seguir entrando... Si no puedes entrar desde fuera es que no tienes bien abierto los puertos.

          • Cerrado

            otra cosilla... NAT, PAT IP WAN... la configuración correcta…

            otra cosilla...
            NAT, PAT IP WAN... la configuración correcta para el funcionamiento de la lan y el FTP sería¿?..--> PAT activado con en el defaultworkstation el servidor de FTP, NAT activado con la IP de la WAN apuntando a la IP del servidor de FTP (IP lan) la IP stática y la dinámica apuntando también a la misma IP(lan)... sería esta configuración correcta¿? .. soy el hombre dudas >;) :-?

            • Cerrado

              BocaDePez BocaDePez
              6
              Vete a la configuración del NAT y pon que el puerto 21 te lo…

              Vete a la configuración del NAT y pon que el puerto 21 te lo pase al puerto 21 del PC con el servidor FTP. Si no tienes muy claro cómo hacerlo, en esta página y en adsl4ver hay tutoriales que te explican como configurar el 3Com y como poner un servidor de FTP.

              • Cerrado

                pues de tanto toketear por el FTP me he bajado el router…

                pues de tanto toketear por el FTP me he bajado el router entero.. lo resetee y lo de dejé de fábrica... dale 1 arma a un niño.. Bueno pues ya habiendo recuperado la total funcionalidad del router..
                tengo abiero el puerto 21 del FTP, tanto en la lan como al exterior.. los testeos de puertos (signel up) me lo dan komo tal.. repito. el FTP sólo me funciona teniendo el Router en Monopuesto, en Multipuesto nones.. y yo necesito el multipuesto para la conexión de los 2 PC´s a la red.. ese es mi problema.. necesito el multipuesto y el FTP simultaneamente.. ese sigue siendo el problemilla.. gracias de nuevo.. y ya estoy por akí.. reconfigurao... XD :-P

    • Cerrado

      BocaDePez BocaDePez
      6

      Supongo que lo que quieres hacer es poner un servidor de FTP,…

      Supongo que lo que quieres hacer es poner un servidor de FTP, ¿no?

      Lo primero que tienes que hacer es que el NAT pase el puerto 21 (del FTP) o el puerto donde hayas puesto el servidor al PC donde está el servidor. A parte de esto está el tema del FTP Pasivo, pero no me enrollo, por si éste no era el problema...