Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

ADSL/VDSL

3com 812 --> Dudas sobre FILTROS y STEALTH

tonikelope

Hola. Pues resulta que los filtros que en mono me iban pefectos ahora no funcionan apenas (y digo apenas porque sólo funcionan dos: el del ICMP ping y el de telnet). Como a veces se le va la pinza con el tema de los filtros (me cambia AND por OR), he borrado el INRSinternet.FLT y los he vuelto a introducir y sigue igual la cosa :(.

TESTS que he hecho:

1 GRC me da todos los puertos (menos el 23) como CLOSED (cuando deberían salir STEALTH).

2 SYGATE igual que el anterior (además del ICMP que sale bien filtrado)

3 UPSEROS me saca TODOS los puertos (incluídos muchos otros que no he filtrado) como STEALH.

Os pongo los filtros que tengo:

[FN=NOPING| FI=1| Enabled=yes | Type=Adv ]
{CI=1| Enabled=yes }
1 AND PROTOCOL=ICMP;
{CI=2| Enabled=yes }
2 REJECT GENERIC=>origin = DATA/offset = 0/length = 1/mask = 0xFF/value = 0x08;

[FN=NOWEBROUTER| FI=2| Enabled=yes | Type=Adv ]
{CI=1| Enabled=yes }
3 REJECT TCP-DST-PORT=9999;
{CI=2| Enabled=yes }
4 REJECT UDP-DST-PORT=9999;

[FN=BlasterSasser| FI=3| Enabled=yes | Type=Adv ]
{CI=1| Enabled=yes }
5 REJECT TCP-DST-PORT=135;
{CI=2| Enabled=yes }
6 REJECT TCP-DST-PORT=445;
{CI=3| Enabled=yes }
7 REJECT UDP-DST-PORT=135;
{CI=4| Enabled=yes }
8 REJECT UDP-DST-PORT=445;

[FN=NetBios| FI=4| Enabled=yes | Type=Adv ]
{CI=1| Enabled=yes }
9 AND TCP-DST-PORT>=137;
{CI=2| Enabled=yes }
10 REJECT TCP-DST-PORT
{CI=3| Enabled=yes }
11 AND UDP-DST-PORT>=137;
{CI=4| Enabled=yes }
12 REJECT UDP-DST-PORT

[FN=NOTELNET| FI=5| Enabled=yes | Type=Adv ]
{CI=1| Enabled=yes }
13 REJECT TCP-DST-PORT=23;
{CI=2| Enabled=yes }
14 REJECT UDP-DST-PORT=23;

[FN=NOFTP| FI=6| Enabled=yes | Type=Adv ]
{CI=1| Enabled=yes }
15 REJECT TCP-DST-PORT=21;
{CI=2| Enabled=yes }
16 REJECT UDP-DST-PORT=21;

A ver si algún gurú me ilumina ¬ ¬...

Salu2 y gracias ;)

**************************************
**************EDITADO*******************
****************************************

Después de varias pruebas he comprobado que los filtros hacen STEALTH los puertos siempre que dichos puertos estén además MAPEADOS. ¿Alguien sabe por qué?

Este tema está cerrado a nuevas respuestas. Abre un nuevo tema para retomar la conversación.
BocaDePez
BocaDePez

Yo estoy en ello tamnbién, no sé si lo conseguiré. Tengo un manual del oficial donde me dice que no puede haber más de 10 lineas en el fichero FLT. Además creo que el verbo AND se utiliza para especifucar rangos del tipo
12 REJECT TCP-DST-PORT>=6881;
13 AND TCP-DST-PORT
acotados por los dos extremos. Ya me contarás como te ha ido.

BocaDePez
BocaDePez

Ahora si está acotado

9 REJECT TCP-DST-PORT>=6881;
10 AND TCP-DST-PORT
acotados por los dos extremos. Ya me contarás como te ha ido.

BocaDePez
BocaDePez

Lo siento pero la linea 10 no sale completa esta acotada con un signo menor o igual que 6999.

🗨️ 1
JoeDalton

porque lo interpreta como html ;)

JoeDalton

Como a veces se le va la pinza con el tema de los filtros (me cambia AND por OR) >> Eso es un problema documentado, ya que cambiaba la visualización una vez reiniciado el router, aunque el archivo del filtro está correcto.

Otra cosa, sólo se soportaban 10 instrucciones por línea de comandos.

y que no te los muestre como stealt es normal, ya que si no hay ningún servicio detrás correindo (telnet, web, etc) el router no tiene nada que filtrar, ya que no se puede establecer conexión contra ese puerto si no hay servicio, o hagas pat a un puerto de una máquina local.

Saludos.

🗨️ 1
tonikelope

Jejejeje, tenía esta thread por olvidado... El caso es que no le di mayor importancia porque tp la tiene...

Gracias por la información ;)