Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

ADSL/VDSL

1 millon de sextercios para quien resuelva este problema

silencioso

Hola a tod@s:

Trataré de simplificar mi pregunta

Si configuro un router cisco para monopuesto asignando a la ethernet la ip pública que me da telefónica x.y.z.1 y a la atm0.1 la ip privada de la red de telefonica 10.a.b.69

defino una ruta por defecto con próximo salto 10.a.b.1

y le asigno una ip publica x.y.z.124 al pc, navego sin problemas

ahora quiero asignarle una ip privada a la ethernet 192.168.5.1 para que haga nat pero si uso la privada de la atm 0.1 no navego porque los paquetes saldrían con ip origen 10.a.b.69 y no pueden ser enrutados desde el destino

Si configuro la ip pública en la atm 0.1 no sabe como llegar a la 10.a.b.1 próximo salto y no funciona
probé asignandole a la atm 0.1 dos direcciones (pri y sec) y tampoco funciona.

Alguien me puede decir como configurar este escenario?

Estaré eternamente agradecido al que resuelva este misterio.

Muchas gracias.

Silencioso

Este tema está cerrado a nuevas respuestas. Abre un nuevo tema para retomar la conversación.
pegial

Hola.

No acabo de entender la configuracion, pero por si acaso te comento lo que yo creo que pretendes hacer. :-D

Para poder monitorizar el trafico de internet de la red de mi trabajo uso un ordenador con LINUX y dos tarjetas de red, una conectada a un router en modo monopuesto, y que tiene la IP publica, y otra conectada a un switch que tiene la IP privada (las tipicas de 192.168.0.x).

El ordenador debe tener dos tarjetas para poder conectarse a dos redes, o bien usar un router, que hace eso mismo.

Si no es eso lo que pretendes, disculpa el rollo. :-D

Frankie2004

¿Va por PPPoE o IP estática (RFC 1483)?

🗨️ 3
silencioso

Estática (RFC 1483) mas precisamente 10.a.b.69
Gracias

🗨️ 2
Frankie2004

Ya veo. Para PPP tenías algo aquí, usando la interfaz Dialer0:
adslayuda.com/cisco-configuracion_jazztel.html

En tu caso no estoy seguro si en la LAN va el ip nat inside y en la WAN el ip nat outside.

Es que desde el CCNA (donde no se toca ADSL) no he trabajado con routers en los curros posteriores.

🗨️ 1
silencioso

Frankie:

Gracias por la respuesta, pero tampoco funciona.
Antes de preguntar estuve recorriendo el foro para encontrar algún escenario como el mio, pero sin éxito.
El problema fundamental es que no puedo asignar a la ATM 0.1 la IP pública, porque esa IF se conecta a una red privada de telefónica, que luego se conecta con Internet.
La ATM 0.1 por narices tiene que tener una IP privada y la se, 10.a.b.69 y la ruta por defecto (próximo salto) es 10.a.b.1
El problema es donde configuro la IP publica que me dio Telefonica.? En la ethernet no porque allí ahora quiero privadas porque necesito multipuesto.

Para monopuesto si la pongo en la ethernet funciona sin problema, pero solo para un pc.
Saludos y gracias por participar.

Alberto

silencioso

Pedro:

Gracias por el esfuerzo, pero no es lo que pretendo.
Lo que trato es de configurar como multipuesto un router configurado originalmente como monopuesto.
El router funciona perfectamente bien si configuro la ethernet con la pública que me dió Telefónica 80.x.y.1 el pc con otra pública 80.x.y.124, la atm 0.1 con la 10.a.b.69 y una ruta por defecto a la 10.a.b.1

Ahora quiero que mis usuarios tengan direcciones 192.168.5.0 entonces cambio en la ethernet la ip publica por la 192.168.5.255

Adonde debo poner la pública 80.x.y.1 ahora?

En la ATM 0.1 no funciona porque allí tiene que ir la privada de telefonica 10.a.b.69
Como hago el nat para que los paquetes salgan con la 80.x.y.1 si no tengo ninguna if con esa dirección

Algún iluminado sabe la respuesta?

Saludos y muuuuchas gracias

Silencioso

🗨️ 8
Frankie2004

Esto estaba en otro hilo de la sección de redes (Joe_Dalton controla Cisco mucho más que yo):

interface ATM0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0.1 point-to-point
ip address ip_publica y mascara
ip nat outside
ip virtual-reassembly
pvc 8/32
encapsulation aal5snap
!
interface FastEthernet0
ip address 192.168.154.200 255.255.255.0
ip nat inside
ip virtual-reassembly
speed auto
!
ip classless
ip route 0.0.0.0 0.0.0.0 ATM0.1
no ip http server
no ip http secure-server
ip nat inside source list 100 interface ATM0.1 overload
!
access-list 100 permit ip 192.168.154.0 0.0.0.255 any
!

BocaDePez
BocaDePez

Una configuración multipuesto que está comproado que funciona (adaptada a tus datos):

Configuración RFC-1483 con NAT
router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
router(config)#no ip http server
router(config)#interface ethernet 0
router(config-if)#ip address 192.168.5.1 255.255.255.0
router(config-if)#ip nat inside
router(config-if)#no shutdown
router(config-if)#exit
router(config)#interface ATM 0
router(config-if)#ip address 80.x.y.124 255.255.255.0
router(config-if)#ip nat outside
router(config-if)#pvc 8/32
router(config-atm-vc)#encapsulation aal5snap
router(config-atm-vc)#no shutdown
router(config-if)#exit
router(config)#ip nat inside source list 1 interface atm0 overload
router(config)#ip route 0.0.0.0 0.0.0.0 80.x.y.2
router(config)#access-list 1 permit 192.168.5.0 0 0.0.0.255
router(config)#exit
router#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
Router#

Fuente:
adslnet.ws/modules.php?name=News&file=ar…icle&sid=994

🗨️ 6
silencioso

Es correcto!!!!

Pido disculpas, pero me lié, ya que en la cfg original tenía la IP 80.a.b.124 y la 80.a.b.1. Supuse que la dirección IP a asignar al la atm 0.1 era la 80.a.b.1 y no lograba hacerlo funcionar.
Con la .124 funciona.
Mis mas profundas gracias a todos los que trataron de ayudar.

Silencioso

🗨️ 4
BocaDePez
BocaDePez

Me alegro de que te funcione.
Jo, que rapidez. No me diste tiempo a postear mi otro mensaje.

Tatolino sin log. ;-)

Tatolino

Ah! que me olvidaba, ¿donde quedamos para la entrega del millón de sextercios?

🗨️ 2
silencioso
🗨️ 1
BocaDePez
BocaDePez

Sorry! La línea de los access list correcta sería:

router(config)#access-list 1 permit 192.168.5.0 0.0.0.255

Sobraba un cero :-P
Por supuesto a tus ordenadores (TCP/IP) has de darles estos datos:

IP- 192.168.5.X
Mask- 255.255.255.0
Pta. enlace- 192.168.5.1 (IP de la ethernet del 827)