Banda Ancha EU

Información independiente
sobre fibra, móvil y ADSL

hosting en interdominios

Cerrado

ADSL y Telefónica. Lo que sufren los usuarios.

Estimados señores:
Actualmente dirijo un proveedor de servicios internet en españa.
les envío emails posteados por mi a la lista de proveedores con objeto de hacer patente, una vez más la situación que padecemos.
Esperando que sea de utilidad

les envío un cordial saludo.

------------- Hola a todas/os

Desde la mañana de hoy vengo observando que todos los clientes que se conectan por adsl a nuestro servidor web tienen problemas para ver las webs... se quedan "paradas". Sin embargo desde RDSI/modem va todo bien.
Tenemos un par de servidores de correo que están detras de adsl en clientes y tienen problemas para enviar correo hacia nuestra máquina (hacia "afuera" no) ... problemas repoortados en maillog y en cola de correo de esta forma:
Oct 5 15:46:57 sendmail[2502]: f95BC7s01728: timeout waiting for input from solunet.es. during client greeting Oct 5 15:47:57 sendmail[2505]: f95C6qs02072: timeout waiting for input from solunet.es. during client greeting
/var/spool/mqueue (2 requests)
----Q-ID---- --Size-- -----Q-Time----- ------------Sender/Recipient------------
f95C6qs02072* 163097 Fri Oct 5 14:06 (... reply: read error from solunet.es.)
f95BC7s01728 164 Fri Oct 5 13:12 (... reply: read error from solunet.es.)

mientras que en solunet se ve lo siguiente:
Oct 5 15:54:37 solunet sendmail[1923]: NOQUEUE: [XXX.XXX.XXX.XXX] did not issue MAIL/EXPN/VRFY/ETRN during connection to MTA Siendo las XXX la ip del servidor detras de la adsl
Si hago un ssh a esos servidores y desde allí un lynx a una de nuestras webs la cosa se queda en algo tipo:
Read 4,2 of 10 KB of data, 426 bytes/sec (stalled for 9 sec), ETA 14 sec.
Y va subiendo el stalled y el ETA descaradamente hasta que a veces no es capaz de descargar las webs (sospecho que es lo que les pasa a los clientes)
En principio los trazados de ruta y los pings son normales... la configuracion de ambos servidores no ha cambiado en nada...
A riesgo que me llameis barbuda por ser el día que es,... ¿a alguien le ha pasado lo mismo o sabe que puede ser?
PD tampoco tengo tráfico como para ir tan lento por pérdida de paquetes (que no la hay)... de hecho con una RDSI va perfectamente todo
Saludos.
------------------------

De cualquier punto de España. Concretamente comprobado con ADSL de Telefónica en Madrid y en Zaragoza. Clientes corporativos y clientes con un PC y ADSL Los dos clientes corporativos tienen un router Nokia de los de Telefónica con puerto redirigido para poder hacer ssh a una máquina interna. La red interna de ambos esta en 192.168.1.x siendo el router 192.168.1.1. Todas las máquinas de la red (no usan dhcp tienen gateway a esa ip, siendo la máscara de red 255.255.255.0 Una de esas máquinas, en ambas redes con una ip... digamos 192.168.1.50 tiene un linux instalado con sendmail. Versión de Sendmail 8.11 y de Linux, en un caso Red Hat 6.2 y en otro Red Hat 7.0 parcheada.
En esas máquinas la configuración de sendmail es simplemente en los ficheros access ip_allow (en el caso del 7.0) y sendmail.cw en los que se da soporte para que un determinado dominio pueda ser enviado actuando esa máquina como relay.
En Solunet, en el DNS, se configura lo siguiente: mail In A XXX.XXX.XXX.XXX siendo evidentemente esta IP la de los routers de esas redes corporativas. De esta forma la máquina mail.dominiocliente.com esta en esas direcciones y dado que existe redirección de puertos 110 y 25 todo el correo que llega para esos clientes no pasa por mi máquina sino que va a la suya directamente. Por eso están configurados dos MX, el primero a mail.dominiocliente.com y el segundo a mail.solunet.es para que en caso de caida quede correo en solunet. Hasta ahora los usuarios de dichas redes utilizan como SMTP su propio servidor de correo y como POP tambien dicho servidor de correo ya que por la configuración DNS llegan los email directos allí (obviamente tienen los usuarios de correo dados de alta en esas máquinas). Hasta ahora todo ha funcionado correctamente.
De pronto, los señores de los puestos de red detrás de esas dos adsl así como algún otro usuario de los que tenemos que sólo tiene una máquina detrás de la adsl comienzan a llamar diciendo que su web "se atasca" Acto seguido comprobamos que los correos que salen (viendo los maillog de las maquinas de correo de los clientes) hacia "afuera" lo hacen correctamente mientras que los que van dirigidos a usuarios cuyos dominios residen en nuestra máquina quedan en cola mostrando los mensajes de error que he posteado antes. Es decir... los emails que me mandan a mi no llegan pero los que me mandan a una cuenta de hotmail si... comprobando que los que me mandan a mi a mi maquina quedan en sus servidores de correo. Los mensajes de error de mi maquina y las suyas son los posteados anteriormente.

Las versiones de sendmail son las mismas
Los dns no han cambiado en meses
La configuración de los sendmail tampoco
Ni la de mi apache
Los MTU (viendo sendmail.org y posibles bugs se apunta esta posibilidad) estan igual en todas las maquinas
Tiempos de ping correctos...
traceroute correcto...
Incluso se hace un ftp a nuestra maquina desde ambos servidores y la velocidad es correcta.
No saturamos caudal
Y como dato curioso, los webs alojados en nuestra máquina no los ven y se atascan pero los alojados en otra máquina que esta en nuestra misma red en la misma clase C y de configuración similar les entran a "cañón"
Es decir por alguna razón que no acabo de comprender y que, dentro de que no soy tan experimentado en estas lides como vosotros, he tratado durante todo un día de buscar documentandome, leyendo, mirando redhat, grupos de adsl, sendmail, apache... etc y foros diversos, todas las adsl se niegan a extraer de forma fluida información por el puertos 80 de mi servidor (detrás de una frame relay) y se niegan a enviar nada por el 25 (al menos dos de ellas). Los usuarios particulares también muestran descontento porque "da errores de timeout" (según expresan) al mandar correo (que yo corroboro en maillog) Por otra parte me alucina que a una máquina que esta físicamente y tcp/ip-...--mente al lado entran sin problemas.
Descarto problema de hardware ya que conectado por infovía con una RDSI y un modem a la máquina que teoricamente da problemas va a toda pastilla, tanto el correo como el web.
Si supiera por donde puede estar el problema pues atacaría por ahí... la historia es que estoy despistado porque nada ha cambiado desde que funcionaba bien y aparentemente desde algo que no sea una adsl todo funciona correctamente y no es siempre la adsl de cliente tal sino que es desde cualquier adsl. Por eso me despisto y por eso pregunto.
Saludos :-).
-----------------------

Holas
Pues tan simple y tan tonto como la inversa y nuevamente nuestros amigos de Telefónica Supongamos que nada, como decía en mi servidor ha cambiado.
Supongamos que mi sendmail chequea, quien esta detrás de una dirección ip cuando envía correo Supongamos que existe la directriz Hostnamelookup on en mi apache `para que los webalizer corriendo resuelvan y digan quien entra en las estadísticas que generan.
Quienes entran por infovía, resuelven y funciona, los que lo hacen por adsl generan una cantidad de tráfico al 52 para ver quienes son que tuesta todo ¡oh grandes amigos de Telefónica! Se os ha jodido la inversa!!!
Uno que mira... que remira... nslookup numero.ip.mi.cliente.... nslookup numero.ip.otro.cliente... voilá NO RESUELVE Hmmm pues a ver... defino en /etc/hosts que numero.ip.mi.cliente es fulanito... meto en hosts.conf order hosts,bind... descativo hostnamelookup en apache y todo funciona a la perfección.
UN Día de trabajo comiendome el tarro. Ya podía volverme loco...
Gracias Telefónica. os quiero. :-(((((
PD: Gracias a los que me habeis dado ideas... no quedan en saco roto y me apunto cosas... Ricardo... el router había sido reseteado si... y el servidor rebotado varias veces entero... snif... y el cliente cabreado... y... ¿como le explico que vivía mejor con los dos canales RDSI levantados con T plana y el 801 dando servicio? se reirá de mi...

Los comentarios más recientes se muestran primero. Haz click sobre un comentario para desplegar/plegar.
1