5 respuestas
19 mensajes

Este tema es antiguo y puede contener información obsoleta. Abre un nuevo tema para publicar tu mensaje.
  • Cerrado

    #1650291

    Sumar en EXCEL (desde celda X hasta infinito)

    Hola!

    Os comento mi duda. Quiero hacer una suma en Excel, que sume toda la columna (o fila, es igual), desde una celda dada hasta el infinito, es decir, que sume esa celda y todas las siguientes.

    La única forma que sé es poner, por ejemplo (pongamos que estamos en la columna A y queremos sumar a partir de A5 hasta el infinito) un valor muy alto (como podría se hasta A5000), y con eso me solventaría el asunto, pero quisiera saber si existe la forma (que seguro que la hay) de que sea hasta la celda Ainfinito).

    Salu2 y gracias!

    • #1775989

      Cerrado

      bueno no se si lo han ampliado ya pero en excel el numero de…

      bueno no se si lo han ampliado ya pero en excel el numero de filas esta limitado en 65500 filas aprox.

      creo que si pones" =A3+A4:A5000"

      sumarias desde la A3 hasta la A5000

      creo que te puede valer Sonriendo

    • #1776035

      Cerrado

      Gracias por las respuestas! Bueno, en el fondo esa solución…

      Gracias por las respuestas!

      Bueno, en el fondo esa solución es la misma que tenía yo de "poner un número muy alto", solo que vosotros vais directamente al número tope, pero la pregunta sigue abierta, ¿es esa la única forma o se puede poner algún "comando" que indique "hasta el final"?

      Salu2 y gracias

      • #1776059

        Cerrado

        Uhm, que yo sepa no existe una función específica que te…

        Uhm, que yo sepa no existe una función específica que te realice esa operación, pero podrías recurrir a generar una fórmula condicional, de tal manera que si la siguiente celda a sumar no se encuentra vacía efectúe la operación y continúe con el sumatorio, de lo contrario se detiene la suma.

        Por otro lado, si tienes conocimientos de VBA podrías hacer virguerías con una hoja de cálculo de Excel.

        Saludos Guiño

    • #1988431

      Cerrado

      Hola. Aunque hace ya algo de tiempo de este hilo o s diré que…

      Hola.

      Aunque hace ya algo de tiempo de este hilo o s diré que en excel 2010 tengo:

      =SUMA(B:F;3:5)

      Esto me suma las columnas B C D E F y las filas 3 4 y 5.

      Saludos.

    • #2101466

      Cerrado

      para sumar toda la fila ignorando cierto numero de columnas…

      para sumar toda la fila ignorando cierto numero de columnas es asi donde "*" es equivalente a la fila que quieran sumar y "?" de que columna donde quieres que se empiece la formula es esta;

      =SUMA($?*:$XFD*)

      entonces si yo quiero hacer una suma infinita en la fila "1" a partir de la columna "C" fila es = "*" columna es = "?" la formula seria esta;

      =SUMA($C1:$XFD1)

      para sumar toda la columna ignorando cierto numero de filas es asi donde "*" es equivalente a la columna que quieran sumar y "?" de que fila donde quieres que se empiece la formula es esta;

      =SUMA(?$*:?$1048576)

      entonces si yo quiero hacer una suma infinita en la columna "C" a partir de la fila "3" fila es = "*" columna es = "?" la formula seria esta;

      =SUMA(C$4:C$1048576)